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SenseCAP Indicator

User Manual

Brief Introduction

SenseCAP Indicator is a 4-inch touch screen driven by ESP32 and RP2040
dual-MCU and supports Wi-Fi/BLE/LoRa communication. It is a fully open
source powerful IoT development platform for developers. One-stop ODM
Fusion service is also available for customization and quick scale-up.

Product Video：https://youtu.be/IOdI5_MGbCw

https://youtu.be/IOdI5_MGbCw


1

Content

Introduction................................................................................................................................................................. 4

Features................................................................................................................................................................4

Hardware Version............................................................................................................................................. 7

Specification........................................................................................................................................................8

Part List .................................................................................................................................................................8

ODM Service .......................................................................................................................................................9

Get Started with SenseCAP Indicator ................................................................................................................10

Hardware Overview....................................................................................................................................... 10

Button Function..................................................................................................................................... 10

Grove Interfaces .....................................................................................................................................10

SX1262 LoRa Chip .................................................................................................................................11

Native Firmware.............................................................................................................................................. 12

Wi-Fi Configuration..............................................................................................................................12

Data Viewing...........................................................................................................................................13

Setting.......................................................................................................................................................15

Development Tutorial ................................................................................................................................... 17

ESP32 Firmware Flashing ...................................................................................................................18

RP2040 Firmware Flashing ................................................................................................................. 23

Resource ..................................................................................................................................................................... 29

FCC Regulatory Conformance：........................................................................................................................ 30



2



3



4

Introduction

SenseCAP Indicator is a 4-inch touch screen driven by ESP32 and RP2040 dual-MCU and
supports Wi-Fi/BLE/LoRa communication.

The board comes with Type-C and Grove interfaces, supports ADC and IIC transmission protocols,
and can easily connect to other peripherals with rich GPIOs.

SenseCAP Indicator is a fully open source powerful IoT development platform for developers.
One-stop ODM Fusion service is also available for customization and quick scale-up.

Features

 Dual MCUs and Rich GPIOs: Equipped with powerful ESP32S3 and RP2040 dual MCUs and
over 400 Grove-compatible GPIOs for flexible expansion options.

 Real-time Air Quality Monitoring: Built-in tVOC and CO2 sensors, and an external Grove
AHT20 temperature and humidity sensor for more precise readings.

 Local LoRa Hub for IoT Connectivity: Integrated Semtech SX1262 LoRa chip (optional) for
connecting LoRa devices to popular IoT platforms such as Matter via Wi-Fi, without the need
for additional compatible devices.

 Fully Open Source Platform: Leverage the extensive ESP32 and Raspberry Pi open source
ecosystem for infinite application possibilities.

 Fusion ODM Service Available: Seeed Studio also provides one-stop ODM service for quick
customization and scale-up to meet various needs.

SenseCAP Indicator native firmware enables you to use it as a desktop air quality detector or you
could customize one of your own styles. There are built-in tVOCs and CO2 sensors, and a Grove
TH sensor is provided to connect externally to reduce heat interference to get more accurate
temperature and humidity results.
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The embedded SX1262 LoRa module enables you to build the LoRa application and connect your
local LoRa sensors to the Cloud via Wi-Fi. For example, you could build a LoRa hub device to
connect your LoRa sensors to your smart home ecosystem to implement Matter over Wi-Fi. In
this way, the LoRa devices could be connected to the Matter ecosystem via Wi-Fi, without the
need to buy a new Matter-compatible device.

The software of SenseCAP Indicator is open source. Developers could create various IoT
applications such as:
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 Air Quality Monitor

 Weather Station Display

 Sensor Data Dashboard

 Smart Home Assistant

 Mini Sensor Hub

 Stock Price Indicator

 Digital Album

 SOP Reminder

...

It can also be used to develop various exciting applications integrating with third-party platforms,
such as: AWS / ChatGPT / Matter / NodeRED / IoTex ...

Note: This sketch shows the development possibilities for the related IoT
ecosystem, developers need to develop the firmware based on need.



7

SenseCAP Indicator is an interactive display and control terminal for various IoT applications. It
provides developers with a powerful and interface-rich development platform powered by
ESP32-S3 and RP2040 dual-MCU.

Don't wait anymore, start your wonderful development journey with SenseCAP Indicator now!

Hardware Version

The SenseCAP Indicator series offers four different versions: D1, D1S, D1L, and D1Pro. Each
version is designed to meet different application needs without any extra cost from unnecessary
hardware. Here are the differences between the versions:
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Specification

Screen 3.95 Inch, Capacitive RGB Touch Screen

Screen Resolution 480 x 480 pixels

Power Supply 5V DC, 1A

Operation Temperature -10℃~50℃

Battery N/A

Processor

ESP32-S3: Xtensa® dual-core 32-bit LX7 microprocessor, up to 240

MHz

RP2040: Dual ARM Cortex-M0+ up to 133MHz

Flash
ESP32S3: 8MB

RP2040: 2MB

External Storage Support up to 32GB Micro SD Card (not included)

Wi-Fi 802.11b/g/n, 2.4GHz

Bluetooth Bluetooth 5.0 LE

LoRa(SX1262)

LoRaWAN/(G)FSK, 21dBm Max Transmitted Power

Sensitivity/-136dBm@SF12 BW=125KHz RX Sensitivity, Up to 5km

(depending on gateway antenna and environments)

Sensors(Optional)

CO2 (SCD41)

Range: 0-40000ppm

Accuracy: 400ppm - 5000ppm

±(50ppm+5% of reading)

TVOC (SGP40) Range: 1-500 VOC Index Points

Grove Temperature and

Humidity Sensor (AHT20)

Range: -40 ~ + 85 ℃/± 0.3 ℃; 0 ~ 100%

RH/± 2% RH (25 ℃)

Buzzer MLT-8530, Resonant Frequency：2700Hz

Part List

Products Quantity

SenseCAP Indicator *1

Grove TH Sensor(For D1Pro and D1S) *1

Type-C Cable *1
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ODM Service

Note:

If you want to customize your own SenseCAP Indicator, Seeed Studio provides one-stop ODM

service for quick customization and scalp-up. Please contact iot@seeed.cc if you have large

quantity customization need.

With over 10 years of ODM & OEM experience, our engineers and product experts are proficient
in delivering customization service for popular open-source hardware platforms, such as:
Raspberry Pi, NVIDIA Jetson, Beagleboard, ESP32, and more.
We are committed to assisting you at any moment and shortening your path from idea to
products for emerging AIoT scenarios.

https://www.seeedstudio.com/odm
http://iot@seeed.cc
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Get Started with SenseCAP Indicator

Hardware Overview

Button Function

Short press: Turn off /wake up the screen
Long press for 3s: Switch on/switch off the device
Long press for 10s: Factory reset

Grove Interfaces

There are two Grove interfaces for connecting Grove modules, providing more possibilities for
developers.

Grove is a modular, standardized connector prototyping system and a strong open source
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hardware ecosystem. （Click Grove - Seeed Studio to learn more）Grove - Seeed

Studio

SX1262 LoRa Chip

The embedded SX1262 LoRa module enables you to build the LoRa application and connect your
local LoRa sensors to the Cloud via Wi-Fi. For example, you could build a LoRa hub device to
connect your LoRa sensors to your smart home ecosystem to implement Matter over Wi-Fi. In
this way, the LoRa devices could be connected to the Matter ecosystem via Wi-Fi, without the
need to buy a new Matter-compatible device.

https://www.seeedstudio.com/category/Grove-c-1003.html
https://www.seeedstudio.com/category/Grove-c-1003.html
https://www.seeedstudio.com/category/Grove-c-1003.html
https://www.seeedstudio.com/category/Grove-c-1003.html
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Native Firmware

SenseCAP Indicator native firmware enables you to use it as a desktop air quality detector，just a
few simple steps to enjoy.

Wi-Fi Configuration

Plug the 5V power adaptor into the USB type-C power connector, the device will

power on automatically, then the display will show the WiFi setting page.
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Select the WiFi you need, input the password and
connect.

Data Viewing

 Home page

Including the time, date, location info.
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 Sensor data

Built-in tVOC and CO2 sensors, and an external Grove AHT20 TH sensor for more precise
temperature and humidity readings.

Click the specified sensor to enter the detailed information page, and you can

choose to display the value of 24h or a week.
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Setting
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Display Setting

Brightness: Adjust screen brightness

Sleep Mode: Turn off the screen according to the interval you set

Date & Time Setting

Time Format: You can set 24H or 12H format.

Time Auto Update/Zone Auto Update: When the device is connected to WiFi, it

will automatically obtain the corresponding time zone and date.
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Manual setting: If the time obtained through the time zone cannot

automatically identify the winter time or device is offline, then you can manually

set the time zone

Development Tutorial
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ESP32 Firmware Flashing

Flash by Flash Download Tools (For Windows only)

 Step 1: Connect the device to your PC with the provided USB type-C cable.

 Step 2:Install the Flash Download Tools

Flash Download Tools for Windows

 Step 3: User interface setting
Double-click the .exe file to enter the main interface of the tool.
Chip Type: ESP32-S3
WorkMode: Develop
LoadMode: UART

 Step 4: SPI Download Tab Configure
Click "..." and select the .bin file in the firmware file to configure the loading path.

There should be 3 .bin files in the firmware , they correspond to 3 different
downloading addresses:
bootloader.bin - 0x0

https://www.espressif.com.cn/en/support/download/other-tools?keys=&field_type_tid%5B%5D=842
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partition-table.bin - 0x8000
terminal.bin - 0x10000

 Step 5: SPI Flash Configure

SPI SPEED: 40MHz
SPI MODE: DIO

 Step 6: Download Panel Configure
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COM: Check the ports on your Device Manage, the USB-SERIAL is the correct one.
Baud: 921600(recommended value）

 Step 6: Start Downloading

Then click "START" to start the downloading.

When it shows "FINISH", the flash has been completed.
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There is "indicator_terminal_demo.bin" firmware (allinone ) in the sdk . you can flash

it to esp32.

https://github.com/Seeed-Solution/sensecap_indicator_esp32
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Flash by IDF

For Linux and MacOS: Standard Toolchain Setup for Linux and macOS

For Windows: Standard Setup of Toolchain for Windows

There is "indicator_terminal_demo.bin" firmware (allinone ) in the sdk . you can flash it
by idf.

https://docs.espressif.com/projects/esp-idf/en/latest/esp32s3/get-started/linux-macos-setup.html
https://docs.espressif.com/projects/esp-idf/en/latest/esp32s3/get-started/windows-setup.html
https://github.com/Seeed-Solution/sensecap_indicator_esp32
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cd <sdk>/examples/factory/

esptool.py write_flash 0x0 indicator_terminal_demo.bin

also you can build, flash and monitor the project.

cd <sdk>/examples/terminal_demo/

idf.py -p PORT build flash monitor

RP2040 Firmware Flashing

Flash by .uf2 file

 Step 1: Connect the device to your PC

Long press this internal button, then connect the device to your PC by the

provided USB type-C cable, release the button once connected.

 Step 2: Firmware Flash

After the connection is successful, your PC will show a disk.
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Copy the .uf2 file in the firmware package to the disk, then the disk will log out.

The upgrade will run automatically.

Flash by Arduino IDE

 Step 1: Install Arduino IDE

Arduino IDE

 Step 2: Add the Raspberry Pi Pico Board

https://www.arduino.cc/en/software
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Open your Arduino IDE, click on Arduino > Settings, and copy the below
URL to Additional Boards Manager URLs:

https://github.com/earlephilhower/arduino-pico/releases/download/global/pa

ckage_rp2040_index.json

Click on Tools > Board > Board Manager.

Search and install "Raspberry Pi Pico/RP2040" in the Boards Manager
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 Step 3: Add Libraries

Download these libraries we need:

Serial communication protocol

SGP40 TVOC sensor library

Transfer index library: Sensirion Gas Index Algorithm

SCD41 CO2 sensor library

AHT20 temperature and humidity sensor libray

Sensirion Arduino Core library

Navigate to Sketch -> Include Library -> Add .ZIP Library, then select the

libraries you download.

https://github.com/bakercp/PacketSerial
https://github.com/Sensirion/arduino-i2c-sgp40
https://github.com/Sensirion/arduino-gas-index-algorithm
https://github.com/Sensirion/arduino-i2c-scd4x
https://github.com/adafruit/Adafruit_AHTX0
https://github.com/Sensirion/arduino-core/
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 Step 4: Connect the device to your PC with the provided USB Typc-C cable.

 Step 5: Select the board

Tools > Board > Raspberry Pi PR2040 Boards > Raspberry Pi Pico

Port: Select the "usbmodem" one

 Step 6: Open the example code file

File > Open, then select the example code file (.ino file).

We provide an example code file, you can modify the code according to your

needs.



28

 Step 7: Verify and Upload the file.
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Resource

IDF Downloard: Standard Toolchain Setup for Linux and macOS

Standard Setup of Toolchain for Windows

SenseCAP Indicator ESP32 SDK：SenseCAP Indicator SDK for esp32

SenseCAP Indicator RP2040 Examples: SenseCAP Indicator examples for rp2040

https://docs.espressif.com/projects/esp-idf/en/latest/esp32s3/get-started/linux-macos-setup.html
https://docs.espressif.com/projects/esp-idf/en/latest/esp32s3/get-started/windows-setup.html
https://github.com/Seeed-Solution/sensecap_indicator_esp32.git
https://github.com/Seeed-Solution/sensecap_indicator_rp2040


30

FCC Regulatory Conformance：

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two

conditions:

(1) This device may not cause harmful interference.

(2) This device must accept any interference received, including interference that may cause

undesired operation.

NOTE: This equipment has been tested and found to comply with the limits for a Class B digital
device, pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable
protection against harmful interference in a residential installation.

This equipment generates uses and can radiate radio frequency energy and, if not installed and
used in accordance with the instructions, may cause harmful interference to radio
communications. However, there is no guarantee that interference will not occur in a particular
installation. If this equipment does cause harmful interference to radio or television reception,
which can be determined by turning the equipment off and on, the user is encouraged to try to
correct the interference by one or more of the following measures:

- Reorient or relocate the receiving antenna.

- Increase the separation between the equipment and receiver.

-Connect the equipment into an outlet on a circuit different from that to which the receiver is
connected.

-Consult the dealer or an experienced radio/TV technician for help

NOTE: The manufacturer is not responsible for any radio or TV interference caused by

unauthorized modifications to this equipment. Such modifications could void the user’s authority

to operate the equipment.

RF Exposure
This equipment complies with FCC radiation exposure limits set forth for an uncontrolled

environment. This equipment should be installed and operated with minimum distance of 20 cm

between the radiator and your body. This transmitter must not be co-located or operating in

conjunction with any other antenna or transmitter.
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