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Document Change Record

This page records changes to this document. The document was originally released as Revision A.

Revision
B

Date
11/2002

04/2003

08/2003

01/2004

04/2004

01/2005

Description of Change

Added information about the Siemens MC45 radio module, the tethered scanner, CAB
extraction, FTP Server parameters, and Data Collection control panel applet imager op-
tions.

Added information about the ambient light sensor, the beeper, keypad sequences, the
alphanumeric keypad, the vibrator, an accessories list, programming notifications, the
MaxiCode symbology, the Utilities control panel applet, and the Wireless Network con-
trol panel applet.

Upgraded Pocket PC 2002 information to Windows Mobile 2003, upgraded all illustra-
tions to gray-scale, added new Imager functions, moved the Automatic Data Collection
COM Interface material to the SDK User’s Manual.

Added 730 Computer information, revised CDMA Setup information, and revised Wire-
less Area Network Printing information.

Updated 802.11 security supplicant information. Added new network selection APIs.
Incorporated information about the Intermec Settings control panel applet for PSM
Builds 3.00 or newer. Added information about the PhoneUltility application. Revised
Chapter 4, “Network Support.” Added tethered scanner and internal scanner configura-
tion and troubleshooting information to Chapter 6, “Scanner Support.”

Added information about resetting the 700 Series Computer. Updated the Profile Wizard
information in Appendix A, “Configurable Settings.” Revised information about using
Sprint Watcher and added information about a Phone application for units with CDMA
or GSM radios in Chapter 4, “Network Support.” Added information about the 741, 751,
and 761 Computers and the MC46 Radio.
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Before You Begin

Before You Begin

Safety Summary

This section provides you with safety information, technical support
information, and sources for additional product information.

Your safety is extremely important. Read and follow all warnings and
cautions in this document before handling and operating Intermec
equipment. You can be seriously injured, and equipment and data can be
damaged if you do not follow the safety warnings and cautions.

Do not repair or adjust alone

Do not repair or adjust energized equipment alone under any
circumstances. Someone capable of providing first aid must always be
present for your safety.

First aid

Always obtain first aid or medical attention immediately after an injury.
Never neglect an injury, no matter how slight it seems.

Resuscitation

Begin resuscitation immediately if someone is injured and stops breathing,.
Any delay could result in death. To work on or near high voltage, you
should be familiar with approved industrial first aid methods.

Energized equipment

Never work on energized equipment unless authorized by a responsible
authority. Energized electrical equipment is dangerous. Electrical shock
from energized equipment can cause death. If you must perform
authorized emergency work on energized equipment, be sure that you
comply strictly with approved safety regulations.
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Before You Begin

Safety Icons

A

Warming

I

This section explains how to identify and understand dangers, warnings,
cautions, and notes that are in this manual. You may also see icons that tell
you when to follow ESD procedures and when to take special precautions

for handling optical parts.

A warning alerts you of an operating procedure, practice, condition,
or statement that must be strictly observed to avoid death or serious
injury to the persons working on the equipment.

Avertissement: Un avertissement vous avertit d’'une procédure de
fonctionnement, d’'une méthode, d’un état ou d’un rapport qui doit
étre strictement respecté pour éviter 'occurrence de mort ou de
blessures graves aux personnes manupulant I’équipement.

A caution alerts you to an operating procedure, practice, condition, or
statement that must be strictly observed to prevent equipment damage
or destruction, or corruption or loss of data.

Attention: Une précaution vous avertit d’une procédure de
fonctionnement, d’'une méthode, d’un état ou d’un rapport qui doit
étre strictement respecté pour empécher I’endommagement ou la
destruction de I'équipement, ou I’altération ou la perte de données.

Note: Notes either provide extra information about a topic or contain

special instructions for handling a particular condition or set of
circumstances.
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Before You Begin

Global Services and Support

Warranty Information

To understand the warranty for your Intermec product, visit the Intermec
web site at www.intermec.com and click Service & Support. The Intermec
Global Sales & Service page appears. From the Service & Support menu,
move your pointer over Support, and then click Warranty.

Disclaimer of warranties: The sample code included in this document is
presented for reference only. The code does not necessarily represent
complete, tested programs. The code is provided “as is with all faults.” All
warranties are expressly disclaimed, including the implied warranties of
merchantability and fitness for a particular purpose.

Web Support

Visit the Intermec web site at www.intermec.com to download our current
manuals in PDF format. To order printed versions of the Intermec
manuals, contact your local Intermec representative or distributor.

Visit the Intermec technical knowledge base (Knowledge Central) at
intermec.custhelp.com to review technical information or to request
technical support for your Intermec product.

Telephone Support

These services are available from Intermec Technologies Corporation.

In the U.S.A. and Canada
call 1-800-755-5505
Service Description and choose this option
Factory Repair and Request a return authorization 1
On-site Repair number for authorized service
center repair, or request an
on-site repair technician.
Technical Support Get technical support on your 2
Intermec product.
Service Contract Inquire about an existing 3
Status contract, renew a contract, or ask
invoicing questions.
Schedule Site Surveys Schedule a site survey, or request 4
or Installations a product or system installation.
Ordering Products Talk to sales administration, 5
place an order, or check the
status of your order.

Outside the U.S.A. and Canada, contact your local Intermec
representative. To search for your local representative, from the Intermec
web site, click Contact.
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Before You Begin

Who Should Read this Manual?

This manual provides you with information about the features of the 700
Series Color Mobile Computer and how to configure, troubleshoot, and
support it. You must be familiar with your host PC, your network, and
your other Intermec equipment.

Related Documents

This table contains a list of related Intermec documents and their part

numbers.

Document Title Part Number
700 Color with Windows Mobile 2003 Quick Start Guide 962-054-069

730 Mobile Computer Quick Start Guide 962-054-068
Intermec Computer Command Reference Manual 073529

Intermec Developer’s Library CD 235-114-001 (Kiz)
700C Recovery CD Windows Mobile 2003 Edition English 235-110-001 (Kiz)

The Intermec web site at www.intermec.com contains many of our
documents that you can download in PDF format.

To order printed versions of the Intermec manuals, contact your local
Intermec representative or distributor.
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1 Introduction

This chapter introduces the 700 Series Color Mobile Computer, devel-
oped by Intermec Technologies Corporation to enhance wireless connec-
tivity needs.

This chapter contains hardware and software configuration information to
assist you in making the most out of your 700 Color Computer.

Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.

The components include:

Ambient light sensors (next page)
Audio system (page 3)

Battery (page 5)

Beeper (page 7)

Keypad (page 11)

Modem support (page 16)

PSM build version (page 16)
Resetting your 700 Series Computer (page 17)
Software build version (page 18)
Storage media (page 19)

Vibrator (page 20)

Wireless network support (page 21)

Note: Desktop icons and control panel applet icons are shown to the left.
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Chapter 1 — Introduction

Ambient Light Sensor

% Note: This information does 7oz apply to the 730 Computer.

The ambient light sensor turns on the display lighting when conditions
warrant but automatically turns if off again as surrounding light increases.
This conserves your 700 Color battery power.

Ambient Light
Sensor

Ambient Light
Sensor

This illustration shows the 700 Color Computer with a numeric keypad (left) and an alphanumeric
keypad (right).

%. To adjust the ambient light sensor, tap Start > Settings > the System tab >
" the Backlight icon > the Both Power tab. Make your selections, then tap
Backlight ok to exit this applet.

o g L TYE I o

Backlight

On Al Power Sources:

Restare backlight stake on
resume

Automatic BacKight Contral

@ Ligabled

O Turn OFF Im Marmal Lighk
) Turn ©FF In Bright Light

Extern Power | Both Power | Keyboard EII

B[
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Chapter 1 — Introduction

Audio System

The audio system consists of the speaker, internal microphone, and the
external headset jack.

Speaker

A speaker capable of variable volume levels is located on the back of the
computer. This speaker has a transducer volume of 85 dB min at 10 CM
and a frequency range of 1-8 KHz.

Speaker Speaker

700 Color Computer 730 Computer

Warning: Do not place the speaker next to your ear when the speaker
volume is set to “Loud” (maximum), or you may damage your
Warning hearing.
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Chapter 1 — Introduction

Microphone

The built-in microphone is located on the bottom of the unit next to the
Hirose docking connector.

Charging/Docking

Microphone
connector

This is the bottom of the 700 Color Computer. Note that the keypad is to the bottom in this
illustration.

External Headset Jack

The external headset jack connects a mobile phone style headset to your
mobile computer for use in noisy environments. The jack is a 2.5 mm,
three-conductor jack, with autosensing of the headset jack insertion which
disables the internal speaker and microphone. The external headset jack is
located on the bottom of the mobile computer next to the Hirose docking
connector.

Charging/Docking

Headset jack connector

This is the bottom of the 700 Color Computer. Note that the keypad is to the bottom in this
illustration.
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Chapter 1 — Introduction

Battery

The 700 Color Computer comes with a 14.4 Watt-hour, 7.2V,
replaceable Lithium-Ion (Lilon) battery.

The 730 Computer comes with an 8.8 Watt-hour, 3.7V, replaceable Lilon
battery.

the Power icon > the Power tab to view the current status of both the
Power  main battery and the backup battery. Tap ok to exit this information.

{E To view the status of this battery, tap Start > Settings > the System tab >

&t gtz @

Main battery: Lilon
Eattery power remaining

Backup battery

o [ "

On battery power:

Turn off device if nat

used for
On external power:

Turr off dewice F mok
used for

Power | Eattery | Matifications |

B[

For Units With PSM Builds Older than 3.00
0 You can also view the battery status by accessing the Unit Information
control panel applet. Tap Start > Settings > the System tab > the Unit
Information icon > the Battery Status tab to view the current status. Tap
ok to exit this information.

Unit
Information

arc1za O

|Qefaults | | Refresh | | apply |

Wersions | Battery Status | CAE Filesl
B[
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Chapter 1 — Introduction

Power

If your computer shuts down because of low battery conditions, your com-
puter does not operate. This is done to ensure that data is protected. Al-
though the battery does protect the data against loss for several hours, you
should connect your computer to a power source when you first detect a
low battery condition.

Your computer contains an internal super capacitor, a temporary power
storage device, that protects data for up to ten minutes. This is to give you
time to replace the main battery pack before that data is lost. Be sure to put
the computer in a suspend mode before doing so.

If you have at least one device in your 700 Color Computer (radio, scan-
ner, imager, or Ethernet), the battery power fail level is set so that after the
system shuts down in a low battery condition, there is still sufficient charge
to allow the unit to remain configured, keep proper time, and maintain
DRAM (Dynamic Random Access Memory) for at least 23 to 32 hours at
room temperature 7f the main battery remains in the mobile computer.
The configuration and time are lost if:

* The battery discharges beyond this level.
* The battery is removed when the computer is not in suspend mode.
* A cold reset is performed on the computer.

You can modify RAM maintenance in a limited way. On the 700 Color
Computer, tap Start > Settings > the System tab > the Power icon > the
Battery tab. Drag the slider bar to the right to change the suspend voltage
to favor suspend time over rundown time, then click ok to exit.

P 4T «£ 1239 @

‘fou can configure the mobile computer ko
increase battery runtime by decreasing
RAM retention time andfar performance,

Mae RAM Max Battery
rekenkion | glaly =3
Max Max Battery
petformance Funkirme
1 1
Power | Eattery | Matifications
B[
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E4

Enable the Beeper

()

Sounds &
Motifications

Chapter 1 — Introduction

Note: Each time the 700 Color Computer is cold-booted, all default set-
tings are restored unless registry storage is enabled. See page 123 for infor-
mation about enabling the registry storage.

For information about setting volume levels for screen taps, ActiveSync
alert noises, etc., tap Start > Help > Pocket PC Basics, then select
Notifications.

To enable the beeper:

1 Tap Start > Settings > the Personal tab > Sounds & Notifications > the
Volume tab.

2 Drag the System volume slider bar to the right of the “Silent” position.

3 Tap ok to exit this applet.

P i 4c1z40 O

Sounds & Motifications

System yolume

Silent Loud

-
1Lr
1 ' ' i ' |

Enable sounds for
Events (warnings, system events)

Programs
Naotifications falarms, reminders)

|:| Screen taps

O Soft @ Loud
[ ] Hardwsare buttons
O Saft @ Loud

Yalume | Tokifications |
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Disable the Scanner Mute
% Note: This information does 7oz apply to the 730 Computer.

To disable the mute feature on the scanner.

E@E 1 Tap Start > Settings > the System tab > the Audio icon, then select
) User defined audio settings.
Audio

F¥ | settings P it 4c1245 D

Audio

Select audio configuration option.
For manual audio setup use
"User defined audio settings" option

{1 set up audio for a Phone call
{1 Play wave to Speaker

(3 Play wave to Radia

O Set up audio for Speaker Phaone
(1 Default audio settings

() Uzer defined audio settings

Set Parameters| Input Mixing | Outpuk SEEE
B[

2 Tap the Input Mixing tab, then clear the SCAN Mute box.

3 Drag its slider bar (note the greyed slider bar) to the appropriate level of
loudest, with the left side being the most loud and the right side being
the most quiet. Tap ok to exit this applet.

P iF 4c1246 O

Radio:  [vw] Mute + —{—"
M [ Mt + —{—

Boost: 20 de

ScaM:  [mute + ——F—— -

Wave:  []mute
Wave to Spesker + —— F—= -

Wave to Radio + -:U =
Set Parameters [ Input Mixing | Qukput SEEE

B[
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Chapter 1 — Introduction

Select a Beeper Volume

% Note: The 730 Computer does 7oz support the laser scanner.

To determine your PSM Build version, tap Start > Programs > File Ex-
plorer > the Flash File Store folder > the PSMinfo text file.

For Units With PSM Builds Older than 3.00

Do the following to select a beeper volume. 700 Color Computers built
with a laser scanner have three options: Off, High, or Medium. 700

12 3lUS
Data Computers built with an imager have just two: Beeper or Vibrate. 730
Ellcstion Computers have just the Beeper option. See Appendix A, “Configurable
Settings,” for more information about the Beeper Volume or Beeper
option.
1 Tap Start > Settings > the System tab > the Data Collection icon to
access its control panel applet.
2 Use the right and left arrows to scroll to the Beeper/LED tab, then tap
this tab.
3 For units with laser scanners:
Tap Beeper Volume, select an option, then tap Apply to change the set-
ting.
For units with imagers:
Select either option, then tap Apply to change the setting. For 730 Com-
puters, the Vibrate option is not supported.
4 Tap ok to confirm this change, then tap ok to exit the Data Collection
control panel applet.
¥ | Settings atqc1z04 D | cettings it 4c1zz0 D | Settings arc1zas O

Data Collection Data Collection Data Collection

----- Eeeper, <Beeper s

Beeper Freguency, <2090
- Gond read beeps, <1
" Good read beep duration, =20

Change 'Beeper volume' Setking —— Change 'Beepet’ Setting — Change 'Beeper' Setting
Eeeper
|High vl R |Beeper vl
O vibrate
Igefaultsl | Refresh | | apply | |Qefaults | | Refresh | | apply | |Qefaults | | Refresh | | apply |

Symbology Options | Beeper/LED | Wirtual 'EII Symbaology Options | Beeper/LED | ImagerEII Symbology Options | Beeper/LED | Yirtual 'EE
E|‘ E|A Mew Tools Accounts g E|‘

700 Color with Laser Scanner 700 Color with Imager Screen 730 Screen
Screen
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For Units With PSM Build 3.00 or Newer
E‘ To select a beeper volume for the 700 Color Computer, tap Start > Set-
tings > the System tab > the Intermec Settings icon. Tap the Device Set-
Intermec tings option, tap (+) to expand Beeper, then tap (+) to expand Volume.
Settings  Gelect an item, then close this option.

j“ Intermec Settings < 4£ 1205 9

Stanners, Syrmbologies
Commurnications

.}:j' Intermec Settings «f 4£ 1244 9

Stanners, Syrmbologies
Communications
Device Settings
= Beeper
E-Wolumne
-Q Off

O Low

- Medium
- High

- Wery high

[+

- Medium
- High
- Wery high

- Wibrate Uit good read beep
= Unit good read beep - Digplay
[ Display [ Power Management
-Power Management - System Companent Versions
[¥-System Companent Versions ] Applications
Applications v
File Edit View Help| [ * E|A File Edit View Help| [ * E|A
700 Color Screen 730 Screen

% Note: Information about the settings you can configure with the Intermec
Settings control panel applet is described in the Intermec Computer Com-
mand Reference Manual (P/N: 073529). The online manual is available

from the Intermec web site at www.intermec.com.

Disable the Beeper
Do the following to disable the beeper:
@ 1 Tap Start > Settings > the Personal tab > Sounds & Notification > the
Volume tab.
NEEEE:EE;S 2 Drag the System volume slider completely to the left to “Silent.”

3 Tap ok to exit this applet.

Sounds & Motifications

System yolume

Silent U=| Loud

Enable sounds for
Events (warnings, system events)

Programs
Naotifications falarms, reminders)

|:| Screen taps

O Soft @ Loud

[ ] Hardwsare buttons

O Saft @ Loud

Yalume | Tokifications |

B[

10 700 Series Color Mobile Computer User’s Manual



Chapter 1 — Introduction

Keypad

Instructions for the keypad include the backlight and keypress sequences.

Backlight for Keypad
% Note: This information does 7oz apply to the 730 Computer.

% You can configure your keypad to turn on a backlight to assist you when

" you are working in low lighting. To adjust the backlight for the keypad,

Backlight tap Start > Settings > the System tab > Backlight. Use the left/right scroll
arrows to move to and tap the Keyboard tab. Make your selection, then
tap ok to exit this applet.

& gcusr O

Backlight

Kevboard Backlight:
@ Blvuays OfF

() on In Low Light
() on In Medium Light

O Blwways On

Extern Power | Bath Power | kewboard | EII
=]
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Chapter 1 — Introduction

Key Sequences

12

Use the following key sequences to enter characters into your 700 Color
Computer using either a numeric keypad or an alphanumeric keypad.

[Gold] or [Gold/White] Plane Keys

The [Gold] © plane key (numeric keypad) or the [Gold/White] @ plane
key (alphanumeric keypad) provides you access to display controls, special
characters, and Pocket PC options.

Press the [Gold] © key or the [Gold/White] @@ key for each gold plane
key stroke you wish to make. For example to turn on the front light, press
and hold the [Gold] © key plus the (3% key on the numeric keypad or
press and hold the [Gold/White] @ key plus the (1) key on the alphanu—
meric keypad. To turn the front light off, press the appropriate keys again.

Below and on the next page are the key sequences.

Numeric Keypad

The following table lists sequences that use the [Gold] © plane key. See
Chapter 2, “Windows Mobile 2003,” for information about the Pocket PC
applications.

Press the Keys To Do This

[Gold] © Toggle the backlight on or off (also goes through backlight
power levels if held down)

[Gold] © Access the Pocket PC Record application (see Noze).

[Gold] © Access the Pocket PC Calendar application (see Note).

[Gold] © Access the Pocket PC Contacts application (see Noze).

[Gold] © Access the Pocket PC Tasks application (see Note).

[Gold] © Move up one page.

[Gold] © Enter an asterisk (*).

[Gold] © Move down one page.

[Gold] © Access the Pocket PC Start menu.

[Gold] © Enter an at symbol (@).

[Gold] © Enter a backslash (/).

[Gold] © Enter a minus sign (-).

[Gold] © Enter a plus sign (+).

[Gold] © — Tab to the right.

[Gold] © < Tab to the left.

[Gold] © Increase volume

[Gold] © Decrease volume

Note: Pocket PC applications are accessible only if configured to do so in the App Launch
portion of the Utilities control panel applet. See page 358 for more information.
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Alphanumeric Keypad

Chapter 1 — Introduction

Note: This information does 7oz apply to the 730 Computer.

The following table lists sequences that use the [Gold/White] @ plane
key. See Chapter 2, “Windows Mobile 2003,” for information about the
Pocket PC applications.

Press the Keys
[Gold/White] @ (1)

o
s:‘@“

‘®‘
\@‘

) )
o o
8 33 3 85 8 &8 &8 333 & E& &
R )
N \&/

o
olole

N
& Qv

J

~
\J

3
=
()

0

&

Gold/White] @ (%)

To Do This

Toggle the backlight on or off (also goes through backlight
power levels if held down)

Access the Pocket PC Record application (see Noze).
Access the Pocket PC Calendar application (see Note).
Access the Pocket PC Contacts application (see Note).
Access the Pocket PC Tasks application (see Note).
Move up one page.

Enter an asterisk (*).

Move down one page.

Access the Pocket PC Start menu.

Enter an at symbol (@).

Enter a backslash (/).

Enter a minus sign (-).

Enter a plus sign (+).

Tab to the right.

Tab to the left.

Increase volume

Decrease volume

Note: Pocket PC applications are accessible only if configured to do so in the App Launch
portion of the Utilities control panel applet. See page 358 for more information.

700 Series Color Mobile Computer User’s Manual
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Chapter 1 — Introduction

Alpha (Blue) Plane Keys
The alphabet can be entered with either the numeric keypad or the alpha-

numeric keypad. Below and on the next page are the key sequences.

Numeric Keypad
When you press (), the Scanning/Alpha LED (+/@©) shows ‘red’ for
the Alpha mode. The keypad stays in Alpha mode until you press (aer.

To type a lowercase ‘c,” press (the [2] key three
times). To type a letter on the same key as the last letter entered, wait two
seconds, then enter the correct series of keystrokes to create the next letter.

While you are in the Alpha mode and you press to initiate the CAPS
mode, you will render a CAPS LOCK until you press again. Once
you are in CAPS mode, you stay in CAPS until it is pressed again.

Press to enter a space.
ToEnter Pressthe Keys ToEnter Pressthe Keys
a A
b B
c C
d D
e E
f F
8 G
h H
i I
j J
k K
l L
m M
n N
o O
p P
q Q
; R
s S
i T
u U
v \
w W
x X
y Y
z z
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Alphanumeric Keypad

When you press @, the Scanning/Alpha LED (+/©) lights ‘red’ to indi-
cate Alpha mode. The keypad stays in the Alpha mode until you press @
again.

If you want to type a lowercase ‘c,” press @ (c#). If you want an uppercase
y p P < y pp

“C,” press and hold the &%) key, then press (c).

Press (sexce) to enter a space.

ToEnter Pressthe Keys ToEnter Pressthe Keys
a @ (v A @ & (v
b B @ & .
¢ ® @ C ®® @
d D @ & .
f ) F )
g @ (v G @ @ @
h @) H D,
i @ O I @ @ v
j J
! @ L @ @ @
m @ 1) M @ & o)
n (w2) N @ & o2
0 @ (3 O @ (@ (3
P P @ @ &
q @ (o) Q @ @ (@)
r R @ @ Gy
s @ 9 S @ @ (9
e (7s) T (75)
u @ (o) U @ & @
v @) 4 @)
x X
y @ (v9) Y @ @ (o)
z z
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Modem Support

The 700 ColorComputer has the following modem options:

* Modem dock that provides charging and includes a built-in modem and
a serial port between which an application can switch.

* Snap-on modem, a stand-alone product, that attaches to the bottom of
your 700 Color Computer. Note that you cannot place this modem in a
dock, printer, or other devices. Contact your Intermec representative for
more information.

PSM Build Version

16

»

File Explorer

The Persistent Storage Manager (PSM) is an area of storage which is em-
bedded in a section of the system’s FLASH memory. This storage area is
not erased during a cold-boot. It may, however, be erased during the re-
flashing process. In addition to storing applications and data files, you do
have the option to store a persistent registry to the PSM region.

To determine what PSM Build is on your 700 Color Computer, tap Start
> Programs > File Explorer. Access the Flash File Store folder from the
My Device root directory, then tap the PSMinfo text file. Take note of
your information, then tap ok to exit.

Fi% Packet Word it 4c1zz0 D
PSM Build 3,65 (12-4-2004)

New Edit Yiew Tools ' E|‘
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Resetting Your 700 Color Computer

In some cases where the 700 Color Computer completely stops respond-
ing, it may be necessary to perform a cold reset. Because cold resetting may
result in data loss, it is not recommended unless all other recovery methods

have failed.

% Note: Cold resetting deletes all programs and data stored in RAM includ-
ing the Object Store. Make sure data is backed up to your host computer
or a storage card before performing a cold reset.
1 Release the lower clip of the hand strap.
2 Remove the battery pack.
3 Press the Reset button.

4 Reinstall the battery pack.

®

q A\
Reset button ﬁ] Reset button
| — /

hn »

o
= ¢

700 Color Computer 730 Computer

This illustration shows the back of the 700 Color Computer on the left and of the 730 Computer on the right.
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Software Build Version

18

o

Unit
Information

To check to see if your 700 Color Computer has the latest software build,
select Start > Internet Explorer > the Intermec logo.

’ntermec:

The latest software build version is displayed beneath the Version
Information title. This information would be useful should you need
assistance.

| Internet Explorer «F £ 12:25 9 [j Internet Explorer + L1244 9

file; { fiwindowrs) 16_0OEM . Him | ﬁ*

’ntermec =

file; { fiwindowrs) 16_0OEM . Him | ﬁ*

’ntermec =

Version Information Version Information

Software Build w441 Pramium Saoftware Build w4.41 Phone (COMA)

Patent Information Patent Information

This product is covered by the following
LIS patents:

This product is covered by the following [~
LIS patents:

4,455,523 5,410,141 5,740,366
4,553,081 5,425,051 5,700,536
4,700,202 5,468,247 5,505,207
4,737,702 5,488,575 5,962,171

¥iew Tools <& € i} <% E|‘

4,455,523 5,410,141 5,740,366
4,553,081 5,425,051 5,700,536
4,700,202 5,468,247 5,505,207
4,737,702 5,488,575 5,962,171

¥iew Tools <& € i} <% E|‘
761 Units with CDMA

A
A

730, 740, 750, 760 Units

For Units With PSM Builds Older than 3.00

You can also view the latest software build by accessing the Unit
Information control panel applet. Select Start > Settings > the System tab
> the Unit Information icon > the Versions tab to view the current build.

P it 4123 O

- DataCollzckion Build, <searavimng3, 123 =

|Qefaults | | Refresh | | apply | |Qefaults | | Refresh | | apply |

Versions | Battery Status | CaE Files |

Versions | CAG Files | Battery Status |

B[

700 Color Screen

730 Screen
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CompactFlash Cards

Secure Digital Cards

Chapter 1 — Introduction

Note: MultiMediaCards (MMCs) are not supported in 700 Color Com-

puters.

The 700 Color Computer supports both CompactFlash and Secure Digital
storage cards. To access either card slot, locate the access door at the top of
the 700 Color Computer, remove its two screws, then remove the door.
See the 700 Color with Windows Mobile 2003 Quick Start Guide (P/N:
962-054-069) for more information.

The 730 Computer only supports the Secure Digital storage card. The
CompactFlash card slot is embedded in the 730 Computer and cannot be
removed. To access the Secure Digital card slot, locate the access door at
the top of the 730 Computer, remove its screws, then remove the door.
See the Model 730 Mobile Computer Quick Start Guide (P/N:
962-054-068) for more information.

On 700 Color Computers, the CompactFlash card slot accepts either a
storage card or the 802.11b or 802.11b/g radio, which is factory-installed
and cannot be removed. The 730 Computer does not support Compact-
Flash storage cards.

The Secure Digital card slot accepts storage cards only.

Storage Media
Access Door

700 Color Computer 730 Computer

This illustration shows the top of the 700 Color Computer on the left and of the 730 Computer on
the right. Note that the keypad is to the bottom.
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Vibrator

% Note: This information does 7oz apply to the 730 Computer.

If your 700 Color Computer is built with an imager or scanner and the
vibrator is disabled, do the following instructions to enable the vibrator. If
you are not able to enable the vibrator, then contact Customer Support.

For information about setting volume levels for screen taps, ActiveSync
alert noises, etc., tap Start > Help > Pocket PC Basics, then select
Notifications.

See Chapter 7, “Programming,” to see how to programmatically control the
vibrator. See Appendix A, “Configurable Settings,” for more information
about the Beeper Volume option.

% Note: Each time the 700 Color Computer is cold-booted, all default set-

tings are restored.

For Units With PSM Builds Older than 3.00

1 Tap Start > Settings > the System tab > Data Collection to access its
control panel applet.

12 345

EDR:E;DH 2 Use the right and left arrows to scroll to the Beeper/LED tab, then tap

this tab.
3 Tap Beeper, select the “Vibrate” option, then tap Apply.

4 Tap ok to confirm this change, then tap ok to exit the Data Collection
control panel applet.

it 4f1z4e D

Data Collection

----- Beeper, <Yibrate =

Change 'Beeper' Setting

Eeeper

@ vibrate
|Qefaults | | Refresh | | apply |
Symbology Options | Beeper/LED ImagerEE

B[
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Intermec
Settings

E4
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For Units With PSM Build 3.00 or Newer

Do the following to enable the vibrator for the 700 Color Computer. Tap
Start > Settings > the System tab > the Intermec Settings icon. Tap the
Device Settings option, tap (+) to expand Beeper, then tap (+) to expand
Vibrate. Select an item, then close this option.

fﬂj‘ Intermec Settings +] £ 12:19 €3

Stahners, Syrnbologies
Communications
Device Settings
= Beeper

B Wolurme
=l Wibrate
& Beegper

- wibrate

B~ Unit good read beep

[+ Display

H-Powet Manadement

- Systemn Component Yersions
Applications

File Edit Yiew Help| [l B[

Note: Information about the settings you can configure with the Intermec
Settings control panel applet is described in the Intermec Computer Com-
mand Reference Manual. The online manual is available from the Intermec
web site at www.intermec.com

Wireless Network Support

E4

700 Series Color Mobile Computer User’s Manual

Radios are installed at the factory and cannot be installed by a user. The
700 Color Computer must be serviced to install or replace radios. Contact
your Intermec representative for more information. See Chapter 4, “Net-
work Support” for information about supported radios.

Note: Changes or modifications not expressly approved by Intermec
Technologies Corporation could void the user’s authority to operate the
equipment.
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Accessories
The following accessories are available for the 700 Color Computer. Noze
that this is not a complete list. Contact your Intermec representative for in-
formation about these and other accessories that are not in this list.
Intermec
Accessory Descriptions Part Number 700 Color 730 Computer
Single Dock Charger with Ethernet and Auxiliary Battery Charger 225-681-001 X xx
Single Dock Charger with USB and Ethernet 225-683-001 X X **
Quad Battery Charger 852-060-001
852-054-001 X
Single Battery Charger 852-060-002 X
Multidock — Charge Only (holds four 700 Computers) 225-682-004 X X
Multidock Charging with Ethernet support (holds four units) 225-682-003 X
Modem Dock 225-683-002 X X
Vehicle Dock 225-685-001 X X
Vehicle Cradle 225-680-101 X X
Snap-On Modem 225-687-001 X
Long Range Tethered Scanning Adapter (3.3v to 5v) 225-686-002 X
DEX Adapter 225-683-001 X
Standard Scan Handle Option 714-525-001 X
714-502-001 X
Dockable Scan Handle 714-525-002
Belt Clip 805-612-001 X X
** No Ethernet Support

What's New

These changes have occurred since the last release of this manual, to in-
clude software changes from software version 4.0:

* Added information about resetting the 700 Color Computer in this
chapter.

* Revised information about using Sprint Watcher and a Phone applica-
tion for 741, 751, or 761 Computers with CDMA or GSM radios in
Chapter 4, “Network Support.”

* Updated information about the Profile Wizard in Appendix A, “Confi-
gurable Settings.”

* Updated the manual to include 741, 751, and 761 Computers and the
MC46 Radio.
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2 Windows Mobile 2003

This chapter introduces Microsoft Windows Mobile 2003 for Pocket PC.
While using your 700 Color Computer, keep these key points in mind:

e Tap Start on the navigation bar, located at the top of the screen, to
quickly move to programs, files, and settings. Use the command bar at
the bottom of the screen to perform tasks in programs. The command
bar includes menus, buttons, and the onscreen keyboard.

* Tap and hold an item to see a pop-up menu containing a list of actions
you can perform. Pop-up menus give you quick and easy access to the
most common actions.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.

| Below is a list of Windows Mobile 2003 components described in this
chapter. Tap Start > Help on your 700 Color Computer to find additional

information on Windows Mobile components.

Windows Mobile 2003 Components
Microsoft ActiveSync Client (page 44)
Microsoft Pocket Outlook (page 46)

Pocket Word (page 78)

Pocket Excel (page 82)

MSN Messenger (page 84)

Windows Media Player for Pocket PC (page 89)
Microsoft Reader (page 90)

Pocket Internet Explorer (page 94)
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Software Builds

Do the following to determine which Intermec build of Windows Mobile
2003 is on your unit.

1 Select Start > Internet Explorer > the Intermec logo.

’ﬂterm ec

2 Note the “Software Build” information displayed beneath the Version
Information title.

file; { fiwindowrs) 16_0OEM . Him | ﬁ* file: f fiwindowrs), 16_0EM, htm | ﬁ*

fntermec = Iatermec —

Version Information Version Information

Software Build w441 Pramium - Saoftware Build w4.41 Phone (COMA) -

Patent Information Patent Information

This product is covered by the following [~ This product is covered by the following [~

LS patents: LS patents:

4,455,523 5,410,141 5,740,366 4,455,523 5,410,141 5,740,366

4,553,091 5,425,051 5,790,536 4,553,091 5,425,051 5,790,536

4,709,202 5,468,947 5,805,507 4,709,202 5,468,947 5,805,507

4,737,702 5,488,575 5,962,171 |4 4,737,702 5,488,575 5,962,171 |4

¥iew Tools <& € i} <% E|‘ ¥iew Tools <& € i} <% E|‘
730, 740, 750, 760 Units 761 Units with CDMA

3 Tap the Close icon in the top right corner to exit the Internet Explorer.
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Where to Find Information

Chapter 2 — Windows Mobile 2003

This chapter describes your 700 Color Computer hardware, provides an
overview of the programs on your 700 Color Computer, and explains how
to connect your 700 Color Computer to a desktop, a network, or the In-
ternet. For instructions on setting up your 700 Color Computer and
installing ActiveSync, see the Quick Start Guide. The following is a guide
to more information to assist you use your 700 Color Computer.

For information on:

Programs on your mobile computer.

Additional programs that can be installed on the mobile
computer.

Connecting to and synchronizing with a desktop.

Last-minute updates and detailed technical information.

Up-to-date information on your Windows Mobile.

See this source:

This chapter and mobile computer Help. To view Help,
tap Start > Help.

The Windows Mobile Companion CD.

The Quick Start Guide or AutoSync Help on your desk-
top. To view Help, click Help > Microsoft ActiveSync
Help.

The Read Me files, located in the Microsoft ActiveSync
folder on the desktop and on the Windows Mobile Com-
panion CD.

http://www.microsoft.com/windowsmobile/resources/
communities/default. mspx

Windows Mobile and many of the technologies supported by the 700 Col-
or Computer are not from Intermec Technologies. Many of the utilities
and features on a Windows Mobile device come directly from Microsoft
without any modification from Intermec Technologies. There may be cer-
tain Microsoft-specific issues that Intermec Technologies would not be
able to support, so contact our front-line support personnel to determine
the best source of assistance.

Use these URLs for additional information about Microsoft Windows

Mobile (Pocket PC):

* http://msdn.microsoft.com/support/

* http://support.microsoft.com/

* news://news.microsoft.com ( free support option)

700 Series Color Mobile Computer User’s Manual
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Basic Skills

Today Screen

26

Today

Learning to use your 700 Color Computer is easy. This section describes
the basic concepts of using and customizing your 700 Color Computer.

When you turn on your 700 Color Computer for the first time each day
(or after four hours of inactivity), you see the Today screen. You can also
display it by tapping the Start flag (shown left) and then Today. On the

Today screen, you can see important information for the day.

Tap to start a program. Tap and hold to change time format.

Start

Friday, March 21, 200 —— Tap to change date and time.
Tap here to s er information Tap to change owner
ents information.

Your day at a glance. Tap
to open the associated

program.

Nﬁw @gﬁl T
Tap to create a | Tap to disconnect from ActiveSync.
new item.

To customize what is displayed on the Today screen, including the back-
ground image, tap Start > Settings > the Personal tab > Today.

Status icons display information such as low batteries or when the 700
Color Computer is connected to a desktop or to the Internet. You can tap
an icon to open the associated setting or program.
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Programs

You can switch from one program to another by selecting it from the Start
menu. (You can customize which programs you see on this menu. For
information, see “Adjusting Settings” on page 41.) To access some
programs, tap Start > Programs, and then the program name.

You can also switch to some programs by pressing a program button. Your
700 Color Computer has one or more program buttons located on the
front or side of the computer. The icons on the buttons identify the pro-
grams to which they switch.

ﬁ Note: Some programs have abbreviated labels for check boxes and drop-
down menus. To see the full spelling of an abbreviated label, tap and hold
the stylus on the label. Drag the stylus off the label so that the command is

not carried out.

The following is a partial list of programs that are on your 700 Color
Computer. Look on the Windows Mobile Companion CD for additional
programs that you can install onto your 700 Color Computer.

3 ActiveSync

Synchronize information between your 700 Color Computer and desktop.

i@ Calendar

Keep track of your appointments and create meeting requests.

BB Contacts

Keep track of your friends and colleagues.

Send and receive e-mail messages.

< Internek E:-:plurf_jr

Browse Web and WAP (Wireless Application Protocol) sites, and down-
load new programs and files from the Internet.

|W Notes

Create handwritten or typed notes, drawings, and recordings.

Keep track of your tasks.

Play digital audio and video files that are stored on your 700 Series Com-
puter or on a network.
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Navigation Bar and Command Bar

28

The navigation bar is located at the top of the screen. It displays the active
program and current time, and allows you to switch to programs and close

screens.

LGB

€, Today

1 AckiveSync

A Avalanche

3 Calendar

B§ Contacts

& Inbox

#* Internet Explorer
| Notes "
M Tasks

G windows Media
¥ Programs

W Setfings
B Find

7 |Help

Vi £ 3:51

Tap to switch to a program
that you recently used.

— Tap to switch to a program.

Tap to see more programs.
Tap to change device
settings.

Tap to see a Help topic
for the current screen.

Use the command bar at the bottom of the screen to perform tasks in pro-
grams. The command bar includes menu names, buttons, and the Input
Panel button. To create a new item in the current program, tap New. To
see the name of a button, tap and hold the stylus on the button. Drag the
stylus off the button so that the command is not carried out.

New Edit Tools

E|‘ Tap to display the input

Tap to select

menu commands.

panel.

I Tap to select
button commands.
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Pop-up Menus

Notifications

Chapter 2 — Windows Mobile 2003

Use pop-up menus to quickly perform an action on an item. For example,
you can use a pop-up menu to delete or make a copy of an item. To access
a pop-up menu, tap and hold the item on which you want to perform the
action. When the menu appears, tap the action you want to perform, or
tap anywhere outside the menu to close the menu without performing the
action.

rf1ze €
All Tasks Priority
1 || Tap here to add a new task |

[]* send status report
Buy birthday gift
Call Maria

Proof new proposal

W L Srhedule message
Create Copy

Delete Task

L]
H

oog

| Tap and hold to display the
pop-up menu.

Lift the stylus and tap the action
you want.

Beam Task...

Tap outside the menu to
close it without performing
an action.

Mew Tools B |‘

When you have something to do, your device notifies you in a variety of
ways. For example, if you have set up an appointment in Calendar, an e-
mail message arrives, or a friend sends you an instant message, you are no-
tified in any of the following ways:

* A message box appears on the screen.

* A sound, which you can specify, is played.

* A light flashes on your 700 Color Computer.
* The 700 Color Computer vibrates.

You can choose the notification types.
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Entering Information

30

You can enter information on your 700 Color Computer in several ways,
depending on the type of device you have and the program you are using:

* Synchronizing
Using Microsoft ActiveSync, synchronize or copy information between
your desktop and 700 Color Computer. For more information on Acti-
veSync, see ActiveSync Help on your desktop.

¢ Typing
Using the input panel, enter typed text into the 700 Color Computer.
You can do this by tapping keys on the onscreen keyboard or by using
handwriting recognition software.

* Writing
Using the stylus, write directly on the screen.

¢ Drawing
Using the stylus, draw directly on the screen.

* Recording
Create a stand-alone recording or embed a recording into a document or
note.

Use the input panel to enter information in any program on your 700
Color Computer. You can either type using the onscreen keyboard or
write using Block Recognizer, Letter Recognizer, or Transcriber. In either
case, the characters appear as typed text on the screen.

To show or hide the input panel, tap the Input Panel button. Tap the ar-
row next to the Input Panel button to see your choices.

y1[2]3]4]5
Tab[a[wle]r )
Eanp|| a|| S|| d|| f| * Keyboard Select an input method.
Shiftl 7 | T | C | y | Letter Recognizer

[ltllél'j| B | \ | Transcriber

New Tools = ‘ Tap to see your choices.

Block Recognizer

Input Panel button.‘
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When you use the input panel, your 700 Color Computer anticipates the
word you are typing or writing and displays it above the input panel.
When you tap the displayed word, it is inserted into your text at the
insertion point. The more you use your 700 Color Computer, the more
words it learns to anticipate.

|
Subject: Statls Meeting S
Lacations [Boar ~]— Tap atext box to display
Starts: B/4/03  12:00PM - the currently selected
Ends: 274,03 1:00 P A input panel (in this case,
AlDay: Mo Keyboard).
Oceurs: Once
Reminder: Remind me
15 minuteds)
Categories: Mo categories...
Appaintment I\-.IotEIBEIardSJ— Tap to insert anticipated
123123 4|5|ﬁ|?|3|9|ﬂ| = word.
Tabja|wle[r [t[y[ufi]o[p |
caPla[s[d[f[a]h]iJk]I1]:]" Jr* To enter characters, tap
chift|z [ [c|v[b|n[m]|,]|. [/]#+| them onthe onscreen
ctifai] * [ ] [+][t]e]=2] keyboard.

Edit [E3[+]

To change word suggestion options, such as the number of words sug-
gested at one time, tap Start > Settings > the Personal tab > Input > the
Word Completion tab.

Typing With the Onscreen Keyboard
Tap the arrow, then tap Keyboard. On the soft keyboard that is dis-
played, tap the keys with your stylus.

* To type lowercase letters, tap the keys with the stylus.

* To type a single uppercase letter or symbol, tap the Shift key. To tap
multiple uppercase letters or symbols, tap the CAP key.

* To convert a letter to uppercase, tap and hold the stylus on the letter
and drag up.

* To add a space, drag the stylus to the right across at least two keys.

* To backspace one character, drag the stylus to the left across at least
two keys.

e To insert a carriage return, tap and hold the stylus anywhere on the
keyboard and drag down.

123{1[2[3[4a[5]a]7][8]9][0]-]=
Tablg[wle[r|t[y[ufilo[p[L]]
capla[s[d[f[a][n[j]k]1
Shiftf z [x[c[¥[b[n[m
ctifan] " [\ ]
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% Note: If you want to use larger keys, tap the arrow, tap Options,
select “Keyboard” from the Input method drop-down list, then select
Large keys.

¥ |Settings & gcrso O

Input method: |KevbDard - |

@ Large keys Hn
O amall keys ﬂnm

D Lze gestures Far the Fallowing lkeys and
remave them From the kevboard

E)Space Ii—l Shift + key
+E| Backspace |I| Enter

Input Method | Waord Completion | Options |

I stywlus taps become inaccurate, align the
touch screen,

B[

Using Block Recognizer

Character recognition software gives you a fast and easy method for enter-
ing information in any program on your 700 Color Computer. Letters,
numbers, and punctuation you write are translated into typed text.

=l szer. Wri -

Tap the ) arrow, then tap Block Recognizer. Write a letter in the box.
When you write a letter, it is converted to typed text that appears on the
screen.

For specific instructions on using Block Recognizer, with Block Recogniz-
er open, tap the question mark next to the writing area.

lal 123

3

Spoy

- Tap for assistance.

\"Jt‘l'

o
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Using Letter Recognizer
With Letter Recognizer, you can write letters using the stylus just as you
would on paper.

Tap the arrow, then tap Letter Recognizer. Write a letter in the box.
When you write a letter, it is converted to typed text that appears on the
screen. For specific instructions on using Letter Recognizer, with Letter
Recognizer open, tap the question mark next to the writing area.

BBC T abc T 129 @

|
PEEE
T

2G Tap for assistance.

o

Using Transcriber

With Transcriber, you can write anywhere on the screen using the stylus
just as you would on paper. Unlike Letter Recognizer and Block Recogniz-
er, you can write a sentence or more of information. Then, pause and let
Transcriber change the written characters to typed characters.

Tap the

For specific instructions on using Transcriber, with Transcriber open, tap
the question mark in the lower, right-hand corner of the screen.

arrow, then tap Transcriber. Write anywhere on the screen.

|f B& @ | .rl?[* Tap for assistance.
[

Selecting Typed Text

If you want to edit or format typed text, you must select it first.
* Drag the stylus across the text you want to select.

You can cut, copy, and paste text by tapping and holding the selected
words and then tapping an editing command on the pop-up menu, or by
tapping the command on the Edit menu.
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Writing on the Screen

In any program that accepts writing, such as the Notes program, and in
the Notes tab in Calendar, Contacts, and Tasks, you can use your stylus to
write directly on the screen. Write the way you do on paper. You can edit
and format what you have written and convert the information to text at a
later time.

* Tap the Pen button to switch to writing mode. This action displays
lines on the screen to help you write.

#3 |Notes o 42113

LEPokT!

-

New Edit Tools [ =]

‘ Tap to use your stylus like a pen.

% Note: Some programs that accept writing may not have the Pen button.
See the documentation for that program to find out how to switch to writ-
ing mode.

Selecting the Writing
If you want to edit or format writing, you must select it first.

1 Tap and hold the stylus next to the text you want to select until the in-
sertion point appears.

2 Without lifting, drag the stylus across the text you want to select.

If you accidentally write on the screen, tap Tools > Undo and try again.
You can also select text by tapping the Pen button to deselect it and then
dragging the stylus across the screen.

You can cut, copy, and paste written text in the same way you work with
typed text: tap and hold the selected words and then tap an editing com-
mand on the pop-up menu, or tap the command on the Edit menu.
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Converting Writing to Text
You can convert words you write in print or cursive to text by tapping
Tools > Recognize. If a word is not recognized, it stays in its written form.

If you want to convert only certain words, tap Pen to disable the writing
function, tap twice over the word or phrase to highlight, then tap Tools >
Recognize.

o 45118 G

Recognize
Alternates...

Send via E-mail...
Beam Mote...

T50%

* 100%
150%%
200%n
300%n

Rename/Movej.

Delete Note I+| +|

New Edit Tuuls| = E|‘ New Edit Tools (= 7 E|‘

Select the text you want to
convert and tap Recognize
on the pop-up menu.

The writing is turned
into text.

Tap to disable the pen function.

If the conversion is incorrect, you can choose different words from a list of
alternates or return to the original writing. To do so, tap and hold the
incorrect word (tap one word at a time). On the pop-up menu, tap
Alternates. Tap the word you want to use from the menu with a list of
alternate words, or tap the writing at the top of the menu to return to the
original writing.

o 4120 @

{ Eme;rf Tap to return to your
report! || original writing.

repork;
report'. Or, tap the word you
want to use.
New Edit Tools = 27 E|‘
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Tips for getting good recognition:

Write neatly.

Write on the lines and draw descenders below the line. Write the cross
of the “t” and apostrophes below the top line so they are not confused
with the word above. Write periods and commas above the baseline.

For better recognition, try increasing the zoom level to 300% by using
the Tools menu. Recognition does not work well below a 150% zoom
level.

Write the letters of a word closely and leave big gaps between words so
that the 700 Color Computer can easily tell where words begin and end.

Hyphenated words, foreign words that use special characters such as ac-
cents, and some punctuation cannot be converted.

If you add writing to a word to change it (such as changing a “3” to an
“8”) after you attempt to recognize the word, the writing you add is not
included if you attempt to recognize the writing again.
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Drawing on the Screen

You can draw on the screen in the same way that you write on the screen.
The difference between writing and drawing on the screen is how you se-
lect items and how they are edited. For example, you can resize selected
drawings, while you cannot resize writing.

Creating a Drawing

* Cross three ruled lines on your first stroke. A drawing box appears. Sub-
sequent strokes in or touching the drawing box become part of the dra-
wing. Drawings that do not cross three ruled lines are treated as writing.

53 |Nates o 42 1002 ¢

\K/

N X

The drawing box indicates
the boundaries of the
drawing.

-

New Edit Tools [ =]

Pen button.

% Note: You may want to change the zoom level so that you can more easily
work on or view your drawing. Tap Tools and then a zoom level.

Selecting a Drawing
If you want to edit or format a drawing, you must select it first.

* Tap and hold the stylus on the drawing until the selection handle ap-
pears. To select multiple drawings, deselect the Pen button and then
drag to select the drawings you want.

You can cut, copy, and paste selected drawings by tapping and holding the
selected drawing and then tapping an editing command on the pop-up
menu, or by tapping the command on the Edit menu. To resize a drawing,
make sure the Pen button is not selected, and drag a selection handle.
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Recording a Message

38

In any program where you can write or draw on the screen, you can also
quickly capture thoughts, reminders, and phone numbers by recording a
message.

In the Inbox program, you can add a recording to an e-mail message. In
Calendar, Tasks, and Contacts, you can include a recording in the Notes

tab. In the Notes program, you can create a stand-alone recording or add a
recording to an open note.

Creating a Recording
1 Hold the 700 Color Computer’s microphone near your mouth or
source of sound.

2 Tap El and make your recording.

3 Tap El when finished. If you are recording in an open note, an icon
appears in the note. If you are creating a stand-alone recording, it ap-
pears in the note list.

4 To play a recording, tap the recording icon in the open note or tap the
recording in the note list.

Note: To quickly create a recording, hold down the Record hardware but-
ton. When you hear the beep, begin your recording. Release the button
when you are finished. The new recording is stored in the open note or as
a stand-alone recording if no note is open.

To play a recording, tap it in the list or tap its icon in the note.

#3 |Notes o 42 21z O
)] -
Indicates an em-

bedded recording.

Quote from
Adam

(@ [m]» [U——— e o]t

ew Edit Tuuls||3||_£| E|‘

Zz

‘ Tap to show or hide the Recording toolbar.

Tap to begin recording.
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Using My Text

When using Inbox or MSN Messenger, use My Text to quickly insert pre-
set or frequently used messages into the text entry area. To insert a mes-
sage, tap My Text and tap a message.

* To quickly add common messages, tap My Text and tap a desired mes-
sage.

* To edit a My Text message, tap Tools > Edit My Text Messages. Tap
the message you want to edit and enter new text at the bottom of the
screen.

& gcens D

=7 | To Adam

Send [Subj: Finance Meeating

L

Hi, Can wou meet at 2007

Yes.
Mo.
Thanks.
Please call my assistant.
I'll be right there.

I'm running late.

I'll get back to you.

I love my Pocket POY
Edit|My Text|[F] (= B[

‘ Tap to select a prewritten message.
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Finding and Organizing Information

40

F4
»

File Explorer

The Find feature on your 700 Color Computer helps you quickly locate
information.

Tap Start > Find. Enter the text you want to find, select a data type, and
then tap Go to initiate the search.

Note: To quickly find information that is taking up storage space on your
700 Color Computer, select Larger than 64 KB in Type.

You can also use the File Explorer to find files on your 700 Color Com-
puter and to organize these files into folders. Tap Start > Programs > File
Explorer.

.}:j' File Explorer - < 9:39 9

My Device - Name «

[=1ConnMgr —— Tap the folder name
[#]Flash File Store to open it.
Chftpdemds

1My Documents

[Caprofiles

[CS1Program Files

ChTemp

E1wWindows

$4DIRLLK 7/15/03 &0B

Paste Shortcut
select all

New Folder
Edit|open [~ [F] M /2 =]

Tap New Folder to
create a new folder.

Note: You can move files in File Explorer by tapping and holding the item
you want to move, and then tapping Cut or Copy and Paste on the pop-
up menu.
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Customizing Your 700 Color Computer

You can customize your 700 Color Computer by adjusting settings and
installing additional software.

Adjusting Settings

You can adjust settings to suit the way you work. To see available options,
tap Start > Settings > either of the following tabs located at the bottom of
the screen. You might want to adjust the following:

Personal Tab

Menus:

To customize what appears on the Start menu, and to enable a pop-up
menu from the New button.

Owner Information:
To enter your contact information.

4
1]
3
[
W

DOwner
Information

Password:
To limit access to your 700 Color Computer.

b

Password
Today:
% To customize the look and information displayed on the Today screen.
Today
System Tab
Clock:

&)

To change the time or to set alarms.

=
=]
fal
=

Power:
To maximize battery life.

-
=] { }
3
1]
-

Adding or Removing Programs

Programs added to your 700 Color Computer at the factory are stored in
ROM (Read Only Memory). You cannot remove this software, and you
cannot accidentally lose ROM contents. ROM programs can be updated
using special installation programs with a *.XIP extension. All other pro-
grams and data files added to your 700 Color Computer after factory
installation are stored in RAM (Random Access Memory).

You can install any program created for your 700 Color Computer, as long
as your 700 Color Computer has enough memory. The most popular
place to find software for your 700 Color Computer is on the Windows
Mobile Web site (http://www.microsoft.com/windowsmobile/resources/
communities/default. mspx).
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About

About

Adding Programs Using ActiveSync
Install the appropriate software for your 700 Color Computer on your
desktop before installing it on your 700 Color Computer.

1

Determine your 700 Color Computer and processor type so that you
know which version of the software to install. Tap Start > Settings > the
System tab > About > the Version tab, then make a note of the
information in Processor.

Download the program to your desktop (or insert the CD or disk that
contains the program into your desktop). You may see a single *.XIP,
* EXE, or *.ZIP file, a SETUP.EXE file, or several versions of files for
different 700 Color Computer types and processors. Be sure to select
the program designed for the Windows Mobile and your 700 Color
Computer processor type.

Read any installation instructions, Read Me files, or documentation that
comes with the program. Many programs provide special installation
instructions.

Connect your 700 Color Computer and desktop.

5 Double-click the *.EXE file.

e If the file is an installer, the installation wizard begins. Follow the di-
rections on the screen. Once the software is installed, the installer au-
tomatically transfers the software to your 700 Color Computer.

e If the file is not an installer, an error message stating that the program
is valid but it is designed for a different type of computer is displayed.
Move this file to your 700 Color Computer. If you cannot find any
installation instructions for the program in the Read Me file or docu-
mentation, use ActiveSync Explore to copy the program file to the
Program Files folder on your 700 Color Computer. For more infor-
mation on copying files using ActiveSync, see ActiveSync Help.

Once installation is complete, tap Start > Programs, and then the program
icon to switch to it.

Adding a Program Directly from the Internet

1

Determine your 700 Color Computer and processor type so that you
know which version of the software to install. Tap Start > Settings > the
System tab > About > the Version tab, then make a note of the
information in Processor.

Download the program to your 700 Color Computer straight from the
Internet using Pocket Internet Explorer. You may see a single *.XIP,

* EXE, or *.ZIP file, a SETUP.EXE file, or several versions of files for
different 700 Color Computer types and processors. Be sure to select
the program designed for the Windows Mobile and your 700 Color
Computer processor type.

Read program installation instructions, Read Me files, or other docu-
mentation. Many programs provide installation instructions.

4 Tap the file, such as a * XIP or *.EXE file to start the installation wi-

zard. Follow the directions on the screen.
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Adding a Program to the Start Menu

Tap Start > Settings > Menus > the Start Menu tab, and then the check
box for the program. If you do not see the program listed, you can either
use File Explorer on the 700 Color Computer to move the program to the
Start Menu folder, or use ActiveSync on the desktop to create a shortcut
to the program and place the shortcut in the Start Menu folder.

Using File Explorer on the 700 Color Computer
%) Tap Start > Programs > File Explorer, and locate the program (tap the

File Explorer  folder list, labeled My Documents by default, and then My Device to see a
list of all folders on the 700 Color Computer). Tap and hold the program
and tap Cut on the pop-up menu. Open the Start Menu folder located in
the Windows folder, tap and hold a blank area of the window, and tap
Paste on the pop-up menu. The program now appears on the Start menu.
For more information on using File Explorer, see “Finding and Organizing
Information” on page 40.

Using ActiveSync on the desktop

Use the Explorer in ActiveSync to explore your 700 Color Computer files
and locate the program. Right-click the program, and then click Create
Shortcut. Move the shortcut to the Start Menu folder in the Windows
folder. The shortcut now appears on the Start menu. For more informa-
tion, see ActiveSync Help.

Removing Programs
Tap Start > Settings > the System tab > Remove Programs.

Remove If the program does not appear in the list of installed programs, use File
Programs Explorer on your 700 Color Computer to locate the program, tap and
hold the program, and then tap Delete on the pop-up menu.
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Microsoft ActiveSync
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Visit the following Microsoft Web site for the latest in updates, technical
information, and samples:

http://www.microsoft.com/windowsmobile/resources/communities/de-
fault.mspx

Using Microsoft ActiveSync, you can synchronize the information on your
desktop with the information on your 700 Color Computer. Synchroniza-
tion compares the data on your 700 Color Computer with your desktop

and updates both computers with the most recent information. For exam-

ple:

* Keep Pocket Outlook data up-to-date by synchronizing your 700 Color
Computer with Microsoft Outlook data on your desktop.

* Synchronize Microsoft Word and Microsoft Excel files between your
700 Color Computer and desktop. Your files are automatically con-
verted to the correct format

Note: By default, ActiveSync does not automatically synchronize all types
of information. Use ActiveSync options to turn synchronization on and off
for specific information types.

With ActiveSync, you can also:
* Back up and restore your 700 Color Computer data.

* Copy (rather than synchronize) files between your 700 Color Computer
and desktop.

* Control when synchronization occurs by selecting a synchronization
mode. For example, you can synchronize continually while connected to
your desktop or only when you choose the synchronize command.

* Select which information types are synchronized and control how much
data is synchronized. For example, you can choose how many weeks of
past appointments you want synchronized.

Before you begin synchronization, install ActiveSync on your desktop from
the Windows Mobile Companion CD. For more information on installing
ActiveSync, see your Quick Start card. ActiveSync is already installed on
your 700 Color Computer.

After installation is complete, the ActiveSync Setup Wizard helps you con-
nect your 700 Color Computer to your desktop, set up a partnership so

you can synchronize information between your 700 Color Computer and
your desktop, and customize your synchronization settings. Your first syn-
chronization process automatically begins when finished using the wizard.

After your first synchronization, look at Calendar, Contacts, and Tasks on
your 700 Color Computer. Notice that information you have stored in
Microsoft Outlook on your desktop was copied to your 700 Color Com-
puter, and you did not have to type a word. Disconnect the 700 Color
Computer from your computer and you are ready to go!
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Once you have set up ActiveSync and completed the first synchronization
process, you can initiate synchronization from your 700 Color Computer.
To switch to ActiveSync on your 700 Color Computer, tap Start >
ActiveSync. Note that if you have a wireless LAN card, you can
synchronize remotely from your 700 Color Computer.

For information about using ActiveSync on your desktop, start ActiveSync
on your desktop, and then see ActiveSync Help.

i rf1a

— 1
Connected View connection status.

Tap to connect and synchronize.

Tap to stop synchronization.

]
@ Syne g Stap

Synchronize with Windows PC
Last Sync: 7/11/04 7:46 AM

View synchronization status.

Tn‘uls B |‘

Tap to synchronize via IR or change
synchronization settings.

For more information about ActiveSync on your 700 Color Computer,
switch to ActiveSync, then tap Start > Help.
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Microsoft Pocket Qutlook

Microsoft Pocket Outlook includes Calendar, Contacts, Tasks, Inbox, and
Notes. You can use these programs individually or together. For example,
you can use e-mail addresses stored in Contacts to address e-mail messages
in Inbox.

Using ActiveSync, you can synchronize information in Microsoft Outlook
or Microsoft Exchange on your desktop with your 700 Color Computer.
You can also synchronize this information directly with a Microsoft Ex-
change server. Each time you synchronize, ActiveSync compares the
changes you made on your 700 Color Computer and desktop or server
and updates both computers with the latest information. For information
on using ActiveSync, see ActiveSync Help on the desktop.

You can switch to any program by tapping it on the Start menu.

Calendar: Scheduling Appointments and Meetings

46

To switch to Calendar on the 700 Color Computer, tap Start > Calendar.

Use Calendar to schedule appointments, including meetings and other
events. You can check your appointments in one of several views (Day,
Week, Month, Year, and Agenda) and set Calendar to remind you of ap-
pointments with a sound or other method.

Appointments for the day can display on the Today screen.

If you use Outlook on your desktop, you can synchronize appointments
between your device and desktop.

.f*j‘ Calendar T o L 242 9
wn 27,03 sMTwTEs 1 «» — TaptogotoToday

Working at home
Lunch w/ Adanm

Tap to display or edit
the appointment details.

12:00p-1:00p (Corner Cafe)

Status Meeking
3:00p-4:00p

Ne;w Tools E E @ E|‘

‘ Tap to create a new appointment
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Synchronizing Calendar

Calendar items stored on your device can be synchronized with calendar
items on your desktop or Microsoft Exchange Server. (Note that you can
only synchronize information directly with an Exchange Server if your
company is running Microsoft Mobile Information Server 2002 or later.)
Calendar synchronization is automatically selected in ActiveSync.

Calendar items entered on one computer are copied to the other during
synchronization. Handwritten notes and drawings are saved as metafiles
(pictures).

For more information on synchronization, see ActiveSync Help on the

desktop.

Why Use Categories in the Calendar?

Use categories to group related tasks, contacts, and appointments. Then,
use these groupings to quickly display only the information you want. For
example, you can easily share your device with another by assigning your
appointments to a category with a special project’s name. You can then use
this category to filter Calendar and only display appointments for that
project.

% Note: In Month View, the day of an appointment assigned to the Holiday

category appears in red.

.}:j' Calendar T o L 212 9
July 2003 B < »
5 M T W T F 5

23 |30 1 z 3 4 5

This day was assigned
R PR R (¥R TV R FE R P the Holiday category.

13 14 15 16 17 16 19

20 |21 22 ez |24 2% |26

27 28 29 30 3l 1 2

New Tools E E E E|‘

\ Tap to access the Month view
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What's an All Day Event?

An appointment can either be a normal appointment or an all day event,
which lasts the full day or spans many days. Examples include a trade
show, a vacation, or a seminar. You can also use all day events to schedule
an annual event, such as a birthday or anniversary. In this case, change the
Status box to Free (you may need to scroll to see it) so that it does not
show time as busy in your calendar. All day events do not occupy blocks of
time in Calendar; they appear in banners at the top of the calendar.

Note: You cannot modify or create all day events with attendees on the
device. If you create all day events with attendees on your desktop, use Ac-
tiveSync to copy such events to the device. Then, view them in Calendar.
For more information on copying files, see ActiveSync Help. To use the
device to schedule an appointment with attendees lasting all day, set type
to “Normal,” then adjust the date and time appropriately.

.}:j' Calendar D ot o4 254 9
un2603 SMTWHFs B < »
Gary’s Birthday ———— This describes the all
8 = day event.
9
10
11
12 —
(« |
2
3 =
s =
5
6 |
)
8 =

New Tools EE @ E|‘

‘ Tap to access the Day view
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What's a Recurrence Pattern?

If you have an appointment or task that you do on a regular basis, such as
a weekly team meeting or a monthly status report, enter the item once and
set a recurrence pattern for it. If the default patterns in the list are not
what you need, you can create your own pattern using the wizard.

& g0 O

Subject: Staff Meeting A

Location: i

Starts; 9:00 &AM 2

Ends: 10:00 AM S

AllDay: MO
Occurs: [Ewary wednesday - Select your recurrence
Reminder pattern from this drop-
ery Wednesday down list.

Day 2 of every month
Categaries: |Evary July 2
Attendees: |= Edit pattern.., =

—— Select <Edit pattern...>
Status; BLSy to access the wizard

Sensitivity: Mormal with which to custom-

ize your recurrence.

Appointment | hotes |

Edit E= |A

Viewing Appointments

You can view appointments in one of several views (Agenda, Day, Week,
and Month). In Agenda view, upcoming appointments are displayed in
bold. To see detailed appointment information in any view, tap the ap-
pointment. To see a list of available actions for an appointment, tap and
hold the appointment.

loi 3t o0 O

02,03 sMTEITFS B 4| »

Staff Meeting — . .
9:005-10: 00a This displays the ap-

pointment in bold.

New Tools E E @ E|‘

‘ Tap to access the Agenda view
% Note: Tap Start > Today to quickly see your appointments for the day.
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Month view displays symbols to indicate the types of appointments you
have on a given day. An upward triangle indicates a morning appointment;
a downward triangle indicates an afternoon appointment. If you have ap-
pointments in the morning and afternoon, a solid square is displayed. If
you have an all day event not marked Free, a hollow square is displayed.

| Calendar o 4 gi43 9
July 2003 B o«
5 M T W T F 5
= B 1T [ [F [+ 5
r = This displays an all day
g |7 [8 |9 |11 |12 event not marked Free.
» This displays a morn-
13 14 15 16 17 15 19 |ng appointment_
= This displays appoint-
e e e A A R - ments in both morning
. and afternoon.
27 28 29 =0 3l 1 Z
| 4 This displays an after-
N A I < N [ noon appointment.

v
New Tools E E E E|‘

‘ Tap to access the Month view
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Creating or Changing an Appointment

To create an appointment, tap New. To select a new date from a pop-up
calendar, tap the display date. To enter or select a new time, tap the dis-

play time. Enter the appointment details, and when finished, tap OK to

return to the calendar.

If you are working in Day view, tap the time slot for the new appointment
and then tap New to have the time automatically entered for you.

To change an appointment, tap it in the calendar, and then tap Edit.
Change any appointment detail by tapping it and entering the new infor-
mation.

% Note: Tap the arrows to the right of the description and location boxes to

choose from previous entries.

When entering a time, you can type military and abbreviated time forms,
such as 2300 (becomes 11:00 PM), 913pm (becomes 9:13 PM), 911 (be-
comes 9:11 AM), and 9p (becomes 9:00 PM).

Tap to return to the calendar
(the appointment is saved
automatically).

.}:j' Calendar o1 £ 204 @
Subject: || -

. -
Location:

Tap to choose from
predefined text.

Tap to choose from previously

Starts: 7/16,/03 12:00 P~ entered locations.
Ends: 716,03  1w00Pm v Tap to select a time.
AlDay: Mo Tap to select a date.

Oceurs: Once

Reminder: Remind me
15 minuteds)
Categaries: Mo categories..,
Attendees: Mo attendees. ..
Status; Busy
Sensitivity: Mormal

. [ .
Appointment |EEEE] Notes is a good place for

Edit B[ maps and directions.
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Creating an All Day Event

To create an all day event, do the following:
1 Tap New.
2 Tap All Day, then select Yes.

43 | Calendar o 4L 942 @

Subject: Training

L4
-

Location:

Starts: 71,403 e
Ends: 7/1/03 M
AlDay: [Yes :7 Tap to select either
Occurs: (NGO Yes or No whether
Reminder: this is an all day
15 minutes) event.

Categaries: Mo categories..,

Attendess: Mo atEndees. ..
Status; Busy

Sensitivity: Mormal

Appointment | hotes |

Edit E= |A

Note: To change an all day event, switch to Day or Agenda view, tap the
event listed at the top of the calendar, and then tap Edit. Change any ap-
pointment detail by tapping it and entering the new information.

You cannot modify or create all day events with attendees on the 700 Col-
or Computer. If you create all day events with attendees on your desktop,
use ActiveSync to copy such events to the 700 Color Computer. Then,
view them in Calendar. For more information on copying files, see Active-
Sync Help. To use the device to schedule an appointment with attendees
lasting all day, set type to Normal, then adjust date and time accordingly.
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Setting a Reminder for an Appointment

Do the following to set a reminder for an appointment in the calendar:

1 Tap the appointment, then tap Edit to change the appointment.

2 Tap Reminder and select Remind me.

3 To change how many minutes before the appointment you are re-

minded, tap the minutes displayed, then select the new minutes from a
drop-down or enter the new minutes.

Tap minutes to change hours, days, or weeks.

Subjzct:
Location:
Starts:
Ends:

Al Day;:
Ocours:
Reminder

Categaries:
Attendess:
Skatus:

Sensitivity:

Calendar

st 4c1ae
h

Review

-

2:00 P hd
5:00 P i

7A6/03
715,03
Mo
Once

Remind me
INore

Mo attendees. ..

BLigy
Morrmal

Appointment | hotes |

Edit

B[

Note: To automatically set a reminder for all new appointments, in the

Tap to select Remind me
to enable the reminder
feature.

calendar, tap Tools > Options, select Set reminders for new items, then

tap the number and timeframe options to change the information given.

& | Calendar

Dptions

i

1st day of week:

Wiesk visw:

I

|:| Shaow half hour slots
[] show week numbers

D Use large fant
Set reminders for new items

|15 v| |minute(s) v|

BClEale]?]
ey ]

Show icons:

Send meeting
requests via:

B[

To choose how you are reminded, for example by a sound, Tap Start >
Settings > the Personal tab > the Sounds & Notifications icon.
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Adding a Note to an Appointment

You can add written or typed notes and even recordings (if your device
supports recordings) to an appointment. This is a good place for maps,
drawings, and other detailed information.

1 In the calendar, tap the appointment, then tap Edit.

2 Tap the Notes tab to enter notes. For specific instructions, tap Start >
Help > Notes to see Notes Help.

Calendar e L1213 @
- — These are controls for

- the recorder.

/’

ﬂM'L rn .
Use your stylus to write

— or draw your informa-
ﬁs tion here.

-

Appointment | hokes |

Edit Tools [E=1] 2| E|‘

‘ Tap to activate the keyboard.
Tap to activate the writing pad.
Tap to activate the recorder.

% Note: To edit an existing note, tap the appointment in the calendar, tap
Edit, then tap the Notes tab.
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Making an Appointment Recurring
Do the following to make a recurring appointment:

1 In the calendar, tap the appointment, then tap Edit

2 Tap Occurs and select a pattern from the list. Or, to create a new pat-
tern, tap <Edit pattern...>, and follow the steps in the wizard.

f Calendar <1 4 19 @

Subject: Staff Meeting v
Location: i
Starts; 9:00 &AM -
Ends: 10:00 AM v
AllDay: MO
oceurs: [Every Wednesday - Select your recurrence
Reminder: |Once pattern from this drop-

Every Wednesday down list.

Day 2 of every month
Categaries: |Evary July 2
Attendees: |= Edit pattern.., =

Select <Edit pattern...>
Skakus: Busy to access the wizard

Sensitivity: Mormal with which to custom-

ize your recurrence.

Appointment | hotes |

Edit E= |A
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E4

Assigning an Appointment to a Category
1 In the calendar, tap the appointment, then tap Edit.

2 Tap Categories.

3 On the Select tab, select the categories to which you want to assign the
appointment.

4 To create a new category, tap the Add/Delete tab, enter the category
name, then tap Add. The new category is automatically selected in the
Select tab.

5 Tap ok to return to the appointment.

43 | Calendar o 41243 @

[ ] Business

[JHoliday

[JPrersonal

Reviews

Staff A check mark indicates
a selected category.

Select | Add,l'DeIetel
Edit B[

Note: To find an appointment assigned to a category, tap Tools > Catego-

ries and select the type of appointment that you want displayed. To show
all appointments again, tap Tools > Categories and clear all categories.
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Sending a Meeting Request

Use Calendar to schedule meetings with people who use Outlook or Pock-
et Outlook. When attendees receive a meeting request, they can accept or
decline the meeting. If they accept, the meeting is automatically added to
their schedule. In addition, their response is sent back to you, and your

calendar is updated.

Before you can send a meeting request, you must enter e-mail addresses in
Contacts Help and set up Inbox to send and receive messages. For more
information on sending and receiving meeting requests, tap Start > Help >
Calendar to see Calendar Help, and tap Start > Help > Inbox to see /nbox
Help.

1 Tap New, then enter the meeting information.

2 Hide the onscreen keyboard, if needed, then tap Attendees. Only those
contacts with e-mail addresses are displayed. Select the contacts you
want to invite, then tap ok to return to the appointment.

3 Select other desired options and then tap ok.

4 Inbox automatically creates a meeting request and sends it to the atten-
dees the next time you synchronize with your desktop. Textual notes
entered in the Notes tab (excluding writing or recordings) are sent also.

. & qf 14 D
[w|Heart, Deborah dheart @xy.. A check mark indicates
[Istephens, william  wstephens... a selected attendee.

¥alley, Eugene evalleydxy...

B[

% Note: If you are sending the meeting request through a connection to an
ISP or the network, rather than through synchronization with your desk-
top, tap Tools > Options. From the Send meeting requests via drop-down
list, tap the service to use to send the meeting request.
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Finding an Appointment
There are two ways to find an appointment:

* Tap Start > Find, enter the appointment name, tap the Type arrow and
select Calendar from the drop-down list, and then tap Go.

* In the calendar, tap Tools > Categories and select the type of appoint-
ment you want displayed. To show all appointments again, tap Tools >
Categories and clear all categories.

gy,
& A< 137 @ Tap this to select from a drop-down

Find:  review ~I > listorenteraphrase.

Tupe: Calendat T 95— Tap this for a drop-down list of
Results areas where to search this phrase.
5] Review

Appeintment  7/16/03 2:00PM—————— Tap this to see its details.

B[

Note: In Find, you can tap the Find arrow to select from a list of items of
. y . p
previously searched items or phrases.

Deleting an Appointment
1 In the calendar, tap and hold the appointment.

2 On the pop-up menu, tap Delete Appointment. The next time you
synchronize, the appointment is also deleted from the desktop.
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Changing Calendar Options
In the calendar, tap Tools > Options.

* To see appointment indicators, select icons to display in Show icons.
You can choose to display indicators for such things as recurring ap-
pointments, appointments with notes, and appointments with remind-
ers. Tap and hold an icon to see its name.

* If you are having trouble reading the calendar, select Use large font.
You may see less appointment information.

agczn O

Dptions

R

|:| Shaow half hour slots
[] show week numbers

Use large font Tap this to view larger text.
Set reminders for new items

|15 v| |minute(s) v|
Show icons: LONENR L1
Send meeting
reguests via: |.l'-‘4.Eti\.rE SYNC v|
-
Tap to indicate private.
Tap to indicate attendees.

Tap to indicate locations.

Tap to indicate notes.

Tap to indicate recurrences.

Tap to indicate reminders.
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Contacts: Tracking Friends and Colleagues

60

To switch to Contacts on the 700 Color Computer, tap Start > Contacts.

Contacts maintains a list of your friends and colleagues so that you can
easily find the information you are looking for, whether you are at home
or on the road. You can enter both personal and business information.

If you use Microsoft Outlook on your desktop, you can synchronize
contacts between your 700 Color Computer and your desktop.

Select the category of contacts you
want displayed in the list.

£ | contacts #4e0 @ Tap and enter part of a name
&ll Contacts [Find aname —}— to quickly find it in the list.
#ab]cde] fgh] ik [ imn]opg] rst o] xz -

Heart, Debor... dheart@xyz.com e Tap to see additional phone
Stephens, Wi... wstephens@uyz.co...e numbers and e-mail addresses.

Yalley, Eugene evalley@ryz.com €
Send Emiail

Tap to display or edit the
contact details.

Tap and hold to display a
pop-up menu of actions.

Beam Contact...
Delete Contack

Mew ?iFw Tools E|‘
|

Tap to toggle to By Company (note the Name view)
Tap to create a new contact.
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Creating a Contact
1 Tap New.

2 Using the input panel, enter a name and other contact information.
Scroll down to see all available fields.

3 To assign the contact to a category, scroll to and tap Categories and se-
lect a category from the list. In the contact list, you can display contacts

by category.
4 To add notes, tap the Notes tab. You can enter text, draw, or create a

recording. For more information on creating notes, see “Notes: Captur-
ing Thoughts and Ideas” on page 71.

5 When finished, tap OK to return to the contact list.

| Contacts Tap to return to the contact list (the
Marne: v contact is saved automatically).
Job ikl

Department:

[

Company
Work kel
i ek fan:
Waork addr: v
E-mail:
tobils kel:

Wb page!
Office loc:
Home kel:

+—— Scroll to see more fields.

1]

Horme addr:

. | .
Details | hotes | Notes is a good place for
Edit B[ maps and directions.

Synchronizing Contacts
Contacts stored on your device can be synchronized with Outlook contacts
stored on your desktop or with Mobile Information Server 2002 or later.

New items entered in one location are copied to the other during synchro-
nization. Handwritten notes and drawings are saved as pictures when syn-
chronizing with your desktop, but are removed when synchronizing with a
server.

For more information on synchronization, see ActiveSync Help on the

desktop.
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Viewing Contacts
The contact list displays the contact name and the first primary phone

number or e-mail address specified for that contact. Contacts are ordered
by name of contact or company.

* Tap the default letter (home, w ork, mobile, or e-mail) to the right of
the contact to see additional phone numbers and e-mail addresses.

* Select a contact and press the Left/Right controls to change the default
number, displayed as a letter to the right of the contact name.

* To see more contact information, tap the contact.

To see a list of available actions for a contact via a pop-up menu, tap
and hold the contact.

* To see a list of contacts employed by a specific company, tap View > By
Company. Then, tap the desired company name.

% Note: You can change the appearance of the contact list by tapping Tools
> Options.

Contacts arfine

All Contacts « |Findaname

#ab|cde| fgh| ik | Imn|opg) rst

Heart, Deborah w

plddi » (425) 123-4567 Work Tel
{ | (425) 8BB-TT77 Home Tel

(425) 987-6543 Muobile Tel

dheart@xyz.com E-mail

Tap for a list of phone num-
bers and e-mail addresses.

Indicates the default number.

Mew Wiew Tools E|‘
|

Tap to toggle By Name and By Company views.
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Creating or Changing a Contact

* To create a contact, tap New. To enter notes, tap the Notes tab. When
finished, tap ok to return to the contact list.

* To change a contact, tap it in the contact list, and then tap Edit. To
cancel edits, tap Edit > Undo. When finished making changes, tap ok to
return to the contact list.

% Note: If you enter a name with more than two words, the middle word
is recorded as a middle name. If your contact has a double first or last
name, tap the Name arrow and enter the names in the proper box.

]

Mame: Deborah Gould Heart = Tap to access the Name
Tob Htle: Executive Asst ] fields.
Deps Title:

cd  First: Deborah
Middle:
i Last: Gould Heart
wal  Suffix

E-mal: dhearii@yz.com

Mobile kel: (4250 987-6543

[ 4]

ek i .
o?f' palgel Tap anywhere outside the box
feeac to close and return to details.
Home kel: (4250 BBE-7777
Home addr: v |-

Dietails | Mokes |
Edit B[

% Note: New contacts are added to the displayed category.
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Adding a Note to a Contact

You can add written or typed notes and even recordings (if your device
supports recordings) to a contact. Notes are handy for maps and drawings.

1 In the contact list, tap the contact.

2 Tap the Notes tab. For specific instructions, tap Start > Help > Notes
to see Notes Help.

Contacts arqc1zz0 D
& These are controls for

. . . . the recorder.
Bring financial B

records to Room
Use your stylus to write
3A. QN or draw your informa-

tion here.

v/

-

Dietails | Mokes |

Edit Tools [E1] 2| mk

‘ Tap to activate the keyboard.
Tap to activate the writing pad.
Tap to activate the recorder.

% Note: To edit an existing note, tap the contact, tap Edit, then tap the
Notes tab.
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Assigning a Contact to a Category
1 In the contact list, tap the contact, and then tap Edit.

2 Scroll to and tap Categories.

3 On the Select tab, select the categories to which you want to assign the
contact.

4 To create a new category, tap the Add/Delete tab, enter the category

name, then tap Add. The new category is automatically selected in the
Select tab.

5 Tap ok to return to the contacts.

¥ |Contacts it 4c1ze D

clivities

[] Business

[JHoliday

Personal A check mark indicates
[Jreviews a selected category.

[] staff

Select | Add,l'DeIetel

Edit =]

Copying a Contact

1 In the contact list, select the contact. To select multiple contacts, tap
and drag.

2 Tap Tools, and then select Copy Contacts.
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Sending a Message to a Contact
1 In the contact list, tap and hold the contact. To select multiple contacts,
tap and drag. Then, tap and hold the selected contacts.

2 On the pop-up menu, select Send Email or Send SMS, depending

upon the type of message to send.

& gc O

To: dheart@xyz.com;
wistephens@xyz, com;

Subi: July meeting

<

i 1[2[3[4][5]a]7[8]o]o]-[=]«
Tabja|wle]r [t]¥JuliJo]p[[]]
CAP[a[s[d[f[g]h]ifk[I[:]"]

shit[ z [x [c[v[b[n[m[, [. [7]+
ctifaal " [\ ] [+[t]e]>
Edit My Text [5] = [E3[+]

% Note: To send an e-mail message, you must have an e-mail address config-
ured for the contact. To send an SMS (Short Messaging Service) message,
you must have an SMS number for the contact, which is usually the mo-
bile phone number.
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Finding a Contact

There are four ways to find a contact:

* Tap Start > Find, enter the contact name (first, last, or middle), phone
number, or address, select Contacts for the type, then tap Go.

* From Contacts, start typing a contact name until you see it displayed on
the screen. To show all contacts again, tap the text box at the top of the
screen and clear the text, or tap the arrow to the right of the text box.

* In the contact list, tap the category list (labeled All Contacts by default)
and tap the category to which you have assigned a contact. To show all
contacts again, select All Contacts.

* To view the names of companies for which your contacts work, in the
contact list, tap View > By Company. The number of contacts that
work for that company is displayed to the right of the company name.

% Note: To quickly move through a long list of contacts, tap one of the sets
of letters displayed at the top of the contact list. This takes you to the con-
tact names beginning with those letters.

i |Contacts & A5 136 € Enter the first few letters of

All Contacts « [Find a name —— the contact in question here.
#ab]cde] fgh] ik [ imn]opg] rst o] xz
X¥Z Corporation {(3)
Gould Hear... dheart@xyz.com e
Stephens, .. (425) 567-9875 m
Yalley, Eug... evalley@xyzcom e

Tap to jump to that por-
tion of the contacts list.

Mew Wiew Tools E|‘
L

Tap to toggle to By Name (note the Company view)

Deleting a Contact
1 In the contact list, tap and hold the contact. To select multiple contacts,
tap and drag. Then, tap and hold the selected contacts.

2 On the pop-up menu, tap Delete Contact. The next time you synchro-
nize, the contact is deleted from the desktop also.
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Adding a Contact to Speed Dial

You can create speed dials to call frequently-called numbers with a single
tap. Before you can create a speed dial entry for a phone number, that
number must already exist in Contacts.

1 From the Phone keypad, tap Speed Dial > New.
2 Tap the desired contact name and number.

3 In the Location field, tap the Up/Down arrows to select an available
location to assign as the new speed dial entry. The first speed dial loca-
tion is reserved for your voice mail.

To delete a speed dial entry, go to the Speed Dial list, tap and hold the
contact name in the box to the right of the assigned speed dial number,
then tap Delete.

Changing Contacts Options
In the contact list, tap Tools > Options.

* The area code and country/region for new contacts are automatically
entered based on the information in Country/Region settings.

* If you are having trouble reading the contacts in the contact list, select
Use large font.

* To increase the available space for displaying contacts in the list, clear

Show ABC tabs.

.}:j' Contacts o} 45 1:54 @

Dptions

List view settings

Show ABC tabs Clear this to view more
D Shaow cantack narmes only contacts per screen.
D IUse large font

Tap this to view larger text.

Country /Region settings

fires code: ———— Enter the three-digit area code.

Country) - i
Regon. | Urited States "} Select from a drop-down list.

Edit E= |A
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Tasks: Keeping a To Do List
| To switch to Tasks on your 700 Color Computer, tap Start > Tasks.

Use Tasks to keep track of what you have to do. A variety of task informa-
tion can display on the Today screen. If you use Microsoft Outlook on
your desktop, you can synchronize tasks between your device and desktop.

Select the category of tasks you want displayed in the list.

rf1ze €
All Tasks Priority «

Select the sort order of the list.

[#[4 ][ Tap heretoaddanewtask |} yse this entry bar to assign a task quickly.
[]* send status report
[] Buy birthday gift
[0 call Maria

[0 Proof new proposal

W L Srhedule message
Create Copy

Indicates a high priority.

Tap to display or edit the
task details.

Delete Task

Beam Task...

Tap and hold to display a
pop-up menu of actions.

Mew Tools B |A
|

‘ Tap to create a new task.

% Note: To change the way information is displayed in the list, tap Tools >
Options.
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Creating a Task

* To quickly create a task, enter text in the Tap here to add a new task
box at the top of the screen. If you do not see this box, tap Tools >
Entry Bar.

e To create a task with detailed information, such as start and due dates,
tap New. To enter notes, tap the Notes tab.

You can enter a start date and due date or enter other information by
first tapping the field. If the input panel is open, you need to hide it to
see all available fields.

You can enter text, draw, or create a recording. For more information
on creating notes, see “Notes: Capturing Thoughts and ldeas” on page 71.

To change a task, tap it in the task list, and then tap Edit.

Using the onscreen keyboard, enter a description.

To assign the task to a category, tap Categories and select a category
from the list. In the task list, you can display tasks by category.

When finished, tap ok to return to the task list.

Tap to return to the task list (the

a1z @ task is saved automatically).

Subject: Tap to choose from predefined
Priority:  Mormal subjects.
Status: Mot Cormrpleted

Skarks: Mone
Due: Mone
Oceurs: Once

Reminder: [HMone

Categaries: Mo categories..,
Sersitivity: Mormal

Task | Mokes i Notes is g goodl place for
T = maps and drawings.

Note: To quickly create a task with only a subject, tap Entry Bar on the
Tools menu. Then, tap Tap here to add a new task and enter your task
information.

Synchronizing Tasks

Tasks stored on your 700 Color Computer can synchronize with Micro-
soft Outlook on your desktop. Task synchronization is automatically se-
lected in ActiveSync.

New items entered on one computer are copied to the other during syn-
chronization. Handwritten notes and drawings are saved as metafiles (pic-
tures).

For more information on synchronization, see ActiveSync Help on the

desktop.
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Notes: Capturing Thoughts and Ideas
‘W Note m To switch to Notes on your 700 Color Computer, tap Start > Notes.

Notes helps you quickly capture your ideas, notes, and thoughts. You can
create a note using written and typed text, drawings, and recordings. You
can also share your notes with others through e-mail, infrared, and syn-
chronization with your desktop.

atqf1z02 €

i) All Folders ~ Date v —  Tap to change the sort
[_]Business1 11146 a T94b order of the list.
[Lloutlook Netes1 11482  916b

Personall 11494 1k

eam meeting no... 11:504 Tap to open a note or

Create Copy play a recording.
Delete

Select all

Tap and hold to display a

pop-up menu of actions.

Beam File...

Rename,/Moye.

Tap to record.

|
(& [m]» [U——— [ |m]a]

Ne‘w Tools B |‘

‘ Tap to show or hide the Recording toolbar.

Tap to create a new item.

% Note: To create documents with advanced formatting or templates, such

as bulleted lists and tabs, use word processing software developed for your
device, such as Pocket Word.

Creating a Note
To create your note, tap New, then write, draw, type, or record your in-
formation. For information about using the input panel, writing and dra-
wing, and creating recordings, see “Basic Skills” on page 26.
* Writing

Using the stylus, write directly on the screen.

¢ Drawing
Using the stylus, draw directly on the screen.

* Typing
Using the input panel, enter typed text into the 700 Color Computer.
Do this by tapping keys on the onscreen keyboard or by using hand-
writing recognition software.

* Recording
Create a stand-alone recording or embed a recording into a note.
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Synchronizing Notes

Notes can be synchronized between your desktop and device either
through notes synchronization or file synchronization. Notes synchroniza-
tion synchronizes the notes on your 700 Color Computer with Outlook
Notes on your desktop. File synchronization synchronizes all notes on
your 700 Color Computer with the My Documents folder for the 700
Color Computer on your desktop.

To synchronize your notes through notes synchronization, first select the
Notes information type for synchronization in ActiveSync. The next time
you synchronize, all notes in My Documents and its subfolder on your
device appear in Outlook Notes on your desktop. Notes that contain only
text appear as regular notes in Outlook on your desktop, while notes con-
taining written text or drawings appear in the device format. In addition,
all notes in the Notes group in Outlook on the desktop appear in Notes on
the device.

To synchronize your notes as files, in ActiveSync, select the Files informa-
tion type for synchronization and clear the Notes information type. When
you select Files, the My Documents folder for the 700 Color Computer is
created on your desktop. All .PWT files placed in the My Documents fold-
er on your device and all .DOC files placed in the My Documents folder
for the 700 Color Computer on your desktop are synchronized. Password-
protected files cannot be synchronized.

ActiveSync converts documents during synchronization. For more infor-
mation on synchronization or file conversion, see ActiveSync Help on the

desktop.

Note: When you delete or change an item on either your desktop or 700
Color Computer, the item is changed or deleted in the other location the
next time you synchronize.

Note: If you synchronize your notes using file synchronization and then
later decide to use notes synchronization, all of your notes are synchro-
nized with Outlook on your desktop and no longer store in the My Docu-
ments folder for the 700 Color Computer.
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Inbox: Sending and Receiving E-mail Messages

To switch to Inbox on your 700 Color Computer, tap Start > Inbox.

You can receive Internet e-mail messages and SMS messages in Inbox. In-
ternet e-mail messages are sent by using an address you receive from your
Internet service provider (ISP) or your employer. SMS messages are sent
and received through your wireless phone service provider by using a
phone number as the message address.

You can send and receive e-mail by synchronizing with your desktop, or
by connecting to a Post Office Protocol 3 (POP3) or Internet Message Ac-
cess Protocol 4 (IMAP4) mail server. You need to set up an e-mail account
for each method that you use except for Microsoft ActiveSync, which is set
up by default. The ActiveSync folder on your 700 Color Computer stores
messages that you send and receive through synchronization with a desk-
top. Account names appear as folders in the folder list (located on the left,
under the navigation bar) in the Inbox message list.

With synchronization, messages are synchronized between the device In-
box and the PC Inbox by using ActiveSync and Microsoft Exchange or
Microsoft Outlook. For more information, see “Synchronizing E-mail Mes-
sages” below.

When connecting to a POP3 or IMAP4 server, you use a modem to con-
nect to your Internet service provider (ISP), or a modem or Ethernet card
to connect to the local area network to which your e-mail server is connec-
ted. You can also use your phone to connect by using a cellular line con-
nection. For more information, see “Connecting to a Mail Server” on page

75.

Synchronizing E-mail Messages

After selecting Inbox for synchronization in ActiveSync, e-mail messages
are synchronized as part of the general synchronization process. During
synchronization:

* Messages are copied from the Inbox folder on your desktop or the
Microsoft Exchange server to the Inbox folder on your 700 Color Com-
puter. (Note that you can only synchronize information directly with an
Exchange Server if your company is running Microsoft Mobile Infor-
mation Server 2002 or later.) By default, you receive messages from the
last three days only, the first 100 lines of each new message, and file at-
tachments of less than 100 KB in size.

* Messages in the Outbox folder on your device are transferred to Ex-
change or Outlook and then sent from those programs.

* The messages on the two computers are linked. When you delete a mes-
sage on your 700 Color Computer, it is deleted from your desktop the
next time you synchronize.

* Messages in subfolders in other e-mail folders in Outlook are synchro-
nized only if they were selected for synchronization in ActiveSync.

For information on initiating Inbox synchronization or changing synchro-
nization settings, see ActiveSync Help on your desktop or select Start >
Help > Connections to see Connections Help.
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Managing E-mail Messages and Folders

Each e-mail account and SMS account has its own folder hierarchy with
five default folders: Inbox, Outbox, Deleted Items, Drafts, and Sent Items.
The messages you receive and send through the mail account are stored in
these folders. You can also create additional folders within each hierarchy.
The Deleted Items folder contains messages that were deleted on the de-
vice. The behavior of the Deleted Items and Sent Items folders depends on
the Inbox options you have chosen.

The behavior of the folders you create depends on whether you are using

ActiveSync, SMS, POP3, or IMAPA4.

* [fyou use ActiveSync,
e-mail messages in the Inbox folder in Outlook automatically synchro-
nize with your device. You can select to synchronize additional folders
by designating them for ActiveSync. The folders you create and the
messages you move are then mirrored on the server. For example, if you
move two messages from the Inbox folder to a folder named Family,
and you have designated Family for synchronization, the server creates a
copy of the Family folder and copies the messages into that folder. You
can then read the messages while away from your desktop.

o [fyou use SMS,

messages are stored in the Inbox folder.

* [fyou use POP3
and you move e-mail messages to a folder you created, the link is broken
between the messages on the device and their copies on the mail server.
The next time you connect, the mail server sees that the messages are
missing from the device Inbox and deletes them from the server. This
prevents you from having duplicate copies of a message, but it also
means that you no longer have access to messages that you move to fold-
ers created from anywhere except the 700 Color Computer.

* [fyou use IMAP4,
the folders you create and the e-mail messages you move are mirrored
on the server. Therefore, messages are available to you anytime you con-
nect to your mail server, whether it is from your 700 Color Computer
or desktop. This synchronization of folders occurs whenever you con-
nect to your mail server, create new folders, or rename or delete folders
when connected.

For all accounts except ActiveSync, you can access folder options by tap-
ping Tools > Manage Folders.
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Connecting to a Mail Server

In addition to synchronizing e-mail messages with your desktop, you can
send and receive e-mail messages by connecting to an e-mail server using a
modem or network card connected to your 700 Color Computer. You
need to set up a remote connection to a network or an ISP, and a connec-
tion to your e-mail server. For more information, see “Gezting Connected”
on page 98.

When you connect to the e-mail server, new messages are downloaded to
the 700 Color Computer Inbox folder, messages in the 700 Color Com-
puter Outbox folder are sent, and messages that were deleted on the e-mail
server are removed from the 700 Color Computer Inbox folder.

Messages that you receive directly from an e-mail server are linked to your
e-mail server rather than your desktop. When you delete a message on
your 700 Color Computer, it is also deleted from the e-mail server the
next time you connect based on the settings selected in ActiveSync.

You can work online or offline. When working online, you read and re-
spond to messages while connected to the e-mail server. Messages are sent
as soon as you tap Send, which saves space on your 700 Color Computer.

When working offline, once you have downloaded new message headers or
partial messages, you can disconnect from the e-mail server and then de-
cide which messages to download completely. The next time you connect,
Inbox downloads the complete messages you have marked for retrieval and
sends the messages you have composed.

Setting Up or Changing an Account

To set up an account:

* To set up a POP3 or IMAP4 e-mail account, tap Accounts > New Ac-
count. Follow the instructions in the New Account Wizard.

* To set up an SMS account, tap Accounts > Accounts, and then tap
SMS. Follow the instructions on the screen.

To change options for an account:

1 Tap Accounts > Accounts.

2 Tap the name of the account, and follow the instructions on the screen.
To delete an account:

1 Tap Accounts > Accounts.

2 Tap and hold the name of the account, and then tap Delete.

Note: You can set up several e-mail accounts including your ActiveSync

account, but you can set up only one SMS account.

Note: You cannot add a new account while connected. Tap Accounts >
Disconnect to disconnect.

Note: You cannot delete your SMS account.

R R K

700 Series Color Mobile Computer User’s Manual 75



Chapter 2 — Windows Mobile 2003

76

R ®

Downloading Messages from the Server

In Inbox, tap Accounts > Connect to open a connection to the Internet or
your corporate network, depending on the account. For more information,
tap Start > Help > Connections to see Connections Help.

1 Tap Accounts and ensure that the account you want to use is selected

(marked by a bullet.)

2 Tap Connect. The messages on your 700 Color Computer and e-mail
server are synchronized: new messages are downloaded to the 700 Color
Inbox folder, messages in the 700 Color Outbox folder are sent, and
messages that were deleted from the server are removed from the 700
Color Inbox. Tap a message in the message list to open it.

3 If you read a message and decide that you need the full copy, tap Edit >
Mark for Download while in the message window. If you are in the
message list, tap and hold the message, and then tap Mark for Down-
load. This also downloads message attachments if you selected those op-
tions when you set up the e-mail account. You can also choose to down-
load full copies of messages by default.

4 When finished, tap Accounts > Disconnect.

Note: Receiving entire messages consumes storage memory.

Note: The size column in the message list displays the local size and server
size of a message. Even when a message has downloaded fully, these num-
bers may differ because the size of a message can vary between the server
and the device.
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Composing and Sending Messages
To compose a message:

1 In the message list, tap New.

2 To select an account, tap the From list and select “ActiveSync,” “SMS,”
or the desired e-mail account.

3 Enter the e-mail address or SMS address of one or more recipients, sepa-
rating them with semicolons. To access addresses and phone numbers
from Contacts, tap To.

4 Enter your message. To quickly add common messages, tap My Text
and tap a desired message.

5 To check spelling, tap Edit > Spell Check.

6 Tap Send. If you are working offline, the message is moved to the Out-
box folder and is sent the next time you connect.

: S gcen O
=1 | To: EES
EERgl|ob: <. > ¥ Tap to show or hide the
complete header.
Edit My Text [7] 1 B[

‘ Tap to show or hide the recording tool bar.
Tap to display the Address Book.
Tap to insert common (preset) messages.

% Note: If you are sending an SMS message and want to know if it was re-
ceived, before sending the message, tap Edit > Options > Request SMS
text message delivery notification.

You can directly call the sender of an SMS message by tapping the icon
E- shown to the left, then Call.

% Note: Depending on the e-mail address options that you select, you can

use a directory service in addition to your contact list to verify names.
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Companion Programs

Pocket Word
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Pocket
Word

The companion programs consist of Microsoft Pocket Word, Microsoft
Pocket Excel, Windows Media Player, and Microsoft Reader. To switch to
a companion program on your 700 Color Computer, tap Start >
Programs, then tap the program name.

Pocket Word works with Microsoft Word on your desktop to give you
access to copies of your documents. You can create new documents on
your 700 Color Computer, or you can copy documents from your desktop
to your 700 Color Computer. Synchronize documents between your desk-
top and your 700 Color Computer to have up-to-date content in both
locations.

Creating a Document

Use Pocket Word to create documents, such as letters or meeting minutes.
To create a new file, tap Start > Programs > Pocket Word > New. You get
either a blank document or a template, depending on what you have se-
lected in the Tools > Options dialog box. Select an input mode from the
View menu.

You can open only one document at a time; when you open a second doc-
ument, you have to save the first. You can save a document you create or
edit in formats such as Word (.DOC), Pocket Word (.PSW), Rich Text
Format (.RTF), and Plain Text (. TXT).

Pocket Word contains a list of files stored on your 700 Color Computer.
Tap a file in the list to open it. To delete, make copies of, and send files,
tap and hold a file in the list, then, select the action on the pop-up menu.

&gz

4 | Packet Word

I All Folders ~ Name ~ Tap to change the sort
BfAgenda 8:39a 420b order of the list.

T Doct 8:38a 416b

B ]Meeting Notes 8:3%a 428b

e i _L

l:rtel:uy

Deleta #:34 a 37h Tap to open a document.

Select all

Send via E-mail...

Beam File...

e e Tap and hold an item to
see a pop-up menu of
actions.

B[

MNew Tools
L

‘ Tap to create a new document.
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You can enter information in Pocket Word in one of four modes (typing,
writing, recording, and drawing), which are displayed on the View menu.
Each mode has its own toolbar, which you can show and hide by tapping
the Show/Hide Toolbar button on the command bar.

You can change the zoom magnification by tapping View > Zoom, then
select the percentage you want. Select a higher percentage to enter text and
a lower one to see more of your document.

If you are opening a Word document created on a desktop, you may select
View > Wrap to Window so that you can see the entire document.

To check spelling, select text, then tap Tools > Spell Check. To use your

new document as a template, move the document to the Templates folder.

You can insert the data in a document. First, make sure that no drawings
are selected, tap and hold anywhere on the document, then tap Insert
Date from the pop-up menu.

Typing Mode
Using the input panel, enter typed text into the document. For more in-
formation on entering typed text, see “Basic Skills” on page 26.

To format existing text and to edit text, first select the text. You can select
text as you do in a Word document, using your stylus instead of the mouse
to drag through the text you want to select. You can search a document to
find text by tapping Edit > Find/Replace.

Tap and hold to see a pop-up menu of actions.

Ef|pocketwre L ™ T rae @

Copy

Tap to return to the
document list (changes are

Wieeting MNotes|

Paste saved automatically).
Clear
Format...
Paragraph...
Recognize Tap to change formatting
Alternates... OpthI’]S.
spellcheck [
¥ B I U & Tap to format text.
1231[2[3]4]5][6[7[8][9]0]-[=]e«
Tabla]w[e[r [t[¥Juli]o]p|[[]]

CaPlas[d][flofh]j[k[I[;]"]

shift[z [<[c[v[b[n[m[, [, Ifl'—‘
ctilaa * 4] [L]t]e
Mew Edit Yiew Tlmls |E|‘|

‘ Tap to show or hide the toolbar.
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Writing Mode

In writing mode, use your stylus to write directly on the screen. Ruled
lines are displayed as a guide, and the zoom magnification is greater than
in typing mode to allow you to write more easily. For more information
on writing and selecting writing, see “Basic Skills” on page 26.

With Space button selected,
drag to insert space. An arrow
appears showing the space
direction and size.

-

Z Z|[o]= & B I U 2 —— Tapto highlight selected text.
New Edit Yiew Tools E|‘

Tap to select formatting options, such as
pen weight and line color.

Space button.
Pen button.

Note: If you cross three ruled lines in a single stylus stroke, the writing
becomes a drawing, and can be edited and manipulated as described in
“Drawing Mode” on the next page.

Note: Written words are converted to graphics (metafiles) when a Pocket
Word document is converted to a Word document on your desktop.

Recording Mode
In recording mode, embed a recording into your document. Recordings
are saved as . WAV files. For more information on recording, see “Basic

Skills” on page 26.

For more information on using Pocket Word, tap Start > Help > Pocket
Word to see Pocket Word Help.
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Drawing Mode

In drawing mode, use your stylus to draw on the screen. Grid lines appear
as a guide. When you lift your stylus off the screen after the first stroke, a
drawing box indicating the boundaries of the drawing appears. Every sub-
sequent stroke within or touching the drawing box becomes part of the
drawing. For more information on drawing and selecting drawings, see
“Basic Skills’ on page 26.

Resize an object by dragging
the selection handles.

W T
N Y
I

7 73#{,}5
VNV (=

AE A Gk
Mew Edit| Yiew Tools . E|‘

O
> 0

~ Tap to select formatting options, such as
line weight, fill color, and line color.

Tap an arrow to see your choices.
Pen button.

Synchronizing Pocket Word Documents

Pocket Word documents can be synchronized with Word documents on
your desktop. To synchronize files, first select the Files information type
for synchronization in ActiveSync. When you select Files, the My Docu-
ments folder for the 700 Color Computer is created on your desktop.
Place all files you want to synchronize with the device in this folder. Pass-
word-protected files cannot be synchronized.

All Pocket Word files stored in My Documents and its subfolders are syn-
chronized with the desktop. ActiveSync converts documents during syn-
chronization.

For more information on synchronization or file conversion, see ActiveSync

Help on the desktop.
% Note: When you delete a file on either your desktop or your 700 Color

Computer, the file is deleted in the other location the next time you syn-
chronize.
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Pocket Excel

You can create and edit workbooks and templates in Microsoft Pocket Ex-
cel as you do in Microsoft Excel on your desktop. Pocket Excel workbooks
are usually saved as .PXL files, but you can also save them in .XLS format.

When you close a workbook, it is automatically named and placed in the
Pocket Excel workbook list. You can attach a password to a workbook to
help ensure privacy.

Creating a Workbook

Use Pocket Excel to create workbooks, such as expense reports and mileage
logs. To create a new file, tap Start > Programs > Pocket Excel > New. A
blank workbook appears. Or, if you have selected a template for new
workbooks in the Tools > Options dialog box, that template appears with
appropriate text and formatting already provided. You can open only one
workbook at a time; when you open a second workbook, save the first.
You can save a workbook you create or edit in a variety of formats,
including Pocket Excel (.PXL) and Excel (.XLS). You can also save a
workbook as a template by moving the workbook to the Templates folder.

Pocket Excel contains a list of the files stored on your 700 Color Comput-
er. Tap a file in the list to open it. To delete, make copies of, and send
files, tap and hold a file in the list. Then select the appropriate action from
the pop-up menu.

Pocket Excel provides fundamental spreadsheet tools, such as formulas,

functions, sorting, and filtering. To display the toolbar, tap View >
Toolbar.

Cell contents appear
here as you enter them.
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Format button.

Note: If your workbook contains sensitive information, you can protect it
with a password. To do so, open the workbook, tap Edit > Password. Ev-
ery time you open the workbook, enter a password, preferably one that is
easy for you to remember but hard for others to guess.
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Tips for Working in Pocket Excel

Note the following when working in large worksheets in Pocket Excel:

* View in full-screen mode to see as much of your worksheet as possible.
Tap View > Full Screen. To exit full-screen mode, tap Restore.

* Tap View > Zoom and select a percentage so that you can easily read
the worksheet.

* Show and hide window elements. Tap View and then tap the elements
you want to show or hide.

* Freeze panes on a worksheet. First select the cell where you want to
freeze panes. Tap View > Freeze Panes. You might want to freeze the
top and leftmost panes in a worksheet to keep row and column labels
visible as you scroll through a sheet. Tap View > Unfreeze Panes to
undo this process.

* Split panes to view different areas of a large worksheet. Tap View >
Split. Then drag the split bar to where you want it. To remove the split,
tap View > Remove Split.

* Show and hide rows. To hide a row, select a cell in the row you want to
hide. Then tap Format > Row > Hide. To show a hidden row, tap
Tools > Go To, and then type a reference that is in the hidden row.
Then tap Format > Row > Unbhide.

* Do the same to show and hide columns. To hide a column, select a cell
in the column you want to hide. Then tap Format > Column > Hide.
To show a hidden column, tap Tools > Go To, and then type a refer-

ence that is in the hidden column. Then tap Format > Column > Un-

hide.

For more information on using Pocket Excel, tap Start > Help > Pocket
Excel to see Pocket Excel Help.
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MSN Messenger

MSN Messenger on your 700 Color Computer provides the same chat
environment as MSN Messenger on your desktop. These features include:

* Seeing who is online

Sending and receiving instant messages

* Having an instant message conversation with a group of contacts

Telling contacts that you are unavailable

Blocking contacts from seeing your status or sending you messages

To use MSN Messenger, you need a Microsoft Passport account, or a
Microsoft Exchange e-mail account that your employer provides. Once
you have one of these accounts, do the following:

1 Set up a connection on your 700 Color Computer, such as a modem or
wireless connection, that enables you to connect to the Internet.

2 Set up an account in MSN Messenger.
3 Sign in to MSN Messenger.
% Note: To set up a free Hotmail account, go to http://www.hotmail.com.

To set up a Microsoft Passport account, go to http://www.passport.com.
To set up an Exchange account, see your network administrator.

For more information on using MSN Messenger, tap Start > Help > MSN
Messenger to see MSN Messenger Help.

s.}& To switch to MSN Messenger, tap Start > Programs > MSN Messenger.

MSN
Messenger
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Setting Up an Account

Before you can use MSN Messenger, you must set up the instant messag-
ing accounts to use. For MSN Messenger Service, you must have a Micro-
soft Passport or Hotmail account. For Exchange Instant Messaging, you
must have an Exchange account.

1 Create a connection for your device. To use MSN Messenger Service,
set up a connection to the Internet; to use Exchange Instant Messaging,
set up a connection to your corporate network. See page 98 for more
information on getting connected.

2 In MSN Messenger, tap Tools > Options > the Accounts tab.

3 Select Enable MSN Messenger Service or Enable Exchange Instant Mes-
saging.

4 Enter your sign-in name and password for the selected accounts. Your
sign-in name is usually in the username@domain.com form.

5 If you selected both accounts, under Sign in using this account first, se-
lect which account to sign in to first.

L\ MEN Messenger <« £ 12:53 @

Accounts
Enable MSMN Messenger Serwice

Jigninname:  repma@abic com
Passward; *******11

Enable Exchangs Instant Messaging
Sign in name: | |

Password: | |

Sign in using this account first
@ MSM Messenger Service
O Exchangs Instant Messaging

General | Privacy | ACcounts |

B
Signing In and Out
* To sign in, tap anywhere on the screen. Follow the directions on the
screen.

* To sign out, tap Tools > Sign Out.

* To sign in upon connecting, tap Tools > Options > General and select
the Run this program upon connection box.

* Signing in to an Exchange account may take several minutes depending
upon your connection speed. Reducing the number of Exchange con-
tacts decreases your sign-in time.
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Working with Contacts

The MSN Messenger window shows all of your messenger contacts at a
glance, divided into Online and Not Online categories. From this view,
while connected, you can chat, send e-mail, block the contact from chat-
ting with you, or delete contacts from your list using the pop-up menu.

45| MSN Messenger < 4£ 219 9
‘i Kim Akers {Online)

‘i Online
Adarn E
ib am Barr Tap a contact to start a
Q& Fandall {oway ) chat
‘i Not Online

‘i Richard Bready
‘i Dravid Hodgson

Send Mail (Tim@woodgrovebank.c...
Block

Delete Contact

Tap and hold to display a
pop-up menu of actions.

Properties

Tools Chats B |‘

To add a contact, tap Tools > Add a Contact and follow the directions on
the screen.

To delete a contact, tap and hold the contact’s name, then tap Delete
Contact from the pop-up menu.

To see others online without being seen, tap Tools > My Status > Appear
Offline.
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Managing Contacts

To be alerted each time you are added to a contact list, tap Tools > Op-
tions > the Privacy tab.

* To block a contact from seeing your status and sending you messages,

tap the contact and tap the right arrow. This moves the contact to the
My Block List.

* To unblock a contact, tap the contact and tap the left arrow. This
moves the contact to the My Allow List.

* To receive an alert when someone adds you to their contacts list, select
Alert me when I am added to a Passport contact list.

* To see who has you listed as a contact, tap View.

3| MSN Messenger < 4 203 @

My Allow List My Block List
Can see my online Can't ses my online
status and send me status or send me
messages messages

l:l flert me when I am added bo g Passpott
contact list

Users who have me in their conkack
s

General | Privacy | ACcounts |

B[
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Sending a Message

* Tap a contact to whom you want to send a message. Enter your message
in the text entry area at the bottom of the screen and tap Send. To
quickly add common messages, tap My Text and tap a desired message.

* To invite another contact to an ongoing chat, tap Tools > Invite and

tap a contact.

* To see who is already chatting or to switch between chats, tap Chats.

| MEN Messenger < 4£ 219 9

Enter a message.

Hi. Can vou meet at 2:007 Send Tap to send message.
123{1[2[3[4[s[e[7[e]o]0]- =]«
Tab[q[wle[r[t]y[uli[o[p[[]

capla[s[d[f[a[n]j]k ]I

=

Shift[z [z [c[¥[b[n[m]

. ]
ctifan] “ JA ] [+

Tools Chats My Text _.‘_'h
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Windows Media Player for Windows Mobile

700 Series Color Mobile Computer User’s Manual

Use Microsoft Windows Media Player for Windows Mobile to play digital
audio and video files that are stored on your 700 Series Computer or on a
network.

To switch to Windows Media Player on your 700 Color Computer, tap
Start > Windows Media.

Use Microsoft Windows Media Player on your desktop to copy digital au-

dio and video files to your 700 Color Computer. You can play Windows
Media and MP3 files on your Windows Mobile.

FF|windows Media 4 4£11:30 €

“Wrelcome To Windows Media - g4k | [

Windows

Media Player

Ready - Tap Flay 0:00 Indicates the progress
T — of the current track.

t} =) () (4 == Tap to adjust volume.

Flaylist Tools B |‘

Tap to skip to the next song.
Tap to play a previous song.
Tap to stop.

Tap to play or pause.

For more information about using Windows Media Player for Windows
Mobile, tap Start > Help > Windows Media Player to sce Windows Media

Player Help.
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Microsoft Reader
wil
Microsoft
Reader
20

Use Microsoft Reader to read eBooks on your 700 Color Computer.
Download books to your desktop from your favorite eBook Web site.
Then, use ActiveSync to copy the book files to your activated 700 Color
Computer. The books appear in the Reader Library, where you can tap
them in the list to open them. Each book consists of a cover page, an op-
tional table of contents, and the pages of the book. You can:

* DPage through the book by using the Up/Down control on your 700
Color Computer or by tapping the page number on each page.

* Annotate the book with highlighting, bookmarks, notes, and drawings.
* Search for text and look up definitions for words.

The Guidebook contains all the information needed to use the software.
To open the Guidebook, tap Help on the Reader command bar. Or, on a
book page, tap and hold on the book title, and then tap Help on the pop-

up menu.

To switch to Microsoft Reader, tap Start > Programs > Microsoft Reader.

Getting Books on Your 700 Color Computer
You can download book files from the Web. Just visit your favorite eBook
retailer and follow the instructions to download the book files.

Sample books and a dictionary are also included in the MSReader folder in
the Extras folder on the Windows Mobile Companion CD.

Use ActiveSync to download the files from your desktop to your activated
mobile computer as described in the Read Me file in the MSReader folder.
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Using the Library

The Library is your Reader home page; it displays a list of all books stored
on your 700 Color Computer or storage card. To open the Library:

1 On the Reader command bar, tap Library.
2 On a book page, tap the book title, then tap Library on the pop-up

menu.

3 To open a book, tap its title in the Library list.

& Microsoft Reader 4 £ 11:49 9

Page 1 Tap to scroll through
the Library list.

The Best American Short Steries

Tap to select a sort order. ﬂ A
The Ghost Writers

The Hundred Secret Senses ————  Tap to open a book.

Outiander
Suger Plum Dead
Another World

Winter of the Walf Moon
The Last Precinct

Tap here to navigate to On Writing
other parts of the Reader. Passage to Juneau

Of Love and Othar Demonz

Stranger ina Strange Land
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Reading a Book

Each book consists of a cover page, an optional table of contents, and the
pages of the book. Navigation options are listed in the bottom portion of
the cover page.

The first time you open a book, go to the first page or to the table of con-
tents, if there is one. Subsequently, whenever you open the book, you are
automatically taken to the last page read.

In addition to the text, each book page includes a page number and book
title.

i Microsoft Reader o =% 12:21 9

Tap to select a — > Microsoft® Reader Help
navigation option.

To edit or eras{ Add Bookmark

From the paj

created the high Add Highlight

_Tap and dr{Add Text Note

light or por i
you want to| Add Drawing
2. Tap Edit Hig|
3. Tap a coler|Eind... 1  Select an option after
Color Select dragging to select a
color of all of COPY Text textgg 9
light. ’
s Tep Erase (PN i the ——  Drag 1o select text.
pop-up menu to erase all or
44 7 ’_»7E
“ 7 > Tap arrows to turn the
O (11 LTI T T 130 page, or tap and hold
page number to bring up
page riffle.

You can also page through a book by using the Up/Down/Left/Right con-
trols on your 700 Color Computer.
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Using Reader Features
Reading a book electronically gives you several options not available with
paper books. These options are available from any book page.

Select text by dragging across the text on the page. Then, tap an option on
the pop-up menu, as described here:

Searching for Text

Copying Text

Adding Bookmarks

Highlighting Text

Attaching Notes to Text

Adding Drawings

Annotations Index

Find text in a book by tapping Find on the pop-up menu. Enter the word you want to
search for, and tap the desired Find option. Reader highlights found text on the page. To
close Find, tap outside the box. To return to your original page, tap the title and then tap
Return on the pop-up menu.

You can copy text from books that support this feature into any program that accepts
text. On a book page, select the text you want to copy. Then, tap Copy Text on the pop-
up menu. The text can be pasted into the program of your choice.

When you add a bookmark to a book, a color-coded bookmark icon appears in the right
margin. You can add multiple bookmarks to a book. Then, from anywhere in the book,
tap the bookmark icon to go to the bookmarked page.

When you highlight text, it appears with a colored background.

When you attach a note to text, you enter the text in a notepad that appears on top of the
book page. A Note icon displays in the left margin. To show or hide the note, tap the
icon.

When you add a drawing, a Drawing icon appears in the bottom-left corner of the page,
and drawing tools appear across the bottom of the page. Draw by dragging your stylus.

To see a list of a book’s annotations, including bookmarks, highlights, text notes, and
drawings, tap Annotations Index on the book’s cover page. You can tap an entry in the
list to go to the annotated page.

Removing a Book

When you finish reading a book, you can delete it to conserve space on
your 700 Color Computer. If a copy of the book is stored on your desk-
top, you can download it again at any time.

To remove a book from your 700 Color Computer, tap and hold the title
in the Library list, and then tap Delete on the pop-up menu.
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Pocket Internet Explorer

Use Microsoft Pocket Internet Explorer to view Web or WAP pages in
either of these ways:

* During synchronization with your desktop, download your favorite
links and mobile favorites that are stored in the Mobile Favorites sub-
folder in Internet Explorer on the desktop.

* Connect to an ISP or network and browse the Web. To do this, create
the connection first, as described in “Gerting Connected’ on page 98.

When connected to an ISP or network, you can also download files and
programs from the Internet or intranet.

To switch to Pocket Internet Explorer on your 700 Color Computer, tap
Start > Internet Explorer.

The Mobile Favorites Folder

Favorite Links

94

Only items stored in the Mobile Favorites subfolder in the Favorites folder
in Internet Explorer on your desktop are synchronized with your 700 Col-
or Computer. This folder was created automatically when you installed
ActiveSync.

During synchronization, the list of favorite links in the Mobile Favorites
folder on your desktop is synchronized with Pocket Internet Explorer on
your 700 Color Computer. Both computers are updated with changes
made to either list each time you synchronize. Unless you mark the favor-
ite link as a mobile favorite, only the link is downloaded to your 700 Color
Computer. Connect to your ISP or network to view the content.

1 In ActiveSync on your desktop, click Tools > Options, and select “Fa-
vorites” from the Mobile Device list. For more information on using
ActiveSync, see ActiveSync Help on the desktop.

2 In Internet Explorer on your desktop, save or move favorite links to the
Mobile Favorites subfolder in the Favorites list via Favorites > Organize
Favorites. For more information on using Internet Explorer, see Internet

Explorer Help on the desktop.

3 Connect your 700 Color Computer to your desktop. If synchronization
does not start automatically, in ActiveSync on your desktop, click Sync.
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Mobile Favorites

If you are using Microsoft Internet Explorer 5.0 or later on your desktop,
you can download mobile favorites to your 700 Color Computer. Syn-
chronizing mobile favorites downloads Web content to your 700 Color
Computer so that you can view pages while you are disconnected from

your ISP and desktop.

Use the Internet Explorer plug-in installed with ActiveSync to create mo-
bile favorites quickly. To create a mobile favorite:

1 In ActiveSync on your desktop, click Tools > Options, and select
“Favorites” from the Mobile Device list. For more information on using
ActiveSync, see ActiveSync Help on the desktop.

2 In Internet Explorer 5.0 or greater on your desktop, browse to the page
you want to view offline, then click Tools > Create Mobile Favorite.

3 To change the link name, enter a new name in the Name box.

4 In the Update box, select a desired update schedule to keep the page in
the Mobile Favorites folder up to date. You can also update content by
clicking Tools > Synchronize in Internet Explorer.

5 To save the link in a subfolder of Mobile Favorites, click Create In and
select the desired subfolder.

6 Click OK. Internet Explorer downloads the latest version of the page to
your desktop.

7 To download the pages that are linked to the mobile favorite you just
created, in Internet Explorer on the desktop, right-click the mobile
favorite, then click Properties. On the Download tab, specify the
number of links deep you want to download. 7o conserve 700 Color
Computer memory, go only one level deep.

8 Connect your 700 Color Computer to your desktop. If synchronization
between your 700 Color Computer and desktop does not start, in Acti-
veSync on your desktop, click Sync.

Mobile favorites take up storage memory on your 700 Color Computer.
To minimize the amount of memory used:

* In the settings for the Favorites information, type in ActiveSync op-
tions, turn off pictures and sounds, or stop some mobile favorites from
being downloaded to the 700 Color Computer. For more information,
see ActiveSync Help.

* Limit the number of downloaded linked pages. In Internet Explorer on
the desktop, right-click the mobile favorite you want to change and then
Properties. In the Download tab, specify “0” or “1” for the number of
linked pages you want to download.
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Using AvantGo Channels

AvantGo is a free interactive service that gives you access to personalized
content and thousands of popular Web sites. You subscribe to AvantGo
channels directly from your 700 Color Computer. Then, you synchronize
your 700 Color Computer and desktop, or connect to the Internet to
download the content. For more information, visit the AvantGo Web site.
To synchronize an AvantGo channel:

27

1 In Pocket Internet Explorer on your 700 Color Computer, tap to

display your list of favorites.
2 Tap the AvantGo Channels link.
3 Tap Activate.

4 Follow the directions on the screen. Synchronize your 700 Series Com-
puter with your desktop, then tap My Channels to complete the Avant-
Go setup.

5 When synchronization is complete, tap the AvantGo Channels link in
your list of favorites to see a few of the most popular channels.

To add or remove channels, tap the Add or Remove link.

Using Pocket Internet Explorer

96

You can use Pocket Internet Explorer to browse mobile favorites and chan-
nels that were downloaded to your 700 Color Computer without connect-
ing to the Internet. You can also connect to the Internet through an ISP or
a network connection and browse the Web.

£ Internet Explorer 47 =4£ 12:32 9

file: f fiwindowrs\default, htm vl s

i ) Wicrosoft
Pocket Internet Explorer

Welcome to Pocket Internet
Explorar. kot online yet? Find aut
hiowr to et connected and save
offline comtent.

fntermec
@ Avant Go-
PocketPC.com

¥iew Tools <& € i} <% E|‘

‘ Favorites button
Home button
Refresh button
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Viewing Mobile Favorites and Channels
1 Tap the Favorites button to display your list of favorites.

2 Tap the page you want to view.

£ Internet Explorer 4F =4£ 1247 @
Favorites
% Mobile Favarites

Ay fvantGo Chanrels — Tap the favorite you want
to view.

[@ Pocket PC Wb Guide

-8 WindowsMedia.com
{21 vacation web Sites
{5 wark wieh Sites

Cpen | Add | Delete

B[

Tap to add or delete a folder or favorite link.

The page that was downloaded the last time you synchronized with your

desktop opens. If the page is not on your 700 Color Computer, the favor-
ite is dimmed. Synchronize with your desktop again to download the page
to your 700 Color Computer, or connect to the Internet to view the page.

Browsing the Internet
1 Set up a connection to your ISP or corporate network using Connec-
tions, as described in “Gesting Connected” on page 98.

2 To connect and start browsing, do one of the following:
* Tap the Favorites button, and then tap the favorite you want to view.

* Tap View > Address Bar. In the address bar that appears at the top of
the screen, enter the Web address you want to visit and then tap Go.
Tap the arrow to choose from previously entered addresses.

% Note: To add a favorite link while using the 700 Color Computer, go to
the page you want to add, tap and hold on the page, and tap Add to
Favorites.
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Getting Connected

You can set up connections to the Internet and corporate network at work
to do such activities as browsing the Internet or intranet, sending and re-
ceiving e-mail and instant messages, and synchronizing information using
ActiveSync.

Connections can be made using a modem, wireless network, or Ethernet.
You can use a modem connection to set up connections with an external
modem, or through your mobile phone network using a cellular line or

GPRS.

Your 700 Series Computer has two groups of connection settings: My ISP
and My Work Network. Use My ISP settings to connect to the Internet.
Use My Work Network settings to connect to any private network, such as
a corporate network used at work.

* My ISP: Once connected, you can send and receive e-mail messages by
using Inbox and view Web or WAP pages by using Pocket Internet Ex-
plorer. The communication software for creating an ISP connection is
already installed on your 700 Series Computer. Your service provider
provides the software needed to install other services, such as paging and
fax services. If this is the method you want to use, see “Connecting to an
Internet Service Provider” on page 98.

* My Work Network: Connect to the network at your company or orga-
nization where you work. Once connected, you can send and receive
e-mail messages by using Inbox, view Web or WAP pages by using
Pocket Internet Explorer, and synchronize with your desktop. If this is
the method you want to use, see “Connecting to Work” on page 102.

Connecting to an Internet Service Provider

98

2

You can connect to your ISP, and use the connection to send and receive
e-mail messages and view Web or WAP pages. You can connect to your
ISP via a modem connection.

Obtain the following information from your ISP. Some ISPs require infor-
mation in front of the user name, such as MSN/username.

e ISP dial-up access telephone number
* User name
* Password

If you do not have a modem dock, use a NULL modem cable and ap-
propriate adapters to connect an external modem to your 700 Color Com-
puter through the serial port.

To view additional information for any screen in the wizard or while
changing settings, tap the Help icon.
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Connections

My ISP, tap Add

Chapter 2 —

a new modem connection.

& gcre O

j“ Settings

Connections

@

Ta set up or change connection infarmation,
tap one of the following links,

My ISP

&dd & new modem connection

My Waork Network

Add a new modem connection
&dd & new YPH server connection

Set up my procy server

Tasks | Advarced |

B[

Windows Mobile 2003

1 Tap Start > Settings > the Connections tab > the Connections icon. In

2 Enter a name for the connection, such as “ISP Connection.”

In the Select a modem list, select your modem type. If your modem
type does not appear, try reinserting the 700 Color Computer into your
modem dock. If you are using an external modem that is connected to
your 700 Color Computer with a cable, select “Hayes Compatible on
COM1.” Tap Next to continue.

- £ z01

j“ Settings

Make Mew Connection

Erker & name far the connection:

|ISP Cannectian

Seleck 3 modenm:

|Hayes Compatible on COMI;

| Cancel || Back || Naxt
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3 Enter the access phone number, then tap Next.

o ¢ 652

ISP Connection 9

Enter the number exactly as it should be
dialed, Include any extra numbers, such as
an outside line or credit card,

|9-319-369-3580 |

If vou travel or change area codes often,
use dialing rules,

| Cancel || Back || Naxt

B[

4 You should not need to change any settings in Advanced. Most ISPs
now use a dynamically-assigned address. If the ISP you are connecting
to does not use a dynamically-assigned address, tap Advanced > the

TCP/IP tab, tap Use specific IP address, then enter the address. Tap ok
to close the Advanced page.

&gtz O

Advanced

D |Use server-assigned IP address
@ Use specific IP address

0o . no.o.0
|:| Use slip
Ise saftw are campression
sz IP header compression

General | Port Settings | TCR/IP | SErVErS |

B[
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Enter the user name, password, and domain (if provided by an ISP or
your network administrator), then tap Finish.

4| Settings - 4 &7

ISP Connection 9

User name: | |

Passward: | |

Coomain: * | |

* If pravided by 15P or network administrator,

Cancel || Back || Finish |

B[

5 Tap the Advanced tab from the Connections screen, then tap Select
Location to specify your current location. These settings apply to all
connections. Tap Use dialing rules, tap OK,then tap Edit to continue.

f| Settings g o qcezz D & 4c137 D
Dialing Locations 9 Dialing Locations 9
Based on your location, dialing rules determine Based on your location, dialing rules determine
bz & number is dialed and the best number bz & number is dialed and the best number
touse if more than one exists. touse if more than one exists.

Use dialing rules Use dialing rules
Select where you are dialing From: Select where you are dialing From;
{CHome {CHome
®wark (CMohile
(OMabile
wrwork
| Edit.. || New.. | [ Edit.. || New.. |
B[ B[
730, 740, 750, 760 Screens 741,751,761 Screens
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E4

Connecting to Work

102

6 Specify your current phone type. If your phone type is pulse dialing,
check the Pulse dialing box. If your type is tone dialing (as most phone
lines are), then clear the Pulse dialing box. Continue to tap ok to close
each page and return to the Settings page.

Work

Settings O LT @
L7
|

Marne: |Wclr|<

Cauntkry cods:

Area code:
|:| Disable call waiting: I:I

[] Pulse dialing
Dialing Patterns...
Edit B[

To start the connection, start using one of the following programs. Once
connected, you can:

* Send and receive e-mail messages by using Inbox. Before you can use
Inbox, you need to provide the information it needs to communicate
with the e-mail server. For specific instructions, see “Connecting Directly
to an E-mail Server” on page 114.

* Visit Web and WAP pages by using Pocket Internet Explorer. For more
information, see “Pocket Internet Explorer” on page 94.

* Send and receive instant messages with MSN Messenger. For more in-
formation, see “MSN Messenger” on page 84.

Note: To change modem connection settings in My ISP, tap Manage
existing connections. Select the desired modem connection, tap Settings,
and follow the instructions on the screen.

If you have access to a network at work, you can send e-mail messages,
view intranet pages, synchronize your 700 Color Computer, and possibly
access the Internet. You can connect to work in one of two ways:

Create a modem connection by using a RAS (Remote Access Server) ac-
count. Before you can create this modem connection, your network ad-
ministrator needs to set up a RAS account for you. Your network adminis-
trator may also give you Virtual Private Network (VPN) settings.

Get a dial-up access telephone number, a user name, and a password from
your network administrator. If your 700 Color Computer does not have
access to a mobile phone network, insert your 700 Color Computer into a
modem dock.
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% Note: To change modem connection settings in My Work Network, tap
Manage existing connections. Select the desired modem connection, tap
Edit, and follow the instructions on the screen.

e To view additional information for any screen in the wizard or while
changing settings, tap the Help icon.

Creating a Modem Connection to Work

7} 1 Tap Start > Settings > the Connections tab > the Connections icon.
%‘* Tap Add a new modem connection beneath My Work Network to ini-
Connections tiate this procedure.

& gcre O

Connections 9

Ta set up or change connection infarmation,
tap one of the following links,

My ISP
&dd & new modem connection

My Waork Network

Add a new modem connection
&dd & new YPH server connection
Set up my procy server

Tasks | Advarced |
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2 Enter a name for the connection, such as “Company Connection.” In
the Select a modem list, select your modem type. If your modem type
does not appear, try reinserting your 700 Color Computer into your
modem dock.

If using an external modem connected to your 700 Computer with a

cable, select “Hayes Compatible on COM1.”

If using any type of external modem, select the modem by name. If a
listing does not exist for your external modem, select “Hayes Com-

patible on COM1.”

Wireless connections can be made via a mobile phone network or
GPRS. If using a mobile phone network to connect, select “Cellular
Line.” If using GPRS, tap “Cellular Line (GPRS).”

Tap Next to continue.

Make Mew Connection 9

Erker & name far the connection:
|Cumpan\,r Cornnection |

Seleck 3 modenm:
|Hayes Compatible on COMI; v|

| Cancel || Back || Naxt

B[

3 Enter the access phone number, using some of the following guidelines.
If you know part of the phone number changes frequently as you travel,
create dialing rules to avoid creating numerous modem connections for
the same phone number. For more information, tap Use Dialing Rules.

Enter the phone number exactly as you want it dialed. For example,
if you call from a business complex or hotel that requires a nine be-
fore dialing out, enter “9” in front of the phone number.

Enter the APN provided by your mobile phone service provider.

When using dialing rules, phone numbers are entered differently. To
use additional numbers, such as a “9” to dial from an office complex
or hotel, you must use additional dialing rules or change dialing pat-
terns. See “Create Dialing Rules” via your online help for information.

a In the Country/Region box, enter the appropriate code when dial-
ing internationally. For more information, contact an operator at
your local phone company.

b In the Area code box, enter the area code. Area codes are not need-
ed in all countries.
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¢ Enter the main phone number, then tap Next to continue.

£ 1:24 ; 4 124

Company Connection 9 Company Connection 9

Country|Region code: Enter the number exactly as it should be

digled, Inlude any exkra numbers, such as
an outside line or credit card,

Area code: Phone number: | |

ps | | |

If vou travel or change area codes often,
use dialing rules,
| Cancel || Back || Next | | Cancel || Back || Next |

1231[2[3]4]5]6][7[8][9[0]-
Tab[a|wle[r [ty u]i[o[p|[[]
CAPlals[d[flalh]i[k[IT:]"]
shiftf z [k [c[v[b[n[m[,[.[/]+
cufai - A ] [L]r]<]>
Bl el

[«

4 Enter the user name, password, and domain (if provided by an ISP or
your network administrator). If a domain name was not provided, try
the connection without entering a domain name.

o qE11:17

Company Connection 9

Liser name: || |

Passward: | |

Coomain: * | |

* If pravided by 15P or network administrator,

Cancel || Back || Finish |

B[

5 You should not need to change any advanced settings. Instances where
you are to change advanced settings include the following. To change
advanced settings, tap Advanced. Otherwise, tap Finish.

* You want to change baud rate settings, dialing string commands, or
credit card options.

* You need to change port settings.

* The server you are connecting to does not use dynamically-assigned
addresses, and you need to enter your TCP/IP settings.
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E4

%

Connections

Note: The following information applies when you have “Wireless

802.11” selected via the NDISTRAY pop-up menu (see page 129).

Creating a Wireless Network Connection

Microsoft Corporation’s wireless network configuration tool is called
“Wireless Zero Config.” Intermec Technologies recommends that you use
the Wireless Network control panel applet instead as it offers more security
choices and exhibit better roaming behavior. Information about the Wire-
less Network control panel applet is in Appendix A.

Networks already configured are preferred networks and are listed in
Wireless networks. You can connect to only preferred networks or search
for and connect to any available network.

A wireless network can be added either when the network is detected, or
manually by entering settings information. To determine if authentication
information is needed, see your network administrator.

1 Tap Start > Settings > the Connections tab > the Connections icon.

& gcre O

Connections 9

Ta set up or change connection infarmation,
tap one of the following links,

My ISP
&dd & new modem connection

My Waork Network

Add a new modem connection
&dd & new YPH server connection
Set up my procy server

Tasks | Advarced |
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2 Tap the Advanced tab > Network Card > the Wireless tab > Add New

F%| cettings  dqc12z47 D
Configure Wireless Metworks 9
Add Mew...

Mebworks to access:
|l Avalabls -

|:| Aubamatically connect to non-preferred
networks

wireless | Metwork Adapters

B[

3 Tap the General tab, then enter a network name. If the network was
detected, the network name is entered and cannot be changed.

From Connects to, select to what your network is to connect. If you
select “Work,” you can do a vpn connection or use proxy servers. If you
select “The Internet,” you can connect directly to the internet.

To connect to an ad-hoc connection, select This is a device-to-device
(ad-hoc) connection.

Configure Wireless Network 9

Mekw otk name: |Management |

Connecks to: |WDrk "|

D Thisis a device-to-device (ad-hoc)

conneckion

General | Network Key | 802, 1x |

B[
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4 Tap the Network Key tab, then do the following:
To Disable Authentication

a Set Authentication to either “Open” if WEP keys are not required;
or “Shared” when WEP keys are required for association.

b Set Data Encryption to “Disabled.”

q 4cn7 @

Configure Metwork Authentication 9

Authentication: (eI} -

Daka Encryplion: Nisabled

The Key is provided For me automatically

Metwork key: | sk e e

Key indesx:

General | Network Key | 802, 1x

B[

To Enable WEP Encryption

a Set Authentication to either “Open” if WEP keys are not required;
or “Shared” when WEP keys are required for association.

b Set Data Encryption to “WEP.”

¢ To change the network key, clear The Key is provided for me auto-
matically box, then enter the new Network key and select the ap-
propriate Key index.

13| Settings & qcaae O
Configure Metwork Authentication 9

Aukhentication (eI} -

Daka Encryplion: WEPR -

D The Key is provided For me automatically

Metwork key: | sk e o

Key index:

General | Network Key | 802, 1x

B[
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Note: The following information applies when you have Enable
Microsoft’s Wireless Zero Config checked via the Wireless Network
control panel applet (see Appendix A, “Configurable Settings”).

To Enable WPA Authentication (730, 751, 751, 761 Computers)

a Set Authentication to “WPA.” See page 364 for information about
WPA encryption.

b Set Data Encryption to either “WEP” or “TKIP.” See page 364 for
information about WEP and TKIP encryption.

q 4c3ss @

Configure Metwork Authentication 9

Lwthentication: WP -
Daka Encryplion: KIP -

The Key is provided For me automatically

Metwork key: | sk e e

Key indesx:

General | Network Key | 802, 1x

B[

To Enable WPA Authentication Using a Preshared Key (730, 741, 751, 761 Computers)

a Set Authentication to “WPA-PSK.” See page 364 for information
about WPA encryption.

b Set Data Encryption to either “WEP” or “TKIP.” See page 364 for
information about WEP and TKIP encryption.

¢ Enter the new Network key.

& 4c 400 @

Configure Metwork Authentication 9

Lwthentication: WP A-Pok -

Daka Encryplion: KIF b

The Key is provided For me automatically

Metwork key: | sk e o

Key indesx:

General | Network Key | 802, 1x

B[
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5 Tap the 802.1x tab, select either “PEAP” or “Smart Card or Certificate”
for the EAP type, then tap Properties to adjust its settings.

q 4c 003 @

Configure Metwork Authentication 9

Use IEEE 202, 13 network access contral

EAF bupe: |5mart Card ar Certificate v|

General | Network Key | @02, 1x |

B[

6 Tap ok to return to the Configure Wireless Network screen.

7 From the Networks to access drop-down list, select “All Available,”
“Only access points,” or “Only computer-to-computer” depending on
the type of networks to which you connect.

To connect only to networks you have already configured, clear Auto-
matically connect to non-preferred networks.

Tap ok to close this screen.

& 45406 D
Configure Wireless Metworks 9
Add Mew... -
i fyailable [
1 psupl Byvailable
1 psup2 Byvailable =
1 psup21 Byvailable
1 psuUpS Ayailable ||
= SyYORdemna Ayailable: =
o fi=em . ] 1 o= =g =il = =],

Mebworks to access:

|:| Aubamatically connect to non-preferred
networks

wireless | Metwork Adapters

B[

% Note: If you select to automatically connect to non-preferred networks,
your device detects any new networks and provide you the opportunity to
configure them.
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Creating a VPN Server Connection to Work

A VPN connection helps you to securely connect to servers, such as a cor-
porate network, via the Internet. Ask your network administrator for the
following:

e User name

Password

¢ Domain name

TCP/IP settings

* Host name or IP address of the VPN server

e To view additional information for any screen in the wizard or while
changing settings, tap the Help icon.

% Note: To change existing settings in My Work Network, tap Manage
existing connections > the VPN tab. Select the desired VPN connection,
tap Settings, and follow the instructions on the screen.

7} 1 Tap Start > Settings > the Connections tab > the Connections icon.
%‘* Tap Add a new VPN server connection beneath My Work Network to
Connections initiate this procedure.

& gcre O

Connections 9

Ta set up or change connection infarmation,
tap one of the following links,

My ISP
&dd & new modem connection

My Waork Network

Add a new modem connection
&dd & new YPH server connection
Set up my procy server

Tasks | Advarced |
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2 In Name, enter a name for the connection, such as a company’s name.
In Host name/ IP, enter the VPN server name or IP address.

Next to VPN type, select the type of authentication to use with your
device: “IPSec/L2TP” or “PPTP.” If you are not sure which option to
choose, ask your network administrator.

Tap Next to continue.

Make Mew Connection 9

Marme: ||'\.||y AN |
Hast narnef IP: | |

VPN type: (W) IPSec/L2TP

{5 PPTP

Cancel || Back || Naxt

B[

3 Select the type of authentication. If you select A pre-shared key, enter
the key provided by your network administrator.

e o £ 11:54
My ¥PN (2]
Authenticate IPSec/L2 TP connections using:

{3 A certificate on this device
@ A pre-shared key

| Cancel || Back || Next |
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4 Enter your user name, password, and domain name as provided by your
ISP or network administrator. If a domain name was not provided, try
the connection without entering a domain name.

o 4£11:50

@

User name: | |

Passward: | |

Coomain: * | |

* If pravided by 15P or network administrator,

Cancel || Back || Finish |

B[

5 You should not need to change any Advanced settings. Instances where
you must change advanced settings include:

* The server to which you are connecting does not use dynamically-as-
signed addresses, and you need to enter your TCP/IP settings.

* You need to change server DNS or WINS settings.
To change advanced settings, tap Advanced. Otherwise, tap Finish.

Insert necessary equipment, such as a network (Ethernet) card, into the
device, and use a desired program to automatically begin connecting. For
example, switch to Pocket Internet Explorer and browse to a Web page.

Ending a Connection
To disconnect, do one of the following:

E * When connected via modem or VPN, tap the Connectivity icon on the

navigation bar, and then tap Disconnect.
* When connected via cable or cradle, detach your device.

* When connected via Infrared, move the device away from the other
computer or device.

o When connected via a wireless network, switch off the connection.
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Connecting Directly to an E-mail Server

E4

You can set up a connection to an e-mail server so that you can send and
receive e-mail messages by using a modem or network connection and In-
box on your 700 Color Computer.

Note: The ISP or network must use a POP3 or IMAP4 e-mail server and
an SMTP gateway.

You can use multiple e-mail services to receive your messages. For each
e-mail service you intend to use, first set up and name the e-mail service. If
you use the same service to connect to different mailboxes, set up and
name each mailbox connection.

Setting Up an E-mail Account

2

114

Do the following to set up an e-mail service. Tap the question mark at the
top of the screen for more assistance.

1 On your 700 Color Computer, tap Start > Inbox to access the Inbox
application. Tap Accounts > New Account.

2 Enter an e-mail address, tap Next, Cancel, then Next after the status of
the automatic configuration is listed as “Completed.”

£ 114
E-mail Setup {1/5) (2]
E-miail address
Enter &-rhail addrass:
|Hame@c0mpany’.mn‘|
Cancel || Back || Next
Edit E|A
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3 Enter the Your name and Password information, then tap Next.

& Inbox o ¢ 1:16

E-mail Setup {3,/5)

User information

oL marme! |,ﬂ-,dam Erarr |

IJzer name: |Adal‘n |

Password: |**"‘****"1 |

D Save passiord

|Eanl:e| || Back || Next |

Edit E|A

4 Select the appropriate service type from the Account type drop-down
list, either “POP3” or “IMAP4,” or enter a new account type, then tap

Next.

& Inbox o ¢ 1:16

E-mail Setup {4,5)

Account information

Account bype:

Mame: |POP3

Cancel || Back || Next

Edit E|A
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5 In Incoming mail, enter the name of your e-mail server. In Outgoing
mail, enter the name of your Simple Mail Transfer Protocol (SMTP)
host. If you are using a network connection, enter your domain name in
Domain. Tap Options to do additional configurations. Tap Finish to

assign this service.

| Inbox < 4f 1118

E-mail Setup {5/5) (2]

Sapver information

Incarning mail: |

|

Dukgoing mail: | |
Dromnain: | |

| Cancel || Back || Finish |

Edit E|A

When finished, to connect to your e-mail server, from the Inbox applica-
tion, tap Accounts > Connect. For more information on using the Inbox
application, see “Inbox: Sending and Receiving E-mail Messages” on page 73.
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3 Installing Applications

There are multiple ways to get an application to your 700 Series Color
Mobile Computer; just as there are multiple ways to package the applica-
tion for delivery.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.
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Packaging an Application

118

Use any of these methods to package an application for installation:

* For very simple applications, the application itself might be the only file
that needs to be delivered.

* It could be a directory structure that contains the application, support-
ing files like ActiveX controls, DLLs, images, sound files, and data files.

* Or, you could package an application via a CAB file.

Consider any of the following when choosing a location into which to
store your application:

* In the basic 700 Color Computer, there are two built-in storage op-
tions: the Object Store and the Persistent Storage Manager (PSM). The
Object Store is RAM that looks like a disk. Anything copied here is de-
leted when a cold-boot is performed on the 700 Color Computer. The
PSM is an area of storage which is embedded in a section of the system’s
FLASH memory. This storage area is 7ot erased during a cold-boot. It
may, however, be erased during the reflashing process. In addition to
storing applications and data files, you do have the option to store a per-
sistent registry to the PSM region.

* If the optional Secure Digital or CompactFlash storage card is in the
system, then consider this card the primary location for placing an ap-
plications install files. The following folders represent either card:

* The Secure Digital storage card creates the “\SDMMC Disk” folder.
* The CompactFlash storage card creates the “\Storage Card” folder.

% Note: The 730 Mobile Computer does 7oz support the Compact

Flash storage card.

* Use the small non-volatile Flash File Store region to hold CAB files that
rebuild the system at cold-boot or install applications from a CAB file
into the Flash File Store so they are “ready-to-run” when a cold-boot is
performed. Since the FLASH in the system has a limited number of
write cycles, do not use the Flash File Store for excessive writing pur-
poses; however, reading is okay.

Files copied to any of these locations are safe when a cold-boot is
performed on a 700 Color Computer — providing the AutoRun system is
installed in the appropriate location You can find this system in the 700
Color Management Tools portion of the Intermec Developer’s Library CD.
Copying a CAB file to the “N\CABFILES” folder on one of these cards
automatically extracts that CAB file on every cold-boot to ensure that your
system is properly set up (see page 124).
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Installing Applications

Consider any of the following options to get the package to the preferred
location on your 700 Series Computer.

* Microsoft ActiveSync
e FTP Server (page 120)
* Secure Digital or CompactFlash storage cards (page 120)

Using Microsoft ActiveSync

E4

Note: These instructions assume the 700 Color Management Tools por-
tion of the Intermec Developer’s Library CD was installed on your desktop.

The Microsoft ActiveSync tool is located on the 700 Color Companion CD.
See Chapter 2, “Windows Mobile 2003,” for information about this tool as
provided by Microsoft Corporation.

This can be a serial, USB, Ethernet, InfraRed, or 802.11b ActiveSync con-

nection. Files can be copied using File Explorer on a desktop or a laptop
computer. This is usually good when updating few 700 Color Computers.

Note: The 730 Computer does 7oz support Ethernet.

These instructions assume that Microsoft ActiveSync was installed onto
your desktop and is up and running. If not, go to Chapter 2, “Windows
Mobile 2003,” for an URL from which to download the latest application.

1 Connect your 700 Color Computer to your desktop computer via an
ActiveSync cable or IrDA.

2 Wait for a “Connected” message to appear in the Microsoft ActiveSync
application to signal a connection to the 700 Series Computer. If neces-
sary, select File > Get Connected to initiate a connection.

+ Microsoft ActiveSync N ]
File Wiew Tools Help

¥ 0 H 8 =

Sync Stop || Details  Explore Options

Pocket_PC O
1+
Connected

Synchronized

Information Type | Skatus
ECalendar Synchronized
ElCDntacts Synchronized
Tasks Synchronized
[E' Favorites Synchronized
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Explore

3 Click Explore to access the Mobile Device folder on your unit.

4 From your desktop, select Start > Windows Explorer, then browse the

Using the FTP Server

The 700 Color Computer has a built-in FTP Server that connects to a net-
work via Ethernet, 802.11b, or WAN (Wireless Access Network). This
allows connections to the 700 Color Computer to perform file transfers or
computer management functions. Another benefit is you can create FTP
scripts to automate the process of copying files to the 700 Color Comput-
er. This option is good for when a large number of 700 Color Computers
need updating. See Chapter 7, “Programming,” for more information.

Using a Storage Card

Use the following steps to install an application using a storage card:

120

E4

“C:\Intermec\700C Mgmt Tools\CabFiles” path for any CAB files
needed for your 700 Color Computer. Select the appropriate file, right-
click the file for a pop-up menu, then select Copy.

Within the Mobile Device directory, go to the directory where you
want the files located on the 700 Color Computer, do a right-click for a
pop-up menu, then select Paste.

When all of the files are pasted, perform a warm-boot on the 700 Color
Computer. When the computer reboots, wait for the LED on the top
left of your keypad to stop blinking. Tap Start > Programs > File
Explorer to locate the newly copied executable files, then tap these files
to activate their utilities.

Copying to a CompactFlash Card

Note: These instructions do 7oz apply to the 730 Computer.

1

Suspend the 700 Color Computer and remove its CompactFlash drive,
which holds a SanDisk CompactFlash storage card.

Using a CompactFlash Adapter card, place the CompactFlash drive in
your desktop PC card drive.

Create a subdirectory on the PCMCIA CompactFlash drive in which to

store your application.

Use the CEImager application to add the autorun system to the storage
card. See the Software Tools User’s Manual to learn about CEImager.

Copy your application, data files, and all required DLLs and drivers to
the subdirectory created on the CompactFlash drive.

6 Add your application to the AUTOUSER.DAT file on the

“\Storage Card\2577” directory with the following statement:
RUN=\<your directory>\<yourapp.exe>

where your directory is the directory on the CompactFlash storage card

where the application was installed, and yourapp.exe is the name of your

application. Finish the “RUN=" statement with a carriage return line-

feed combination. There may be multiple run statements in the file.
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7 Remove the CompactFlash card from your desktop and reinstall it into
the 700 Color Computer.

8 Warm-boot the 700 Color Computer to add these files to the Compact-
Flash storage card.

If the AUTOUSER.DAT file is found and the “RUN=" statement is cor-

rect, the task manager launches and executes your program on startup.

(opymg to a Secure Digital Storage Card
1 Suspend the 700 Color Computer and remove its Secure Digital drive,
which holds a Secure Digital storage card.

2 Using a Secure Digital Adapter card, place the Secure Digital drive in
your desktop PC card drive.

3 Create a subdirectory on the PCMCIA Secure Digital drive in which to
store your application.

4 Use the CEImager application to add the autorun system to the storage
card. See the Software Tools User’s Manual to learn about CEImager.

5 Copy your application, data files, and all required DLLs and drivers to
the subdirectory created on the Secure Digital drive.

6 Add your application to the AUTOUSER.DAT file on the
“\SDMMC Disk\2577” directory with the following statement:
RUN=\<your directory>\<yourapp.exe>
where your directory is the directory on the Secure Digital storage card
where the application was installed, and yourapp.exe is the name of your
application. Finish the “RUN=" statement with a carriage return line-
feed combination. There may be multiple run statements in the file.

7 Remove the Secure Digital card from your desktop and reinstall it into
the 700 Color Computer.

8 Warm-boot the 700 Color Computer to add these files to the Secure
Digital storage card.

If the AUTOUSER.DAT file is found and the “RUN=" statement is cor-

rect, the task manager launches and executes your program on startup.

Updating the System Software

You can use the Intermec Recovery CD to reinstall or update the operating
system software on the 700 Color Computer. For more information, con-
tact your Intermec representative.
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Migrating Applications

Intermec CE
Imager

Note: These instructions assume that the 700 Color Management Tools
portion of the Intermec Developer’s Library CD was installed on your desk-
top and that a storage card was added to the base configuration of the 700
Color Computer.

Do the following required steps to ensure that CAB files are restored, ap-
plications automatically start, and registry is restored on cold-boot:

1 From your desktop, double-click the Intermec CE Imager desktop icon
to access the Intermec CEImager application. If this icon is not on your

desktop, then double-click the CEIMAGER.EXE executable from the
“C:\Intermec\700C Mgmt Tools\Tools\CEImager” folder.

2 Click Default under Components List to activate the components.

3 Click (+) to expand the AutoRun System component, click (+) to ex-
pand the Destination Media option, then select either the
CompactFlash Card option or the Secure Digital Card option. Do not
select both storage cards, as the AutoRun files copied will work for one stor-
age card, but not work on the other storage card.

% Note: The 730 Computer does 7ot support CompactFlash storage cards.

122

i Intermec CEImager 1[
r Source Falder Inztal
|E:‘\Intermec\?DDE gt Tools Browse |

E xit |

— Destination
[~ AIFOOFTF Servers

IF: LI Browse |

¥ Fomat Drive | Remove Registy

Components List
’V & Defak " Custom

— Components

Drefault |
-[] Destination Media-SELECT ONE MED
- [0 CompactFlash Card [32K) Wiriirmur |

H i [#] Secure Digital Card [32K]
D Demos (0K selected] Al

-] Programs [OK. zelected)
Mane |
Tatal Size Selected
32K

| | i3

4 Click Install to install the AUTORUN files onto the storage card.
5 Create a “\CabFiles” folder on the storage card. Copy any CAB files that

are to be extracted on every startup into this folder.
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6 In the “\2577” directory, add your custom AUTOUSER.DAT file. See
the Recovery Help for more information on how to set up an

AUTOUSER.DAT file.

7 If you are using the RegFlushKey() API, the application must use a spe-
cial API to make sure the registry is written to the appropriate card; or
you can use the Utilities control panel applet, as follows. See Appendix
A, “Configurable Settings,” for more information about this applet.

a From the 700 Series Computer, tap Start > Settings > the System tab
W > the Utilities icon > the Registry Save tab.

Utilities b Tap Enable Registry Storage to save the registry in the Flash File Sys-
tem (PSM) via the “\Flash_File_Store\Registry” path.

¢ Tap ok to save your entry and exit the Utilities control panel applet.

¥ |Settings g &F AE 754 (D &g O
Utilities Utilities
Registry settings can be saved between cold Reqiskry ssttings can be saved betweaen cold
boots, The regiskry is saved during device baoats, The rediskry is saved during devics
resets or when applications use the resets or when applications use the
RegFlushkey Function, RegFlushkey function.

Enable Registry Storage Enable Registry Starage

If enabled, the real time clack
can be restored on a cold book

Enable RTC Restare

Dock Switch | Registry Save | akeup MaEII Dock Switch | Registry Save | akeup MaEII

=] =]

700 Color Screen 730 Screen

8 Remove the storage card from the desktop PC and install the card into
the 700 Series Computer.

9 Perform a cold-boot on the 700 Series Computer. Files automatically
install from the storage card upon reboot. Any calls to the
RegFlushKey() API automatically writes the registry to the appropriate
location.

% Note: Both the warm-boot and the cold-boot procedures, via the software
API, will also flush the registry.
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Migrating from a 700 Monochrome Computer

As you migrate from a 700 Monochrome Computer to a 700 Color Com-
puter, you need to consider the following: When converting a 700 Mono-
chrome Computer application to run on the 700 Color Computer, most
APIs should work without changes. Below are a few exceptions:

* The 700 Monochrome Computer uses the “\Storage Card” folder for
nonvolatile storage. You may need to change the application to store
data onto the “SDMMC Disk” folder instead of the “\Storage Card”
folder if a Secure Digital storage card is present in the system.

e If the application uses the RegFlushKey() API, it must first verify that
the proper media is available in the system and call the special API men-
tioned in Step 7 on the previous page.

e If the application is using the 700 Color switchable dock, use the
IOCTL_DOCK_SWITCH value from the
IOCTL_HAL_ITC_WRITE_SYSPARM function to set the proper
port on the dock before communications. See more information about
this KernellOControl function in Chapter 7, “Programming.”

* Some WAN radio options have changed. Review the WAN radio infor-
mation in Chapter 4, “Network Support,“to determine if any changes are
required in your application.

* Arrow and tab keys are reversed from the 700 Monochrome Computer.
Keyboard remapping is available on the 700 Color Computer should
you need to map these keys like that of the 700 Monochrome Comput-
er (see page 121).

* Special SDKs are not needed to compile applications for the Xscale pro-
cessor. Targeting the SA1110 processor creates applications that run on

the 700 Color Computer.

Installing Cabinet Files

124

CAB files (short form of “cabinet” files) are compressed folders as defined by
Microsoft. A “cabinet” file is a single file, usually suffixed with .CAB, that
stores compressed files in a file library. A compressed file can be spread
over several cabinet files. During installation, the setup application decom-
presses the files stored in a cabinet and copies them to the user’s system.

For the 700 Series Computer, CAB files register DLLs, create shortcuts,
modify registry entries, and run custom setup programs. Tap a CAB file to
extract that file or place the CAB file on one of the approved storage de-
vices in the “\CabFiles” folder, then perform a warm-boot on the 700 Se-
ries Computer. There are two methods available to extract a CAB file:

* Tap a CAB file to extract it. With this method, the CAB file is automat-
ically deleted when the extraction process is successful, unless the CAB
file is set with the read-only attribute.

* Use the AUTOCAB method to extract all files when a cold-boot is per-
formed on the 700 Series Computer. This method is on the /ntermec
Developer’s Library CD, see its Software Tools User’s Manual for informa-
tion.
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4 Network Support

The 700 Series Color Mobile Computer can integrate up to three radios in
a single unit, and automatically installs the appropriate software for radio
or phone use when the unit is powered on.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.
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Understanding Your 700 Series Computer

Due to the number of 700 Series Computers now available, and to the
number of applications, drivers, and modules that may or may not be
available, these tables are to help you determine what is on your particular
computer.

Hardware Features

730 Computers
740 Computers
741 Computers
750 Computers
751 Computers
760 Computers

761 Computers

802.11b radio, Bluetooth

Ethernet, Bluetooth

Ethernet, Bluetooth

Ethernet, 802.11b radios, Bluetooth
Ethernet, 802.11b/g radios, Bluetooth

Ethernet, 802.11b, CDMA/1xRTT WAN (data only*), GSM/GPRS WAN (data and voice)
radios, Bluetooth

Ethernet, 802.11b/g, CDMA/1xRTT WAN (data and voice), GSM/GPRS WAN (data and

voice) radios, Bluetooth

* This is for units sold in the United States.

Software Applications

CORE (page 132)

WWAN Toolkit

Microsoft Phone for CDMA Radios (page 140)

Microsoft Phone for GSM Radios (page 149)

On-board Wired Ethernet (page 128) X X X X
PhoneUltility (page 154)

SB555 Watcher (page 157)

Wireless Local Area Network (page 129) X
Wireless Personal Area Network (page 182) X X X X X
Wireless Wide Area Network

WWAN Communicator**

Computers: 730 740 741 750 751 760 761
X X X X X X X*

<o

>~
>~
X)X X X ) X

XKoo}k X X

* Does not apply to WAN radios
** See the “WWAN Commaunicator User’s Guide” P/N: 074250.
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Antennas (760/761 Computers)

The 760 Computers have color-coded tips to identify the WWAN radio
type within. Below are the colors and their types. The 761 Computers in
the United States and Canada use the external antenna with no color in its
tip. See your Intermec representative for more information.

* Red (760 Computers)
CDMA (non-Sprint networks) and GSM/GPRS US/Canada

* White (760 Computers)
GSM/GPRS US/Canada and CDMA Sprint networks

* Blue (760/761 Computers)
GSM/GPRS International (MC45 WAN radios)

* No Color (761 Computers)
CDMA and GSM/GPRS US/Canada (MC46 WAN radios)

D

m

Network Adapters

Your 700 Color Computer can have up to three radios installed. The de-
fault network adapter or radio is dependent on what radios are installed in
your 700 Color Computer.

With the boot menu, you can specify “802.11,” “Ethernet,” or “No Net-

working” to load onto your 700 Color Computer when a cold-boot is per-
formed. When a warm boot is performed, the 700 Color Computer loads
the network set just prior to the warm boot.

The 730 Computer only has the 802.11b radio and wireless printing. It
does not have an external antenna. Other radios are 7oz supported. See the
Developer’s Support web site for the latest information on network adapt-
ers for your unit.
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Ethernet Communications (740, 741,750, 751,760, 761 Computers)

Follow the steps below to start Ethernet communications on the 700 Color
Computer. If your system does not contain an 802.11b or 802.11b/g
radio, then Ethernet networking using DHCP is selected as the default.

When “Built-in Ethernet” is selected from the NDISTRAY pop-up menu
(the Network Driver Interface Specification tray application),

* Built-in Ethernet

Wireless 802.11
Mo networking

* AutoFTP On
AutoFTP OFf

then the Ethernet icon shown to the left appears in the System Tray as
circled in the following illustration.

s

 Friday, March 21, 2003
Tap he

128 700 Series Color Mobile Computer User’s Manual



Chapter 4 — Network Support

Wireless 802.11 Communications
When “Wireless 802.117 is selected via the NDISTRAY pop-up menu:
Built-in Ethernet

* Wireless 802.11
Mo networking

* AutoFTP On
AutoFTP OFf

n the Wireless 802.11 antenna icon shown to the left appears in the system
tray as circled in the following illustration.

Start

5 Friday, March 21, 2003
Tap here

=

To configure wireless 802.11 communications on the 700 Color
o Computer, tap Start > Settings > the System tab > the Wireless Network
Wireless icon to access the Profile Wizard for the 802.11b or 802.11b/g radio

LIS TS module. Go to Appendix A, “Configurable Settings,” for configuration
information.

-
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No Networking
When “No networking” is selected from the NDISTRAY pop-up menu:

Built-in Ethernet

Wireless 802.11
* Mo networking

* AutoFTP On
AutoFTP OFf

the disconnected icon shown to the left appears in the system tray as
circled in the following illustration.

Network Selection APIs

The Network Selection APIs change the network adapter configuration
programmatically. Both drivers support the same IOCTL function num-
bers for loading and unloading the drivers. Go to Chapter 7, “Program-
ming,” to see the APIs.
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Network Connections

7] From the 700 Color Computer, tap Start > Settings > the Connections

%‘* tab > Connections > the Advanced tab > Network Card or the Network

Connections  Adapters tab to access the network connections for this unit. Make the
changes necessary for your network, then tap ok when finished. Consider
the following before making your selection:

¢ For a work connection or an internet connection, select the “Built-In
Ethernet (10 Mbps)” option.

* The “802.11b Wireless LAN” option is for 750 and 760 Computers
with legacy 802.11b radios.

* The “802.11b PRISM Wireless LAN” option is for 750 and 760 Com-
puters with standard 802.11b radios.

* The “802.11b/g Wireless LAN” option is for 751 and 761 Computers
with the latest 802.11b/g radios.

13| Settings & 4c100 D 3| Settings S gz O
Configure Network Adapters 9 Configure Network Adapters 9
My network card connects to: My network card connects to:
Tap an adapter to modify settings: Tap an adapter to modify settings:
Built-In Ethernet (10Mbps) - 202,11k Wirslsss LAN
202.11b Wircless LAM | 202.11b PRISM wireless Lok
802.11b PRISM wWireless LAN _ B802.11bfg Wireless LAN
202.11bfg Wirekess LAN = 202.11b Wircless LAN (751 bfg)
802.11b Wireless LAM (751 bfg) L2TP MOISWAN Miniport

LETP NOISYWAM Minipork
Leyricac MOISW AR Miniport
4] I [T»

AsyrcMac NDISYY AN Miniport
PPTP MDISWAN Miniport

417

wireless | Metwork Adapters wireless | Metwork Adapters

B B

700 Color Screen 730 Screen
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CORE (760, 761 Computers with WAN Radios)

Activating CORE

»

File Explorer

&

Core

E4

The Intermec CORE application provides a framework for various mod-
ules that let you configure and manage your Intermec products. If a mod-
ule is not yet used or set, CORE defaults to the first module as listed al-
phabetically.

These modules are software plug-ins that can be configuration tools, such
as the 802.11b or 802.11b/g radio configuration module, or they can pro-
vide information on your environment, such as a battery life module.

CORE modules are collections of specific information. Each module can
display general and detailed information. Tap the General and Details tabs
near the bottom to switch between general and detailed information. Note
that not all modules have detailed information.

CORE is built into the operating system of every 760 or 761 Computer.
To run CORE for the first time, select Start > Programs > File Explorer,
select “\Flash File Store\Apps\CORE,” then tap the CORE executable file.

After CORE is run on the 760 or 761 Computer, tap Start > Programs >
Core to access this application henceforth.

Note: To deactivate CORE, tap CORE > Exit from within the CORE

application.

Install an Available Radio Module

132

To install an available radio module onto your 760 or 761 Computer, tap
Modules > Add/Remove, select a module from the bottom Available box,
then tap Add to put the selected module in the upper Installed box. Click
OK to exit the Add/Remove Modules screen.
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Loading a Radio Module

To load or switch to another radio module installed on the 760 or 761
Computer, tap Modules > Choose Module, select a module from the
Installed Modules box, then tap Choose to initialize and begin using that
module.

To learn more about this application, see its online help. Tap Start >
% Programs > File Explorer and select “\Flash File Store\Apps\CORE,” then
File Explorer  tap the corehelp .HTM file.

ﬁ Note: Once CORE is running, you can return to it by tapping its icon
from the System Tray via the Today screen. Tap Start > Today > the Core
three-ring icon (circled in the following illustration).

HF | start
Friday, March 21, 2008

802.11 CF CORE Module

The 802.11 CF CORE module displays helpful information about the
802.11b or 802.11b/g radio option built into your 760 or 761 Computer.

Note that you can configure the 802.11b or 802.11b/g radio module from
this CORE application. Select Configure > Configure Intermec 802.11
CF from the bottom menu bar to access the Profile Wizard application.
See Appendix A, “Configurable Settings,” for information about this ap-
plication via the Wireless Network control panel applet.
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General

Below are descriptions and meanings for each piece of information pro-
vided via the General tab. Note that the information is listed alphabetically.

Adapter MAC

Antenna

AP Mac

Connected to
or Scanning...

Encryption or
Keys Absent

ESS
P

Link
Power
Signal

TX Power

Identifies the MAC address for this 802.11b or 802.11b/g adapter.
Identifies the antenna used with the 802.11b or 802.11b/g radio: “Primary,” “Secondary,” or “Di-

versity.”

Identifies the MAC address of the access point to which this 760 Computer is connected.

Reports the connection status and to which SSID this 760 Computer is attached.

“Encryption” reports the encryption mode and the association mode (in parentheses). See page 367
for information about WEP encryption. “Keys Absent” reports the association mode in parentheses.
See page 367 for information about WPA encryption.

Identifies the type of network to which you are attached, either an ESS (Extended Service Set)
802.11 Station, or Ad-hoc.

Provides the IP address which can be set as either DHCP (Dynamic Host Configuration Protocol)

or statically.

Indicates the speed at which a connection is made, the data rate of the last transmitted packet.

Indicates the power status of this 802.11b profile, such as “CAM,” “Auto,” or “PSP.”

Identifies the radio signal strength (in dBm) of signals coming from an access point.

Shows the transmit power (in milliwatts) at which transmissions are made.

i
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History

&

History:

This bar graph displays an active history of this radio module’s quality of

connections.

Friendly Indicator:
This indicates the general quality of the 802.11b or 802.11b/g connection.
Three filled dots indicates the best quality; two filled dots dictates good
quality; one filled dot is of fair quality; and when all three dots are empty,
the quality is considered poor. When this icon appears with a red line, the
radio is disconnected or nearly so from the access point.

Intermec 202,11 CF

T @

ESS
802,11 Station

Adapter MaC:
00-02-b3-cf-f9-80
Cornected to:
INTERMEC

Encryption:
Dizabled (Open)

Antenna:
Sacondary

AP Mac:
00-02-2d-ba-33-4f
IP: DHCP Enabled
0.0.00

Povver: Always On
{CAM)

Link: 11 Mbps
TX Power: 63 mar
Signal: -80 dem

bu._n &

Histary

General | Detals

CORE Modules Configure

B[
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Below are descriptions and meanings for each piece of information pro-
vided via the Details tab. Note the information is listed alphabetically.

Attach-Roam Cnt  Includes the number of new associations made during the current session, due to roaming. The
number is reset on suspend/resume cycles.

CCX Status States the status of the CCX features, either enabled or disabled.
Desired SSID Identifies the preferred Service Set Identifier (SSID).
Driver Name Identifies the 802.11b or 802.11b/g driver installed on this 700 Color Computer.

Last 5 Supp Msgs Monitors and reports the 802.11 Security Supplicant activity.
Scanlist Indicates whether the Scan List option was enabled or disabled.

Supplicant Status  Monitors the 802.11 security activity on the client: “Running” or “Stopped.”

Attach-Roam Crk
Drriver Mame:
Scanlist:

Athenticating. ..
State Idle.
Authenticating. ..
State Idle,
Authenticating. ..

CCH Status:
Desired 5510

Watchdog Status:

Last 5 Supp Msgs:

Supplicant Status:

arf1z1z

11
METWLANL
Disabled
Mot Running

08:12:43
0312118
05:12:02
o@lzi02
05:11:55

Running
Dicablad
INTERMEC

Gereral | Details

CORE Modules Configure

B[

CDMA/1xRTT CORE Module (760 Computers with WAN Radios)

Code Division Multiple Access (CDMA) is a form of wide area wireless
communications. IXRTT supports up to 144 KB per second packet data

transmission.

The WAN radio CORE module displays helpful information about the
CDMA/1xRTT radio option built into your 760 Computer.
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WAN Monitor — General

Below are descriptions and meanings for each piece of information pro-
vided via the General tab. Note that the information is listed alphabetically.

Activated

flw

Network Type
On

Phone Number
Radio ESN

Registered on
home network

RSSI

Serial Status

Verizon Network

Indicates whether the ESN on this unit was ever activated. Note: this activation indicates that the
device was activated at some point in time. However, it does not guarantee that the activation is valid
or is working on the carrier’s network.

Identifies the firmware version, if available.

The network type which would list “CDMA-1XRTT.”

Indicates when activation was provided by your service provider.

Identifies the telephone number (or MDN) assigned to the WAN Module installed in your unit.

Lists the Electronic Serial Number (ESN) assigned to this radio module or “Unavailable” if a
number cannot be read from the radio. This number is required for activation. You must provide
this number to your service provider, such as Sprint, Verizon, Bell Mobility, etc., for activation.
Note a decimal version of your ESN is on the Details page.

If the WAN radio module is registered with a service provider network, one of these appears:
* Registered on home network: Radio module is registered on its “home” network.
* Registered on roamed network: Radio module registered on another service provider’s network.
* Radio Not Registered: There is no network within range of this radio module.

Displays the Received Signal Strength Indicator (RSSI) frequency or lists “Unavailable” if there
is no signal or the signal cannot be retrieved from the radio module.

Indicates whether serial communications passed (“Serial com OK”) or failed (“Serial com FAIL”)
in its last transaction. A status of “Serial com FAIL” typically indicates that the 760 Computer is
unable to establish communication with the radio module installed within.

Identifies your network service provider.

i

History

&
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History:
This bar graph displays an active history of this radio module’s quality of
connections.

Friendly Indicator:

Usually indicates the signal strength for this radio module. Three filled
dots indicate a high quality or strong signal. Three empty dots indicate
that the signal is out of range or there is no signal detected.

CORE &gtz

WM Manitar

Metwark Type: ffw: R2.1.0.65E
COMA-1XRTT WA S H
Warizon Sarial Status:
Metwork Serial com OK

Phiore Nurnber:
{319)329-5379

Registered on
Home network

Radio ESM: Activated: ves
B201FD46 oy 12-028-2003
RSSI: -89 dEm £ st:)
i
Histary
General |D9t3“5
CORE Modules Configure E|‘
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WAN Monitor — Details

Below are descriptions and meanings for each piece of information pro-
vided via the Details tab. Most of this is similar to what is shown under
the General tab. Note that the information is listed alphabetically.

ESN

Firmware Rev

Firmware Type

Hardware Rev

IMSI/MIN

Manufacturer

MDN

Model

Phone Number
PRI Version
Radio Temp

Rx

Tx

Lists the Electronic Serial Number (ESN) assigned to this radio module or “Unavailable” if a num-
ber cannot be read from the radio. This number is required for activation. You must provide this
number to your service provider, such as Sprint, Verizon, Bell Mobility, etc., for activation. Noze
that both the hex version and the decimal version of your ESN is provided.

Identifies the firmware version, if available.

Identifies the type of firmware installed in the WAN radio module. It should match the carrier
you are using as your network provider.

Identifies the hardware revision of the WAN radio module installed in your unit.

Shows the IMSI (International Mobile Subscriber Identity) number assigned to the Subscriber
Identity Module (SIM) card installed in this 760 Computer.

Lists the name of the manufacturer that developed this radio module, such as “Sierra Wireless.”

Shows the MDN (Mobile Directory Number) or DN (Directory Number) — the number that
identifies the account tied to your device. You can consider this the “phone number.” Note that
the MDN and IMSI/MIN numbers can be the same.

Lists the product name for this radio module, such as “Model 72.”
Identifies the telephone assigned to the WAN radio module.
Provides the version number of the Preferred Roaming List (PRL).

Identifies the temperature of the radio module, or lists “Unavailable degrees” if no information or
temperature cannot be measured.

(abbreviation for receive) Indicates the number of bytes received over the WAN connection since

the CORE WAN Module was started.

(abbreviation for transmit) Indicates the number of bytes received over the WAN connection since

the CORE WAN Module was started.
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&gtz
COMA-1IXRTT WaAN
Marufacturer: Sierra wireless
Model: SB555 Module
T 0 Rx: O
ESM: 6301FD46
ESh: 099-00130374
IMSI | MIM: 3193295379
[0 3193295379
Radio Termp.: 29 degrees C
Harchiare Rew,: 010
Firmware Rev.: R2.1.0.658
Firmware Type: YWerizon
PRL Wersion: s0112

Gereral | Details

CORE Modules Configure

B[
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GSM/GPRS CORE Module (760 Computers with WAN Radios)

GSM (Global System for Mobile communications) is an open, nonpro-
prietary wireless system. GPRS (General Packet Radio Service) is the high-
speed data evolution of GSM that supports Internet Protocol (IP), enab-
ling access to Internet and intranet content and applications from GPRS
wireless devices.

WAN Monitor — General

The WAN Monitor CORE module displays helpful information about the
GSM/GPRS radio option built into your 760 Computer. 7he following
illustrations are for a GSM/GPRS Siemens MC45 radio.

Below are descriptions and meanings for each piece of information pro-
vided via the General tab. Note that the information is listed alphabetically.

ATT Wireless
Network

Band

BER

fiw

h/w

Network Type
Phone Number
Radio ESN

Registered on
home network

RSSI

Serial Status

Lists the name of the service providing the network support.

Identifies the frequency spectrum used by the radio module.

(Bit Error Rate) The average number of bits transmitted in error.
Identifies the firmware version, if available.

Identifies the hardware version, if available.

The network type which would list “GSM-GPRS.”

Identifies the telephone number assigned to the SIM card.

The Electronic Serial Number (ESN) assigned to this radio module. “Unavailable” appears if a
number cannot be read from the radio.

If the WAN radio module has registered with a service provider network, one of these appears:
* Registered on home network: Radio module is registered on its “home” network.
* Registered on roamed network: Radio module registered on another service provider’s network.
® Radio Not Registered: There is no network within range of this radio module.

Displays the Received Signal Strength Indicator (RSSI) frequency or lists “Unavailable” if there
is no signal or the signal cannot be retrieved from the radio module.

Indicates whether serial communications passed (“Serial com OK”) or failed (“Serial com FAIL”)
in its last transaction. A status of “Serial com FAIL” typically indicates that the 760 Computer is
unable to establish communication with the radio module installed within.

History:
F NINN] - This bar‘ graph displays an active history of this radio module’s quality of

138

History

connections.
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Ggg) Friendly Indicator:

Usually indicates the signal strength for this radio module. Three filled
dots indicate a high quality or strong signal. Three empty dots indicate
that the signal is out of range or there is no signal detected.

£ CORE drE1sT
WM Manitar
Metwark Type: fhw: 02,04
GSM-GPRS b fe
ATT WIRELESS Serial Status:
Metwork Serial com OK
Registered on Phiore Nurnber:
hiorme network (d=5¥879-3070
Radio ESM: Band is
35045041004 2694 || auto detected
== i &
BER.: «0,2%: Histary
General |D9t3“5

CORE Modules Configure E|‘

WAN Monitor — Details

Below are descriptions and meanings for each piece of information pro-
vided via the Details tab. Most of this is similar to what is shown under
the General tab. Note that the information is listed alphabetically.

Firmware Rev

IMEI #

IMSI #

Manufacturer

Model
Net Provider

RSSI

SIM Status

Identifies the firmware version, if available.

The IMEI (International Mobile station Equipment Identity) serial number of the GSM/GPRS
radio module.

Shows the IMSI (International Mobile Subscriber Identity) number assigned to the SIM card
installed in this 760 Computer.

Lists the name of the manufacturer that developed this radio module, such as “Siemens.”
Lists the product name for this radio module, such as “MC45.”
Lists the name of the service providing the network support.

Displays the RSSI frequency or lists “Unavailable” if there is no signal or the signal cannot be
retrieved from the radio module.

Identifies whether a SIM card is installed in this 760 Computer.

l:l:tp.E o qe1se
GEM-GPRS WAN

Manufactrer: SIEMENS

Model: MC45

IMST #: 310380035186265
TMET #: SSMES04 10043654
Frmware Rev.: 02,04

RSSI: -75 cBm

=t Provider: ATT WIRELESS

5IM Status: SIM Present

General | Datals

CORE Modules Configure E|‘-
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Microsoft Phone Application (761 Computers with CDOMA Radios)

&

Phone

With the WAN radio module installed in your 761 Computer, you can
send and receive telephone calls. Use the speaker on the back of the com-
puter as your earpiece and use the connector on the bottom of the com-
puter for your mouthpiece.

Tap Start > Programs > the Phone desktop icon or tap Start > Phone
from the Today screen to access the application which processes your
phone calls. Tap the Close button in the upper right corner of this
application to close.

Data Provisioning (Sprint)

140

E4

Phone

Note: If you wish to do this activation another time, tap Cancel to close
this wizard, then tap Yes.

Exit Activation Wizard

Your wireless device may
not be activated yet. Are
you sure you want to exit
the Activation Wizard?

It is necessary to initiate activation before using your Microsoft Phone ap-
plication. Below are the instructions:

1 From the Phone application, tap Tools > Activation Wizard.

2 Have your activation code, phone number (MDN), and MSID infor-
mation ready before you tap Next to continue. You can get this infor-
mation from your network provider.

q 4c 007 @

el o i i

Your PCS wirgless device must be

activated. For activation, you will need
to provide an Activation Cods, Phone
Murmber (MDN], and MSID information.

| Mext = | I Cancel |

B[
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3 Enter your 6-digit activation code, then tap Next to continue.

Please enter your Activation Code below,

Your Device's Electronic Serial Number is:

|sot37B0C |
Activation Code: I:l
| < Back | | Mext = | | Cancel |

B[

4 Enter your phone number and MSID from Sprint, then tap Next to
continue.

flStart g 4c 521 D

Your Activation Code was accapted.

o will o need toenter the Phone
Mumber (MOMN) and MSID (IMSIT_S) for

your device.

v [ 1y (] - [
e [0 [ - [
|qBack| |Next> | | I:anl:ell

B[
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5 The application prompts whether the information entered is correct. If
so, tap Yes to continue, otherwise tap No to return to the MSN and
MSID screen.

Phore number (DR ):
F1eEFE1209

MSID (IMSI_S):
210002186 351209

Please double-check these
Aumbers,

Is the information vou
antered corract?

6 Note that voice service is available immediately. Data service take a
minimum of four hours of activation before you can use the service. If
after four hours, a data connection is not established, see “Data Provi-
sioning” on page 140 to manually launch data provisioning,.

The application acknowledges that your phone will be in service in four
hours. Tap Finish to close the wizard.

g 4csm @

i)

Your PCS phione is being acivated,
our phone will be avalable to use in
approximately four hours,

Thark you for choosing Sprint!

Click Fimish to close the Activation
Wizard,

B[
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Phone Application

ﬁ Note: Wait at least four hours after activation is complete before using this
application. Data provisioning should occur automatically. Network infor-
mation about your 761 Computer needs to propogate through the Sprint
Network after the activation is complete.

If data provisioning does not occur automatically, tap Start > Settings >
the Personal tab > the Phone icon. Tap the Data tab, then tap Provision
to Initiate a session.

Tap the appropriate keys to enter a telephone number, then tap Talk to
dial the number. Tap End to “hang up” the phone.

4| phone +ﬁ < 410 9
&= =S Sprint

*2913193698450 [l Tap this to backspace one digit

L F o . [
w Tap this to dial the phone number

i shown above the keypad.
[ I ( .
Speed Dial Tap this to select a previously
dialed number.
[ L
w Tap this to view your previous calls.

" - C g "
#* Tap this to “hang up” your current
call.
Edit Tools Q 78>

‘ Tap this toggle the mute option.

Tap this to access the Contacts application.

Tap this to access the Notes application.
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Speed Dial

Tap Speed Dial to select a telephone number with which the 761 Com-
puter is to dial automatically. To add to this list, use the Contacts applica-
tion. See Chapter 2, “Windows Mobile 2003,” for more information about
the Contacts application.

#¥ | Phone & 45506 D
Voice Mail
{000) 0009420
F s Me
(319) 369-3828 w
New
Call History

Tap Call History to note the telephone numbers that were previously
dialed from this 761 Computer.

¥ Phone & 45501 O

all calls »

¥, Me 506 3

{219) 260-2828 w

Pt F7) Voice Mail 4116 4
{000) 000-9420

Ft E] Unknown Caller 409 a
*2013102602828

™ Me 407 a
A
(319) 369-3528

Tools E|‘
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Tools
Use the Tools menu to send a voice mail, access the Activation Wizard,
send an SMS email message, or configure phone settings.

* Tap Tools > Voice Mail to call and leave a voice message.

* Tap Tools > Activation Wizard to access the wizard with which to acti-
vate your 761 Computer. Be sure to have an activation code, a phone
number, and MSID information ready. See page 140 for instructions on
using this wizard.

q 4c 007 @

Your PCS wirgless device must be
activated. For activation, you will need
to provide an Activation Cods, Phone
Murmber (MDN], and MSID information.

| Mext = | I Cancel |

B[

* Tap Tools > Send SMS tab to access the Inbox application and send an
SMS (Short Messaging Service) message. Be sure to have an SMS num-
ber ready to send the message — this is usually the mobile phone num-
ber. See Chapter 2, “Windows Mobile 2003,” for information about the
Inbox application.

S gcen O

Send|Subj <. =

L

Edit My Text 5 [= B[
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Phone Settings
& Either select Tools > Options from the Phone application or select Start >
Settings > the Personal tab > the Phone icon to access the Phone Settings
Phone  control panel applet.

* Tap the Phone tab to customize your phone settings such as the ring
type and ring tone to use for incoming calls, and the keypad tone to use
when entering phone numbers. Tap Other Settings to go to the Sounds
& Notifications control panel applet. Select Start > Help for more online
information about this feature.

q 4ce1z @

Phone

Phone Mumber: (000) 000-9420

Yoicemail: | {000} 000-9420 |

Sounds
Ring type: 3

Ring kone: |Wind0ws DiefaLlt Y|| » || [ ] |
Kevpadi  [Shart Tanes -]

| Other Settings... |

Motify me when voice privacy is
unavaiable

Phone | Location | Data | Swstem | Phone Info |

B[

e Tap the Location tab to toggle between letting your location be visible

for everyone to detect and hiding your location from everyone except
911.

F%| cettings & g4z O

Phone

Turring location an will allow the
network to detect your pozition,
making sorne Sprint PCS applications
eazier to use, Turning location off wil
hide your location from everyone
except 911, Even if location is turned
on in this handset, no service may use
wour location without wour express
permission.

Location
@ Location OW ) 911 Only

Phone | Location | Data | Swstem | Phone Info |

B[
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* Tap the Data tab to either reset your connection settings for PCS Vi-
sion or update your PCS Vision profile.

If your 761 Computer is unable to make a data connection and it has
been more than four hours since activation, you can launch data provi-
sioning from this screen. Tap Provision, then follow the prompts. This
would take several minutes to set up the data connections.

% Note: The data provisioning process can be automatically initiated by
the Sprint network, by attempting to make a cellular line connection to
the WAN before the 761 Computer is data provisioned, or by manually
starting the connections through this screen. Intermec recommends that
Sprint Network “push” the data provisioning to your unit. This should oc-
cur shortly after the voice activation is complete.

a 4c13 @

Phone

Ev clicking the "Reset Connection”
button, your device wil reset the
connection settings for PCS Yision,

| Reset Connection |

By clicking the "Provision” button,
your device wil atternpt to auto-
update your Visian profie,

l Provision |

Phone |anaUnn| Daka |Svstew1|PhuneInFo|

B[

* Tap the System tab to toggle between automatic or Sprint roaming and
to enable the Call Guard alert when roaming,.

a 4c13 @

Phone

Roaming

(@) Automatic ) sprint

0 Enable Call Guard alert when
roaming

Phone |anaUnn| Data |Svstew1|PhuneInFo|

B[
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148

j‘ Settings

Phone

* Tap the Phone Info tab to view the phone settings.

q 4c e @

ESM:

1My Phone Murmber:
MSID:

Modern P er:
RIL SW Ver:

PRL %ersion:

OxBE013760C
000-000-9420
000-000-9420
E0.45.0
1.31.0.0
10023

FiS Wision Llsername:
Lizerharne Mot Available,

Phone | Location | Data | Swstem | Phone Info r

B[
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Microsoft Phone Application (761 Computers with GSM Radios)

With the WAN radio module installed in your 761 Computer, you can
send and receive telephone calls. Use the speaker on the back of the com-
puter as your earpiece and use the connector on the bottom of the com-
puter for your mouthpiece.

Q Tap Start > Programs > the Phone desktop icon or tap Start > Phone
from the Today screen to access the application which processes your
phone  phone calls. Tap the Close button in the upper right corner of this
application to close.

Activation

The GSM phone is activated via a SIM card that you can purchase from
your network provider.

Phone Application

Tap the appropriate keys to enter a telephone number, then tap Talk to
dial the number.

Y Af1204 9

Hi Tap this to backspace one digit.
@ r I P
M Tap this to view your previous calls.
[ I ( .
— i - = dialed number.
po—
A 3 P r »
-@ Tap this to dial the phone number

Edit Tools Q EE %x shown above the keypad.

‘ Tap this toggle the mute option.
Tap this to access the Contacts application.

Tap this to access the Notes application.
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Call History

Tap Call History to note the telephone numbers that were previously
dialed from this 761 Computer.

#3|Phone <) ¢ 507 @

all calls »

¥, Me 506 3

{219) 260-2828 w

Pt F7) Voice Mail 4116 4
{000) 000-9420

Ft E] Unknown Caller 409 a
*2013102602828

™ Me 407 a
A
(319) 369-3528

Tools E|‘

Speed Dial

Tap Speed Dial to select a telephone number with which the 761 Com-
puter is to dial automatically. To add to this list, use the Contacts applica-
tion. See Chapter 2, “Windows Mobile 2003,” for more information about
the Contacts application.

1% Phone & 45506 D
Voice Mail
{000) oon-9420
[ Me
2 (319) 369-3828 w
New
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Tools

Tap Tools > Send SMS tab to access the Inbox application and send an
SMS (Short Messaging Service) message. Be sure to have an SMS number
ready to send the message — this is usually the mobile phone number. See
Chapter 2, “Windows Mobile 2003,” for information about the Inbox ap-
plication.

S gcen O

i=1 | o R

Send|Subj <. =

L

Edit My Text 5 [= B[

Phone Settings
& Either select Tools > Options from the Phone application or select Start >
Settings > the Personal tab > the Phone icon to access the Phone Settings
Phone  control panel applet. Select Start > Help for more online information about
these features.

* Tap the Phone tab to customize your phone settings such as the ring
type and ring tone to use for incoming calls, and the keypad tone to use
when entering phone numbers. Tap Other Settings to go to the Sounds
& Notifications control panel applet.

Y 4c1213 D

Phore Mumber: Mok availabls
Sounds

Ring bype: hd

Ring kone: |Wind0ws DifaLlt v|| » || [ ] |

Keypad: |Eleep - |

| Other Settings... |

Security

D Require PIN when phone is used

| Change PIN |

Phone | Serwices | Tebwork, |

B[
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e Tap the Services tab to access settings for any of the provided services.

[F| cettings Y «4c1215 D

Phone

To access settings For & service, select i from
the Fallawing list and tap "Gat Sekkings”

Call Barring

Caller 1D

Call Forwarding

i all Waiting

oice Mal and SMS

Get Settings...

Phone | Serwices | Tebwork, |

B[

Tap any of the settings, then tap Get Settings. Make your changes, then
tap ok to return to the Settings screen. Below is a sample Settings
screen.

Z|Settings Y. 4c1217 D

Phone ; Yoice Mail and SMS

M5 service center:

Woice Mail: +1 (319) 951-9999

1231[2[3]4]5]6][7[8][9[0]-
Tab[a|wle[r [ty u]i[o[p|[[]
CAPlals[d[flalh]i[k[IT:]"]

[«

Shift| 2 [« ][V [b[n[m[ [ [/~
cufadl T\] PG
ElS
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* Tap the Network tab to find, set, or select the type of network on
which this phone is to communicate.

Y 4c1225 D

Phone

Current network: Searching...

Set Networks

Preferred networks:

MNetwork selection
@ Automnatic

O Marual
Select Network

Phone | Serwices | Tebwork, |

B[
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PhoneUtility (760 Computers with GPRS Radios)

% Note: This application is for 760 Computers with GPRS radios only, due
to E911 requirements issued by the FCC. In the United States, voice is
not an option on 760 Computers with CDMA radios.

With the WAN radio module installed in your 760 Computer, you can
send and receive telephone calls. Use the speaker on the back of the com-
puter as your earpiece and use the connector on the bottom of the com-
puter for your mouthpiece.

ZvPhoneltility] Tap Start > PhoneUtility from the Today screen to access the application
which will process your phone calls. Tap Exit or ok to close this
application and return to the Today screen.

Audio Mode

Select either Handset or Speakerphone from the Audio Mode box, then
do the following to send or answer a phone call:

* Tap the numbers for a phone call, using Clear to erase each digit, then
tap Send to initiate the call.

Tap Answer to receive an incoming call.

Tap End to disconnect a transaction.

Drag the Vol slider up or down to adjust the speaker volume.

Drag the Mic slider up or down to adjust the microphone sensitivity.

#& Phone App o 4 s37 @

4% | Phone App < 4 a0z @

Signal Signal

Initializing Phone... Initializing Phone...

it 71

wal o Mic wal o Mic

[13193593811 -

|Answer|| Send || End || Clear | |Answer|| Send || End || Clear |

e —

Elglmis =) Elglmis =)
"1 Speakemshane {#® Speakemhane

[e][e] [e][e]

[+ ]™] [+ ]™]

B B

Handset Audio Mode Speakerphone Audio Mode
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Notification

Tap Settings to set your 760 Computer to either ring or vibrate or do
both, then tap OK or ok to return to the Audio Mode screen. If you need
to adjust the audio settings, tap Advanced Audio to continue.

3 Phone App o 4 gi38 @

Motification —
Ring

wibrate
Advanced Audio...

B[

Advanced Audio

Tap ok to close the warning and continue.

PhoneUtility

Warning - Adjusting these
levels can cause audio to
feedback, Use caution
whien adjusting lewvels,
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Drag the appropriate slider bars left or right to adjust the output and in-
put levels. Tap Defaults to return the handset or speakerphone levels to
their factory defaults. Click OK or ok to return to the Notification screen.

f Phone App o 4 gi38 @ 2% Phone App < 4 a0z @
Output Levels Output Levels
Speaker 22 Speaker 26
To Radia 11 To Radia 27

HeadPh, 25
PCM 31

Input Levels Input Levels
From Radio 17 From Radio 23
Frorn Mic 17
Rec. Gain 0 From Mic 13
Adio Mode:  Handset Audio Mode:  Speakerphon
| oK | |[:ante| | |Defaults| | oK | |[:ante| | |Defaults|
B[ B[
Handset Output/Input Levels Speakerphone Output/Input Levels

Tap ? for more information on these level settings, then click ok or OK to
return to the Output/Input Levels screen.

f Phone App <} 4 si39 @

Caution: Use care when
adiusting the audio levels,

Microphone: "To Radio” and "Mic”
iders adjust the microphone sensitivity
§volume, Adjust these if the party at
the other end of the call cannot hear
Yo,

Speaker: "From Radio” and "Speaker”
sliders will adiust output level from
spaaker, Adiust these if you cannot
heliar the party at the other end of the
call.

B[
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SB555 Watcher (760 Computers with CDMA Radios)

The SB555 Watcher program is used on the 760 Computer with CDMA
radios only. Use this primarily to activate the WAN radio. Once the WAN
radio is activiated, you can remove the SB555 Watcher program from the

760 Computer.

This tells you how to set up your CDMA radio in your 760 Computer.
Below are terms to familiarize you with CDMA radio technology:

% Note: Set up and provision information is also available in the 700 Color
CDMA Radio Setup Quick Start Guide PIN: 962-054-063.

Activation The process of programming the radio with the lock code (MSL) and phone number (MIN) to
allow it to communicate on the provider’s network. Once activation is complete you can make
voice calls (if enabled by the carrier) with the mobile computer.

Data Provisioning ~ The process of activating the ability for the CDMA radio to establish data connections, such as
connecting to the Internet. The CDMA radio makes data connection only after it is activated
and data provisioned.

NID (Network ID) A numeric value programmed into the CDMA radio at the factory or during the activation
process. Your carrier may or may not use this value, but your carrier may provide this for ac-
tivation purposes.

SID (System ID) A numeric value programmed into the CDMA radio at the factory or during the activation
process. This number is used by your carrier to determine if the radio belongs to its CDMA
network. Your carrier may provide this number for activation purposes.

% Note: Descriptions in this chapter are for Sprint PCS, Bell Mobility, Te-
lus, and Verizon Networks versions of the SB555 Watcher program. Oth-
er carriers may be added pending regulatory and carrier approval.

Copying CDMA Radio Module CAB Files from Intermec Web Site

Copy CAB files from the Intermec web site at www.intermec.com onto
your desktop. Note that this is subject to change.

1 Select Service & Support > Developers Support from the blue naviga-
tion bar on the Intermec home page.

2 Select 700 Color Support from the Developers Support navigation co-
lumn on the left side of the screen.

3 Select Downloads from beneath the 700 Color Support selection in the
Developers Support navigation column on the left side of the screen.

4 Select WWAN from the center of the screen, beneath the “Downloads”
title.

5 From beneath the “Sierra Wireless “Watcher” Application” title, down-
load any of the CAB files shown, then choose your carrier CAB files.

Intermec recommends one of two methods with which to load these CAB
files onto your 760 Computer: via the Microsoft ActiveSync application
(next paragraph) or via a CompactFlash or Secure Digital storage card
(next page). See Chapter 3, “Installing Applications,” for more information
about these methods.
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Via Microsoft ActiveSync

You can transfer files from your desktop to your 760 Computer via Micro-
soft ActiveSync. See Chapter 2, “Windows Mobile 2003” for more infor-
mation about ActiveSync.

1 Obtain software from the Intermec web site as described earlier. Down-
load the software to any location on your 760 Computer, such as the
Temp folder via the My Device root location.

2 Tap the carrier CAB file to install the application.
3 Go to “Finishing the Installation” on page 159.

Via a CompactFlash or Secure Digital Storage Card

158

54
Ci

Utilities

»

File Explorer

Note: These instructions are based on default locations. You can change
the location to which to copy your CAB files.

1 Make sure the Registry Restore feature on your 760 Computer is dis-
abled. Select Start > Settings > the System tab. Tap the Utilities desk-
top icon, then the Registry Save tab. Clear the Enable Registry Save
box.

& gcz0e O

Utilities

Reqiskry ssttings can be saved betweaen cold
baoats, The rediskry is saved during devics
resets or when applications use the
RegFlushkey function.

D Enable Registry Starage

If enabled, the real time clack
can be restored on a cold book

Enable RTC Restare

Dock Switch | Registry Save | akeup MaEII

B[

2 Copy the CAB files for your carrier to your CompactFlash or Secure
Digital storage card after downloading it from the web site.

3 Cold-boot your 760 Computer. Remove the battery pack and press the
reset button in the bottom of the battery compartment.

4 Go through the normal getting started steps detailed in your 700 Color
CDMA Radio Setup Quick Start Guide.

5 Install the CompactFlash or Secure Digital memory card into the card
slot in your 760 Computer. Note that if you do not want the CAB files
erased after installation, set the CAB file attributes to “read-only” after copy-
ing them to the storage card.

6 From the 760 Computer, tap Start > Programs > the File Explorer

icon.
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7 Tap the pull-down menu for My Documents and tap the My Device

10

root location.

Finishing the Installation

If you are using a CompactFlash storage card,
tap Storage Card.

If you are using an Secure Digital storage card,
tap SDMMC Disk.

Scroll down, then tap the Sprint Watcher CAB file to install the ap-

plication.

Go to “Finishing the Installation” in the next paragraph.

Do the following to run the SB555 Watcher application. Be sure to do
step 1 as it is important to perform a warm-boot on your 760 Computer.
Upon restart, the Watcher application sets up on the 760 Computer for

activation.
? 1 Tap Start > Programs > the Watcher icon.
I 2 Tap Yes, I accept to accept the license agreement, then tap OK to con-

Please read the license agreenent
carefully:

£ License Agreement 4F ={£ 1:39 @

SIERR.A WIRELESS SOFTWARE EMD-
ATTEMTION:

CAREFULLY READ THIS AGREEMENT
YOU IMDICATE THAT YOU HAVERI
AUTHORITY TOEMTER INTO THIS .
TERMS AMD COMDITIOMNS AMD THA'

IF ¥OU DO MNOT AGREE WITH THE ™

[l »

BOUND BY THE TERMS 4ND CONDIT|_|

A W D

() ves, [ accept
() Mo, | Dedine

B[

tinue. Note that this license agreement does not appear again after this
installation.

3 Tap OK for the 760 Computer to perform a warm-boot and complete

the installation.

watcherLauncher

To completa tha
installation the device wil
nowe perfarm a warmboof.
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Activation

160

E4

RN

Note: Set the date and time before doing this activation.

SB555 Watcher is for activation and data provisioning. Once you enable
voice capability, data capability, or both depending on the carrier, remove
this program from the system by cold-booting your computer.

Intermec Technologies does not recommend using the SB555 Watcher
program to make data and voice calls on a daily basis for these reasons:

* The SB555 Watcher application is a third-party application unaware of
certain power management methods used in your 760 Computer.
Therefore, the application consumes more power than necessary.

* The application size consumes memory better used for your application
data.

The process of setting up the account with your carrier and enabling the
CDMA WAN radio in your 760 Computer is called activation. To proper-
ly function, program the CDMA device with the necessary information
and set up the network carrier account. If either piece has errors, the de-
vice does not function on the CDMA network.

The CDMA radio is pre-programmed for a specific carrier, such as Sprint,
Telus, Bell Mobility, Verizon, etc.). Therefore, information about your
radio should already be in your carrier’s database.

You need to notify the carrier and set up mobile accounts for each unit
you are activating. The Electronic Serial Number (ESN hex 63xxxxxx)
that you need to supply to your carrier is located in two places:

* On the outside of the 760 Computer shipping box.
* On the inside of the 760 Computer battery compartment.

The ESN comes in both decimal and hexadecimal formats. Most carriers
accept either format, but with a preference for the decimal format. You
only need to provide one number to your carrier.

* The decimal format consists of 11 digits, beginning with “099.”
* The hexadecimal format is an 8-digit number, beginning with “63.”

Accounts for Verizon and Sprint carriers can be set up for data only. Cana-
dian carriers (Telus and Bell Mobility) can be set for data only, voice only,
or both voice and data. This is determined by your application and the
services your carrier offers.

After the all ESNs are provided to the carrier and the carrier has estab-
lished the accounts, you will be provided with the lock codes and tele-
phone numbers needed to complete the activation process. You use the
SB555 Watcher program to accomplish this task. Be sure to write down this
information for future use.

Note: Ensure that you receive a spreadsheet with your order that calls out

all ESNs in both decimal and hexadecimal formats.

Note: Keep the activation information for your devices in a safe, accessible
p _ y
place should you have any future issues.
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ﬁ Note: Not all of the elements listed are required by all service providers.

ESN of the modem

Lock/Activation Code (may be termed one of the following):
* MSL — Master Subsidy Lock
* OTSL — OneTime Subsidy Lock
* SPC — Service Provisioning Code

* OTKSL — One Time Key Subsidy Lock
SID (System ID)
NID (Network ID)
User Name
Password
MIN
MSD
MDN

ﬁ Note: The activation process for your Watcher version may vary from the
following steps. Thus, you may not have to do all of them.

? 1 Tap Start > Programs > the Watcher icon or tap the Watcher icon from
the NDISTRAY via the Today screen (circled in the following illustra-
Watcher tion) to launch the SB555 Watcher program.

o £ 1:55
Friday, March 21, 2003
Tap here to set owener inFormation

Mo upcoming sppoinkments

L] [ @
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162

2 The Activation Wizard should start automatically. If not, then tap
Admin > Activation Wizard from the bottom of the screen.

."i.i'_,r" SB555 Watcher

Ready to Connect

SIERRA WIFFELESR

{51245 €3

=

|- 1xRTT High-Speed

'|

DATA

%

VoIcE

Tools Admin

B[

3 Follow the screen prompts, tapping Next to move from one screen to

the next.

4 When you reach the Activation screen, select Manual Activation.

5 At the appropriate screen, enter the Activation Code (OTSL, MSL,
OTKSL, or SPC) provided by your carrier and tap Next.

6 Enter the phone number provided when your 760 Computer was acti-
vated and tap Next.
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Verizon Automated Activation Process
% Note: This process takes approximately 60 seconds.

Do the following to activate Verizon on your 760 Computer:

1 After initializing the Watcher program, tap Yes, I accept to accept the
license agreement, then tap OK to perform a warm-start on the 760
Computer. Note this license agreement does not appear again after the
installation.

fLicense Agreement i =% 1:39 @

Please read the license agreenent
carefully:

SIERR.A WIRELESS SOFTWARE EMD-
ATTEMTION:

CAREFULLY READ THIS AGREEMENT
YOU IMDICATE THAT YOU HAVERI
AUTHORITY TOEMTER INTO THIS .
TERMS AMD COMDITIOMNS AMD THA'
BOUND BY THE TERMS AND COMNDIT|_ |
IF ¥OU DO NOT AGREE WITH THE |+

A W D
@ Yes, I Accept -
() Mo, | Dedine “

B[

[l »

2 Start the Watcher program again, select Automated Activation, then
click Next.

% Note: You must be in the Verizon coverage area to activate your 760
Computer and only in the location of intended use.

T |cB555 Watcher s 206 €9

Please seleck ane of the following options:

O trlanual “fou enter the ackivation
Aactiwation code, Yerizon account
phone number, and
System [0 (SID) provided
with the product
document.ation.

@ Bukomated LUse your SESSS to skart an
Ackivation aukomated activation
SESSI0N.

E|A
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3 Click Next, click Next again to dial the number displayed on the screen.

“Watcher will establish a connection ko an
automated activabion service. Please be
patient, as this may take a fews minutes,
Once campleted, you should z=e
"Pragramming OK" displayed on the soreen,

Flease select Mext" to begin,

The following numbsr
wilbe e 22358 |

E|A

4 The activation process starts automatically.

Tools Admin E| -~
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5 You will see a series of unlock codes on your screen.

BSSS Watcher o1z 207 €3

. @i

Carnrit CK!
Rrogramrming Ok

€

SIERRA WIEELESE

|— 1% High-Speed v|

=

'\/

VEIFEAOYciois

Tools &dmin E| -
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ﬂ 7 Click the Connect button (circled in the following illustration) to connect

to the carrier’s network.

Tools &dmin E| -

8 Select Start > Internet Explorer, then choose a web site. Your unit is
now successfully activated.

< Internek Euplurgr

l;{?g' Internet Explorer < 2:08 Q

Welcome

| MSN Hotmail
(" WindowsMedia.com
{] Money
'S ews
@} Sports (FSPN)
Ji% Entertainment

© 2003 Micresoft Somp. Al vights reserved, Temng OF
e Privacy Statement

Yiew Tools <& & @ & E|‘

9 Perform a cold-boot on your 760 Computer to uninstall the Watcher
application. Watcher is intended for activation purposes only. Intermec

recommends using the following for establishing and maintaining con-
nection to the WAN radio.

* Custom application using Intermec WWAN Toolkit API

* Custom customer application using Connection Manager Interface

ﬁ Note: When connecting to the WAN radio via Pocket PC Connection
Manager, use the 10-digit phone number@vzw3g.com for the user
name (such as 1234567890@vzw3g.com) and “vzw” for the password.
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Sprint Automated Activation Process
% Note: Sprint PCS uses a data provisioning method termed IOTA (Internet

Over The Air) to complete its activation and data enablement. The follow-
ing steps detail how to properly activate and data provision your 760
Computer.

Do the following to set up activation:
1 Provide Sprint with your ESN, rate plan, and account information.
2 Sprint provides you with the following for each ESN:

e MDN, such as 214-555-5555

e MSID, such as 214-555-5555

e MSL/OTKSL (Activation Code), such as 945614

e NAI (Network Access Identifier), such as the following:
CustomerNameo103@sprintpcs.com

You must use a Secure Digital storage card with only the

SPRINT_WATCHER.CAB file in the “\SDMMC/Cabfiles” directory.
% Note: Other CAB files in the “SDMMC/Cabfiles” directory may cause

problems with testing — remove or uninstall these before proceeding,.

You need at least 80% (4 of 5 bars) CDMA signal strength for a successful
over-the-air activation.

Download and Activate Sprint Watcher
W 1 Make sure the Registry Restore feature on your 760 Computer is dis-
abled. Select Start > Settings > the System tab. Tap the Utilities desk-
Utilities top icon, then the Registry Save tab. Clear the Enable Registry Save
box.

& gcz0e O

Utilities

Reqiskry ssttings can be saved betweaen cold
baoats, The rediskry is saved during devics
resets or when applications use the
RegFlushkey function.

D Enable Registry Starage

If enabled, the real time clack
can be restored on a cold book

Enable RTC Restare

Dock Switch | Registry Save | akeup MaEII

B[

2 Perform a cold-boot on your 760 Computer, then go through the nor-
mal Pocket PC set-up (i.e. Align Screen etc.).

700 Series Color Mobile Computer User’s Manual 167



Chapter 4 — Network Support

3 Important! Set the Date and Time.

4 Tap the Sprint_Watcher_ PPC_2002-03xxx.CAB file to perform the
installation.

5 Perform a warm-boot on your 760 Computer to load the CAB file.

6 From the Today screen, tap the LAN Network icon in the System Tray
(circled in the following illustration).

7 In the NDISTRAY pop-up menu (the Network Driver Interface Speci-
fication tray application), select No Networking and Auto FTP Off.
Tap anywhere on the screen to close the menu.

Built-in Ethernet

Wireless 802.11

* Mo networking

AutoeFTP On
* AutaFTP OFF
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? 8 Tap Start > Programs > the Watcher icon or tap the Watcher icon from
the NDISTRAY via the Today screen (circled in the following illustra-
Watcher tion) to launch the SB555 Watcher program.

Friday, March 21, 2003
Tap here to set owener inFormation

Mo upcoming sppoinkments

| A F

9 Tap Yes, I accept to accept the license agreement, then tap OK to con-
tinue. Note that this license agreement does not appear again after this
installation.

License Agreement af =< 1:39 @

Please read the license agreenent
carefully:

SIERR.A WIRELESS SOFTWARE EMD-
ATTEMTION:

CAREFULLY READ THIS AGREEMENT
YOU IMDICATE THAT YOU HAVERI
AUTHORITY TOEMTER INTO THIS .
TERMS AMD COMDITIOMNS AMD THA'
BOUND BY THE TERMS AND COMNDIT|_ |
IF ¥OU DO NOT AGREE WITH THE |+

A W D
@ Yes, I Accept -
() Mo, | Dedine “

B[

[l »
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170

K 4

Watcher

Tap OK for the 760 Computer to perform a warm-boot and complete the
installation.

watcherLauncher

To completa tha
installation the device wil
nowe perfarm a warmboof.

Using Sprint Watcher

Before you start using the Sprint Watcher application, make sure you

match the correct ESN with each 760 Computer and that you have at least
80% CDMA signal strength.

1 Tap Start > Programs > the Watcher icon or tap the Watcher icon from
the NDISTRAY via the Today screen (circled in the following illustra-
tion) to launch the SB555 Watcher program.

- £ 1:55
£ Friday, March 21, 2003

E Tap here to set owener inFormation

Mo upcoming appaintments

@ . a
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2 If your 760 Computer was not previously activated, Watcher automati-
cally starts the Activation Wizard. Otherwise, select Manual Activation
to continue.

15 |5B555 Watcher 41209 €9

< Back Mext = Cancel Hints

Flease select one of the Following options:

@ Manual Speak with & Customer
Ackivation Care representative using
a standard phone. (Also
requires the manual input
of certain items)

E|A

3 Enter the MSL or lock code received from Sprint.

15 |5B555 Watcher {1211 €

< Back Mesxct = Cancel Hints

YWher the service representative asks For the
Electronic Serial Mumber (ESM), please
provide the Following number,

093-00130243

YWher the service representative provides
you with the activation cods, please enter
the number below:

E|A
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4 Enter the phone number (MIN) and MSID received from Sprint.

These numbers may be the same.

f|SB555 Watcher 41210 €

< Back Mesxct = Cancel Hints

Please enter the phone number given toyou
by your wirsless service provider,

Please enter the MSID given ta yau by wour
wireless service provider,

E|A

5 After entering the phone number and MSID, the modem resets. Watch-
er displays the following two screens:

13 |SB555 Watcher 13 |SB555 Watcher {51212 €3

Searching for SB555S ... Searching for X 5§ =

Initializing modem.
Flease wait...

EERAA WIRELEER EERAA WIRELEER

=Sprint. =Sprint.

Tools Admin E| - Tools Admin E| -

ﬁ Note: If the “searching for SB555” screen does not proceed to the next
screen after 30-40 seconds, perform a warm-boot on your 760 Comput-
er, then restart the Watcher program.
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Data Provisioning

At this point, the activation on the Sprint network is complete. It is rec-
ommended by Sprint to wait before you launch data provisioning to allow
time for the activation to propagate through your Sprint network.

Before you manually launch data provisioning, wait at least 30 minutes. In
some cases, you may have to wait up to two hours.

1 If Data Provisioning does not start automatically, select Admin > Data
Provisioning from the bottom menu bar.

£ 12:18 €3

13 |SB555 Watcher

2_--. @
Ready to Connect

- 1% High-Speed -|
Connect % |
about ...

Spirint.

Activation Wizard...
Data Provisioning

Tools | Admin E| -

2 Tap Yes to proceed with data provisioning,.

SBS55 Watcher

vou have requested to
laurich Data Provisioning,
Would you ke to
continue?
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Activation over the air typically takes 1-20 minutes.

SB555 Watcher 21220 €) |

jig———

Preparing data services
Please wait... Click this
display to cancel.

€

EERRA WIRELESES

|- PCS Yision -|

%
=== Sprint.

Tools Admin E| -

If data provisioning fails, do the following:

e If Data Provisioning fails and the message “could not prepare data ser-
vices, please contact Sprint” displays, retry the Data Provisioning step by
tapping the “Admin” menu icon at the bottom of the Watcher screen.
Select “Data Provisioning...” and answer “yes” to the request.

e If after several attempts to complete the Data Provisioning over the air,
it may be necessary to manually enter the data activation method.

* Go to Intermec Knowledge Central www.intermec.com, then select Ser-
vice & Support > Knowledge Central) to learn about manual activa-
tion. The article (number 5749) is titled How to Manually Activate a
Sprint CDMA WAN Radio in the 760 Device.

/|SBE555 Watcher

{1222 €3

2_--. @

Could not prepare data
services. Please contact
Sprink.

e

EERAA WIRELEBE

|- PCS Wision vl

[ ] 5|

== Sprint.

Tools Admin E|*

174 700 Series Color Mobile Computer User’s Manual



Chapter 4 — Network Support

3 The following screen appears once data provisioning is complete:

#i3|5B555 Watcher £ 858 €9

It }_IJ = @

Provisioning complete.

EERAA WIRELEBE

|— PCS Wision vl

=1 5

== Sprint.

Tools Admin E|*

ﬂ 4 Test the data connection by tapping on the “connect” button to make a
data connection to the network. Watcher progresses through the follow-
ing two screens. Once you see the second screen you know that your
mobile computer has successfully connected to the IXRTT network.

5B555 Watcher s 11:06 €3 15 |5B555 Watcher

£ 11:09 €

2_--. @
Dialing
- PC5 Wizion

2_--. JP @

0o:o0:07%
381 B
349 B

c

EERAA WIRELEBE EERAA WIRELEBE

|- PCS Wision vl | PCS Wision v|
3 3
== Sprint. ==Sprint.
Tools Admin E|A Tools Admin E|A
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#* Internek Ex

now successfully activated.

l;gj‘ Internet Explorer

15208 €9

msn* .~ walcome

.! MSN Hobtmail
¢ windowsMedi

Money
4 News

¢4 weather
(g,‘Sjmtts_[ESEHl
Ji% Entertainment

© 2003 Micresoft Somp. Al vights reserved, Temng OF
e Privacy Statement

Yiew Tools <& & @ &

E|A

5 Select Start > Internet Explorer, then choose a web site. Your unit is

Perform a cold-boot on your 760 Computer to uninstall the Watcher ap-
plication. Watcher is intended for activation purposes only. Intermec rec-
ommends using the following for establishing and maintaining connection

to the WAN radio.
* Custom application using Intermec WWAN Toolkit API

* Custom customer application using Connection Manager Interface

Telus and Bell Mobility Activation

Activation of Bell Mobility and Telus are similar to the first portion of the
Sprint activation process. Follow the instructions for manual activation

using the Bell Mobility Watcher.CAB or Telus Watcher.CAB file to install
the applicable application. Enter the activation lock codes and phone num-
bers as requested.

Username, Password, SID Information

SID

Username

Password

Bell Mobility

10 digit phone
number@]1xbell.ca

Original Voice Mail system pass-
word (usually a 4 digit number)
This is available from the activat-
ing organization.

16420

Telus

10-digit phone
number@1x.telusmobility.com
The 11-digit ESN printed inside
the 760 Computer battery

compartment, begins with 099.

16422

176
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AT Command Interface (760 Computers)
This interface specification is based on the following recommendation:

e ETSI GSM 07.05:
European Digital Cellular Telecommunication System (phase 2)
Use of DTE-DCE interface for Short message and cell broadcast service.

e ETSI GSM 07.07:
European Digital Cellular Telecommunication System (phase 2)
AT command set for GSM Mobile Equipment.

* ITU-T Recommendation V.25 ter
Serial asynchronous automatic dialing and control.

% Note: You need the Adobe Acrobat Reader application to view a PDF do-
cument. Go to www.adobe.com/prodindex/acrobat/readstep.html to install
or download the latest Adobe Acrobat Reader.

Command Set for Sierra Wireless SB555

Use the AT command interface from Sierra Wireless to program the
CDMA/1xRTT SB555 radio module. Documentation for this interface is
available via the following URL. Click the “General AT command refer-
ence” link for a PDF document, which is 680 KB in size. Note that this
URL is subject to change.
www.sierrawireless.com/ProductsOrdering/embedded_docs.html

Command Set for Siemens M(45 or M(46

Use the MC45 or MC46 AT command interface from Siemens AG to
program the GPRS/GSM MC45 or MC46 radio module. The “MC45
Siemens Cellular Engine AT Command Set” and the “MC46 Siemens Cellu-
lar Engine AT Command Set” are available either from Intermec Technolo-
gies or from Siemens AG. Contact either your Intermec representative or
the Siemens AG support personnel at the following URL for more infor-
mation. Note this URL is subject to change.
www.siemens-mobile.com/btob/CDA/presentation/ap_btob_cda_presenta-
tion_frontdoor/0,2950,12,FF.html
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Testing the AT Commands

These commands can be sent to either WAN radio by setting up a dial-up
networking connection to COM4. Do the following to initiate this con-
nection and test these commands to your radio:

7] 1 From the 760 Computer, select Start > Settings > the Connections tab
%‘* > Connections. Under My ISP, tap Add a new modem connection.
Connections

arqf1as D

Connections 9

Ta set up or change connection infarmation,
tap one of the following links,

My ISP
&dd & new modem connection

My Waork Network

Add a new modem connection
&dd & new YPH server connection
Set up my procy server

Tasks | Advarced |

B[

2 Enter a name for the connection, select “WANA on COM4” from the
Select a modem drop-down list, then tap Next to continue.

o ¢ 1:23

Make Mew Connection 9

Erker & name far the connection:

|Mv Connection |

Seleck 3 modenm:
[0 on COM4; -

| Cancel || Back || Naxt
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3 Enter a phone number as it should be dialed, then tap Next to continue.
Select Start > Help for more information or tap use dialing rules to
make modifications. Note that this screen may vary based on dialing rules.

1| settings o 4 1:24 3| setti 4 124

Company Connection 9 Company Connection 9

Country|Region code: Enter the number exactly as it should be

digled, Inlude any exkra numbers, such as

an outside line or credit card,
Area code: Phone number: |

ps | | |

If vou travel or change area codes often,
use dialing rules,

| Cancel || Back || Next | | Cancel || Back || Next |

1231[2[3]4]5]6][7[8][9[0]-
Tab[a|wle[r [ty u]i[o[p|[[]
CAPlals[d[flalh]i[k[IT:]"]

[«

shifz [x [c[v]b[n[m[ ] 7]+
cfai 1] LIe]<]>
B ]

4 Tap Advanced to continue.

o ¢ 1:26

My Connection 9

User name: | |

Passward: | |

Coomain: * | |

* If pravided by 15P or network administrator,

Cancel || Back || Finish |
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5 Select “115200” from the Baud rate drop-down list via the General

page.
Settings &gtz O
Advanced
Baud rate:

M'aik for dial bone befaore disling

W' it For credit card El seL,

Extra digl-string modem commands:

Cancel if not connected in sec,

General | Port Settings | TCR/IP | SErVErS |

B[

6 Tap the Port Settings tab, check Enter dialing commands manually,
then tap ok, then Finish to return to the Connections screen.

Settings & gcze O

Advanced

Connection preferences

Data bits:

Parity:

Skop bits:

Flow control!
Terminal

|:| se terminal before connecting
D Use terminal after cannecting

Enker dialing cormmands manualy

General | Port Settings | TCRJIP | Servers

|‘
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7 Tap Manage existing connections from the Connections page, press
and hold the new connection for a pop-up menu, then tap Connect to
initiate the connection.

S gtz O
My ISP name 9

To create a connection, tap Mew, Tap and
hiald am am existing commection Far rors

options.
Marne | Mumber
) auka pick
ction (425 )505-4555
Delete

[ Edi. || mew.. |

General | Modem | Proxy Settings |

B[

8 Wait about ten seconds for the Network Log On screen, then tap OK.
Note: You do not need to enter any information within the Network Log
On screen.

¥\ Logon to Server 4 45 1:33

MNetwork Log On

Resource: My Connection

[] Save password

I 0K | | Cancel |

B[

Use either the onscreen keyboard, or press the keys to type any of the AT
commands provided. Press or tap Enter to send each command. The re-
sults of each command sent will print onscreen. Note that each “AT” com-
mand must start with the “at” characters.

* To see what you typed onscreen, type “atel” to initiate the AT Echo
command, then press Enter.

700 Series Color Mobile Computer User’s Manual 181



Chapter 4 — Network Support

Wireless Personal Area Networking

Documentation

“Bluetooth” is the name given to a technology standard using short-range
radio links, intended to replace the cables connecting portable and fixed
electronic devices. The standard defines a uniform structure for a wide
range of devices to communicate with each other, with minimal user ef-
fort. Its key features are robustness, low complexity, low power, and low
cost. The technology also offers wireless access to LANs, the mobile phone
network, and the internet for a host of home appliances and portable

hand-held interfaces.

Information about other Bluetooth software is in the Wireless Printing
SDK and the Wireless Printing Development Guide (on the Intermec Devel-
oper’s Library CD, via the “\Wireless Printing SDK” directory off the root).

About the Application

3

Bluetooth

182

Bluetooth is not started automatically by default after a cold-boot is per-
formed. To run Bluetooth, tap Start > Settings > the Connections tab >
the Bluetooth icon. The 700 Color Computer retains the Bluetooth state
when warm-boots are performed, for example:

* [f Bluetooth is active, and a warm-boot was performed, the 700 Color
Computer boots up with the Bluetooth state activated and Bluetooth
vircual COM ports (such as printing) registered. However, you must
reactivate connections, as the system does not do these automatically.

* [f Bluetooth is inactive, and a warm-boot was performed, the 700 Color
Computer boots up with Bluetooth deactivated.

Mode

The default tab activates or deactivates Bluetooth. When Bluetooth is acti-
vated, the 700 Color Computer can discover and connect to remote de-
vices.

&g O

7| cettings & g z00 D

Bluetooth Bluetooth

Turn Blustooth On to enabhe E Turn Blustooth On to enabhe E
this device to discover and this device to discover and

Ccomnect to remote devices. Comhect to remote devices
This will also disable Infrared
® On
{3 on
Turn Bluetooth Off to dicable Turn Bluetooth Off to dicable
connections from remaote connections from remaote
devices and to save poveer, devices and to save pover
This will also enable Infrared
{5 Off
(W Off
Mode | Wireless Prinking | File Transfer | AEII Mode | Wireless Prinking | File Transfer | AEII
Mew Tools Accounts g E|‘ E|‘
700 Color Screen 730 Screen
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Wireless Printing

Use this tab to print via Bluetooth devices. Tap Device Discovery to disco-
ver (or scan) for remote Bluetooth devices. When the 700 Color Comput-
er is finished scanning, any newly discovered devices appear in the upper
Devices box.

Tap Clear Devices to remove the list from the Devices box.

To print to a Bluetooth device, select any of the devices listed in the
Devices box, then tap Connect. Once connected, the selected device
moves to the lower Connected box.

To view connection information or register a COM port for a device,
from the lower Connected box, select a device, then tap Properties. See
“Properties” on the next page for information.

When done printing to a device, select that device in the Connected box,
then tap Disconnect. This moves the device in question back to the upper
Devices box.

% Settings &gz D

Bluetooth

Bl

Devices

Pocket_PC (0002602« Device

4nonymous (00c01b0—| | Discovery
FE42-FOC (00aD960!=
PE20-4262374 (0020 | Clear Devices
W SE-CUSLBOKITSE (0{ |
Pocket_PC (QEII:ID;EEIIJ ~|| Cohnect

I -

il i

Connected
PB40-4293365 (00c0 10| T
Disconnect
Mode | Wireless Prinking | File TransFerlAEE
=]
Properties

Select a COM Port from the Choose COM Port box to register for this
device, then check Enable Wireless Printing to complete the COM port
registration. To change your COM port selection, clear (uncheck) the En-
able Wireless Printing box, select a new COM port, then check Enable
Wireless Printing again. Check Default COM ports that already are in use
are grayed out.

When you enable Wireless Printing, a status message is shown near the
bottom of the screen to confirm your action. To print a test page to your
printer, tap Print Test Page.

Check Default to set this printer to identify the assigned COM Port as the
WPPort in the registry. See the Wireless Printing Development Guide for
more details on WPPort.
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184

»

File Explorer

Tap ok to return to the Wireless Printing page.

g0 O

Bluetooth

WindowsCE (002020935ch0)
——Choose COM Port
() COmd (5 comz
() COMS {3 come
) COMs () comg

Enable wireless Printing
[] Default
Printer is enabled on COMBG

Print Test Page

B[

File Transfer
Use this page to enable your unit to receive files from another Bluetooth
device, or from any device that supports this function.

& gczze D

Bluetooth

Rermote devices can discover

and connect to this device to
baarn files, contacts, calendars,
and business cards.

() Enable

{7 Enable for 3 minutes

() Disable

Mode | Wireless Prinking | File Transfer | AEII

B[

Note that this does not apply to the 730 Computer. From this point, this
transfer is similar to an IrDA file transfer. To transfer a file, tap Start >
Programs > File Explorer and locate the file to transfer. Press and hold on
the file for a pop-up menu, then select Beam File.

Cut
Copy

Rename
Delete

send via E-mail...

Beam File...
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The system searches for a list of Bluetooth devices that will accept a con-
nection from your unit. When the list is complete, tap on a device to
which to send the file. Note: in some cases, the user of the target device has to
“accept” the file before it is transmitted.

& Ae 424 D

[ Matel, pwi

To beam, select a device.

2, Infrared Tap to send
= 0002c70000e8 Tap to send
= 00c01b0Sc217 Tap to send
= SF51-12 Tap to send
= PB20-fake Tap to send
@, Searching
B[
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AutolP/DHCP

R

186

Automatic Private IP Addressing (AutolP) is enabled by default in
Windows Mobile 2003. To remain compatible with other versions of
Pocket PC, this setting needs to be enabled. You can configure the registry
settings in the following to set the required AutoIP/DHCP behavior:

e For Ethernet: HKEY LOCAL MACHINE\Comm\LAN9001\TcpIp
e Fot 802.11: HKEY_LOCAL_MACHINE\Comm\NETWLAN1\TcpIp

Other registry keys that can modify the behavior of AutolP are as follows.
You can find the appropriate settings and behavior of each of these keys in
Microsoft Help.

¢ Autolnterval
AutoMask
AutoSubnet
AutolP
AutoSeed

When a TCP/IP client cannot find a DHCP server, it generates an AutolIP
address from the 169.254.xxx.xxx block. The client then tries to check for
a DHCP server every 15 seconds and if a DHCP server is found, the client
drops the AutolP address and uses the address from the DHCP server.

In the MSDN Windows CE documentation available out on the Micro-
soft Developer Network web site (www.msdn.com), see “Automatic Client
Configuration” for more information on AutolP.

To disable AutolP, set the AutoCfg registry entry to “0.” If a DHCP serv-
er cannot be found, instead of using AutoIP, the system will display the
“Unable to obtain a server assigned IP address” message.

Note: If you try to disable AutoIP using a CAB file to set the registry value
for AutolP, remember to set the EnableDHCP value to “1” to keep
DHCP enabled

Note: To extend the number of attempts that a DHCP client makes to get
a DHCP address, use the DhepRetryDialogue and DhepMaxRetry registry

settings.

Note: Change the Autolnterval registry key value to make the client retry
more often to obtain a DHCP address.
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SNMP Configuration on the 700 Color Computer

E4

In short, SNMP is an application-layer protocol that facilitates the ex-
change of management information between network devices. The 700
Color Computer is such an SNMP-enabled device. Use SNMP to control
and configure the 700 Color Computer anywhere on an SNMP-enabled
network.

The 700 Color Computer supports four proprietary Management Infor-
mation Bases (MIBs) and Intermec Technologies provides SNMP support
for MIB-II through seven read-only MIB-II (RFC1213-MIB) Object
Identifiers (OIDs).

Note: You can only query these seven OIDs through an SNMP manage-
ment station.

Management Information Base

The Management Information Base is a database that contains information
about the elements to be managed. The information identifies the manage-
ment element and specifies its type and access mode (Read-Only, Read-
Write). MIBs are written in ASN.1 (Abstract Syntax Notation.1) — a ma-
chine independent data definition language. Note: Elements to be managed
are represented by objects. The MIB is a structured collection of such objects.

You will find the following MIB files either in the 700 Color Management
Tools portion of the Intermec Developer’s Library CD or on the web via
Wwww.intermec.com:

e INTERMEC.MIB
Defines the root of the Intermec MIB tree.

e [TCADC.MIB
Defines objects for Automated Data Collection (ADC), such as bar
code symbologies.

¢ ITCSNMP.MIB
Defines objects for Intermec SNMP parameters and security methods,
such as an SNMP security IP address.

e ITCTERMINAL.MIB
Defines objects for 700 Color parameters, such as key clicks.
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Object Identifiers

MIB Object Identifiers

Each object has a unique identifier called an OID, which consist of a se-
quence of integer values represented in dot notation. Objects are stored in
a tree structure and OIDs are assigned based on the position of the object
in the tree. For example, the internet OID is equal to 1.3.6.1. Seven MIB
OIDs are shown in the following table:

MIB-II Item OoID

ifNumber 1.3.6.1.2.1.2.1.0 Interfaces Group Indicates the number of adapters

ifIndex 1.3.6.1.2.1.2.2.1.1.ifIndex Interfaces Table (ifTable) A unique value for each interface.

ifDescr 1.3.6.1.2.1.2.2.1.2.ifIndex Interfaces Table (ifTable) A textual string containing informa-

ifType 1.3.6.1.2.1.2.2.1.3.ifIndex Interfaces Table (ifTable) An integer containing information

ipAdEntAddr 1.3.6.1.2.1.4.20.1.1.IpAddress IP address Table The IP address to which this entry’s

ipAdEntIflndex  1.3.6.1.2.1.4.20.1.2.IpAddress IP address Table The index value that uniquely iden-

ipAdEntNetMask 1.3.6.1.2.1.4.20.1.3.IpAddress IP address Table The subnet mask associated with

Group or Table Description

present in the system. For the 700
Color Computer, if one adapter is

present in the system, then ifNum-
ber =1 and ifIndex = 1.

The value ranges between 1 and the
value of ifINumber.

tion about the interface.

about the type of the interface. It is
equal to 1 for Other.

(ipAddrTable) addressing information pertains
(same as 700 IP address), where 1P
Address is the valid non-zero IP ad-
dress of the 700 Color Computer.

(ipAddrTable) tifies the interface to which this
entry is applicable (same as iflndex).

(ipAddrTable) the IP address of this entry (same as
Subnet Mask).

Configuring with SNMP

188

The community string allows an SNMP manager to manage the 700 Col-
or Computer with a specified privilege level. The default read-only com-
munity string is “public” and “private” is the default read/write communi-
ty string. See the specific configuration parameter to find its OID. To
configure the 700 Color Computers using SNMP:

1 Configure 700 Color Computers for RF or Ethernet communications.

2 Determine the OID (Object Identifier) for the parameter to be chan-
ged. The Intermec base OID is 1.3.6.1.4.1.1963.

3 Use your SNMP management station to get and set variables that are
defined in the Intermec MIBs. You can set the traps, identification, or
security configuration parameters for SNMP. See Appendix A, “Confi-
gurable Settings,” to learn more about these parameters.
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5 Printer Support

The 700 Series Color Mobile Computer works with the following printers
from Intermec Technologies. Contact an Intermec representative for infor-
mation about these printers.

* 6820
A full-page, 80-column printer.

* 6808
A 4-inch belt-mount printer.

e PB20
A 2-inch belt-mount printer with a Bluetooth compatible module from
Socket Communications.

e 782T
A 2-inch workboard printer.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.
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Printing ASCII

Directly to a Port

The following methods for printing using Pocket PC at this time is as fol-
lows:

* Add port drivers to print ASCII directly to the port.

* Use LinePrinter ActiveX Control from the Software Developer’s Kit
(SDK) — see the SDK User’s Manual for more information.

* Via wireless printing - see the Wireless Printing Development Guide on the
Intermec Developer’s Library CD for more information.

Printing directly to the port sends RAW data to the printer. The format of
this data depends upon your application and the printer capabilities.

You must understand the printer commands available for your specific
printer. Generally, applications just send raw ASCII text to the printer.
Since you are sending data to the printer from your application directly to
the port you are in complete control of the printers operations. This allows
you to do line printing (print one line at a time) rather than the page for-
mat printing offered by the GDI approach. It is also much faster since data
does not have to be converted from one graphics format to the other (dis-
play to printer). Most Intermec® printers use Epson Escape Sequences to
control print format operations.

These commands are available in documentation you receive with your

. . . y . -y .
printers or from technical support. Win32 APIs are required to print di-
rectly to the port.

Directly to a Generic Serial Port

To print directly to a generic serial port printer (non-Intermec printers):

* Use CreateFile() to open ports — COMI1 can be opened on most de-

vices.
* Use WriteFile() to send data directly to the printer.

* Use CloseHandle() when you are finished printing to close the port.

IrDA Printer Driver

190

IrDA printing is only available on the certain devices and is supported di-
rectly by the Windows CE load via the IrSock API provided by the Micro-
soft Win32 API without need for additional drivers. Intermec 6804, 6805,
6806, 6808 and 6820 and other IrDA printers are supported.
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NPCP Printer Driver

About NPCP

The NPCP printer communications driver (NPCPPORT.DLL) is a
Stream Device Driver built into the operating system. The driver supports
only NPCP communications to and from the 6820 and 4820 printers over
a selected serial port.

All applications use WIN32 API functions to access the drivers. Basic op-
erations are easily implemented by applications through the CreateFile(),
WriteFile(), ReadFile(), DevicelOControl(), and CloseHandle() Win32
APIs.

Operations to upgrade printer modules, perform printer diagnostics, and
get printer configuration are performed largely via DevicelOControl()
functions.

NPCP (Norand® Portable Communications Protocol) is a proprietary
protocol that provides session, network, and datalink services for Intermec
mobile computers in the Intermec LAN environment used with printers
and data communications.

NPCP Driver Installation and Removal

Install ()

Use LPT9: for the NPCP printer device and COM1 for the last parame-
ter. COML1 is the connection available via the 700 Color Computer.

Applications use the RegisterDevice() function to install the driver.
DeregisterDevice() uninstalls the device driver and frees memory space

when the driver is not required. Use the HANDLE returned by
RegisterDevice() as the parameter to DeregisterDevice().

Use the RegisterDevice() function call as demonstrated below. Specify the
full path name to the driver starting at the root for the RegisterDevice()
function to work properly. The last parameter to RegisterDevice() is a
DWORD that represents the name of the port for the NPCP stream
driver to use. Build this parameter on the stack if it is not to be paged out
during the call. The first parameter “LPT” (Device Name) and the second
parameter “9’ (index), indicate the name of the registered device, such as

LPT9. This is used in the CreateFile() function call.

HANDLE hDevi ce;
TCHAR port|[6];

port[ 0]
port[ 1]
port[ 2]
port[ 3]
port[ 4]
port[ 5]
hDevi ce

TCHAR(‘ C);

TCHAR(* O );

TCHAR(‘ M ) ;

TCHAR(‘ 1) ;

TCHAR( :");

TCHAR(0) ;

Regi st erDevice ( (TEXT("LPT"), 9,

TEXT(“\\ STORAGE CARD\ \ W NDOWE\ \ NPCPPORT. dI | "), ( DWORD) port);
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Opening the NPCP Driver

The application opens the NPCP driver by using the CreateFile()
function. The call can be implemented as follows. The first parameter
“LPT9:” must reflect the device name and index used in the
RegisterDevice() function call and will fail for any of the following reasons:

hFile = CreateFile(_T("LPT9:”), GENERI C WRI TE |

GENERI C READ, 0, NULL, OPEN ALWAYS, FILE_ATTRI BUTE_NORMAL,
NULL) ;

* The port associated with the device during RegisterDevice() is in use.
e The NPCP device is already open.
¢ The share mode is not set to zero. The device cannot be shared.

* Access permissions are not set to GENERIC_WRITE |
GENERIC_READ. Both modes must be specified.

Closing the NPCP Driver

Using the CloseHandle() (hFile) function closes the NPCP driver. Where
hFile is the handle returned by the CreateFile() function call.

* TRUE = the device is successfully closed.
e FALSE = an attempt to close NULL HANDLE or an already closed de-

vice.

Reading from the NPCP Driver

Reading of the NPCP printers is not supported since all responses from
the printer are the result of commands sent to the printer.
DeviceloControl() functions are provided where data is to be received
from the printer.

Writing to the NPCP Driver

192

All Print data can be sent to the printer using the WriteFile() function.
The print data written to the driver must contain the proper printer
commands for formatting. If the function returns FALSE, the NPCP error
may be retrieved using IOCTL_NPCP_ERROR. See the description on
the next page.
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NPCP Driver 1/0 Controls

An application uses the DeviceloControl() function to specify an printer
operation to be performed. Certain I/O controls are required to bind and
close communication sessions with the printer, and must be completed
before any other commands to the driver can execute properly.

The function returns TRUE to indicate the device successfully completed
its specified I/O control operation, otherwise it returns FALSE. The
following I/O control codes are defined:

#def i ne | OCTL_NPCP_CANCEL

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x400, METHOD BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_BI ND

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x401, METHOD BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_CLOSE

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x402, METHOD _BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_ERROR

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x403, METHOD _BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_FLUSH

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x404, METHOD _BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_| OCTL

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x405, METHOD _BUFFERED, FI LE_ANY_ACCESS)
#defi ne | OCTL_NPCP_PRTVER

CTL_CODE( FI LE_DEVI CE_SERI AL_PORT, 0x406, METHOD _BUFFERED, FI LE_ANY_ACCESS)

IOCTL_NPCP_CANCEL
This cancels all printing at the printer. It flushes the printer buffers and
reinitializes the printer to its default state. No parameters are required.

IOCTL_NPCP_BIND

This command is required before any data is sent or received by the
printer. Once the driver is opened, the application must bind the com-
munications session with the printer before any data can be sent or re-
ceived by the printer. If an error occurs during the bind, the application
may use [IOCTL_NPCP_ERROR to get the current extended error
code. No parameters are required.

IOCTL_NPCP_CLOSE
This command closes the current session with the printer. This function
always returns TRUE. No parameters are required.

IOCTL_NPCP_ERROR

This command returns the extended NPCP error code in PL/N format.
The word returned will contain the PL/N compatible error code in the
low byte and completion flags in the high byte. If the frame that re-
turned an error was not received correctly by the printer the
FRAME_NOT_ACKED bit will be set in the high byte. This operation
always returns TRUE. An output buffer of at least 2 bytes is required.
See “NPCP Error Codes” on page 195.

IOCTL_NPCP_FLUSH

This command allows the application to poll the printer for errors while
the report is completing the print process at the printer. If an error oc-
curs during the polling process, the operation will return FALSE and
the application can get the extended error code by using

IOCTL_NPCP_ERROR. No parameters are required.
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NPCP Printer Communications

Sample Code

194

All NPCP printer communications should be based on the following flow:

1
2

Use CreateFile(); to open the printer driver.

Use IOCTL_NPCP_BIND to bind a session with the printer;
IOCTL_NPCP_ERROR to check for errors on the bind to ensure suc-
cess; and IOCTL_NPCP_CANCEL to cancel any outstanding print
jobs.

Use IOCTL_NPCP_FLUSH to poll the printer to free up printer buff-
er resources. Use IOCTL_NPCP_FLUSH to poll the printer’s status. If
an error is reported by the IOCTL, then use IOCTL_NPCP_ERROR

to get the error and determine the correct recovery procedure.

Use WriteFile(); to write your data to the printer. Check for errors and
that all data were written. Use IOCTL_NPCP_ERROR to get the ex-
tended error. If the error is critical in nature, use
IOCTL_NPCP_CLOSE, followed by CloseFile(), to end the commu-
nications session. Start a new session, beginning with step 1 to ensure
proper printing. For noncritical errors display the error and retry the
operation.

After all data is sent to the printer, ensure that the printer continues to
print the report properly by polling the printer’s status. Use
IOCTL_NPCP_FLUSH to poll the printer’s status. If an error is re-
ported by the IOCTL, then use IOCTL_NPCP_ERROR to get the

error and determine the correct recovery procedure.

See sample code in the “\700C Dev Tools\Installable Drivers\Port
Drivers\Npcp\NPCPPrint\” directory for more details on printing, printer
communications and error code handling.
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NPCP Error Codes
Call the IOCTL_NPCP_ERROR I/O control function to receive PL/N

compatible error codes. Applications must decide how to act upon the data
returned.

/1 Definition of NPCP communications Errors and Printer Errors

#defi ne PNRDY (BYTE)102 // link not ready error

#defi ne RXTMO (BYTE)104 // link no receive error

#define TXTMO (BYTE) 106 // link no transnmit error

#defi ne BADADR (BYTE) 111 // franme address error

#defi ne GAPERR (BYTE) 112 // link gap error (timeout) in receive data
#define LSRPE (BYTE) 113 // frame parity error on length field
#define | FTS (BYTE) 120 // session layer - invalid frame this state
#define NS_NE VR (BYTE) 121 // session |ayer sequence error

#define NR_NE_ VS (BYTE) 122 // session |ayer sequence error

#defi ne MAC_CRCERR (BYTE) 124 // MAC CRC error

#defi ne RLENERR (BYTE) 123 // MAC too nuch data received

#defi ne FRVERR (BYTE) 200 // Franme Reject

#define FRVERR | F (BYTE)201 // Frame Reject - Invalid Frane

#defi ne FRVERR_NR (BYTE)202 // Frame Reject - NR M snmatch

#defi ne FRVERR_ NS (BYTE)203 // Frame Reject - NS M snmatch

#defi ne NDMERR (BYTE) 204 // Normal D sconnect node error

#defi ne BI NDERR (BYTE) 210 // bind error

#define I PLDUR (BYTE)221 // invalid presentation |ayer response
#defi ne HEADJAM (BYTE) 222 // printer head jam

#defi ne PAPEROUT (BYTE)?223 // printer paper out

#defi ne LOWOLTS (BYTE)224 // printer |ow voltage

#define H VOLTS (BYTE)225 // printer over voltage

#defi ne LOABAT (BYTE)226 // printer |ow battery

#defi ne COVEROFF (BYTE)?227 // printer cover off error

#defi ne HEADFAULT (BYTE)228 // printer head short or driver short error
#defi ne PFFAULT (BYTE)229 // paper feed nmotor fault.

#defi ne FRAME_NOT_ACKED 0x8000 // franme was not received by printer and need
to be resent.
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0’Neil Printer Driver

The DTR printer communications driver is a Stream Device Driver

named ONEIL.DLL.

All applications use WIN32 API functions to access drivers. Basic
operations are easily implemented by applications through the
CreateFile(), WriteFile(), DevicelOControl() and CloseHandle() Win32
APlIs.

The driver supports communications to 6804DM, 6804T, 6805A, 68006,
6808, 681T, and PB20 printers over a selected serial port.

DTR Driver Installation and Removal

Install ()
{

HANDLE hDevi ce;
TCHAR port|[6];

Your application must install the device driver by using the RegisterDe-
vice() function. The driver name is ONEIL.DLL. We recommend that
you use “DTR?” for the Device Name parameter, “1” for the Device Driv-
er index parameter, and use any of the following strings for the last param-
eter:

e NULL (==0) Defaults to COM1 @ 9600

* “COM1” only COM port specified defaults to 9600

* “COM1:9600” sets to COM port and specified bit rate
e “COM1:19200” sets to COM port and specified bit rate

Use the HANDLE returned by RegisterDevice() as the parameter to
DeregisterDevice(). The correct usage of the RegisterDevice() function call
is demonstrated below. You may use DeregisterDevice() to uninstall the
driver.

port[0] = TCHAR('C );
port[1l] = TCHAR('O);
port[2] = TCHAR(‘M);
port[3] = TCHAR('1");
port[4] = TCHAR(':');
port[5] = TCHAR(O);
hDevi ce = Regi sterDevice ( (TEXT("DTR'), 1, TEXT("\\W NDOAS\\ONEI L. DLL"),
( DWORD) port);
}
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Opening the DTR Driver

The application opens the DTR driver by using the CreateFile() function.
The call can be implemented as follows:

hFile = CreateFile(_T("DIR1: "), GENERIC_ WRI TE, 0, NULL,
OPEN_ALWAYS, FILE_ATTRI BUTE_NORVAL, NULL);

The first parameter “DTR1:” must reflect the device name and index used
in the RegisterDevice() function call.

The function call will fail for any of the following reasons:

* The port associated with the device during RegisterDevice() is currently
in use.

* The DTR device is already open.
¢ The share mode is not set to zero. The device cannot be shared.

* Access permissions are not set to GENERIC_WRITE.

Closing the DTR Driver

Using the CloseHandle() (hFile) function closes the DTR driver. Where
hFile is the handle returned by the CreateFile() function call.

* TRUE indicates the device is successfully closed.
* FALSE indicates an attempt to close a NULL HANDLE or an already

closed device.

Writing to the DTR Driver

You can use the WriteFile() function to send all Print data to the printer.
The print data being written must contain the proper formatting printer
commands.

DTR Printer Communications

All DTR printer communications should be based on the following flow:
1 Use CreateFile() to open the printer driver.

2 Use WriteFile() to write your data to the printer. Check for errors and
that all data were written.

3 Use CloseHandle() to close the driver.
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The 700 Series Color Mobile Computer is available with imaging or laser
scanning technologies, including the following:

APS Linear Imager: (standard for 730 Computers)
— includes the EV10 Scan Engine

2D Imager: (not supported on 730 Computers)
— includes the IT4000 Scan Engine

1D Laser Scanner: (not supported on 730 Computers)
— includes the SE900, SE900HS, SE900-S6, and
SE900HS-S6 scan engines

PDF417 Laser Scanner: (not supported on
730 Computers)

Reads 1D symbologies and PDF417 bar codes. Linear imag-
ing using Vista Scanning technology reads low-contrast bar
codes, laminated bar codes, and bar codes displayed on CRT
or TRT displays. This imaging uses harmless LED:s for illu-
mination and does not require any warning labels. Vista Scan-
ning is more reliable than lasers as it is a completely solid state
with no moving parts or oscillating mirrors.

This decodes several stacked 1D and 2D symbologies, includ-
ing PDF417, Data Matrix, and MaxiCode without “paint-
ing.” It can also read 1D codes from any orientation, for ex-
ample the scan beam does not need to align perpendicular to
the symbol to read it. Photography is a secondary application;
the lens in the device favors bar code reading. Photos are

640x480, 256 gray-scale.

Traditional laser scanner that decodes 1D bar codes.

Higher speed laser scanner that can read PDF417 labels by
“painting” the label.

A 700 Color Imager Demo application demonstrates the more common
features of the 700 Color Computer imager. See the /mager Demo V1.0
User’s Guide on the Intermec Developer’s Library CD for information.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.

700 Series Color Mobile Computer User’s Manual

199




Chapter 6 — Scanner Support

Scanner Control and Data Transfer

200

E4

Note: To use the methods described below, enable Data Collection func-
tionality on the 700 Computer using the bootloader configuration menu.

The Data Server and associated software provide several ways to manipu-
late scanner control and data transfer between the scanner subsystem and
user applications:

¢ Automatic Data Collection COM Interfaces:
These COM interfaces allow user applications to receive bar code data,
and configure and control the bar code reader engine.

¢ ITCAxBarCodeReaderControl functions:
These ActiveX controls allow user applications to collect bar code data
from the scanner, to configure the scanner, and to configure audio and
visual notification when data arrives.

¢ ITCAxReaderCommand functions:
Use these ActiveX controls to modify and retrieve configuration infor-
mation using the reader interface commands.

* Scanning EasySet bar code labels:
You can use the EasySet® bar code creation software from Intermec
Technologies Corporation to print configuration labels. Scan the labels
to change the scanner configuration and data transfer settings.

Use the Intermec EasySet software to print configuration labels you can
scan to change your configuration settings. For more information, see
the EasySet online help. EasySet is available from the Intermec Data
Capture web site.

For more information, see the SDK User’s Manual provided with your
Windows CE/PocketPC SDK.
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Data Collection Configuration

For Units with PSM Builds Older than 3.00
”” ||| Scanner settings for the 700 Color Computer can be configured via the
i35 Data Collection control panel applet. From the 700 Color Computer, tap

Data Start > Settings > the System tab > Data Collection. See Appendix A,
Collection

“Configurable Settings” for more information about the following parame-
ters. Note that these are in alphabetical order.

* Codabar (page 298)
* Code 11 (page 312)
* Code 128 (page 301)
* Code 128 Options (page 302)
* Code 128 FNC1 Character (page 303)
* Code 39 (page 296)
* Code 93 (page 300)
* Code 93 Length (page 300)
* Data Matrix (page 314)
* Interleaved 2 of 5 (page 309)
* Matrix 2 of 5 (page 310)
* MaxiCode (page 315)
* MSI (page 305)
o PDF417 (page 306)
* Macro PDF (page 306)
« Micro PDF417 (page 308)
* Plessey (page 304)
* QR Code (page 313)
* Standard 2 of 5 (page 297)
* Telepen (page 311)
« UPC/EAN (page 299)

For Units With PSM Build 3.00 or Newer
C You can configure scanner settings for the 700 Color Computer via the
Intermec Settings control panel applet. From the 700 Color Computer,
;';tt‘i;:g:': tap Start > Settings > the System tab > the Intermec Settings icon. See the
Intermec Computer Command Reference Manual (P/N: 073529) for infor-
mation about the settings you can configure with this applet. This online
manual is available from the Intermec web site at www.intermec.com.
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Internal Scanners

The Intermec Internal Scanner feature allows Automatic Data Collection
(ADC) by accepting data from the COM1 port and wedging it into the
keyboard interface. You can enable or disable this feature from the Today
screen on the 700 Color Computer.

For Units With PSM Build 3.00 or Newer

%
Intermec
Settings

202

Do the following before you configure your internal scanner from the In-
termec Settings control panel applet. Information about the settings you
can configure with this applet is described in the Intermec Computer Com-
mand Reference Manual. The online manual is available from the Intermec

web site at www.intermec.com.
1 From the 700 Color Computer, tap Start > Settings > the System tab >
the Intermec Settings icon.

f‘ f Intermec Settings . 4% 2:40 9

Device Settings
Applications

File Edit Yiew Help| [l B[

2 Tap the Scanners, Symbologies option, then tap (+) to expand Internal
Scanner. This sample screen is for the IT4000 scan engine.

Enable scanner port
yrnbologie s

wmbology Cptions
% Scanner model = [T4000

Canner Settings

rmager Settings
- Decode Security
+-Dock Tethered Scanner

- Wirtual Wedge Settings
Communications

Device Settinds
Applications

File Edit Yiew Help| [l B[
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Scanner and Imager Settings

Depending on what is selected as the scanner model, image settings, de-
code security, scanner settings, and virtual wedge are configured from the
Intermec Settings applet. See the the Intermec Computer Command Refer-
ence Manual, available from the Intermec web site at www.intermec.com,
for more information about each enabled option.

Internal Scanner Supported Symbologies
See the following table for a guideline and Appendix B, “Bar Code Symbol-

ogies” for more information on each supported symbology:

Symbologies EV10 IT4000 SE900 SE900HS SE900-S6 SE900HS-S6

Code39 X X X X X X

UPC/EAN X X X X X X

Code 128 X X X X X X

Interleaved 2 of 5 X X X X X X

Code 93 X X X X X X

Codabar X X X X X X

Code 2 of 5 X X X X X X

MSI X X X X X X

Plessey X X X X X X

Code 11 X X X X X X

Matrix 2 of 5 X X X X X X

Telepen X X X X X X

PDF417 X X X X X X

Micro PDF417 X X X X X X

MaxiCode X

Data Matrix X

QR Code X

RSS 14 X X X X Available in f/w  Available in f/w
Sxxp304 Sxxp304

RSS Limited X X X X Available in f/w  Available in f/w
Sxxp304 Sxxp304

RSS Expanded X X X X Available in f/w  Available in f/w
Sxxp304 Sxxp304

Codablock A X X X X X X

Codablock F X X X X X X

UCC Composite X
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Tethered Scanners

The Intermec Tethered Scanner feature allows Automatic Data Collection
(ADC) by accepting data from the COM1 port and wedging it into the
keyboard interface. You can enable or disable this feature from the Today
screen on the 700 Color Computer.

The following information is divided between units with PSM Builds old-
er than 3.00 (next paragraph) or units with PSM Builds 3.00 or newer
(starting on page 209).

For Units With PSM Builds Older than 3.00

204

T

E4

Enabling and Disabling

On the 700 Color Computer, tap Start > Today. Tap the bar code scan-
ner icon in the System Tray (circled below). Initially, the bar code scanner
icon indicates that this feature is disabled (shown to the left).

4 | start &1 4 210
Friday, March 21, 2003
Tap here to set owener inFormation

Mo upcoming sppoinkments

Mo untesd messages

* Select Comm Port Wedge to send any data, coming into the 700 Color
Computer through the COM1 port from an external input device, as
keyboard data to an application on the desktop.

For example, if you have Pocket Word running on your 700 Color
Computer desktop, information scanned with a scanner connected to
the COMLI port appears in the Word document. If another data collec-
tion application is running and is active on the 700 Color Computer,
the scanned information appears in that application.

Note: When Comm Port Wedge is selected, regardless of the data sent
by the external input device, you cannot control the device or the data
format using any of the Intermec scanner control or data transfer APIs
from the SDK or the internal Data Collection software. The external
input device is governed by what software it has onboard to tell it how
to scan, take pictures, or send the data elsewhere.
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e Select 1551/1553 to enable the Sabre 1551E or 1553 Tethered Scanner
to scan, then send data as keyboard data. The 1551/1553 Tethered
Scanner has software onboard that translates scanned data into charac-
ters, so the running/active application does not need to know how to do
that. All the scanner control and data transfer APIs will work with the
1551/1553 Tethered Scanner, so you can control the device.

* Select Disable All to disable this feature and use the COM1 port for
another application, such as ActiveSync. An error message will result if
this option were not selected, but this action was attempted. Similarly, if
ActiveSync is using the COM1 port, and you select Comm Port Wedge
or 1551/1553, an error message will result. See “Error Message” for
more information.

Comm Port Wedge
155171553

* Disable all

Change Comm Settings

Error Message

If the COM1 port is used by another application, such as ActiveSync, nei-
ther the Comm Port Wedge nor the 1551/1553 Tethered Scanner can be
enabled. As a result, the following message may appear. Note that this mes-
sage is for the Comm Port Wedge. You must disable that application to free
up the COM1 port before you can enable either the wedge or the scanner.

ITC TetherScan ok}

Error enabled
CormmPortyedge: Comm
port unavailable,

Changing Comm Settings

Tap Change Comm Settings to configure the settings for the COM1
port. Current settings are restored after a warm-boot is performed, but are
lost after a cold-boot is performed. When these settings are not changed,
the OK button is disabled (grayed out). When changes are made, tap OK

after it is enabled to accept these changes.

* Baud Rate: 1200, 2400, 4800, 9600, 19200, 38400, 57600,

115200
¢ Data Bits: 7 or 8
* Parity: None, Odd, Even, Mark, Space
* Stop Bits: lor2

Flow Control: None or Hardware
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206

Tethered Scanner
Default settings for the Tethered Scanner are shown in this illustration:

rComm Port 1 Settings
Baud Rate:  |EEElm
Data Bits
Parity:
Stop Bits:
Flove Control:
Cancel | | 0K |

Sabre 1551E or 1553 Tethered Scanner

The default communication configuration for the Sabre 1551E or 1553
Tethered Scanner is shown in the following illustration. Scan the EasySet
Reset Factory Defaults label to set the Sabre 1551E or 1553 tethered scan-
ner communications settings to this configuration. The COM1 port con-
figuration settings must also match those of the scanner to scan labels.

-Comm Port 1 Settings
Baud Rate:
Data Bits
Parity:
Stop Bits:
Flove Control:
Cancel | I 0K |

Welch Allyn 1470 Imager Settings
You can set the Welch Allyn 1470 Imager to this configuration by scan-
ning the Factory Default Settings label.
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Scanner Cabling
A null modem cable is required for the Welch Allyn 1470 Imager to com-

municate with the 700 Color Computer when using the 700 Color Serial
Cable (P/N: 226-999-001).

Sabre 1551E / 1553 Cables connect directly to the Model 700 COM Port.

Limitations and Capabilities
The Tethered Scanner has the following limitations:

* No auto detection of a scanner’s physical connection to COM1 port.
User needs to ensure the communication settings of COM1 port
matched the settings of the device.

* The Pocket PC Pocket Office applications misbehave when control
characters such as carriage return are wedged. This is a known Pocket
PC problem, which is being worked with Microsoft and for which a

work around is being developed.
e Communications port is COM1 and cannot be changed.

* A complete bar code label is detected when the time between bytes (the
inter-byte gap) exceeds 100 ms. This allows that data could be concate-
nated if two labels were received while the Comm Port Wedge or the
1551/1553 Tethered Scanner was not performing a read. That is, it
could be wedging data just read or the read thread could be preempted.
Also, the labels could appear concatenated if the scanner itself were to
buffer the labels before transmitting them.

When enabled, the “Comm Port Wedge” menu option has this limitation:

* There is no bar code API to get bar code data from the bar code scan-
ner. The Comm Port Wedge transmits the data through the keyboard
interface only.

When enabled, the “1551/1553” menu option has these capabilities:
* Grid Data Editing is available.

* The source of the symbology configurations is only available via the
Easy Set command labels. You can only configure the Virtual Wedge
configurations via the Data Collection control panel applet Virtual

Wedge page. See Appendix A, “Configurable Settings,” for information.

* May transmit the data through the keyboard interface (via the Virtual
Wedge).
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* The bar code APIs, defined in the IADC interface, are available to get
bar code data from the bar code scanner. The following example shows
how to programmatically collects bar code data:

#i ncl ude “1 ADC. h”
#i ncl ude “I TCAdcMgnt . h”

/1
/1

| ADC* pl ADC;
HRESULT hr St at us

S

/] Create a ADC COMinterface to collec

Li nked with 1 TCUU D. LI B
Li nked with | TCAdcDevignt. li b

t bar code data fromthe 1551FE/ 1553

/1 when the 1551/1553 menu option is enabl ed.

hr St atus =

| TCDevi ceOpen( TEXT(“ Ext Scanner™), [/
I 1 D_I ADC, /1
| TC_DHDEVFLAG READAHEAD, /1
(LPVO D *) &pl ADQ) ; /1

i f( SUCCEEDED( hr St at us) )

BYTE byt eBuf f er [ MAX_LABEL_SI ZE] ;
DWORD dwiength = 0;

HRESULT hr = pl DC- >Read(
byt eBuf f er, /1
MAX_LABEL_SI ZE, /1
&dwlLengt h, /1
NULL, /1
I NFINI TE /1

when done using this COMinterface,
| TCDevi ced ose( (I Unknown **) pl ADC);

208

Narme of the ADC devi ce.
COMinterface to return
Devi ce’s Fl ags

the returned interface

Buf fer to put the ADC dat a.

Si ze of pDataBuffer in bytes.
Nurmber bytes returned.

Tinme stanmp of the received data.
Number of milliseconds to wait.

NULL.

delete it:
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For Units With PSM Build 3.00 or Newer

Configuring the Tethered Scanner

Do the following before you configure your tethered scanner from the In-
termec Settings control panel applet. Information about the settings you
can configure with this applet is described in the Intermec Computer Com-
mand Reference Manual. The online manual is available from the Intermec
web site at www.intermec.com.

1 Connect your tethered scanner to the tethered scanner port.

E‘ 2 From the 700 Color Computer, tap Start > Settings > the System tab >
the Intermec Settings icon.

Intermec
Settings

F f Intermec Settings . 4% 2:40 9

= 'r|'|t||:| ||:||;| 2%
Comrmunications
Device Settings
Applications

File Edit Yiew Help| [l B[

3 Tap the Scanners, Symbologies option, then tap (+) to expand Dock
Tethered Scanner.

}1 f Intermec Settings 4 4% 2:43 9

= rbg 3
Internal Scanner
=-Dock Tethered Scanner

-~ Enable scarrer port

- Syrbologies

- Syrnbclogy Options

- % Scanner model = 1551E
H- Scanner Settings

Scanner Port Settings

- Imager Settings

- Decods Secutity

F-irtual Wedge Settings
Communications

Device Settings

Applications

File Edit Yiew Help| [l B[
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4 Tap Scanner model for a drop-down list, then select the applicable
scanner, such as “1551E” or “1553” in this sample screen.

Intermec Setlings -« =< Z:50 9

Scanners, Syrbologies

- Intermal Scanner
=-Dock Tethered Scanner

[ Erable scarmer port

Symbologies
Syrnbolagy Options

# Scanner model =

- DegASCIl
F-irtual Wedge Settings
Corrmunications

Device Settings
Applications

File Edit Yiew Help| [l B[

5 Make sure a scanner is connected to your 700 Computer properly.
Then, tap to check Enable scanner port, then tap File > Save Settings
from the bottom of the screen. These changes take several moments to

210

reset.

f Intermec Settings 4 4% 2:55 9

Scanners, Syrbologies

- Intermal Scanner
= Dock Tethered Scanner

Syrnbolagy Options
% Scanner model = 1551
Scanner Settings

Scanner Port Settings
Irmager Settings

H-Decode Security
F-irtual Wedge Settings

Corrmunications
Device Settings
Applications

File Edit View Help| [ *

B[
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1551E or 1553 Selected for Scanner Model

When “1551E” or “1553” is selected from the Scanner model option (see
step 4 above), and the port state is already enabled (see szep 5), the process
will take several moments to reset. When 1551E or 1553 is successfully
connected during this step, the unit will emit some beeps. Here, the termi-
nal is initializing the scanner at 9600 for the baud rate, 7 data bits, even
parity, and 2 stop bits and synchronizing the terminal’s configuration with
the attached scanner.

With “1551E” or “1553” selected, Symbologies, Symbology Options,
Hardware Trigger, and Scanner Port settings are configured from the In-
termec Settings applet. See the the ntermec Computer Command Reference
Manual, available from the Intermec web site at www.intermec.com, for
more information about each enabled option.

ASCllI Selected for Scanner Model
To send data coming into the 700 Color Computer through the COM1
port from an external input device, as keyboard data to an application on

the desktop, do the following:
1 Select “ASCII” from the Scanner model option.
2 Tap to check Enable scanner port.

3 Tap File > Save Settings from the bottom of the screen.

.}:j' Intermec Setlings o =< 57 9

Scanners, Syrbologies

- Intermal Scanner

=-Dock Tethered Scanner

""" Erable scarmer port
B+ Symbilogies

- Gyrnbology Options

-~ @ Scanner model =
B~ SCd A Sl

# Scdiegs

E-Imd1551E

Cie

F-irtual Wedge Settings
Communications

Device Settings
Applications

File Edit Yiew Help| [l B[

With “ASCII” selected, Symbology Options, Hardware Trigger, and Scan-
ner Port settings are configured from the Intermec Settings applet. See the
the Intermec Computer Command Reference Manual, available from the In-
termec web site at www.intermec.com, for more information about each
enabled option.
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E4

Note: When selecting either the 1551E or the 1553 Scanner or enabling
the scanner port for these scanners, the 700 Computer tries to communi-
cate with the attached scanner. If the scanner is not powered, if the cable is
not connected properly, the wrong cable is used, or if the scanner firmware
is older than 2.0, and the “Failed to save one or more settings” message

appears, then this step failed.

This process can take time as the terminal is going through a group of
RS-232 settings to communicate with the scanner. After successful com-
municated with the scanner (about eight beeps are generated), it initializes
the scanner with the 700 Computer’s current settings. This process might
generate a series of beeps pending on the firmware version installed in the
scanner. These beeps are suppressed in firmware versions 2.08 or greater.

Troubleshooting the 1551E/1553 Tethered Scanner
Do the following to troubleshoot your 1551/1553 Tethered Scanner:

1 Ensure the correct cable is used for the scanner on the tethered scanner
port. Note the 700 Computer cannot supply power to the scanner.

2 Perform a quick test to determine whether the connection is good.
Temporary select the scanner model as “ASCIL,” then enable the scan-
ner port state. Go to a command prompt or a notepad and scan a data
label. If a label is wedged into the command prompt or notepad, then
the connection is good.

3 If step 2 passes, reset the scanner configurations to their defaults (scan
the Reset Factory Defaults label on the next page) to prevent miscom-
munication, then reenable the scanner port state.

4 If step 2 fails, then the firmware installed in the tethered scanner may be
older than version 2.0. Upgrade your scanner firmware.

Reset Factory Defaults

Scan the EasySet software bar code label “Reset Factory Default” to restore
all of your scanner’s configurations to their factory defaults. When this
command label is scanned, reinitialize the tethered scanner (such as disable
the scanner port state, then enable it) on the 700 Computer. Otherwise,
the online configuration and scanning on the 700 Computer are not func-
tional. In general, scan this label only to initially reset the scanner.

Do not scan EasySet command labels to change the following settings:
* Symbologies code mark * Code 128, EAN29 Identifier

* Preamble and Postamble * Enable/Disable symbologies

* Symbology ID transmit option

In some cases, scanning EasySet Command labels cause the current setting
on the user interface to be out of sync with the scanner settings. However,
in some cases, scanning these labels does corrupt scanned data.

The “Open COMXx error: 0x00000037” message appears if the COM port
cannot open due to another application using the port. Disable that ap-
plication to free up the COM1 port before you can enable the scanner. “x
is the COM port number, such as 1, 2, or 3.

»
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Tethered Scanner Supported Symbologies

The user interface may allow configuration of PDF417, Micro PDF417,
RSS, and Codablock bar code symbologies. However, these symbologies
are dependant on what scanner models and firmware versions are in use.
See the following table for a guideline and Appendix B, “Bar Code Symbol-

ogies” for more information on each supported symbology:

You can use a generic ASCII scanner with the 700 Color Computer.
Pending on the scanner, linear symbologies such as Code39, should de-
code correctly. However, 2D symbologies such as PDF417 may not de-
code correctly.

Symbologies 1551E 1553

Code39 X X
UPC/EAN X X

Code 128 X X
Interleaved 2 of 5 X X

Code 93 X X

Codabar X X

Code 2 of 5 X X

MSI X X

Plessey X X

Code 11 X X

Matrix 2 of 5 X X

Telepen X X

PDF417 Available in 1551 0808 PDF

Micro PDF417 Available in 1551 0808 PDF, Sxxp217_ or later

MaxiCode

Data Matrix

QR Code

RSS 14 F/w version 2.15 or later F/w version 2.15 or later
RSS Limited F/w version 2.15 or later F/w version 2.15 or later
RSS Expanded F/w version 2.15 or later F/w version 2.15 or later
Codablock A Available in 1551 0808 PDF

Codablock F Available in 1551 0808 PDF

UCC Composite
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7 Programming

The following programming information pertains to the 700 Series Color
Mobile Computer:

* Creating CAB Files (page 216)
* Customization and Lockdown (page 233)
* FTP Server (page 234)
* Kernel I/O Control Functions (page 242)
* Network Selection APIs (page 258)
* Notifications (page 281)
* Reboot Functions (page 283)
* Remapping the Keypad (page 284)
% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.
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Creating CAB Files

The Windows CE operating system uses a .CAB file to install an applica-
tion on a Windows CE-based device. A .CAB file is composed of multiple
files that are compressed into one file. Compressing multiple files into one
file provides the following benefits:

* All application files are present.
* A partial installation is prevented.

* The application can be installed from several sources, such as a desktop
computer or a Web site.

Use the CAB Wizard application (CABWIZ.EXE) to generate a .CAB file

for your application.

Creating Device-Specific CAB Files

Do the following to create a device-specific .CAB file for an application, iz

the order provided:

1 Create an .INF file with Windows CE-specific modifications (page
216).

2 Optional Create a SETUP.DLL file to provide custom control of the
installation process (page 228).

3 Use the CAB Wizard to create the .CAB file, using the .INF file, the
optional SETUP.DLL file, and the device-specific application files as
parameters (page 231).

Creating an .INF File
An .INF file specifies information about an application for the CAB Wi-
zard. Below are the sections of an .INF file:

[Version]

This specifies the creator of the file, version, and other relevant informa-
tion.

Required? Yes

* Signature: “signature_name”
“$Windows NT$”
* Provider: “INF_creator”

The company name of the application, such as “Microsoft.”

¢ CESignature

“$Windows CE$”
Example
[Version]
Signature = “$Wndows NT$”
Provider = "“Internec”

CESi gnature = “$W ndows CE$”
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[CEStrings]
This specifies string substitutions for the application name and the default
installation directory.

Required? Yes

e AppName: app_name
Name of the application. Other instances of %AppName% in the .INF
file are replaced with this string value, such as RP32.

* InstallDir:  default_install dir
Default installation directory on the device. Other instances of %Install-
Dir% in the .INF file are replaced with this string value. Example:
\SDMMC_Disk\%AppName%

Example

[CEStrings]

AppNane=" Gane Pack”

I nstal | Di r =%CE1% %AppNanme%

[Strings]
This section is optional and defines one or more string keys. A string key
represents a string of printable characters.

Required? No

* string key:  wvalue
String consisting of letters, digits, or other printable characters. Enclose
value in double quotation marks ““”” if the corresponding string key is
used in an item that requires double quotation marks. No string_keys is

okay.
Example

[Strings]
reg_path = Software\lnternmec\My Test App
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Required?
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[CEDevice]

Describes the platform for the targeted application. All keys in this section
are optional. If a key is nonexistent or has no data, Windows CE does not
perform any checking with the exception being UnsupportedPlatforms. 1f
the UnsupportedPlatforms key exists but no data, the previous value is not
overridden.

Yes

ProcessorType : processor_type
The value that is returned by SYSTEMINFO.dwProcessor T'ype.For
example, the value for the ARM CPU is 2577

UnsupportedPlatforms: platform_family_name

This lists known unsupported platform family names. If the name
specified in the [CEDevice.xxx] section is different from that in the
[CEDevice] section, both platform_family_name values are unsupported
for the microprocessor specified by xxx. That is, the list of unsupported
platform family names is appended to the previous list of unsupported
names. Application Manager will not display the application for an
unsupported platform. Also, a user will be warned during the setup
process if the .CAB file is copied to an unsupported device.

Example

[CEDevice]

UnsupportedPl atforns = pltfrnl ; pltfrml is unsupported
[CEDevice.SH3]

Unsupport edPl at f or ns

pltfrml is still unsupported

VersionMin: minor_version

Numeric value returned by OSVERSIONINFO.dwVersionMinor. The
.CARB file is valid for the currently connected device if the version of
this device is greater than or equal to VersionMin.

VersionMax: major_version

Numeric value returned by OSVERSIONINFO.dwVersionMajor. The
.CARB file is valid for the currently connected device if the version of
this device is less than or equal to VersionMax.

BuildMin: build number

Numeric value returned by OSVERSIONINFO.dwBuildNumber. The
.CARB file is valid for the currently connected device if the version of
this device is greater than or equal to BuildMin.

BuildMax: build_number

Numeric value returned by OSVERSIONINFO.dwBuildNumber. The
.CARB file is valid for the currently connected device if the version of
this device is less than or equal to BuildMax.
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Example

The following code example shows three [CEDevice] sections: one that
gives basic information for any CPU and two that are specific to the SH3
and the MIPS microprocessors.

[CEDevice] ; A “tenplate” for all platforns
UnsupportedPl atforns = pltfrnl ; Does not support pltfrml

; The follow ng specifies version 1.0 devices only.
VersionMn = 1.0
VersionMax = 1.0

[CEDevice.ARM] ; Inherits all [CEDevice] settings

; This will create a .CAB file specific to ARM devi ces.

Processor Type = 2577 ; ARM .cab file is valid for ARM m croprocessors.
UnsupportedPl atfornms = ; pltfrml is still unsupported

; The followi ng overrides the version settings so that no version checking is
per f or med.

VersionM n =

Ver si onMax =

[CEDevice.MIPS] ; Inherits all [CEDevice] settings

; This will create a .CAB file specific to “MPS" devi ces.

Processor Type = 4000 ; MPS .CAB file is valid for MPS

m croprocessor.
UnsupportedPl atfornms =pltfrn2 ; pltfrml, pltFfrm2 unsupported for M Ps . CAB

file.
% Note: To create the two CPU-specific .CAB files for the SETUP.INF file

in the previous example, run the CAB Wizard with the “/cpu arm mips”
parameter.

700 Series Color Mobile Computer User’s Manual 219



Chapter 7 — Programming

[Defaultinstall]

This describes the default installation of your application. Note that under
this section, you will list items expanded upon later in this description.

Required? Yes

* Copyfiles:

copyfile_list_section

Maps to files defined later in the .INF file, such as Files.App, Files.Font,

and Files.Bitmaps.

* AddReg:
Example: RegSettings.All

¢ CEShortcuts:

add_registry_section

shortcut_list _section

String that identifies one more section that defines shortcuts to a file, as
defined in the [CEShortcuts] section.

¢ CESetupDLL:

setup_DLL

Optimal string that specifies a SETUP.DLL file. It is written by the In-
dependent Software Vendor (ISV) and contains customized functions
for operations during installation and removal of the application. The
file must be specified in the [SourceDisksFiles] section.

* CESelfRegister:

self reg DLL_filename

String that identifies files that self-register by exporting the DIIRegister-
Server and DllUnregisterServer Component Object Model (COM)
functions. Specify these files in the [SourceDiskFiles] section. During
installation, if installation on the device fails to call the file’s exported
DIIRegisterServer function, the file’s exported DIlUnregisterServer
function will not be called during removal.

Example
[Defaultinstall]

AddReg = RegSettings. All

CEShortcuts

[SourceDiskNames]

= Shortcuts. Al l

This section describes the name and path of the disk on which your ap-

plication resides.

Required? Yes

e disk ordinal:

disk_label,, path

1=,“App files” , C:\Appsoft\RP32\...
2=,“Font files”,,C:\RpTools\...
3=,“CE Tools” ,,C:\windows ce tools...

* CESignature:

Example

[SourceDisksNames]

1 = ,“Comon files”,,C\app\comon
[SourceDisksNames.SH3]

2 = ,“SH3 files”,,sh3
[SourceDisksNames.MIPS]

2= ,“MPS files”,,mps
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“$Windows CE$”

Requi red section
Usi ng an absolute path

Using a relative path

Using a relative path
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[SourceDiskFiles]
This describes the name and path of the files in which your application
resides.

Required? Yes

¢ filename: disk_number[,subdir]
RPM.EXE = 1,c:\appsoft\...
WCESTART.INI = 1
RPMCE212.INI =1
TAHOMA.TTF =2

% Note: [,subdir] is relative to the location of the INF file.

Example
[SourceDisksFiles] ; Required section
begin.wav =1
end.wav = 1
sanple.hlp = 1
[SourceDisksFiles.SH3]

sanpl e. exe = 2 ; Uses the SourceDisksNames. SH3 identification of 2.
[SourceDisksFiles.MIPS]
sanpl e. exe = 2 ; Uses the SourceDisksNames. M PS identification of 2.
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[DestinationDirs]

This describes the names and paths of the destination directories for the
application on the target device. Note Windows CE does not support directo-
ry identifiers.

Required? Yes

¢ file list_section: 0,subdir
String that identifies the destination directory. The following list shows
the string substitutions supported by Windows CE. Use these only for
the beginning of the path. \
%CE1% \Program Files
%CE2% \Windows
%CE3% \My Documents
%CE4% \Windows\Startup
%CE5% \My Documents
%CEG6%  \Program Files\Accessories
%CE7% \Program Files\Communication
%CE8%  \Program Files\Games
%CE9%  \Program Files\Pocket Outlook
%CE10% \Program Files\Office
%CE11% \Windows\Start Menu\Programs
%CE12% \Windows\Start Menu\Programs\Accessories
%CE13% \Windows\Start Menu\Programs\Communications
%CE14% \Windows\Start Menu\Programs\Games
%CE15% \Windows\Fonts
%CE16% \Windows\Recent
%CE17% \Windows\Start Menu
%]InstallDir%
Contains the path to the target directory selected during installation. It
is declared in the [CEStrings] section
%AppName%
Contains the application name defined in the [CEStrings] section.

Example
[DestinationDirs]
Fil es. Common = 0, %CE1% My Subdir ; \Program Fi |l es\ My Subdir
Files. Shared = 0, %CE2% 7 \Wndows
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[CopyFiles]

This section, under the [DefaultInstall] section, describes the default files
to copy to the target device. Within the [DefaultInstall] section, files were
listed that must be defined elsewhere in the INF file. This section identi-
fies that mapping and may contain flags.

Required? Yes

* copyfile_list_section: destination_filename, [source_filename]
The source_filename parameter is optional if it is the same as destina-
tion_filename.

* copyfile_list_section:  flags
The numeric value that specifies an action to be done while copying fi-

les. The following table shows values supported by Windows CE.

Flag Value Description

COPYFLG_WARN_IF_SKIP 0x00000001 Warn user if skipping a file is attempted after error.
COPYFLG_NOSKIP 0x00000002 Do not allow a user to skip copying a file.
COPYFLG_NO_OVERWRITE 0x00000010 Do not overwrite files in destination directory.
COPYFLG_REPLACEONLY 0x00000400 Copy the source file to the destination directory only if the

file is already in the destination directory.
CE_COPYFLG_NO_DATE_DIALOG 0x20000000 Do not copy files if the target file is newer.
CE_COPYFLG_NODATECHECK 0x40000000 Ignore date while overwriting the target file.
CE_COPYFLG_SHARED 0x80000000 Cireate a reference when a shared DLL is counted.

Example

[Defaultinstall._SH3]

CopyFiles = Fil es. Conmon, Files.SH3
[Defaultinstall _MIPS]

CopyFiles = Files. Common, Files.MPS
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[AddReg]

This section, under the [DefaultInstall] section, is optional and describes
the keys and values that the .CAB file adds to the device registry. Within
the [Defaultlnstall] section, a reference may have been made to this
section, such as “AddReg=RegSettings.All”. This section defines the
options for that setting.

Required? No

* add_registry_section: registry_root_string
String that specifies the registry root location. The following list shows
the values supported by Windows CE.

e HKCR Same as HKEY CLASSES ROOT
e HKCU Same as HKEY CURRENT USER
e HKLM Same as HKEY LOCAL MACHINE

* add_registry_section: wvalue_name
Registry value name. If empty, the “default” registry value name is used.

* add_registry_section: flags
Numeric value that specifies information about the registry key. The
following table shows the values that are supported by Window CE.

Flag Value Description

FLG_ADDREG_NOCLOBBER 0x00000002 If the registry key exists, do not overwrite it. Can be used
with any of the other flags in this table.

FLG_ADDREG_TYPE_SZ 0x00000000 REG_SZ registry data type.
FLG_ADDREG_TYPE_MULTI_SZ 0x00010000 REG_MULTI_SZ registry data type. Value field that follows

can be a list of strings separated by commas.

FLG_ADDREG_TYPE_BINARY 0x00000001 REG_BINARY registry data type. Value field that follows
must be a list of numeric values separated by commas, one
byte per field, and must not use the Ox hexadecimal prefix.

FLG_ADDREG_TYPE_DWORD 0x00010001 REG_DWORD data type. The noncompatible format in the
Win32 Setup .INF documentation is supported.

Example
AddReg = RegSettings. All

[RegSettings._All]

HKLM % eg_pat h% , 0x00000000, al pha ; <default> = “al pha”
HKLM % eg_pat h% t est, 0x00010001, 3 ; Test = 3
HKLM % eg_pat h% new, anot her, 0x00010001, 6 ; New\ another = 6

224 700 Series Color Mobile Computer User’s Manual



Chapter 7 — Programming

[CEShortCuts]

This section, a Windows CE-specific section under the [DefaultInstall]
section, is optional and describes the shortcuts that the installation applica-
tion creates on the device. Within the [DefaultInstall] section, a reference
may have been made to this section, such as “ShortCuts.All”. This section
defines the options for that setting.

Required? No

* shortcut_list_section:  shortcut_filename
String that identifies the shortcut name. It does not require the .LNK
extension.

* shortcut_list_section:  shortcut_type_flag
Numeric value. Zero or empty represents a shortcut to a file; any non-
zero numeric value represents a shortcut to a folder.

e shortcut_list_section:  target_file_path
String value that specifies the destination location. Use the target file
name for a file, such as MyApp.exe, that must be defined in a file copy
list. For a path, use a file_list_section name defined in the [Destination-
Dirs] section, such as DefaultDestDir, or the %InstallDir% string.

* shortcut_list_section:  standard_destination_path
Optional string value. A standard %CEx% path or %/nstallDir%. If no
value is specified, the shortcut_list_section name of the current section or
the DefaultDestDir value from the [DestinationDirs] section is used.

Example
CEShortcuts = Shortcuts. All
[Shortcuts.All]

Sanpl e App, 0, sanpl e. exe ; Uses the path in DestinationDirs. Sample
App, 0, sanpl e. exe, B nstal | Di r% ; The path is explicitly specified.
Sample .INF File
[Version] ; Required section
Signature = “$W ndows NT$”
Provider = “Intermec Technol ogi es Corporation”

CESi gnature = “$W ndows CE$”

; [CEDevice]
; Processor Type =

[Defaultinstall] ; Required section

CopyFiles = Files. App, Files.Fonts, Files.BitMaps, Files.Intl,

Fil es. Tel econNcsCE, Files. Wndows, Files.lnmport, Files.Export, Files.Wrk,
Fi | es. Dat abase, Files. WnCE AddReg = RegSettings. Al ; CEShortcuts =
Shortcuts. Al l

[SourceDisksNames] ; Required section
1 ,“App files” ,,c:\appsoft\...

2 = ,"Font files” ,,c:\WnNT\Fonts

3 = ,"CE Tools” ,,c:\windows ce tool s\wed400\700i e\ nfc\lib\x86
[SourceDisksFiles] ; Required section

rpm exe = 1, C \ Appsoft\ program wce400\ WCEX86Rel 700
weestart.ini = 1
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rpnce212.ini
i nternec. bnp
rpm ogo. bnp
r ppmane. bnp
i mport. bnp
export. bnmp
clock.bmp =1
printer.bmp = 1
filecopy.bnp =1

nmmnn
N

readme.txt =1

lang_eng.bin = 1

rpndat a. dbd = 1, dat abase\ wcel

tahoma. ttf = 2

nfcce212.dll =3

ol ece212.dll =3

ol ece211.dll = 1,c:\w ndows ce tool s\we400\ NVMBD61102. 11\ nfc\|i b\ x86
rdmiSwee. dl | = 1, c:\rptool s\rdmi5wcel4_50\1i b\ wce400\ wcex86r e
picfnt.dll = ,c \rptools\picfnt\1_00\mce400\mcex86re|6110
fmctrl.dll = c \rptools\fntctrl\1 00\we400\wcex86rel 6110

ugrid.dll = 1 \rptools\ugr|d\1 00\ wce400\ wcex86r el 6110

sinple.dll = 1,c:\rptool s\ pspbnDc\1_00\ wce400\ wcex86r e

psink.dll = 1,c:\ rptools\psink\l_OO\mce400\WCEX86ReIM nDependency

psl pwce. dl | =1, c:\rptool s\ psl pnOc\ 1_00\ wce400\ WCEXB6Rel M nDependency
npcpport.dll = 1,c:\rptool s\cedk\ 212 03\installable drivers\printer\npcp
;dexcomdll = 1,c:\rptool s\ psdxnDc\1_00\ x86

ncsce.exe = 1,c:\rptools\ncsce\l 04

nrinet.dll = 1,c:\rptools\ncsce\l 04

[DestinationDirs] ; Required section

; Shortcuts. All = 0, %CE3% ; \ W ndows\ Deskt op

Fil es. App = 0,%nstal I Dr%

Fi | es. Dat aBase 0, % nst al | Di r % Dat aBase

Fi | es. Bi t Maps , % nstall Dir%Bitnaps

Fil es. Fonts ,% nstal |l Di r % Font s

Files.Intl ,%nstalIDir%lntl

Fil es. Tel ecomNcsCE 0,% nstal | Di r% Tel ecom NcsCE
Fil es. W ndows 0, % nstal | Di r % W ndows

1000 |1 ©

Files. | nport = 0,%nstall Dir%| nmport
Fi | es. Export = 0,%nstal | D r% Export
Files. Wrk = 0,%nstall D r% Wrk
Files. WnCE = 0,\storage_card\wi nce
[CEStrings] ; Required section

AppName = Rp32
Install Dir = \storage_card\ %AppNane%

[Strings] ; Optional section

;[ Shortcuts. Al'l]

; Sanmpl e App, 0, sanpl e. exe ; Uses the path in DestinationDrs.

; Sanpl e App, 0, sanpl e. exe, % nstal | Dir% ; The path is explicitly specified
[Files. App]

rpmexe,,,0
rpmini,rpnce2l2.ini,,0

nfcce212.dl1,,,0
ol ece212.dl1,,,0
ol ece211.dl1,,,0
rdmdswee. dl |, ,,0
picfnt.dll,,,0
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fmctrl.dllI,,,0
ugrid.dll,,,0
simple.dll,,,0
psink.dlI,,,0
psl pwce.dl |, ,,0
npcpport.dll,,,0
; dexcomdl|,,,0

[ Fi | es. Dat aBase]
r pndat a. dbd, ,, 0

[Fil es. Fonts]
tahoma.ttf,,,0

[Fil es. Bit Maps]

i nternec. bmp,,, 0
r pm ogo. bnp, ,, 0
r ppmmane. bnp, ,, 0

i mport.bnp,,,0
export.bmp,,,0

cl ock. bnp,,, 0
printer.bnmp,,,0
filecopy. bnp,,,0

[Files.Intl]
| ang_eng. bin,,,0

[Fil es. Tel econNcsCE]
ncsce. exe,,, 0
nrinet.dll,,,0

[ Fil es. Wndows]
readne. txt,,, 0

[Files. I nport]
readne. txt,,, 0

[Files. Export]
readne. txt,,, 0

[Files. Wrk]
readne.txt,,,0

[Fil es. WnCE]
wecestart.ini,,,0

[ RegSettings. Al l]

HKLM " SOFTWARE\ M cr osof t\ Shel | \ Aut oHi de”,, 0x00010001, 1
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; Aut ohi de the taskbar HKLM " SOFTWARE\ M crosof t\ Shel |\ OnTop”, , 0x00010001, O

; Shell is not on top
HKLM " SOFTWARE\ M cr osof t\ Cl ock”, SHOW CLOCK, 0x00010001, 0
: Clock is not on taskbar
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Using Installation Functions in SETUP.DLL

SETUP.DLL is an optional file that enables you to perform custom opera-

tions during installation and removal of your application. The following
list shows the functions that are exported by SETUP.DLL.

Install_Init Called before installation begins. Use this function to check the application version when reinstal-

ling an application and to determine if a dependent application is present.

Install_Exit Called after installation is complete. Use this function to handle errors that occur during applica-

tion installation.

Uninstall_Init  Called before the removal process begins. Use this function to close the application, if the applica-

tion is running.

Uninstall Exit  Called after the removal process is complete. Use this function to save database information to a

file and delete the database and to tell the user where the user data files are stored and how to rein-
stall the application.

% Note; Use [DefaultInstall] > CESelfRegister (page 220) in the .INF file to
point to SETUP.DLL.

After the (AB File Extraction

Cab files that need to cause a warm reset after cab extraction will need to
create the _ RESETMEPLEASE__.TXT file in the “\Windows” directory.
The preferred method to create this file is within the DIIMain portion of
the SETUP.DLL file. It looks like this:

#i ncl ude <wi ndows. h>

#i ncl ude <TI hel p32. h>

#i ncl ude <w nioctl. h>

#i ncl ude <ce_setup.h> // in the public SDK dir

#define | OCTL_TERM NAL_RESET CTL_CODE (FI LE_DEVI CE_UNKNOWN, FI LE_ANY_ACCESS,
2050, METHOD_NEI THER)

BOOL API ENTRY DI | Mai n(  HANDLE h, DWORD reason, LPVO D | pReserved )

{

return TRUE;

} // DI Min

//************************************************************************

$DOCBEG N$
BOCL | sProcessRunni ng( TCHAR * pnane );

Description: Get process table snapshot, | ook for pname running.

Argunents: pname - pointer to nane of programto | ook for.
for exanple, app.exe.

Returns: TRUE - process is running.
FALSE - process is not running.
$DOCENDS

//************************************************************************

BOCL | sProcessRunni ng( TCHAR * pnane )

HANDLE hPr oclLi st ;
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PROCESSENTRY32 pePr ocess;
DWORD t hDevi ceProcessl D
TCHAR | pnane[ MAX_PATH] ;

if ( !pnanme || !*pnanme ) return FALSE;

_tcscpy( | pname, pnane );
_teslw( | pname );
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hProcLi st = CreateTool hel p32Snapshot ( TH32CS_SNAPPRCCESS, 0 );

if ( hProcList == | NVALI D_HANDLE VALUE ) {

return FALSE;
} // end if

menset ( &peProcess, 0, sizeof (peProcess) );

peProcess. dwSi ze = si zeof (peProce

if ( !Process32First( hProclList,

SS);

&peProcess ) ) {

C oseTool hel p32Snapshot ( hProclLi st );

return FALSE;
} // end if

t hDevi ceProcessI D = 0O;

do {
_tcslwr( peProcess. szExeFile );

if ( _tcsstr( peProcess. szExeFi

le, Ipname ) ) {

t hDevi ceProcessl D = peProcess. t h32Processl D,

br eak;
} /! end if
} while ( Process32Next( hProclLis

t, &peProcess ) );

if ( ( GetLastError() == ERROR_NO MORE FILES ) && ( thDeviceProcessl D ==

) ) A

Cl oseTool hel p32Snapshot ( hProcLi st );

return FALSE;
} /1 end if

Cl oseTool hel p32Snapshot ( hProcLi s
return TRUE;
} /1 1sProcessRunning

codel NSTALL_INIT Install _Init(
HWD hwndPar ent ,
BOOL fFirstCall,
BOCL f Previouslylnstalled,
LPCTSTR pszinstal IDir )

{
return codel NSTALL | NI T_CONTI NUE;

}

codel NSTALL_EXIT Install _Exit (
HWD hwndPar ent ,
LPCTSTR pszinstal I Dir,
WORD cFail edDi rs,
WORD cFai | edFi | es,
WORD cFai | edRegKeys,
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WORD cFai | edRegVal s,

WORD cFai |l edShortcuts )
{

HANDLE h;

TCHAR srcfil e[ MAX_PATH| ;

TCHAR dstfil e[ MAX_PATH ;

if (cFailedDirs || cFailedFiles || cFail edRegKeys ||
cFai |l edRegVal s || cFail edShortcuts)
return codel NSTALL EXI T_UNI NSTALL;

if ( IsProcessRunni ng( L”autocab.exe” ) )
h = CreateFile( L"\\Wndows\\_resetnepl ease__.txt",

(GENERI C_READ | GENERI C WRI TE), 0, NULL, CREATE_ALWAYS,
FI LE_ATTRI BUTE_HI DDEN, NULL );

if ( h!= I1NVALI D HANDLE VALUE )
Cl oseHandl e( h );
el se
/Il Couldn't create the file. |If it failed because the file already

exists, it is not fatal.

/1 Otherwi se, notify user of the inability to reset the device and they
will have to
/1 performit manually after all of the installations are conplete.

} /! end if
}
el se
DWORD dr et ;
h = CreateFile( L"SYl1:",
(GENERIC WRI TE | GENERI C_READ), 0, NULL, OPEN_EXI STI NG
FI LE_ATTRI BUTE_NORMAL, NULL );
/1 Force a warm start NOW
if ( h!= I1NVALI D HANDLE VALUE )
Devi cel oControl ( h, | OCTL_TERM NAL_RESET, NULL, O, NULL, O, &dret,
NULL) ;
/1 wWon't return, but we'll show clean up anyway
Cl oseHandl e( h );
}
el se
/1 Couldn't access SYSIO Notify user.
} /! end if
} /1 end if
return codel NSTALL EXI T_DONE;
}
codeUNI NSTALL_INI'T
Uninstall _Init(

HWAD hwndPar ent ,
LPCTSTR pszinstal IDir ) {
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/1 TODO Performthe reverse of INSTALL INIT here
return codeUNI NSTALL_ | NI T_CONTI NUE;
}

codeUNI NSTALL_EXI T
Uninstal | _Exit (HWND hwndParent) {

/1 TODO Performthe reverse of INSTALL EXIT here
return codeUNI NSTALL EXI T_DONE;
}

The system software looks for the following directory structure and files on
the installed media card whether it be an SD card or CF card or embedded
flash file system. No other folders need exist.

\ 2577\ aut orun. exe

\ 2577\ aut or un. dat

\ 2577\ aut ocab. exe

\ 2577\ aut ocab. dat
\cabfiles\*.cab

Creating CAB Files with CAB Wizard

After you create the .INF file and the optional SETUP.DLL file, use the
CAB Wizard to create the .CAB file. The command-line syntax for the
CAB Wizard is as follows:

cabwi z.exe “inf_file” [/dest dest_directory] [/err error_file] [/cpu cpu_type
[cpu_type]]

A batch file, located in <program> directory, with the following com-
mands, works well:

cabw z. exe c:\appsoft\<progranmr\<inf_file_nanme>
cd \appsoft\<prograne

“Inf_file” The SETUP.INF file path.

dest_directory The destination directory for the .CAB files. If no directory is specified, the .CAB files are created
in the “inf_file” directory.

error_file The file name for a log file that contains all warnings and errors that are encountered when the
.CAB files are compiled. If no file name is specified, errors are displayed in message boxes. If a file
name is used, the CAB Wizard runs without the user interface (UI); this is useful for automated

builds.

cpu_type Creates a .CAB file for each specified microprocessor tag, which is a label used in the Win32 SE-
TUP.INF file to differentiate between different microprocessor types. The /cpu parameter, fol-
lowed by multiple ¢pu_type values, must be the last qualifier in the command line.

Example

This example creates .CAB files for the ARM and MIPS microprocessors,

assuming the Win32 SETUP.INF file contains the ARM and MIPS tags:

cabwi z.exe “c:\nyfile.inf” /err nyfile.err /cpu armn ps
% Note: CABWIZ.EXE, MAKECAB.EXE, and CABWIZ.DDF (Windows

CE files available on the Windows CE Toolkit) must be installed in the

same directory on the desktop computer. Call CABWIZ.EXE using its full
path for the CAB Wizard application to run correctly.
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Troubleshooting the CAB Wizard

To identify and avoid problems that might occur when using the CAB
Wizard, follow these guidelines:

232

Use %% for a percent sign (%) character when using this character in
an .INF file string, as specified in Win32 documentation. This will not
work under the [Strings] section.

Do not use .INF or .CAB files created for Windows CE to install ap-
plications on Windows-based desktop platforms.

Ensure the MAKECAB.EXE and CABWIZ.DDF files, included with
Windows CE, are in the same directory as CABWIZ.EXE.

Use the full path to call CABWIZ.EXE.

Do not create a .CAB file with the MAKECAB.EXE file included with
Windows CE. You must use CABWIZ.EXE, which uses
MAKECAB.EXE to generate the .CAB files for Windows CE.

Do not set the read-only attribute for .CAB files.
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Customization and Lockdown

Pocket PC (Windows Mobile) is a hardware specification created by
Microsoft Corporation. Devices that wish to carry the Pocket PC logo
must meet the minimum hardware requirements set in the Pocket PC spe-
cification. Manufacturers are free to add extra hardware functionality.

Pocket PC devices also use a specialized version of the CE operating sys-
tem. This operating system is built from Windows CE 4.2 but contains
customizations, most notably the lack of a desktop and the addition of the
Today Screen.

To carry the Pocket PC logo, all devices must be tested at an Independent
Test Laboratory. The I'TL testing is done based on Microsoft require-
ments. The test lab then reports the findings back to Microsoft Corpora-
tion and Intermec Technologies. If the 700 Color Computer passed all
tests, Intermec is allowed to ship the device with the Pocket PC logo. Each
time the operating system is modified, Intermec must resubmit to ITL
testing.

This means we cannot change the operating system much and still be a
Pocket PC device. For example, if we remove Word from the Start menu,

the device would fail ITL testing and we would not be able to ship devices
with the Pocket PC logo.

Although many customers want a Pocket PC device, some customers
would prefer that their users not have access to all of the Pocket PC featu-
res. Intermec cannot customize the operating system in any way but a cus-
tom application can:

Delete items from the Start menu, and Programs folder. These items are just shortcuts in the file system so the ap-
plication is not really being deleted. Cold booting the device will bring these items back so the application will need
to be run on every cold boot.

Use the RegFlushKey() API to save a copy of the registry to a storage device. See the 700 Color Management Tools
portion of the Intermec Developer’s Library CD for more information on how to do this. Saving a copy of the registry
restores most system settings in a cold boot situation.

Use the SHFullScreen() API in conjunction with other APIs to make the application take up the entire display and
prevent the start menu from being available.

Remap keys and disable keys on the keypad.
Create a custom SIP.

Make changes to the registry to configure the device.

Should you want your 700 Color Computer to display a full screen, keep
in mind that your computer is Pocket-PC certified by Microsoft Corpora-
tion. Check out resources on programming for the Pocket PC, using the
following links. These give full instructions on how to display full screen.

* Instructions on how to create a full screen application for eVC++ ap-
plications using an SHFullScreen() API:
http://support.microsoft.com/support/kb/articles/Q266/2/44.ASP

* Instructions on how to create a full screen application for eVB applica-
tions also using the SHFullScreen() API:
http://support.microsoft.com/support/kb/articles/Q265/4/51.ASP
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FTP Server

FTP support is provided through the FTP Server application
FTPDCE.EXE (MS Windows CE Versions) which is provided as part the

base system.

FTPDCE is the Internet File Transfer Protocol (FTP) server process. The
server can be invoked from an application or command line. Besides ser-
vicing FTP client requests the FTP Server also send a “network announce-
ment” to notify prospective clients of server availability.

% Note: You should consult the REC959 specification for proper use of
some of these commands at the following URL:
* hutp://www.ietf.org/rfc/rfc959.txt for the text version, or
* http://www.w3.org/Protocols/rfc959/ for an html version
Do the following to send commands:
1 Start an FTP client and connect to the device FTP server.

2 Log in with “intermec” as the user name and “cr52401” for the pass-
word.

3 From the FTP client, send the command.

4 Wait for a response.

Synopsis
ftpdce [ options ]
Options
—Aaddy (where addr is in the form of a.b.c.d) Sets the single target address to which to send the network an-
nouncement. Default is broadcast.
—Bbyte Sets the FTP data block size. Smaller sizes may be useful over slower links. Default is 65536.
—Cname Sets the device name. Used by Intermec management software.
—Fvalue Disables the default Intermec account. A value of “0” disables the account. Default is “1”.

Note that disabling the default account without providing a working access control list on the server
will result in a device that will not accept any FTP connections.

—Hsec Sets the interval between network announcements in seconds.A value of “0” turns the network an-
nouncement off. Default is 30 seconds.

—laddr (where addr is in the form of a.b.c.d) Sets the preferred 6920 Communications Server (optional).
~Llog (where log is either “0” or “17) Sets the state of logging. Default is 0 (disabled).

—Nsec Specifies the number of seconds to wait before initially starting FTP server services.

—Pport Sets the UDP port on which the network announcement will be sent. Default port is 52401.
—Qport Sets the port on which the FTP Server will listen for connections. Default port is 21.

—Rdir Sets the FTP mount point to this directory. Default is the root folder of the object store.
—Tscrip Sets the script name for the 6920 Communications Server to process.

~Uurl Sets the default URL for this device.

—Z‘parms”  Sets extended parameters to be included in the network announcement.
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Configurable Parameters Via the Registry Editor

The following parameters receive default values during the installation of

the Intermec FTP Server components. A few of the parameters are visible

in the registry by default, but most must be created in order to modify the
default behavior of the FTP server.

BlockSize

Setting this parameter configures the Intermec FTP Server to transmit and
receive Ethernet packets using the specified data block size. By default, the
FTP server transmits and receives data using a 64K data block size. Adjust-
ing this value may be useful in certain wireless TCP/IP installations.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_DWORD - data block size, in bytes.
Valid Range 0x100-0x10000 (256-65536 decimal).
Default 65536

DeviceName

This parameter configures the Intermec FTP Server to include the speci-
fied device name in the Intermec Device Network Announcement
(IDNA). Adjusting this value may be useful in assigning a symbolic name
to this device for asset tracking.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_SZ

Valid Range None.

Default None.

DeviceURL

This parameter configures the Intermec FTP Server to transmit the speci-
fied URL in the IDNA. This can be used by Intermec management soft-
ware for asset management.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_SZ

Valid Range None.

Default None.
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IDNATarget

This parameter configures the Intermec FTP Server to transmit the IDNA
to a specific destination instead of a general UDP broadcast. This parame-
ter is useful on networks that do not allow UDP broadcasts to be routed
between subnets. The use of this parameter restricts the reception of the
IDNA to the target destination only.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_SZ

Valid Range None.

Default None.

ManifestName

This parameter configures the Intermec FTP Server to transmit the speci-
fied manifest name in the IDNA. This parameter is used by the Intermec
6920 Communications Server for communication transactions. See the
6920 Communications Server documentation for proper use of this pa-
rameter.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_SZ

Valid Range None.

Default iftp.ini

PauseAtStartup

This parameter configures the Intermec FTP Server to sleep for the speci-
fied number of seconds before making the FTP service available on the
device.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_DWORD - stored in seconds.
Valid Range None.

Default 0

Root

This parameter configures the Intermec FTP Server to set the root of the
FTP mount point to the specified value. Note that this must map to an ex-
isting directory or you will not be able to log into the FTP Server.

Key HKLM Sof t war e\ | nt er mec\ | FTP
Value Type REG_SZ

Valid Range None.

Default \
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Transferring Files Over TCP/IP Networks

The File Transfer Protocol (FTP) server transfers files over TCP/IP net-
works. The FTPDCE.EXE program is a version that does not display a
window, but can run in the background.

FTPDCE is the Internet File Transfer Protocol (FTP) server process. The
server can be invoked from an application or command line. Besides ser-
vicing FTP client requests, the FTP Server also sends a “network an-
nouncement” to notify prospective clients of server availability.

Remarks
The FTP Server currently supports the following FTP requests:

CDUP
CWD
DELE
HELP
LIST
MKD
MODE
NLST
NOOP
PASS
PWD
QUIT
RETR
RMD
RNFR
RNTO
STOR
SYST
TYPE
USER
XCUP
XCWD
XMKD
XPWD
XRMD

Changes to the parent directory of the current working directory.

Changes working directory.

Deletes a file.

Gives help information.

(This FTP request is the same as the Is -lgA command). Gives list files in a directory.
Makes a directory.

(Ahways Uses Binary). Specifies data transfer mode.

(Not supported) Gives a name list of files in directory (this FTP request is the same as the /s command).
Does nothing,.

Specifies a password.

Prints the current working directory.

Terminates session.

Retrieves a file.

Removes a directory.

Specifies rename-from file name.

Specifies rename-to file name.

Stores a file.

Shows the operating system type of server system.

(Binary transfers only.) Specifies the data transfer type with the Type parameter.
Specifies user name.

(Not Normally Used) Changes the parent directory of the current working directory.
(Not Normally Used) Changes the current directory.

(Not Normally Used) Creates a directory.

(Not Normally Used) Prints the current working directory.

(Not Normally Used) Removes a directory.
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SITE The following extended OEM commands are supported by the SITE request. For Microsoft FTP cli-
ents, you can send site commands by preceding the command with “quote” such as “quote site status.”

ATTRIB Gets or sets the attributes of a given file. (SITE ATTRIB)

Usage QUOTE SITE ATTRIB [+R | -R] [+A | -A]1 [+S | -S] [+H | -H] [[path]
filename)
+ Sets an attribute.
Clears an attribute.
Read-only file attribute.
Archive file attribute.
System file attribute.
H Hidden file attribute.

ISl

To retrieve the attributes of a file, only specify the file. The server response will be:
200-AD SHRCEIX filename

If the flag exists in its position shown above, it is set. Also, in addition to the values
defined above, there is also defined:

C Compressed file attribute.

E  Encrypted file attribute.

I INROM file attribute.

X XIP file attribute (execute in ROM, not shadowed in RAM).

BOOT Reboots the server OS. This will cause the system on which the server is executing to
reboot. The FTP Server will shut down cleanly before reboot. All client connections
will be terminated. Cold boot is default except for the PocketPC build in which the
default is warm boot. (SITE BOOT)

Usage: QUOTE SITE BOOT [WARM | COLD]
COPrY Copies a file from one location to another. (SITE COPY)
Usage: QUOTE SITE COPY [source] [destination]

Example: QUOTE SI TE COPY ‘\Storage Card\one.dat’ ‘\Stor-
age Card\two. dat’

EXIT Exits the FTP Server. This command will shut down the FTP Server thus termina-
ting all client connections. (SITE EXIT)

Usage: QUOTE SITE EXIT

HELP Gives site command help information. (SITE HELP)
Usage: QUOTE SITE HELP [command)
KILL Terminates a running program. (SITE KILL)
Usage:  QUOTE SITE KILL [program | pid)
LOG Opens or closes the program log. (SITE LOG)
Usage:  QUOTE SITE LOG [open [filenamel| close]
PLIST Lists the running processes (SITE PLIST)
Usage: QUOTE SITE PLIST
RUN Starts a program running. If the program to run has spaces in path or filename,

wrapping the name with single quotes is required.
Usage: QUOTE SITE RUN [program]
Example: QUOTE SI TE RUN ‘\ St orage Card\ app. exe’
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TIMEOUT

EKEY

EVAL

GVAL

PVAL
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Returns the current settings of the FTP Server. MAC, serial number, model, IP ad-
dress, network announcement information as well as OS memory usage are returned.

(SITE STATUS)
Usage: QUOTE SITE STATUS

Toggles idle timeout between 120 to 1200 seconds (2 to 20 minutes). If this timer
expires with no activity between the client and the server, the client connection will
be disconnected. If the optional seconds argument is supplied, the server will set the
connection timeout to the number of seconds specified. Default is 120 seconds or 2

minutes. (SITE TIMEOUT)

Usage: QUOTE SITE TIMEOUT [seconds)

Gives site command electronic key information. (SITE HELP)
Usage: QUOTE SITE EKEY [command)]

Gives site command electronic value information. (SITE HELP)
Usage: QUOTE SITE EVAL [command)

Gives site command general value information. (SITE HELP)
Usage: QUOTE SITE GVAL [command)

Gives site command value information. (SITE HELP)

Usage: QUOTE SITE PVAL [command)]

The remaining FTP requests specified in RFC 959 are recognized, but not
implemented.

The banner returned in the parenthetical portion of its greeting shows the
version number of the FTP Server as well as the MAC address, serial num-
ber and operating system of the machine hosting the server.

The FTP Server supports browsing from the latest Netscape and Microsoft
web browsers. Drag-and-drop capability is available using this environ-
ment.

The FTPDCMDS subdirectory contains commands to use from the web
browser.

Click EXITME.BIN to execute a SITE EXIT command.
Click REBOOTME.BIN to execute SITE BOOT command.

Use the GET command on these files to have the FTP Server execute
these commands.

¢ Security:
A customer configurable access control list may be installed on the
700 Color Computer. This list will allow customers to restrict access
via the FTP Server to users they wish and is in addition to default
Intermec accounts that are disabled using the -F0 option at runtime.

The access control list is named FTPDCE.TXT and is placed in the
same directory on the 700 Color Computer as the FTPDCE.EXE
server. The FTP Server encrypts this file to keep the information safe
from unauthorized users. This file is encrypted when the FTP Server
is started so a file that is placed onto the 700 Color Computer after
the FTP Server starts will require a restart of the FTP Server to take
effect.
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The format of the FTPDCE.TXT is as follows:

FTPDCE: user 1! passwdl<cr><| f >user 2! passwd2<cr ><| f >user 3
I passwd3<cr><| f>. ..

ﬁ Note: The user accounts and passwords are case sensitive.

Once the access control list is encrypted on the 700 Color Computer,
the FTP Server hides this file from users. Once an access control list
is installed on the 700 Color Computer, a new one is not accepted by
the FTP Server until the previous one is removed. Encrypted access
control lists are not portable between 700 Color Computers.

Stopping the FTP Server from Your Application

Autostart FTP

240

To allow application programmers the ability to programmatically shut
down the FTP Server, the FTP Server periodically tests to see if a named
event is signaled. The name for this event is “I'TC_IFTP_STOP” (no
quotes).

For examples on how to use events, consult the Microsoft Developer Net-
work Library at http://www.msdn.com. The MSDN Library is an essential
resource for developers using Microsoft tools, products, and technologies.
It contains a bounty of technical programming information, including
sample code, documentation, technical articles, and reference guides.

This automatically starts the FTP Server (FTPDCE.EXE) when the 700
Color Computer is powered on. This is provided with the NDISTRAY
program (the Network Driver Interface Specification tray application),
which displays the popup menu that currently allows you to load and un-
load the network drivers. Tap the antenna icon in the System Tray of the
Today screen (a sample antenna icon is circled below) for this pop-up menu.

HF | start

Friday, March 2
Tap here ko s
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The default is to start the FTP Server at boot time, unless the following
registry entry is defined and set to “0” which disables AutoFTP. “1” en-
ables the AutoFTP. The entry can be set from the NDISTRAY pop-up
menu by selecting either AutoFTP On or AutoFTP Off.

HKEY_LOCAL_MACHI NE\ Sof t war e\ I nt er mec\ Ndi stray\ St art upl FTP

These new entries are located below the selections to load the network
drivers. If the StartupIFTP registry key is not defined, the FTP Server is
loaded by default, to provide “out-of-the-box” capability for customers
who want to begin loading files to the 700 Color Computer without any
prior configuration.

% Note: If a network driver is unloaded using the NDISTRAY popup menu,
and the FTP Server is running, the FTP Server is stopped.

On a resume, if AutoFTDP is enabled and the FTP Server is running, it is
stopped and restarted. NDISTRAY uses a helper application named RESE-

TIFTP to implement the restart on resume feature.
To do an AutoFTP Installation Check:
1 Ensure the FTP Server is running “out-of-the-box” the first time.

2 Tap Start > Today to access the Today screen, then tap the antenna
icon in the System Tray to bring up the NDISTRAY pop-up menu.
Select AutoFTP Off to disable AutoFTP. Do a warm boot and confirm
the FTP Server is not running,.

Built-in Ethernet

* Wireless 802.11
Mo networking

AutoFTP On
* AutoFTP OFF

3 Tap Start > Today to access the Today screen, then tap the antenna
icon in the System Tray to bring up the NDISTRAY pop-up menu.
Select AutoFTP On to enable AutoFTP, reboot, confirm it is running.

Built-in Ethernet
* Wireless 802.11
Mo networking

* AutoFTP On
AutoFTP OFf

4 Unload the network driver when the FTP Server is running and con-
firm that it is not running any more.

5 Load the FTP Server, establish a connection, then suspend and resume.
The server should still run, but the FTP connection to the client should
be dropped.
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Kernel 1/0 Controls

This describes the KernelloControl() functions available to application
programmers. Most C++ applications will need to prototype the function
as the following to avoid link and compile errors.

extern “C’ BOOL KernelloControl (DAORD dwl oCont rol Code, LPVOA D | pl nBuf, DWORD
nl nBuf Si ze, LPVA D | pQut Buf, DWORD nQut Buf Si ze, LPDWORD | pByt esRet ur ned) ;

I0CTL_HAL_GET DEVICE INFO
This IOCTL returns either the platform type or the OEMPLATFORM

name based on an input value.

Syntax

BOOL KernelloControl( | OCTL_HAL_GET_DEVI CE_I NFO, LPVA D
IpInBuf, DWORD nInBufSize, LPVAO D IpOutBuf, DWORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

IpInBuf Points to a DWORD containing either the SPI_GETPLAT-
FORMTYPE or SPI_GETOEMINFO value.

lpInBufSize Must be set to sizeof(DWORD).

IpOutBuf Must point to a buffer large enough to hold the return data of the
function. If SPI_GETPLATFORMTYPE is specified in jp/nBuf,
then the “PocketPC\0” Unicode string is returned. If SPI_GE-
TOEMINFO is specified in [p/nBuf, then the “Intermec 700\0”
Unicode string is returned.

nOutBufSize The size of jpOutBuf'in bytes. Must be large enough to hold the
string returned.

IpBytesReturned ~ The actual number of bytes returned by the function for the data
requested.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_HAL_ITC_READ_PARM
Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_|I TC_READ PARM LPVA D
IpInBuf, DAORD niInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters
IpInBuf Points to this structure. See “ID Field Values” below.
struct PARMS {
BYTE i d;
BYTE d assl d;
}s
nInBufSize Must be set to the size of the PARMS structure.
IpOutBuf Must point to a buffer large enough to hold the return data of the

function. If this field is set to NULL and #OuzBufSize is set to zero
when the function is called the function will return the number

bytes required by the buffer.
nOutBufSize The size of pOutBuf'in bytes.

IpBytesReturned Number of bytes returned by the function for the data requested.

Return Values

Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the error value. Either
ERROR_INVALID PARAMETER or
ERROR_INSUFFICIENT_BUFFER may be returned when this function

is used to get the error.

ID Field Values
The id field of the PARMS structure may be one of the following values:

ID Field Values

ITC_NVPARM_ETHERNET_ID
This IOCTL returns the Ethernet 802.11b or 802.11b/g MAC Address. Six bytes are returned in the buffer pointed
to by the JpOutBuffer parameter.

ITC_NVPARM_SERIAL_NUM
This IOCTL returns the serial number of the device in BCD format. Six bytes are returned in the buffer pointed to
by the lpOutBuffer parameter.

ITC_NVPARM_MANF_DATE
This IOCTL returns the device date of manufacture in the BCD YYYY/MM/DD format. Four bytes are returned in
the buffer pointed to by the lpOutBuffer parameter.

ITC_NVPARM_SERVICE _DATE
This IOCTL returns the device’s date of last service in BCD YYYY/MM/DD format. Four bytes are returned in the
buffer pointed to by the jp OutBuffer parameter.
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ID Field Values (continued)

ITC_NVPARM_DISPLAY_TYPE
This IOCTL returns the device’s display type. One byte is returned in the buffer pointed to by the JpOutBuffer

parameter.

ITC_NVPARM_EDG_IP
This IOCTL returns the device Ethernet debug IP address. Four bytes are returned in the buffer pointed to by the
lpOutBuffer parameter.

ITC_NVPARM_EDBG_SUBNET
This IOCTL returns the device Ethernet debug subnet mask. Four bytes are returned in the buffer pointed to by the
lpOutBuffer parameter.

ITC_NVPARM_ECN
This IOCTL returns ECNs applied to the device in a bit array format. Four bytes are returned in the buffer pointed
to by the jpOutBuffer parameter.

ITC_NVPARM_CONTRAST
This IOCTL returns the device default contrast setting. Two bytes are returned in the buffer pointed to by the
lpOutBuffer parameter.

ITC_NVPARM_MCODE
This IOCTL returns the manufacturing configuration code for the device. Sixteen bytes are
returned in the buffer pointed to by the [pOusBuffer parameter.

ITC_NVPARM_VERSION_NUMBER

This IOCTL returns the firmware version for various system components. These values for the Classld field of the
PARMS structure are allowed when ITC_NVPARM_VERSION_NUMBER is used in the 7 field:

* VN_CLASS_KBD Returns a five-byte string, including null terminator, that contains an ASCII value which
represents the keypad microprocessor version in the system. The format of the string is x.xx with a terminating null
character.

* VN_CLASS_ASIC Returns a five-byte string, including null terminator, that contains an ASCII value which
represents the version of the FPGA firmware in the system. The format of the string is x.xx with a terminating null
character.

* VN_CLASS_BOOTSTRAP Returns a five-byte string, including null terminator, that contains an ASCII value
which represents the version of the Bootstrap Loader firmware in the system. The format of the string is x.xx with a
terminating null character.

ITC_NVPARM_INTERMEC_SOFTWARE_CONTENT

This IOCTL reads the manufacturing flag bits from the non-volatile data store that dictates certain software
parameters. A BOOLEAN DWORD is returned in the buffer pointed to by jpOuzBuffer that indicates if Intermec
Content is enabled in the XIP regions. TRUE indicates that it is enabled. FALSE indicates that it is not enabled.

ITC_NVPARM_ANTENNA_DIVERSITY

This IOCTL reads the state of the antenna diversity flag. A BOOLEAN DWORD is returned in the buffer pointed
to by lpOutBuffer that indicates if there is a diversity antenna installed. TRUE indicates that it is installed. FALSE
indicates that it is not installed.

ITC_NVPARM_WAN_RI

This IOCTL reads the state of the WAN ring indicator flag. A BOOLEAN DWORD is returned in the buffer
pointed to by /[pOuzBuffer that indicates the polarity of the WAN RI signal. TRUE indicates active high. FALSE

indicates active low.
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ID Field Values (continued)

ITC_NVPARM_RTC_RESTORE

This IOCTL reads the state of the real-time clock restore flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the RTC is restored upon a cold boot. FALSE indicates that the
RTC is not restored.

ITC_NVPARM_INTERMEC_DATACOLLECTION_SW

This IOCTL reads the state of the data collection software enabled flag. A BOOLEAN DWORD is returned in the
buffer pointer to by [pOutBuffer that indicates the data collection software is to install at boot time. FALSE indicates
the data collection software should not install.

ITC_NVPARM_INTERMEC_DATACOLLECTION_HW

This IOCTL reads the data collection hardware flags. A BYTE is returned in the buffer pointer to by jpOutBujffer
that indicates the type of data collection hardware installed. The maximum possible value returned is
ITC_DEVID_SCANHW_MAX.

¢ ITC_DEVID_SCANHW_NONE No scanner hardware is installed.

* ITC_DEVID_OEM2D_IMAGER OEM 2D imager is installed.

* ITC_DEVID_INTERMEC2D_IMAGER Intermec 2D imager is installed.

¢ ITC_DEVID_SE900_LASER SE900 laser is installed.

¢ ITC_DEVID_SE900HS_LASER SE900HS laser is installed.

* ITC_DEVID_INTERMEC_EVIO EVIO linear imager is installed.

The high bit indicates whether the S6 scanning engine is installed. The bit mask for this is
ITC_DEVID_S6ENGINE_MASK. A non-zero value indicates that the S6 scanning engine is installed.

ITC_NVPARM_WAN_INSTALLED

This IOCTL reads the state of the WAN radio installed flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the WAN radio is installed. FALSE indicates that no WAN radio is
installed.

ITC_NVPARM_WAN_FREQUENCY

This IOCTL reads the state of the WAN radio frequency flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the WAN radio frequency is United States. FALSE indicates that
the WAN radio frequency is European.

ITC_NVPARM_WAN_RADIOTYPE

This IOCTL reads the WAN radio ID installed by manufacturing. A BYTE is returned in the buffer pointer to by
lp OutBuffer which indicates the type of WAN radio hardware installed. The maximum possible value returned is
ITC_DEVID_WANRADIO_MAX. The current definitions are:

* ITC_DEVID_WANRADIO_NONE No WAN radio installed.

* ITC_DEVID_WANRADIO_SIERRA_SB555 CDMA Sierra Wireless radio.

* ITC_DEVID_WANRADIO_XIRCOM_GEM3503 GSM/GPRS Intel Xircom) radio.

e ITC_DEVID_WANRADIO_SIEMENS_MC45 GSM/GPRS Siemens radio.

e ITC_DEVID_WANRADIO_SIEMENS_MC46 GSM/GPRS Siemens radio.

ITC_NVPARM_80211_INSTALLED

This IOCTL reads the state of the 802.11b or 802.11b/g radio installed flag. A BOOLEAN DWORD is returned in
the buffer pointed to by JpOutBuffer. TRUE indicates that the 802.11b or 802.11b/g radio is installed. FALSE
indicates that no 802.11b or 802.11b/g radio is installed.

ITC_NVPARM_80211_RADIOTYPE

This IOCTL reads the 802.11b or 802.11b/g radio ID installed by manufacturing. A BYTE is returned in the buffer
pointer to by lpOutBuffer that indicates the type of 802.11b or 802.11b/g radio hardware installed. The maximum
possible value returned is ITC_DEVID_80211RADIO_MAX. The current definitions are:

* ITC_DEVID_80211RADIO_NONE No 802.11b or 802.11b/g radio installed.

e ITC_DEVID_80211RADIO_INTEL_2011B Intel 2011B radio installed.
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ID Field Values (continued)

ITC_NVPARM_BLUETOOTH_INSTALLED

This IOCTL reads the state of the Bluetooth radio installed flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the Bluetooth radio is installed. FALSE indicates that no Bluetooth
radio is installed.

ITC_NVPARM_SERIAL2_INSTALLED

This IOCTL reads the state of the serial 2 (COM2) device installed flag. A BOOLEAN DWORD is returned in the
buffer pointed to by ppOutBuffer. TRUE indicates that the serial 2 device is installed. FALSE indicates that no serial
2 device is installed.

ITC_NVPARM_VIBRATE_INSTALLED

This IOCTL reads the state of the vibrate device installed flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the vibrate device is installed. FALSE indicates that no vibrate
device is installed.

ITC_NVPARM_LAN9000_INSTALLED

This IOCTL reads the state of the Ethernet device installed flag. A BOOLEAN DWORD is returned in the buffer
pointed to by [pOutBuffer. TRUE indicates that the Ethernet device is installed. FALSE indicates that no Ethernet
device is installed.

ITC_NVPARM_SIM_PROTECT_HW_INSTALLED

This IOCTL reads the state of the SIM card protection hardware installed flag. A BOOLEAN DWORD is returned
in the buffer pointed to by ppOusBuffer. TRUE indicates that the SIM card protection hardware is installed. FALSE
indicates that no SIM card protection hardware is installed.

ITC_NVPARM_SIM_PROTECT_SW_INSTALLED

This IOCTL reads the state of the SIM card protection software installed flag. A BOOLEAN DWORD is returned
in the buffer pointed to by /pOuzBuffer. TRUE indicates that the SIM card protection software is installed. FALSE
indicates that no SIM card protection software is installed.

ITC_NVPARM_SIM_PROTECT_SW_INSTALLED
This IOCTL reads the state of the SIM card protection software installed flag. A BOOLEAN DWORD is returned
in the buffer pointed to by [pOuzBuffer. TRUE indicates that the SIM card protection software is installed. FALSE

indicates that no SIM card protection software is installed.
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10CTL_HAL_ITC_WRITE_SYSPARM

Describes and enables the registry save location.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_| TC WRI TE_SYSPARM LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DWORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf A single byte that may be one of the id values. See “ID Field Values
on the next page.

nlnBufSize Must be set to the size of the /p/nBufin bytes.

IpOutBuf Must point to a buffer large enough to hold the data to be written

to the non-volatile data store.

nOutBufSize The size of lpOutBuf'in bytes.

IpBytesReturned  The number of bytes returned by the function.

Return Values

Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the error value. Either
ERROR_INVALID PARAMETER or
ERROR_INSUFFICIENT_BUFFER may be returned when this function

is used to get the error.
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ID Field Values
The id field of lpInBuf may be one of the following values:

ID Field Values
ITC_REGISTRY_SAVE_ENABLE

This function enables or disables the save registry to non-volatile media feature of the RegFlushKey() function.
lpOutBuf must be set to zero (FALSE) if the feature is to be disabled or one (TRUE) if the feature is to be enabled.

ITC_DOCK _SWITCH

This IOCTL sets a position of the dock switch. The dock switch may be set to either “modem” or “serial” positions.

lpOutBuf must point to a buffer that contains a byte value of either DOCK_MODEM or DOCK_SERIAL as

defined in OEMIOCTL.H; the value specifies the position the switch is to be set. The call appears as follows:

[/l port = DOCK _MODEM or DOCK SERI AL as defined in oemioctl.h

BOOL Set DockSwi t ch( BYTE port)

{
DWORD cnd = | TC_DOCK_SW TCH;
DWORD cbRet ;

return KernelloControl (I OCTL_HAL_| TC WRI TE_SYSPARM &cnd, si zeof (cnd),
&port, si zeof (port), &bRet)

}

ITC_WAKEUP_MASK

This IOCTL sets a bit mask that represents the mask for the five programmable wakeup keys. The 1/O key is not a
programmable wakeup key. By default it is always the system resume key and all other keys are set to disable key
wakeup. A zero in a bit position masks the wakeup for that key. A one in a bit position enables wakeup for that key.
lpOutBuf must point to a buffer that contains a byte value of a wakeup mask consisting of the OR’ed constants as
defined in OEMIOCTL.H. Only the following keys are programmable as wakeup events.

#defi ne SCANNER TRI GGER 1

#defi ne SCANNER_LEFT 2

#define SCANNER RIGHT 4

#define GOLD Al 8

#define GOLD A2 0x10

ITC_AMBIENT_KEYBOARD (does not apply to the 730 Computer)
This IOCTL sets the threshold for the keypad ambient sensor. This can be a value from 0 (always off) to 255 (always
on). /pOutBuf must point to a buffer that contains a byte value of the desired setting.

ITC_AMBIENT_FRONTLIGHT (does not apply to the 730 Computer)
This IOCTL sets the threshold for the frontlight ambient sensor. This can be a value from 0 (always off) to 255.
lpOutBuf must point to a buffer that contains a byte value of the desired setting.
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10CTL_HAL_GET_DEVICEID

This IOCTL returns the device ID. There are two types of device IDs
supported, which are differentiated based on the size of the ouzpur buffer.
The UUID is returned if the buffer size is set to

sizeofl UNIQUE_DEVICEID), otherwise the oldstyle device ID is re-

turned.

Usage
#include “pkfuncs.h”
#include “deviceid.h”

Syntax

BOOL KernelloControl ( | OCTL_HAL_GET_DEVI CEI D, LPVA D
IpInBuf, DAORD niInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

IpInBuf Should be set to NULL. STRICT_ID settings are not supported.
IpInBufSize Should be set to zero.

IpOutBuf Must point to a UNIQUE_DEVICEID structure as defined by

DEVICEID.H if the UUID is to be returned

nOutBufSize The size of the UNIQUE_DEVICEID in bytes if the UUID is to
be returned. A DEVICE_ID as defined by PKFUNCS.H is re-
turned if the size in bytes is greater than or equal to sizeof{DE-
VICE_ID).

IpBytesReturned  The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_HAL_GET_OAL_VERINFO

Returns the HAL version information of the Pocket PC image.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_GET_OAL_VERI NFO, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

IpOutBuf Must point to a VERSIONINFO structure as defined by

OEMIOCTL.H. The fields should have these values:
e cboenverinfo sizeof (tagOemVerlnfo);

everinfover 1
*sig; “ITC\O”
eid; N’

et gtcustomner

et gt pl at SeaRay

e tgtplatversion Current build version number
etgtcputype[8]; “Intel\0”

etgtcpu “PXA255\07;
etgtcoreversion

e date Build time
etine Build date

nOutBufSize The size of VERSIONINEFO in bytes.
IpBytesReturned  Returns sizeof{ PVERSIONINFO).

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_HAL_GET_BOOTLOADER_VERINFO

Returns the HAL version information of the Pocket PC image.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_GET_OAL_VERI NFO, LPVA D
IpInBuf, DWORD niInBufSize, LPVO D 1pOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.

nlnBufSize Should be set to zero.

IpOutBuf Must point to a VERSIONINFO structure as defined by

OEMIOCTL.H. The fields should have these values:
e cboenverinfo Sizeof (tagOemVerlnfo);

everinfover 1
*sig; “ITC\O”
eid; ‘B’

et gtcustomner

et gt pl at SeaRay

etgtplatversion Current build version number of the
bootstrap loader
etgtcputype[8]; “Intel\0”;

etgtcpu “PXA255\0”
etgtcoreversion

e dat e Build time
etine Build date

nOutBufSize The size of VERSIONINEFO in bytes.
IpBytesReturned  The number of bytes returned to lpOutBuf.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_HAL_WARMBOOT

Causes the system to perform a warm-boot. The object store is retained.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_ WARMBOOT, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.
lpInBufSize Should be set to zero.
IpOutBuf Should be NULL.
nOutBufSize Should be zero.

Return Values
None.

10CTL_HAL_COLDBOOT

Causes the system to perform a cold-boot. The object store is cleared.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_COLDBOOT, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

IpInBuf Should be set to NULL.
IpInBufSize Should be set to zero.
IpOutBuf Should be NULL.
nOutBufSize Should be zero.

Return Values
None.
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10CTL_HAL_GET_RESET_INFO

typedef struct {
DWORD Reset Reason;

This IOCTL code allows software to check the type of the most recent
reset.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_GET_RESET_I NFO, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

IpInBuf Should be set to NULL.

IpInBufSize Should be set to zero.

IpOutBuf Must point to a HAL RESET_INFO structure. See sample below.

nOutBufSize The size of HAL_RESET_INFO in byrtes.

IpBytesReturned  The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.

Sample

/1 nost recent reset type

DWORD (nj ect St or eSt at e; /1 state of object store

} HAL_RESET_ | NFO,

/] Reset

#def i
#def i
#def i
#def i
#def i
#def i

ne
ne
ne
ne
ne
ne

PHAL_RESET | NFO

reason types
HAL_RESET TYPE_UNKNOAN
HAL_RESET_REASON HARDWARE
HAL_RESET_REASON_SOFTWARE
HAL_RESET_REASON_WATCHDOG
HAL_RESET_BATT_FAULT
HAL_RESET_VDD_FAULT

/1 cold
/1 suspend

/1 power fai
6 // warm boot

RPoOR~ANEFLO

/1l Qbject store state flags
#defi ne HAL_OBJECT_STORE_STATE UNKNOWWN 0
#defi ne HAL_OBJECT_STORE_STATE_CLEAR 1
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I0CTL HAL_GET BOOT DEVICE
This IOCTL code allows software to check which device CE booted from.

254

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_GET_BOOT_DEVI CE, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.
lpInBufSize Should be set to zero.
IpOutBuf Must point to a buffer large enough to hold a DWORD (4 bytes)

that contains the boot device. The following boot devices are sup-

ported:
#def i
#def i
#def i
#def i
#def i
#def i
#def i

ne
ne
ne
ne
ne
ne
ne

HAL_BOOT_DEVI CE_UNKNOMN 0
HAL_BOOT_DEVI CE_ROM XI P 1
HAL_BOOT_DEVI CE_ROM 2
HAL_BOOT DEVI CE_PCMCI A ATA 3
HAL_BOOT_DEVI CE_PCMCI A_LI NEAR 4
HAL_BOOT_DEVI CE_| DE_ATA 5
HAL_BOOT_DEVI CE_| DE_ATAPI 6

nOutBufSize The size of jpOutBufin bytes (4).

IpBytesReturned  The number of bytes returned by the function.

Return Values

Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_HAL_REBOOT

Causes the system to perform a warm-boot. The object store is retained.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_HAL_REBOOT, LPVO D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.
lpInBufSize Should be set to zero.
IpOutBuf Should be NULL.
nOutBufSize Should be zero.

Return Values
None.
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10CTL_PROCESSOR_INFORMATION

Returns processor information.

Usage
#include “pkfuncs.h”

Syntax

BOOL KernelloControl( | OCTL_PROCESSOR | NFORNMATI ON, LPVA D
IpInBuf, DAORD nInBufSize, LPVAO D IpOutBuf, DAORD
nOutBufSize, LPDWORD IpBytesReturned );

Parameters

lpInBuf Should be set to NULL.

nlnBufSize Should be set to zero.

IpOutBuf Should be a pointer to the PROCESSOR_INFO structure. The

PROCESSOR_INFO structure stores information that describes
the CPU more descriptively.

typedef _ PROCESSOR | NFO {

VWORD w\Ver si on; // Set to value 1
WCHAR szProcessorCore[40]; // "ARMO”
WORD wCor eRevi si on; /] 4

WCHAR szProcessor Nane[ 40]; // " PXA255\0”
WORD  wProcessor Revi si on; /10
WCAHR  szCat al ogNunber[100]; // O

WCHAR  szVendor [ 100] ; /1 “1Intel Corporation\0”
DWORD dw nstructionSet; /1 0

DWORD dwC ockSpeed; /1 400

}

nOutBufSize Should be set to sizeof(PROCESSOR_INFO) in bytes.
IpBytesReturned  Returns sizeof PROCESSOR_INFO);

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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10CTL_GET_CPU_ID
Returns Xscale processor ID.

Usage

#include “oemioctl.h”

Syntax

BOOL KernelloControl( | OCTL_GET_CPU_I D, LPVAO D IpInBuf,
DWORD niInBufSize, LPVAO D 1pOutBuf, DAWORD nOutBufSize, LPDWORD
IpBytesReturned );

Parameters

lpInBuf Should point to a CPUldInfo structure defined in OEMIOCTL.H.
lpInBufSize Should be sizeof( CPUIdInfo).

IpOutBuf Should be NULL.

nOutBufSize Should be set to 0.
IpBytesReturned  Returns sizeof{PROCESSOR_INFO);

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails.
GetLastError() may be used to get the extended error value.
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Network Selection APIs

The Network Selection APIs change the network adapter configuration
programmatically. Both drivers support the same IOCTL function num-
bers for loading and unloading the drivers.

Loading and unloading of the 802.11b or 802.11b/g driver is performed
by the FWL1: device in the system by performing DevicelOControl() calls
to the driver.

Loading and unloading of the driver for the built-in Ethernet adapter is

performed by the SYI1: device in the system by performing
DevicelOControl() calls to the driver.

* For loading an NDIS driver associated with an adapter, the IOCTL is
IOCTL_LOAD_NDIS _MINIPORT.

* For unloading NDIS drivers associated with an adapter the IOCTL is

IOCTL_UNLOAD_NDIS_MINIPORT.
Example

#include <winioctl.h>

#include “sysio.h”

void DoLoad(int nDevice) {
LPTSTR devs[] = { _T(“SYIl:”), _T(“FWLl:") };
HANDLE hLoaderDev;
DWORD bytesReturned;

hLoaderDev = CreateFile(devs[nDevice], GENERIC_READ|GENERIC_WRITE, 0,
NULL, OPEN EXISTING, 0, NULL);

&bytesReturned, NULL)){

telse {

}

void DoUnload(int nDevice) {

HANDLE hLoaderDev;
DWORD bytesReturned;

NULL, OPEN EXISTING, 0, NULL);

if (hLoaderDev != INVALID HANDLE VALUE) {
if (!DeviceIoControl( hLoaderDev, IOCTL_LOAD NDIS_MINIPORT, NULL, -1, NULL, O,
MessageBox (NULL, TEXT(“SYSIO IoControl Failed”), TEXT(“Network
loader”) ,MB_ICONHAND) ;
if (hLoaderDev!=INVALID HANDLE VALUE) CloseHandle(hLoaderDev);
hLoaderDev = INVALID HANDLE VALUE; // bad handle
CloseHandle(hLoaderDev) ;
LPTSTR devs[] = { _T(“SYIl:"), T(“FWLl:") };
hLoaderDev = CreateFile(devs[nDevice], GENERIC_READ|GENERIC_WRITE, 0,
if (hLoaderDev != INVALID HANDLE VALUE) {
if (!DeviceIoControl( hLoaderDev, IOCTL_UNLOAD NDIS_ MINIPORT, NULL, -1, NULL, O,

&bytesReturned, NULL)){
MessageBox (NULL, TEXT(“SYSIO IoControl Failed”),TEXT(“Network
loader”) ,MB_ICONHAND) ;
if (hLoaderDev!=INVALID HANDLE VALUE) CloseHandle(hLoaderDev);
hLoaderDev = INVALID HANDLE VALUE; // bad handle

telse {
CloseHandle(hLoaderDev) ;
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The API provided by Intermec Technologies exposes a limited set of rou-
tines that allows a programmer to access and affect the 802.11b or
802.11b/g network interface card from within their application. The rou-
tines provided also reads/writes values to the CE registry that pertain to the
802.11b or 802.11b/g radio driver. By using the provided functions, a
programmer can alter the 802.11b or 802.11b/g parameters of Network
Name (SSID), WEP keys, infrastructure modes, radio channel, and power
management modes. A programmer can also retrieve network connect sta-
tus and signal strength indication from the RF network card.

The API is contained within the 80211APL.DLL file that should be pres-
ent in any load with the 802.11b or 802.11b/g networking installed.

NETWLAN.DLL  This file is the 802.11b or 802.11b/g driver. It is present in all 700 CE loads that use the
PRISMNDS.DLL ~ 802.11b or 802.11b/g network interface card.

80211API.DLL This file is an Intermec authored file that provides the programmer with a set of API calls to
configure or monitor status of the 802.11b or 802.11b/g network.

MODS80211.DLL  The CORE module for the 802.11 NIC. It provides the 802.11b or 802.11b/g status informa-
tion displayed when the CORE application is running.

80211CONE.EXE  This is the “Control Panel” for configuring the 802.11b or 802.11b/g network parameters.
Note that it is an EXE file and is actually called by CPL802.CPL (see below). It is also called
by the CORE application when the “Configuration” button is pressed.

CPL802.CPL A control panel application that does nothing but call 80211CONF.EXE.
80211SCAN.EXE Internally manages the Scan List activity.
802PM.DLL This handles profile management for radio configurable values.

URODDSVC.EXE This handles radio configuration and security authentication based on a selected profile.

The Profile Manager supports up to four radio configuration profiles.
These profiles are the same as those set by the Wireless Network control
panel applet that runs on the Windows CE unit. You can configure
different 802.11b or 802.11b/g profiles and switch between them using
the 802.11 API. See the ConfigureProfile() function on page 275 for more
information.
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Basic Connect/Disconnect Functions

260

Below are functions available for the 700 Color Computer when enabled
with the 802.11b or 802.11b/g radio module.

RadioConnect()

Connects to the available radio. Use this function if you plan on using a
lot of API calls that talk directly to the radio. Note that the 802.11b or
802.11b/g radio must be enabled via NDISTRAY before you can connect
to 1It.

Syntax U NT RadioConnect( );
Parameters None.

Return Values ERROR_SUCCESS when successful, otherwise
ERR_CONNECT_FAILED

Remarks Call this function before you call any other function found within
this API. It hunts out and connects to the 802.11b or 802.11b/g
radio available on the system. Check extended error codes if it re-
turns anything else for information.

Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Radi oConnect) ();
#el se
U NT Radi oConnect () ;
#endi f

RadioDisconnect()

Call this function when done using the 802.11 API to clean up a
connection from a previous RadioConnect() call. If you do not call this
function, you may leave memory allocated.

Syntax U NT RadioDisconnect( );
Parameters None.

Return Values  ERROR_SUCCESS when successful, otherwise
ERR_CONNECT_FAILED.

Remarks None.

Definitions #i f def DYNAM C_LQOADI NG
typedef Ul NT (*PFN_Radi oDi sconnect)();
#el se
U NT Radi oDi sconnect ();
#endi f
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RadioDisassociate()

Call this function to have the 802.11b or 802.11b/g radio disassociate
from the current service set. The radio then enters an “off” mode until it is
woken again by setting the Service Set Identifier (SSID). Also, the NDIS
driver generates an NDIS media disconnect event.

Syntax U NT RadioDisassociate( );
Parameters None.

Return Values  ERROR_SUCCESS when successful, otherwise
ERR_CONNECT_FAILED.

Remarks None.

Definitions #i f def DYNAM C_LQOADI NG
typedef Ul NT (*PFN_Radi oDi sassoci ate)();
#el se
U NT Radi oDi sassoci ate();
#endi f

Query Information Functions

GetAssociationStatus()
Call this function to obtain the radio’s current association status with a
service set.

Syntax

Parameters

Return Values

Remarks

Definitions

U NT GetAssociationStatus( ULONG & );
NDIS_RADIO_ASSOCIATED  Indicates the radio is associated with an access point
NDIS_RADIO_SCANNING Indicates the radio is looking for an access point with which

to associate

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Data is only valid if the function returns ERROR_SUCCESS. Also, if ERROR_SUCCESS is re-
turned, your ULONG reference is populated by one of the parameters listed above.

#i f def DYNAM C_LQADI NG

typedef U NT (*PFN_Get Associ ati onSt at us) (ULONG &) ;
#el se

U NT Get Associ ati onSt at us( ULONG &) ;

#endi f
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GetAuthenticationMode()

Call this function to obtain the radio’s current authentication mode.

Syntax

Parameters

Return Values
Remarks

Definitions

U NT GetAuthenticationMode( ULONG & );

NDIS_RADIO _AUTH_MODE_OPEN 802.11 Open Authentication. Indicates that
the radio is using an open system.
NDIS_RADIO AUTH_MODE_SHARED 802.11 Shared Authentication. Indicates that
the radio is using a shared key.
NDIS_RADIO AUTH_MODE_AUTO Auto switch between Open/Shared. Indicates
automatic detection is used when available.
NDIS_RADIO _AUTH_MODE_ERROR Defined as error value. Indicates the authen-

tication mode was not determined at this
time or is unknown.

NDIS_RADIO_AUTH_MODE_WPA WPA Authentication
NDIS_RADIO AUTH_MODE_WPA_ PSK WPA Preshared Key Authentication
NDIS_RADIO_AUTH_MODE_WPA_NONE WPA None

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Data is only valid if ERROR_SUCCESS is returned. Also, if ERROR_SUCCESS is returned,
your USHORT reference is populated with one of the parameters listed above.

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_Get Aut henti cati onMode) (ULONG &) ;
#el se

U NT Get Aut henti cati onMbde( ULONG &) ;

#endi f

GetBSSID()

Call this function to get the current MAC address (BSSID) of the service
set. In ESS mode, this is the MAC address of the access point the radio is
associated with. In IBSS mode, this is a randomly generated MAC address,
and serves as the ID for the IBSS.

Syntax
Parameters

Return Values
Remarks

Definitions

U NT GetBSSID( TCHAR * );
Pointer to a character array, which is populated with the current BSSID after a successful call.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

If ERROR_SUCCESS is returned, your TCHAR array is populated with the BSSID of the cur-
rent service set: XX- XX- XX- XX- XX~ XX

#i f def DYNAM C_LOADI NG

typedef U NT (*PFN_Get BSSI D) ( TCHAR *);
#el se

U NT Get BSSI D{ TCHAR *);

#endi f
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GetDiversity()

Call this function to get the current diversity setting of your 802.11b or
802.11b/g radio. This uses an optional NDIS5.1 OID to query the radio,
of which a large number of 802.11b or 802.11b/g devices do not support.
This may be inaccurate.

Syntax

Parameters

Return Values
Remarks

Definitions

U NT GetDiversity(USHORT *);

ANT_PRIMARY The primary antenna is selected.
ANT_SECONDARY The secondary antenna is selected.
ANT_DIVERSITY The radio is in diversity mode, and uses both antennas

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

If ERROR_SUCCESS is returned, your USHORT reference is populated with one of the parame-

ters listed above.

#i f def DYNAM C_LQADI NG

typedef U NT (*PFN_GetDiversity) (USHORT *);
#el se

U NT Get Di versity(USHORT *);

#endi f

GetLinkSpeed()

Call this function to get the current link speed of the 802.11b or
802.11b/g radio.

Syntax

Parameters
Return Values

Remarks

Definitions

U NT GetLinkSpeed( int & );

This function accepts an int reference, and your int is populated with the current link speed, in
Mbps, rounded to the nearest whole integer, for example: 1, 2, 5, 11, etc.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Data returned is valid if ERROR_SUCCESS is returned.

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_GCetLi nkSpeed) (i nt &);
#el se

U NT Get Li nkSpeed(int &);

#endi f
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GetMac()
Call this function to get the MAC address of the 802.11b or 802.11b/g
radio.

Syntax U NT GetMac( TCHAR * ):

Parameters Pointer to a character array, which is populated with the MAC address after a successful call.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array is populated with the formatted MAC
address of the adapter, as follows: XX- XX- XX- XX- XX- XX

Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Get Mac) (TCHAR *);
#el se
U NT Get Mac(TCHAR *);
#endi f

% Note: Be sure to call RadioConnect() before calling this function for this

function to work properly.

GetNetworkMode()
Call this function to get the current Network Mode (SSID) for the
802.11b or 802.11b/g radio.

Syntax U NT GetNetworkMode( ULONG & );
Parameters NDIS_NET_MODE_IBSS 802.11 Ad-Hoc Mode.
NDIS_NET MODE_ESS 802.11 Infrastructure Mode.

NDIS_NET_MODE_UNKNOWN  Anything Else/Unknown Error
NDIS_NET_AUTO_UNKNOWN  Automatic Selection. Use of this option is not supported or

recommended.
NDIS_NET TYPE_OFDM_5G 5 Gigahertz 54 Mbps
NDIS_NET TYPE OFDM_2 4G 802.11 2.4 Gigahertz

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parame-

ters listed above.

Definitions #i f def DYNAM C_LQOADI NG
typedef Ul NT (*PFN_Get Net wor kivbde) (ULONG &) ;
#el se
U NT Get Net wor kMbde( ULONG &) ;
#endi f
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GetNetworkType()
Call this function to get the current network type of the radio. Do not
confuse this with GetNetworkMode().

Syntax U NT GetNetworkType( ULONG & );
Parameters NDIS_NET TYPE FH Indicates this is a frequency hopping radio.
NDIS_NET _TYPE_DS Indicates that this is a direct sequence radio.

NDIS_NET_TYPE_UNDEFINED  Indicates this radio type is unknown or undefined.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parame-

ters listed above.

Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Get Net wor kType) (ULONG &) ;
#el se
U NT Get Net wor kType( ULONG &) ;
#endi f

GetSSID()
Call this function to get the desired SSID of the 802.11b or 802.11b/g
radio.

Syntax U NT GetSSID( TCHAR * );
Parameters Pointer to a character array, which is populated with the current SSID when successful.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array is populated with the desired SSID.

Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Get SSI D) (TCHAR *);
#el se
U NT Get SSI D( TCHAR *);
#endi f

% Note: Call RadioConnect() before this function for this function to work
properly.
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GetPowerMode()
Call this function to get the current power savings mode of the radio.

Syntax U NT GetPowerMode( ULONG & );

Parameters NDIS_RADIO_POWER_MODE_CAM Continuous Access Mode (Ze: always on).
NDIS_RADIO_POWER_MODE_PSP Power Saving Mode.
NDIS_RADIO_POWER_UNKNOWN Unknown power mode.
NDIS_RADIO_POWER_AUTO Auto. (Available for 730 Mobile Computers)

NDIS_RADIO_POWER_MODE_FAST PSP  Fast PSP, good savings, fast

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parame-

ters listed above.

Definitions #i f def DYNAM C_LQOADI NG
typedef Ul NT (*PFN_Get Power Mode) (ULONG &) ;
#el se
U NT Get Power Mode( ULONG &) ;
#endi f

% Note: Do not use Automatic Switching mode at this time.

GetRSSI()
Call this function to get the current RSSI (Radio Signal Strength Indica-
tor), in Dbm.

Syntax U NT GetRSSI( ULONG & );
Parameters References a ULONG that is populated with the current RSST after a successful call.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference contains the RSSI. Valid RSSI range
is from —100 Dbm to —30 Dbm.

Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Get RSSI) (ULONG &) ;
#el se
U NT Get RSSI (ULONG &) ;
#endi f
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GetTXPower()
Call this function to get the current transmit power of the radio.
Syntax U NT GetTXPower( ULONG & ):
Parameters NDIS_POWER_LEVEL_63 63 mW
NDIS_POWER_LEVEL_ 30 30 mW
NDIS_POWER_LEVEL_15 15 mW
NDIS_POWER_LEVEL_5 5 mW
NDIS_POWER_LEVEL 1 1 mW

NDIS_POWER_LEVEL_UNKNOWN Unknown Value or Error.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with the TX power in
milliwatts (mW). Valid ranges are from 5 mW to 100 mW.

Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Get TXPower) (ULONG &) ;
#el se
U NT Get TXPower (ULONG &) ;
#endi f
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GetWepStatus()
Call this function to get the current state of the radio’s WEP and encryp-
tion levels.

Syntax U NT GetWepStatus( ULONG & );
Parameters NDIS_ENCRYPTION 1 _ENABLED WEDP is enabled; TKIP and AES are not enabled,

and a transmit key may or may not be available.

(same as NDIS_RADIO_WEP_ENABLED)
NDIS_ENCRYPTION_DISABLED Indicates that AES, TKIP, and WEP are

disabled, and a transmit key is available. (Same as

NDIS_RADIO_WEP_DISABLED)

NDIS_ENCRYPTION_NOT_SUPPORTED Indicates encryption (WEP, TKIP, AES) is not
supported. (Same as
NDIS_RADIO_WEP_NOT_SUPPORTED)

NDIS_ENCRYPTION_ 1 KEY ABSENT Indicates that AES, TKIP, and WEP are
disabled, and a transmit key is not available.

(Same as NDIS_RADIO_WEP_ABSENT)
NDIS_ENCRYPTION 2 ENABLED Indicates that TKIP and WEP are enabled; AES

is not enabled, and a transmit key is available.

NDIS_ENCRYPTION 2 KEY ABSENT Indicates that there are no transmit keys available
for use by TKIP or WEP, TKIP and WEP are
enabled; and AES is not enabled.

NDIS_ENCRYPTION_3_ENABLED Indicates that AES, TKIP, and WEP are enabled,

and a transmit key is available.

NDIS_ENCRYPTION_3 KEY ABSENT Indicates that there are no transmit keys available
for use by AES, TKIP, or WEP, and AES, TKIP,
and WEP are enabled.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the

parameters listed above.

Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Get WepSt at us) (ULONG &) ;
#el se
U NT Get WepSt at us( ULONG &) ;
#endi f

268 700 Series Color Mobile Computer User’s Manual



Chapter 7 — Programming

GetRadiolpAddress()

Call this function to obtain a formatted string indicating whether DHCP
is enabled, and what is the current adapters IP address.

Syntax

Parameters

Return Values

U NT GetRadiolpAddress( TCHAR * );

Pointer to a character array that contains the formatted string of the IP address and static/DHCP
information.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array contains a string formatted as follows:
| P. DHCP Enabl ed\ nxxx. xxx. XxxX. Xxxx\ n or
| P. DHCP Di sabl ed\ nxxx. XxxX. XXx. XxxXx\ n
Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_Get Radi ol pAddr ess) ( TCHAR *);
#el se
U NT Get Radi ol pAddr ess( TCHAR *);
#endi f
Get(C(XStatus()
Call this function to get information about the current CCX status of the
adapter.
Syntax U NT GetCCXStatus( ULONG & );
Parameters NDIS_NETWORK_EAP_ MODE_OFF Disable EAP mode.
NDIS_NETWORK_EAP_MODE_ON Enable EAP mode.

Return Values

Remarks

Definitions

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

If ERROR_SUCCESS is returned, your ULONG reference is populated with one of parameters

listed above.

#i f def DYNAM C _LOADI NG

typedef Ul NT (*PFN_Get CCXSt at us) (ULONG &) ;
#el se

U NT Get CCXSt at us( ULONG &) ;

#endi f
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Set Information Functions

AddWep()

Call this function to add a WEP key to the radio. Call this function multi-
ple times when adding more than one WEP key. Save the “default” key for
last. For example, when adding four keys, and the second key is the default
transmit key, add keys 1, 3 and 4 before you add key 2.

% Note: Add the default transmit key /Zasz.

Syntax

Parameters

Return Values
Remarks

Definitions

U NT AddWep( ULONG BOOL, TCHAR * );

ULONG Specifies the key index to be set. Valid values are 0-3.
BOOL When set to TRUE, specifies that this key is the default transmit key.
TCHAR Pointer to a character array that specifies the key data in either HEX (length of

10 or 26) or ASCII (length of 5 or 13). This string must be null-terminated.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

When adding WEP keys to the radio, turn off encryption before you add the keys, then turn en-
cryption back on afterwards. Also, be sure to add the TRANSMIT KEY last.

#i f def DYNAM C_LOADI NG

typedef U NT (*PFN_AddWep) (ULONG BOOL, TCHAR *);
#el se

U NT AddWep(ULONG, BOOL, TCHAR *);

#endi f

EnableWep()
Enables or disables WEP encryption on the radio (TRUE/FALSE).

Syntax
Parameters

Return Values

Remarks

Definitions

U NT EnableWep( BOOL );
Set BOOL to TRUE to enable WEP encryption, or FALSE to disable WEP encryption.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Call this function with TRUE as the parameter to enable WEP encryption. Call this function with
the FALSE parameter to disable WEP encryption. This call is an alias for EncryptionStatus(). See
the following:

Enabl eWEP( TRUE) = EncryptionSt at us(NDI S_ENCRYPTI ON_1_ENABLED)
Enabl eWEP( FALSE) = Encrypti onSt at us(NDI S_ENCRYPTI ON_DI SABLED)

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_Enabl eV\ep) (BOQL) ;
#el se

U NT Enabl eVeep(BOQL) ;

#endi f

270

700 Series Color Mobile Computer User’s Manual




Chapter 7 — Programming

EncryptionStatus()
Call this function to set the desired encryption status.
Syntax U NT EncryptionStatus( U NT mode );
Parameters NDIS_ENCRYPTION 1 _ENABLED WEDP is enabled; TKIP and AES are not

enabled, and a transmit key may or may not be
available. (same as

NDIS_RADIO_WEP _ENABLED)
NDIS_ENCRYPTION_DISABLED Indicates that AES, TKIP, and WEP are

disabled, and a transmit key is available. (Same

as NDIS_RADIO_WEP_DISABLED)

NDIS_ENCRYPTION_NOT_SUPPORTED Indicates that encryption (WEP, TKIP, and
AES) is not supported. (Same as
NDIS_RADIO_WEP_NOT_SUPPORTED)

NDIS_ENCRYPTION 1 KEY ABSENT Indicates that AES, TKIP, and WEP are
disabled, and a transmit key is not available.

(Same as NDIS_RADIO_WEP_ABSENT)

NDIS_ENCRYPTION 2 ENABLED Indicates that TKIP and WEP are enabled; AES
is not enabled, and a transmit key is available.
NDIS_ENCRYPTION_2_KEY_ABSENT Indicates that there are no transmit keys

available for use by TKIP or WEP, TKIP and
WEDP are enabled; and AES is not enabled.

NDIS_ENCRYPTION_3_ENABLED Indicates that AES, TKIP, and WEP are
enabled, and a transmit key is available.
NDIS_ENCRYPTION_3_KEY_ABSENT Indicates that there are no transmit keys

available for use by AES, TKIP, or WEP, and
AES, TKIP, and WEP are enabled.

Return Values ~ ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_EncryptionStatus) (U NT node);
#el se
U NT EncryptionStatus(U NT node);
#endi f
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SetAuthenticationMode()

Call this function to set the desired authentication mode.

Syntax

Parameters

Return Values

U NT SetAuthenticationMode( ULONG );
NDIS_RADIO_AUTH_MODE_OPEN 802.11 Open Authentication. Indicates that

the radio is using an open system.

NDIS_RADIO AUTH_MODE_SHARED 802.11 Shared Authentication. Indicates that
the radio is using a shared key.

NDIS_RADIO AUTH_MODE_AUTO Auto switch between Open/Shared. Indicates
automatic detection is used when available.
NDIS_RADIO _AUTH_MODE_ERROR Defined as error value. Indicates the authenti-

cation mode was not determined at this time
or is unknown.

NDIS_RADIO_AUTH_MODE_WPA WPA Authentication
NDIS_RADIO AUTH_MODE_WPA_ PSK WPA Preshared Key Authentication
NDIS_RADIO_AUTH_MODE_WPA_NONE WPA None

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.
Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_Set Aut henti cati onMbde) (ULONG ;
#el se
U NT Set Aut henti cat i onMode( ULONG) ;
#endi f
SetChannel()
This function is currently not implemented. Ad-hoc networks automatical-
ly select a channel or use the already existing channel.
Syntax U NT SetChannel ( USHORT );
Parameters USHORT value that should populate with the desired channel (1-14).
Return Values  None.
Remarks None.
Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_Set Channel ) ( USHORT) ;
#el se
U NT Set Channel ( USHORT) ;
#endi f
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SetNetworkMode()
Call this function to set the desired Network Mode.

Syntax

Parameters

Return Values

U NT SetNetworkMode( ULONG );

NDIS_NET_MODE_IBSS 802.11 Ad-Hoc Mode.

NDIS_NET_MODE_ESS 802.11 Infrastructure Mode.
NDIS_NET_MODE_UNKNOWN  Anything Else/Unknown Error
NDIS_NET_AUTO_UNKNOWN  Automatic Selection. Use of this option is not supported or

recommended.
NDIS_NET _TYPE_OFDM_5G 5 Gigahertz 54 Mbps
NDIS_NET TYPE OFDM_2 4G 802.11 2.4 Gigahertz

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_Set Net wor kivbde) ( ULONG) ;

#el se
U NT Set Net wor kMbde( ULONG) ;
#endi f
SetPowerMode()
Call this function to set the desired power mode.

Syntax U NT SetPowerMode( ULONG mode );

Parameters NDIS_RADIO_POWER_MODE_CAM Continuous Access Mode (Ze: always on).
NDIS_RADIO_POWER_MODE_PSP Power Saving Mode.
NDIS_RADIO_POWER_UNKNOWN Unknown power mode.
NDIS_RADIO_POWER_AUTO Auto. (Available for 730 Computers)

Return Values

Remarks

Definitions

NDIS_RADIO_POWER_MODE_FAST PSP  Fast PSP, good savings, fast

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

None.

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_Set Power Mbde) ( ULONG node) ;
#el se

U NT Set Power Mode( ULONG node) ;

#endi f
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SetSSID()
Call this function with a pointer to a null-terminated TCHAR array con-
taining the desired SSID to set the desired SSID of the adapter.

Syntax
Parameters

Return Values

U NT SetSSID( TCHAR * );
Pointer to a character array that contains the desired SSID. This should be null-terminated.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Return Values

Remarks

Definitions

Remarks If an “ANY” network is desired, pass in _T(“ANY”).
Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Set SSI D) (TCHAR *);
#el se
Ul NT Set SSI D TCHAR *);
#endi f
SetC(XStatus()
Call this function to set the desired CCX / Network EAP status.
Syntax U NT SetCCXStatus( ULONG );
Parameters NDIS_NETWORK_EAP_MODE_OFF Disable Network EAP / CCX

NDIS_NETWORK_EAP_MODE_ON Enable Network EAP / CCX

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

None.

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_Set CCXSt at us) (ULONG) ;
#el se

U NT Set CCXSt at us( ULONG) ;

#endi f

SetMixedCellMode()

Call this function to set the desired mixed cell mode.

Syntax

Parameters

Return Values

U NT SetMixedCelIMode( ULONG );
NDIS_MIXED_CELL_OFF Disable Mixed Cell
NDIS_MIXED_CELL_ON Enable Mixed Cell

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Set M xedCel | Mode) (ULONG) ;
#el se
U NT Set M xedCel | Mode( ULONG) ;
#endi f
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RemoveWep()
Call this function with a key index of 0-3 to remove the WEP key at that

index.

Syntax
Parameters

Return Values

U NT RemoveWep( ULONG );
ULONG value that specifies the key index to set. Valid values are 0-3.

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks On disassociation with all BSSIDs of the current service set, WEP key is removed by the adapter.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_RemoveVEP) (ULONG) :
#el se
Ul NT ReroveVEP( ULONG)
#endi f
Helper Functions
ConfigureProfile()
If using the Intermec 802.11 Profile Management system, you can pro-
gram the API to configure the radio to a specific profile by passing the
profile name.
Syntax U NT ConfigureProfile( TCHAR * );
Parameters Pointer to a character array that contains the profile name. This should be null-terminated.

Return Values

Remarks

Definitions

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or
ERR_CONNECT_FAILED if a connection with the radio failed.

Call this function with a pointer to a null-terminated TCHAR array that contains the name of the
profile you wish to configure. This function reads profile data from the profile manager, sets that
profile as the default active profile, and configures the radio appropriately.

If needed, the supplicant and any other related services are automatically started and stopped.

#i f def DYNAM C_LQADI NG

typedef U NT (*PFN_ConfigureProfile)(TCHAR *);
#el se

U NT ConfigureProfil e(TCHAR *);

#endi f
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E4

EnableZeroConfig()
This enables or disables the Wireless Zero Configuration Wizard from
Microsoft. After calling this function, a warm-boot is required for the
change to take effect.

Note: Enabling this function effectively disables all the SET commands in
this APL.

Syntax

Parameters

Return Values

U NT EnableZeroConfig( USHORT );
TRUE Enable Wireless Zero Config
FALSE Disable Wireless Zero Config

ERROR_SUCCESS when successful, ERR_ZERO_CONFIG_CHANGE_FAILED when the
query failed.

Return Values

Remarks Call this function to set the desired Zero Config status.
Definitions #i f def DYNAM C_LQOADI NG
typedef Ul NT (*PFN_Enabl eZer oConfi g) ( USHORT) ;
#el se
U NT Enabl eZer oConf i g( USHORT) ;
#endi f
isZeroConfigEnabled()
Call this function to determine whether Zero Config is currently enabled.
Syntax U NT isZeroConfigEnabled( );
Parameters None.

TRUE if ZeroConfig is enabled, and FALSE if it is disabled.

Return Values

Remarks None.
Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_i sZer oConfi gEnabl ed) () ;
#el se
U NT i sZeroConfi gEnabl ed();
#endi f
isOrinoco()
Call this function to determine whether the current radio is an
ORiINOCO, Lucent, or WaveLLAN radio.
Syntax U NT isOrinoco( );
Parameters None.

TRUE if this is an ORINOCO radio, and FALSE if it is not.

Remarks None.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFEN_i sOrinoco)();
#el se
U NT i sOrinoco();
#endi f
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isSupplicantRunning()

Call this function to determine whether the security supplicant is running.

Syntax
Parameters

Return Values

U NT isSupplicantRunning( );
None.

TRUE if the security supplicant is running, FALSE if it is not running.

Remarks None.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_i sSuppl i cant Runni ng) () ;
#el se
Ul NT i sSuppl i cant Runni ng();
#endi f
StartScanList()
If a scan list is configured on the system, this causes the API to begin the
process of scanning for an available network. This call can take quite a
while to process (depending upon the length of the scan list and how long it
takes to find a valid network), you may wish to call it from a separate
thread.
Syntax U NT StartScanList( );
Parameters None.

Return Values

ERROR_SUCCESS when successful.

Remarks Call this function to start the scan list functionality of the system.
Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_Start ScanList)();
#el se
U NT Start ScanLi st ();
#endi f
StartSupplicant()
Call this function to start the supplicant service if it is installed on the sys-
tem.
Syntax U NT StartSupplicant( );
Parameters None.
Return Values = ERROR_SUCCESS when successful.
Remarks None.
Definitions #i f def DYNAM C_LQADI NG

typedef U NT (*PFEN_Start Supplicant)();
#el se

U NT Start Supplicant();

#endi f
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StopSupplicant()

Call this function to stop the supplicant service.

Return Values

Syntax U NT StopSupplicant( );
Parameters None.
Return Values = ERROR_SUCCESS when successful.
Remarks None.
Definitions #i f def DYNAM C_LQADI NG
typedef U NT (*PFN_St opSupplicant)();
#el se
U NT St opSupplicant();
#endi f
isDHCPEnabled()
Call this function to determine whether DHCP is enabled on the current
adapter.
Syntax U NT i1sDHCPEnabled( );
Parameters None.

TRUE if DHCP is enabled, FALSE if it is not.

Remarks None.
Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_i sDHCPEnabl ed) () ;
#el se
Ul NT i sDHCPEnabl ed() ;
#endi f
RenewDHCP()
Call this function to force a DHCP renewal on the current network adap-
ter.
Syntax Ul NT RenewDHCP( ):
Parameters None.
Return Values = ERROR_SUCCESS when successful.
Remarks You should not have to call this function on Microsoft PocketPC 2003 or Microsoft Windows CE
4.2 NET and later devices.
Definitions #i f def DYNAM C_LQADI NG
typedef Ul NT (*PFN_RenewDHCP) () ;
#el se
U NT RenewDHCP() ;
#endi f
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GetCurrentDriverName()
Call this function to populate the TCHAR array with the driver name.

Syntax
Parameters
Return Values

Remarks

Definitions

U NT GetCurrentDriverName( TCHAR * );
Pointer to a TCHAR array which contains the name of the driver when successful.
ERROR_SUCCESS when successful.

This function is called with a pointer to a TCHAR array that is large enough to hold the name of
the driver PLUS the null terminator.

#i f def DYNAM C_LQADI NG

typedef U NT (*PFN_Get CurrentDriver Nane) (TCHAR *);
#el se

U NT Get CurrentDriver Nane( TCHAR *);

#endi f

ResetRadioToSystemSave()

Call this function to force the radio to reset to the last desired active pro-

file.

Syntax
Parameters

Return Values

U NT ResetRadioToSystemSave( );
None.

ERROR_SUCCESS when successful.

Remarks None.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Reset Radi oToSyst enSave) () ;
#el se
U NT Reset Radi oToSyst enfSave() ;
#endi f
EnableSuppLogging()
Call this function to set the desired supplicant logging mode.
Syntax U NT EnableSuppLogging( ULONG );
Parameters NDIS_SUPP_LOGGING_ON Supplicant Logging Enabled

Return Values
Remarks

Definitions

NDIS_SUPP_LOGGING_OFF
ERROR_SUCCESS when successful.

Supplicant Logging Disabled

None.

#i f def DYNAM C_LQADI NG

typedef Ul NT (*PFN_Enabl eSuppLoggi ng) (ULONG) ;
#el se

U NT Enabl eSuppLoggi ng( ULONG) ;

#endi f
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SwitchPacketDriver()

Call this function to switch between available packet drivers on the system.

Syntax

Parameters

Return Values

U NT SwitchPacketDriver( USHORT );
INTERMEC_PACKET_DRIVER Intermec Packet Driver (ZNICZIO)
NDISUIO_PACKET_DRIVER Microsoft Packet Driver (NDISUIO)
ERROR_SUCCESS when successful.

Remarks After switching to a new packet driver, perform a warm boot for changes to take effect.
Definitions #i f def DYNAM C_LQOADI NG
typedef U NT (*PFN_Swi t chPacket Dri ver) ( USHORT) ;
#el se
U NT Swi t chPacket Dri ver ( USHORT) ;
#endi f
Deprecated Functions
The following functions are deprecated. While these are not removed from
the API, these are no longer supported. Their parameters are no longer
applicable and the return value for all of these functions is:
ERR_FUNCTION_DEPRECATED
Function Syntax
GetRTSThreshold(Deprecated) U NT GetRTSThreshold( USHORT & );
GetMedia(Deprecated) U NT GetMedia( ULONG & );
GetMedium(Deprecated) U NT GetMedium( ULONG & );
GetNicStats(Deprecated) U NT GetNicStats( NDI S 802_11_ STATISTICS & );
SetRTSThreshold(Deprecated) U NT SetRTSThreshold( USHORT & );
SetTXRate(Deprecated) U NT SetTXRate( UCHAR );

EncryptWepKeyForRegistry(Deprecated) Ul NT EncryptWepKeyForRegistry( TCHAR * szDest,

SetDiversity(Deprecicated) U NT SetDiversity( USHORT );

TCHAR * szSource );
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Notifications

Use the following information to programmatically control the vibrator, to
write an application to turn on the vibrator when a message is received via

the WLAN radio link, and turn it off when the user hits a key.

Vibrator support is implemented in the NLED driver as a false LED. The
vibrator is LED 5 and is identified with an CycleAdjust of —1. The vibrate
option is only available in the notifications panel when the vibrator is pres-
ent in the system.

Regarding an applications interface to NLED.DLL, LEDs must be avail-
able for use by applications. This is possible via two functions exported by
the COREDLL.DLL file. To use the LED functions, declare these as ex-
tern C” as follows:

extern 7C” BOOL W NAPI NLEDGet Devi cel nfo(U NT nl nfold,

voi d *pCut put);

extern 7’C” BOOL W NAPI NLEDSet Devi ce( U NT nDevi celd, void
*plnput);

The LEDs are enumerated for access through the data structures associated
with these APIs:

¢ Notification LED 0
Radio On LED 1 (does not apply to the 730 Computer)
Alpha Lock LED 2

¢ Scanner LED 3
* Low Battery 4
* Vibrator 5 (does not apply to the 730 Computer)
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NLEDGetDevicelnfo

Usage
#include “nled.h”

Syntax
BOOL NLEDGetDevicelnfo ( U NT ninfold, void *pOutput );

Parameters

nlnfold Integer specifying the information to return. These values are defined:

NLED_COUNT_INFO Indicates the pOutput buffer specifies the number of LEDs on

the device.

NLED_SUPPORTS_INFO_ID  Indicates the pOuzput buffer specifies information about the
capabilities supported by the LED.

NLED_SETTINGS_INFO_ID  Indicates the pOutput buffer contains information about the
LED current settings.

pOutput Pointer to the buffer to which the information is returned. The buffer points to various structure
types defined in “nled.h”, depending on the value of 7/4, as detailed in the following table:
Value of nID Structure in pOutput
LED_COUNT_INFO NLED_COUNT_INFO
NLED_SUPPORTS_INFO NLED_SUPPORTS_INFO
NLED_SETTINGS_INFO NLED_SETTINGS_INFO
NLEDSetDevice
Usage
#include “nled.h”
Syntax
BOOL NLEDSetDevice ( U NT nDeviceld, void *plnput );
Parameters
nDeviceld Integer specifying the device identification. The following is defined:
NLED_SETTINGS_INFO_ID  Contains information about the desired LED settings.
plnput Pointer to the buffer that contains the NLED_SETTINGS_INFO structure.
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Reboot Functions

There are several methods, via Kernel I/O Control functions, that an ap-
. . p
plication program can use to force the 700 Color Computer to reboot.

10CTL_HAL_REBOOT
IOCTL_HAL_REBOOT performs a warm-boot. See page 255.

10CTL_HAL_COLDBOOT

Invoking the KernellOControl function with
IOCTL_HAL COLDBOOT forces a cold reboot. This resets the 700

Color Computer and reloads Windows CE as if a power-up was
performed. The contents of the Windows CE RAM-based object store are
discarded. See page 252.

10CTL_HAL_WARMBOOT

This function is supported on 700 Color Computers. It performs a warm
boot of the system, preserving the object store. See page 252.
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Remapping the Keypad

E4

Unshifted Plane

Gold Plane

284

Note: Use caution when remapping the keypad. Improper remapping may
render the keypad unusable. Data within the 700 Color Computer could
also be lost, should any problems occur.

Applications have the ability to remap keys on the 700 Color Numeric
Keypad and 700 Color Alphanumeric Keypad. This will allow applications
to enable keys that would otherwise not be available, such as the [F1]
function key. Also, to disable keys that should not be available, such as the
alpha key because no alpha entry is required. Care should be exercised
when attempting to remap the keypad because improper remapping may
cause the keypad to become unusable. This can be corrected by cold boot-
ing the device which will cause the default keymap to be loaded again.

Note that remapping the keys in this way affects the key mapping for the
entire system, not just for the application that does the remapping.

There are three “planes” supported for the 700 Color Numeric Keypad
and Alphanumeric Keypad. Keys that are to be used in more than one shift
plane must be described in each plane.

The unshifted plane contains values from the keypad when not pressed
with other keys, such as the following:

Press the Keys
Numeric Keypad Alphanumeric Keypad To Enter This
185 (m1) 1
(rs) 5
(o) 9

The gold plane contains values from the keypad when a key is simulta-
neously pressed with the [Gold] © key on the numeric keypad or the
[Gold/White] @@ key on the alphanumeric keypad, such as the following:

Press the Keys
Numeric Keypad AlphanumericKeypad  To Enter This
[Gold] © [Gold/White] @ (g2) Send
[Gold] © [Gold/White] @ (c=) A3
[Gold] © [Gold/White] @ (5. PgDn
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Alpha (Blue) Plane
The alpha plane contains values from the keypad when the keypad has
been placed in alpha mode by pressing the blue alpha key, such as the fol-
lowing:
Press the Keys
Numeric Keypad Alphanumeric Keypad To Enter This
[Alpha] [Alpha] @ 2 Caps
[Alpha] [Alpha] @ j
[Alpha] [Alpha] @ w7 v
Key Values

Key values for each plane are stored in the registry. All units ship with a
default key mapping already loaded in the registry. Applications that wish
to change the default mapping need to read the appropriate key from the
registry into an array of Words, modify the values required and then write
the updated values back into the registry. The registry access can be done
with standard Microsoft API calls, such as RegOpenKeyEx(),
RegQueryValueEx(), and RegSetValueEx().

Numeric Keypad

For the 700 Color Numeric Keypad, the following registry keys contain
the plane mappings:

* The unshifted plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ Vkey

* The gold plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ Vkey Gol d

* The alpha plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ VkeyAl pha

Alphanumeric Keypad
For the 700 Color Alphanumeric Keypad, the following registry keys con-
tain the plane mappings:

* The unshifted plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ ALPHA\ Vkey

* The gold plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ ALPHA\ Vkey Gol d

* The alpha plane mapping can be found in the registry at:
HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD\ ALPHA\ Vkey Al pha
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How Key Values Are Stored in Registry

Change Notification

E4

To know which fields to update in the registry, you must know what Scan
Codes are assigned to each physical key (see the “Keypad Scan Codes and
Meanings” table on the next page). The Scan Code is used at the lowest
level of the system to let the keypad driver know which physical key has
been pressed. The keypad driver takes that scan code and looks it up in a
table (a copy of the one stored in the registry) to determine which values
to pass on to the operating system.

Each registry key is just an array that describes to the keypad driver what
value needs to be passed for each physical key. The key values are indexed
by the scan code, this is a zero-based index. For example in the unshifted
plane, the [4] key has a scan code of 0x06. This means that the seventh
word under the “Vkey” registry key will have the value for the [4] key.
Taking a sample of the “Vkey” registry key shows the following values:

00, 00, 0B, 05, 02, 03, C1, 07, 04, 03, BE, 00, 34, 00, 00, 00, .

The value is 34,00. The values are in reverse byte order because that is the
way the processor handles data. When writing an application, nothing
needs to be done to swap the bytes, as this will happen automatically when
the data is read into a byte value. This is something you just need to be
aware of when looking at the registry. Knowing this, we can see that the
value that the keypad driver will pass to the system is a hex 34. Looking
that up on an UNICODE character chart, we see that it maps to a “4”. If
you wanted the key, labeled “4”, to output the letter “A” instead, you
would need to change the seventh word to “41” (the hexadecimal repre-
sentation of “A” from the UNICODE chart), then put the key back into
the registry.

Note: Do not remap scan codes 0x01, 0x41, 0x42, 0x43, 0x44. Remap-
ping these scan codes could render your 700 Color Computer unusable
until a cold-boot is performed.

If you wish to disable a certain key, remap its scan code to 0x00.

Just changing the registry keys will not immediately change the key
mappings. To notify the keypad driver that the registry has been updated,
signal the “I'TC_KEYBOARD_CHANGE” named event using the
CreateEvent() APL.

Advanced Keypad Remapping

286

It is also possible to map multiple key presses to one button and to map
named system events to a button. The multiple key press option could be
useful to cut down on the number of keys needed to press in a given situa-
tion or to remap which key behaves like the action key. Mapping events to
a button could be useful to change which buttons will fire the scanner,
control volume, and allow for suspending and resuming the device. If you
need help performing one of these advanced topics please contact Intermec

Technical Support.

700 Series Color Mobile Computer User’s Manual



Scan Codes

Chapter 7 — Programming

At the lowest driver level, the 700 Color Numeric Keypad and the 700
Color Alphanumeric Keypad identifies keys as scan codes. These scan
codes are sent via the keypad microcontroller, and cannot be changed
without modifying the keypad firmware.

NumericKeypad

The following scan codes pertain to the 700 Color Numeric keypad:

Numeric Keypad Scan Codes and Meanings

Press this Key Meaning ScanCode
Reserved 0x00
I/O button 0x01
Scanner Handle Trigger 0x02
Scanner Left 0x03
Scanner Right 0x04
4/GHI/A2 0x06
None 0x07
Left arrow/Back Tab 0x08
None 0x09
BkSp// (forward slash) 0x0A
@) [Gold] key 0x0B
None 0x0C
Esc/— (minus sign) 0x0D
Down arrow/Volume decrease 0xOE
1% 1/Caps/Send 0xOF
7/PQRS/PgUp 0x10
[Alpha] key 0x11
None 0x12
Up arrow/Volume increase 0x13
Right arrow/Tab 0x14
2/ABC/End 0x15
8/TUV/* (asterisk) 0x16
0/Win 0x17
5/JKL/A3 0x18
None 0x19
Action/+ (plus symbol) 0x1A
3/DEF/backlight 0x1B
9/WXYZ/PgDn 0x1C
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Numeric Keypad Scan Codes and Meanings (continued)

Press this Key Meaning ScanCode

Enter/@ (at symbol) 0x1D

6/MNO/A4 0x1E
None 0x1F-0x40

@l Charge Detect 0x41

JO LCD frontlight 0x42

(@) Ambient light 0x42
Threshold crossed 0x42
Headset detected 0x43
Keypad Backlight 0x44

(@) Ambient Light 0x44
Threshold Crossed 0x44

Alphanumeric Keypad

The following scan codes pertain to the 700 Color Alphanumeric keypad:

Alphanumeric Keypad Scan Codes and Meanings

Press this Key

(o0

Meaning

Reserved

I/O button

Scanner Handle Trigger
Scanner Left

Scanner Right

A/A1 key

B/A2 key

Escape/Send

Left arrow/Back Tab

Up arrow/Volume increase
Down arrow/Volume decrease
Right arrow/Tab
Action/End

E/Win

F/= (equal sign)

G/* (asterisk)

C/A3

H// (forward slash)

D/A4

ScanCode
0x00
0x01
0x02
0x03
0x04
0x05
0x06
0x07
0x08
0x09
0x0A
0x0B
0x0C
0x0D
0xOE
0xOF
0x10
0x11
0x12
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Alphanumeric Keypad Scan Codes and Meanings (continued)

Press this Key Meaning ScanCode
&) J/PgUp 0x13
K/@ (as symbol) 0x14
(L-) L/~ (minus sign) 0x15
D M/1 0x16
(N2 N/2 0x17
I/backlight 0x18
& P/PgDn 0x19
Q/, (comma) 0x1A
(R+ R/+ (plus sign) 0x1B
S/4 0x1C
(15) T/5 0x1D
0/3 0x1E
& Caps/Lock 0x1F
BkSp 0x20
(ve) V/. (period) 0x21
w?7) w/7 0x22
(x8) X/8 0x23
u/6 0x24
> Gold/White 0x25
NumLock 0x26
(‘Space) Space 0x27
ZI0 0x28
Entor Enter 0x29
Y/9 0x2A
None 0x2B-0x40
@)l Charge Detect 0x41
JO LCD frontlight 0x42
O Ambient light 0x42
Threshold crossed 0x42
Headset detected 0x43
Keypad Backlight 0x44
(©) Ambient Light 0x44
Threshold Crossed 0x44
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Sample View of Registry Keys

The following is a sample view of the current default key mapping for the
700 Color Numeric Keypad. See the registry on your device for the latest
key mappings.

[ HKEY_LOCAL_MACHI NE\ HARDWARE\ DEVI CEMAP\ KEYBD]

"ResuneMask” =dwor d: 7

"Vkey” =hex: 00, 00, 0B, 05, 02, 03, C1, 07, 04, 03, BE, 00, 34, 00, 00, 00, \
25, 00, 00, 00, 08, 00, 03, 02, 00, 00, 1B, 00, 28, 00, 31, 00, \
37, 00, 01, 02, 00, 00, 26, 00, 27, 00, 32, 00, 38, 00, 30, 00, \
35, 00, 00, 00, 01, 03, 33, 00, 39, 00, OD, 00, 36, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 07, 05, 01, 05, 03, 05, 02, 05

0,\
0,\
0,\
0,\
0,\

"VkeyCol d” =hex: 00, 00, 0B, 05, 02, 03, C1, 07, 04, 03, BE, 00, 34, 00, 00, 00, \
09, 01, 00, 00, BF, 00, 03, 02, 00, 00, BD, 00, 75, 00, 72, 00, \
21, 00, 01, 02, 00, 00, 76, 00, 09, 00, 73, 00, 38, 01, 5B, 00, \
35, 00, 00, 00, BB, 01, 09, 05, 22, 00, 32, 01, 36, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 07, 05, 01, 05, 03, 05, 02, 05

0,\
0,\
0,\
0,\
0,\

"VkeyAl pha”=hex: 00, 00, 0B, 05, 02, 03, C1, 07, 04, 03, BE, 00, 47, 00, 00, 00, \
25, 00, 00, 00, 08, 00, 03, 02, 00, 00, 1B, 00, 28, 00, 02, 02, \
50, 00, 01, 02, 00, 00, 26, 00, 27, 00, 41, 00, 54, 00, 20, 00,
4A, 00, 00, 00, 01, 03, 44, 00, 57, 00, 0D, 00, 4D, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00, 00,
00, 00, 07, 05, 01, 05, 03, 05, 02, 05

\
0,\
0,\
0,\
0,\
0,\

290 700 Series Color Mobile Computer User’s Manual



A Configurable Settings

This appendix contains information about the Data Collection, Intermec
Settings, SNMP, Unit Information, Utilities, and Wireless Network con-
trol panel applets that may be on the 700 Series Color Mobile Computer.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.

SNMP, Intermec Settings, and Data Collection settings that can appear
under Settings are dependent on what hardware configuration is done for
each 700 Color Computer at the time of shipment. These settings current-
ly only appear if a scanner or an imager option is present.

Likewise, other control panel applets that are specifically related to the
802.11b or 802.11b/g radio module will appear when a 802.11b or
802.11b/g radio module is installed in a 700 Color Computer. Control
panel applets that are specific for Wireless Printing, CDMA/1xRTT, and
GSM/GPRS radio modules will only appear when each respective hard-
ware configuration is done on the 700 Color Computer. See Chaprer 4,
“Network Support,” for more information about the radio modules or the wire-
less printing.

Information about using reader commands and configuration bar codes to
configure some of your settings is also in this appendix.

% Note: Information about the settings you can configure with the Intermec
Settings control panel applet is described in the Intermec Computer Com-

mand Reference Manual (P/N: 073529). The online manual is available
from the Intermec web site at www.intermec.com.
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Configuration Parameters

A configuration parameter changes the way the 700 Color Computer op-
erates, such as configuring a parameter to have the 700 Color Computer
emit a very loud beep in a noisy environment. Use any of the following
methods to execute configuration parameters:

* Change Data Collection and SNMP parameters via control panel ap-
plets later in this appendix.

* Send parameters from an SNMP management station. See “SNMP Con-
Sfiguration on the 700 Color Computer” starting on page 187.

* Scan EasySet bar codes. You can use the EasySet bar code creation soft-
ware from Intermec Technologies Corporation to print configuration
labels. Scan the labels to change the scanner configuration and data
transfer settings.

Use the Intermec EasySet software to print configuration labels you can
scan to change your configuration settings. For more information, see
the EasySet online help. EasySet is available from the Intermec Data
Capture web site.

Changing a Parameter Setting

Menus of available parameters for each group are listed. Use the scroll bars
to go through the list. Expand each menu (+) to view its parameter set-
tings. Tap a parameter to select, or expand a parameter (+) to view its sub-
parameters.

Note that each parameter or subparameter is shown with its default setting
or current setting in (< >) brackets. Tap a parameter or subparameter to
select that parameter, then do any of the following to change its setting:
Tap Apply to apply any changes. Note that these illustrations are from a
Symbologies parameter.

* Typing a new value in an entry field.

* Choosing a new value from the drop-down list.

Selecting a different option. The selected option contains a bullet.

Tap Defaults, then Apply to restore factory-default settings. Tap Yes
when you are prompted to verify this action.

Symbologies

Caution restoring Factory
Defaults wil replace all
settings for this page.
Restare Factory Defaults
(m Uy

Yes No

292 700 Series Color Mobile Computer User’s Manual



Appendix A — Configurable Settings

* Tap Refresh to discard changes and start again. Tap Yes when you are
prompted to verify this action.

Symbologies

Refresh will discard all
unapplied edits and refetch
values for this page.
Refresh now 2

Yes No

About Configuration Parameters

You can find this information about each configuration parameter:

e Name and Purpose:
Describes the parameter and its function.

¢ Action:
Describes what to do with a parameter once that parameter is selected.

¢ SNMP OID:
Lists the SNMP OID for the parameter.

¢ Syntax or Options:
Syntax lists the two-character code for the parameter, if the parameter is
configurable by scanning a bar code or by sending parameters through a
network. Both Syntax and Options list acceptable values for the para-
meter.
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Data Collection Control Panel Applet

294

54
@

Intermec
Settings

12 345

Data
Collection

Note: This applet is not available in units with PSM Build 3.00 or newer.
To determine your PSM Build version, tap Start > Programs >
File Explorer > the PSMinfo text file.

If your unit has PSM Build 3.00 or newer, then you may have the Intermec
Settings control panel applet in place of the Data Collection applet.
Information about the settings you can configure with the Intermec
Settings applet is described in the Intermec Computer Command Reference
Manual. The online manual is available from the Intermec web site at
Wwww.intermec.com.

See “Scanner Control and Data Transfer” in the Intermec Windows CE/
Pocket PC Software Developer’s Kit (SDK) User’s Manual shipped with the
Software Developer’s Kit (SDK) for information about data collection
functions. Note that icons are shown to the left.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Data Collection to access its control panel applet.

Use the left and right arrows to scroll through the tabs along the bottom of
the control panel applet, then tap a tab to access its menus. These tabs rep-
resent the following groups of settings or parameters:

* Symbologies (starting on page 295)

Symbology Options (starting on page 316)

Beeper/LED (starting on page 324)

Imager (starting on page 330)

Virtual Wedge (starting on page 335)
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You can change bar code symbology parameter settings in your 700 Color
Computer via the Data Collection control panel applet. The following

parameters are for bar code symbologies. Additional information about the
more common bar code symbologies are in Appendix B, “Bar Codes.” Note
that these parameters are listed in the order of their appearance within this tab.

Most of these symbologies apply to both the imager and the laser scanner
tools. However, when using an imager, the Macro PDF (page 306), Micro
PDF417 (page 308), Matrix 2 of 5 (page 310), Telepen (page 311), and
Code 11 (page 312) symbologies are not supported. Likewise, when using

a laser scanner, the QR Code (page 313), Data Matrix (page 314), and

MaxiCode (page 315) symbologies are not supported.
Note: The 730 Computer uses the EV10 APS linear imager which sup-

ports 1D symbologies.

The following table shows which bar code symbologies are supported by

an imager, a laser scanner, or the EV10 APS Linear Imager

Bar Code Symbology
Code 39
Interleaved 2 of 5
Standard 2 of 5
Matrix 2 of 5
Code 128

Code 93
Codabar

MSI

Plessey

UPC

EAN/EAN 128
Code 11
PDF417

Micro PDF417
Telepen

Data Matrix

QR Code
MaxiCode

Imager
X
X
X

<

<

<o

Laser Scanner

MK KX X X X XK XK X X X X ) X

EV10 APS

Linear Imager

X

MoK XX XK X ) X X X X ) X
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Code 39
Code 39 is a discrete, self-checking, variable length symbology. The char-
acter set is uppercase A—Z, 0-9, dollar sign ($), period (.), slash (/), per-

cent (%), space (), plus (+), and minus (-).

Action
Tap (+) to expand the Code 39 parameter, select the setting to be
changed, then tap an option to change this setting or select an option from

296

the drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.3.1

Options
Decoding 0 Not active
1 Active (default)
Format 0 Standard 43 characters (default)
1 Full ASCII
Start/Stop 0 Not transmitted (default)
1 Transmitted
Start/Stop characters 0 $ (dollar sign) only
(Not supported when us- 1 * (asterisk) only (default)
ing an imager) 2 $ and * (dollar sign and asterisk)
Check digit 0 Not used (default)
1 Mod 43 transmitted
2 Mod 43 not transmitted
3 French CIP transmitted
4 French CIP not transmitted
5 Italian CPI transmitted
6 Italian CPI not transmitted
Bar code length 0 Any length (default)
1 Minimum length
Minimum length 001-254 Minimum length 1-254 (default is 6)

Note: If Bar code length = “1” then Minimum length is entered.

Data Collection

ecoding, <dckive =
armat, <Skandard 43 characterss
tarkfStop, =mok transmitted>

. - Startfstop characters, <Mot supporte

il i [ T¥

1]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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Standard 2 of 5

Standard 2 of 5 is a discrete and self-checking symbology that uses the bars
to encode information and the spaces to separate the individual bars.

Action

Tap (+) to expand the Standard 2 of 5 parameter, select the setting to be
changed, then tap an option to change this setting or select an option from
the drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.4.1
Options
Decoding 0 Not active (default)

1 Active
Format 0 Identicon, 6 start/stop bars (default)

1 Computer Identics, 4 start/stop bars
Check digit 0 Not used (default)

1 Mod 10 transmitted

2 Mod 10 not transmitted
Bar code length 0 Any length

1 Minimum length (default)

2 Fixed lengths
Minimum length 001-254 Minimum length 1-254 (default is 6)
Fixed length 1 000-254 Fixed bar code length 0-254 (default is 0)
Fixed length 2 000-254 Fixed bar code length 0-254 (default is 0)
Fixed length 3 000-254 Fixed bar code length 0-254 (default is 0)

% Note: If Bar code length = “1” then Minimum length is entered. If Bar
code length = “2” then Fixed length 1, Fixed length 2, or Fixed length 3

is entered.

& g0z O

Data Collection

$--Standard 2 of 5, <0001006000000000 =
" Decading, <Mk active >

armat, <Idanticon, & stark/stap bars
heck digit, <Mot used>

ar code length, <Minimum lengths

Il [T

[ »

1]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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Codabar
Codabar is a self-checking, discrete symbology.

Action
Tap (+) to expand the Codabar parameter, select a setting to be changed,
then select an option from the drop-down list to change this setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.1.1.5.1

Options
Decoding 0 Not active (default)
1 Active
Start/Stop 0 Not transmitted (default)
1 abcd transmitted
2 ABCD transmitted
3 abcd/tn*e transmitted
4 DCI1-DC4 transmitted
CLSI library system 0 Not active (default)
(Not supported when us- 1 Active
ing an imager)
Check digit 0 Not used (default)
1 Transmitted
2 Not transmitted
Bar code length 0 Any length
1 Minimum length (default)
2 Fixed lengths
Minimum length 003-254 Minimum length 3-254 (default is 6)
Fixed length 1 000-254 Fixed bar code length 0-254 (default is 0)
Fixed length 2 000-254 Fixed bar code length 0-254 (default is 0)
Fixed length 3 000-254 Fixed bar code length 0-254 (default is 0)

% Note: If Bar code length = “1” then Minimum length is entered. If Bar
code length = “2” then Fixed length 1, Fixed length 2, or Fixed length 3

is entered.

& g 105 D

Data Collection

&-Codabar, <00001006000000000:
ecoding, <Mt active =

tatkfStop, =Mk tramsmitked>

LSI library system, <Mot supported =|
heck digit, <Mat used=

[ [

[T »

1]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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S UPC/EAN, <1111000111111100>
LPC A, <hctives

Tl

UPC E, <Actives>
EAN 8, <Active>
EAN 13, <iictives
Ell| L] I

]

[pofouits | [mefresh | [ ooy |
Symbolngies | Symbology Options | Beepel 4] ¥
New Tools Accounts [1] 1= E|A
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UPC/EAN

UPC/EAN are fixed-length, numeric, continuous symbologies that use
four element widths.

Action
Tap (+) to expand the UPC/EAN parameter, select the setting to be

changed, then select an option to change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.6.1

Options
UPCA 0 Not Active
1 Active (default)
UPCE 0 Not Active
1 Active (default)
EAN 8 0 Not Active
1 Active (default)
EAN 13 0 Not Active
1 Active (default)
Add-on digits 0 Not required (default)
1 Required
Add-on 2 digits 0 Not active (default)
1 Active
Add-on 5 digits 0 Not active (default)
(Not supported when us- 1 Active
ing an imager)
UPC A check digit 0 Not transmitted
1 Transmitted (default)
UPC E check digit 0 Not transmitted
1 Transmitted (default)
EAN 8 check digit 0 Not transmitted
1 Transmitted (default)
EAN 13 check digit 0 Not transmitted
1 Transmitted (default)
UPC A number system 0 Not transmitted
1 Transmitted (default)
UPC E number system 0 Not transmitted
1 Transmitted (default)
UPC A re-encoding 0 UPC A transmitted as UPC A
1 UPC A transmitted as EAN 13 (default)
UPC E re-encoding 0 UPC E transmitted as UPC E (default)
1 UPC E transmitted as UPC A
EAN 8 re-encoding 0 EAN 8 transmitted as EAN 8 (default)
1 EAN 8 transmitted as EAN 13
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Code 93
Code 93 is a variable length, continuous symbology that uses four element

widths.

Action
Tap the Code 93 parameter, then select an option to change this parame-
ter setting. Tap (+) to access the Code 93 Lengths parameter.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.7.1

Options
0 Not active (default)
1 Active

Code 93 Length
Sets the Code 93 bar code length.

Action

Tap (+) to expand the Code 93 parameter, then tap (+) to expand the
Code 93 Lengths parameter. Tap the setting to be changed, then tap an
option to change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.19.1

Options
Bar code length 0 Any length
1 Minimum length (default)
Minimum length 001-254 Minimum length 1-254 (default is 6)

Note: If Bar code length = “1” then Minimum length is entered.

st 4f 106 (D

Data Collection

$--C0de 33, Mok ackive >

. &-Code 93 length, <0008

; E---Bar cade l=ngth, =Any lengths

: - Minimum lerigkh, <&

#-Code 128, <Activex

] [ T

[mT T»

1]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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Code 128

Code 128 is a variable-length, continuous, high-density, alphanumeric
symbology that uses multiple element widths and supports the extended
ASCII character set.

Action
Tap the Code 128 parameter, then select an option to change this parame-
ter setting,.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.1.1.9.1

Options
0 Not active (default)
1 Active

47 |Settings st 4c100 D
Data Collection

$--C0de 128, <Actives

. ©-Code 128 options, <00000& >
" Code 128 FNCL character, < =
- Plessey, <000006 >

&ML, <000006>

] i ¥

D

A Tug

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[

This illustration is from a 700 Color Computer using a laser scanner.
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Code 128 Options

Set the following for the Code 128 parameter. Note that the EAN 128 ]C1
and CIP 128 French Pharmaceutical options are not available when you use
an imager with your 700 Color Computer.

Action
Tap (+) to expand the Code 128 Options parameter, select a setting, then
select an option to change this setting.

SNMP OID

None.

Options

EAN 128 ]C1 Identifier 0 Remove (default)

(Not supported when using an 1 Include

imager)

CIP 128 French Pharmaceutical 0 Not active (default)

(Not supported when using an 1 Active

imager)

Bar code length 0 Any length (default)
1 Minimum length

Minimum length 001-254 Minimum length 1-254 (default is 6)

Data Collection

$|--C0de 1258 options, <000006 =

. ~EAM 128 JC1 Identifier, <Remove ]
-CIP 128 French Pharmaceukizal, <
-Bar code length, <Any lengthz>

- Minimum lengkh, <6 =
[ |' [ [ [
Change 'Code 93" Setting

Mok ackive

O Active

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[

This illustration is from a 700 Color Computer using a laser scanner.
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Code 128 FNC1 Character

The Code 128 FNCI1 character (EAN 128 norms) can be any ASCII char-
acter and is used as a separator when multiple identifiers and their fields
are concatenated. Note that this is not available when you use an imager with
your 700 Color Computer.

Non-printable ASCII characters can be entered using the following syntax
where HH is the hexadecimal value of the character.

\ xHH

For example, the GS character, whose hexadecimal value is 1D, would be
entered as \x1D. In addition,the following characters have their own

identifiers:
e BEL \a
*BS b
e FF \f
e LF \n
e CR \r
 HT \t
e VI \v
Action

Tap (+) to expand the Code 128 parameter, then type the ASCII charac-
ters to be set for the Code 128 FNC1 character parameter.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.1.1.21.1

Options
Any ASCII character (default is the GS function character — ID hex)

gz

Data Collection

$--C0de 1258 options, <000006 =
B8 _ode 128 FNCL character, < =
H-Plessey, <000006 =

H-MS1, 000008

B-FDF 417, <hot ackive >

[l i [
Change 'Code 128 FHC1 characker' Setting —

D

A [

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[

700 Series Color Mobile Computer User’s Manual 303



Appendix A

304

— Configurable Settings

Plessey

Plessey is a pulse-width modulated symbology like most other bar codes. It
includes a start character, data characters, an eight-bit cyclic check digit,
and a termination bar. The code is continuous and not self-checking. You
need to configure two parameters for Plessey code: Start Code and Check
Digit. Note that this is not available when you use an imager with your 700
Color Computer.

Action

Tap (+) to expand the Plessey parameter, select the setting to be changed,
then select an option to change this setting or select an option from the
drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.10.1

Options
Decoding 0 Not active (default)
1 Active
Check digit 0 Not transmitted (default)
1 Transmitted
Bar code length 0 Any length
1 Minimum length (default)
Minimum length 001-254 Minimum length 1-254 (default is 6)

Note: If Bar code length = “1” then Minimum length is entered.

arcaz @

ecoding, <Mt active =

hieck digit, <Mat Eransmitked =
ar code length, <any length =
inimurn length, <6

] i [

A T

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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MSI

MSI is a symbology similar to Plessey code (page 304) that includes a start
pattern, data characters, one or two check digits, and a stop pattern. Noze
that this is not available when you use an imager with your 700 Color Com-
puter.

Action

Tap (+) to expand the MSI parameter, select the setting to be changed,
then select an option to change this setting or select an option from the
drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.15.1

Options
Decoding 0 Not active (default)
1 Active
Check digit 0 Mod 10 transmitted (default)
1 Mod 10 not transmitted
2 Double Mod 10 transmitted
3 Double Mod 10 not transmitted
Bar code length 0 Any length
1 Minimum length (default)
Minimum length 001-254 Minimum length 1-254 (default is 6)

% Note: If Bar code length = “1” then Minimum length is entered.

arce O

Data Collection

&-M5I, <0000083

ecoding, <Mt active =

heck digie, <Mad 10 kransrittad =
ar code length, <any length =
inimurn length, <6

] i ¥

D

A [

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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PDF417

PDF417 is a stacked two-dimensional symbology that provides the ability
to scan across rows of code. Each row consists of start/stop characters, row
identifiers, and symbol characters, which consist of four bars and four
spaces each and contain the actual data. This symbology uses error correc-
tion symbol characters appended at the end to recover loss of data.

Because the virtual wedge translates incoming data into keypad input, the
size of the keypad buffer limits the effective length of the label to 128
characters. Longer labels may be truncated. For PDF417 labels of more

than 128 characters, you can develop an application that bypasses the key-
pad buffer.

Action
Tap the PDF417 parameter, then select an option to change this parame-

ter setting. Tap (+) to access either the Macro PDF options parameter or
the Micro PDF417 parameter.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.1.1.17.1

Options
0 Not active
1 Active (default)

s @

D

: #-Macro PDF options, <000000000 =

| @-Micro PDF-417, <003

Eia--lnterlea\-'ed 2 of 5, <00000&000000000
&-Matrix 2 of 5, <010063

] I ¥
Change 'PDF 417" Setbing

Mok ackive

O Active

|Qefaults | | Refresh | | apply |

A [T

Symbalogies | Symbology Options | BeeperEE
B[

This illustration is from a 700 Color Computer using a laser scanner.

Macro PDF options

Macro PDF is used when a long message requires more than one PDF417
label. Note that this is not available when you use an imager with your 700
Color Computer.

* Select Buffered to store a multi-label PDF417 message in the Sabre
buffer, thus transmitting the entire message when all labels are read.
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* Select Unbuffered for multi-label PDF417 messages that are too long
for the Sabre buffer (memory overflow). Each part of the PDF417 label
is transmitted separately, and the host application must then assemble
the message using the macro PDF control header transmitted with each

label. Control Header is only present in macro PDF codes and is always

transmitted with unbuffered option.

Action

Tap (+) to expand the PDF417 parameter, tap (+) to expand the Macro

PDF parameter, select a setting to be changed, then select an option to

change this setting.

SNMP 0ID

1.3.6.1.4.1.1963.15.3.3.1.1.22.1

Options

Macro PDF
Control header
File name
Segment count
Time stamp
Sender
Addressee

File size

Checksum

— o = O —_ o =, O = O =OoO = O — o = O

Unbuffered
Buffered (default)

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

Not transmitted (default)
Transmitted

o 4¢11a06 @

Data Collection

E;l--Man:m FPDF aptions, 0000000002 i
- Macra PDF, <Unbuffered = |
- Contral header, <MNot transmitke d=
- File name, <Mat transmitted =

- Segment counk, <Mot transmithed 5|

4|: ] m

[

| Defaults | | Refresh |

| apply |

Symbologies | Symbology Options | Beepel »

E|“
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Micro PDF417

Micro PDF417 is a multi-row symbology derived from and closely based
on PDF417 (page 306). A limited set of symbology sizes is available, to-
gether with a fixed level of error correction for each symbology size. Noze
that this is not available when you use an imager with your 700 Color Com-
puter.

Action

Tap (+) to expand the PDF417 parameter, tap (+) to expand the Micro
PDF417 parameter, select a setting to be changed, then select an option to
change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.27.1

Options
Decoding

Not active (default)
Active

Code 128 Emulation Not active (default)

Active

— o = O

st 4c1ae

Data Collection

&-Micro PDF-417, <00

Decoding, <hok ackive:

i Code 128 Ervlation, <Mat ackive s
&#-Intetleaved 2 of 5, <000008000000000 =
H-Matrix 2 of 5, <01006=

] i [

D

A [T

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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Interleaved 2 of 5

Interleaved 2 of 5 (I 2 of 5) is a high-density, self-checking, continuous,
numeric symbology used mainly in inventory distribution and the automo-
bile industry.

% Note: An Interleaved 2 of 5 bar code label must be at least three characters
long for the 700 Color Computer to scan and decode correctly.

Action

Tap (+) to expand the Interleaved 2 of 5 parameter, select the setting to be
changed, then tap an option to change this setting or select an option from
the drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.23.1

Options
Decoding 0 Not active (default)

1 Active
Check digit 0 Not used (default)

1 Mod 10 transmitted

2 Mod 10 not transmitted

3 French CIP transmitted

4 French CIP not transmitted
Bar code length 0 Any length

1 Minimum length (default)

2 Fixed lengths
Minimum length 003-254 Minimum length 3-254 (default is 6)
Fixed length 1 003-254 Fixed bar code length 3-254 (default is 3)
Fixed length 2 003-254 Fixed bar code length 3-254 (default is 3)
Fixed length 3 003-254 Fixed bar code length 3-254 (default is 3)

% Note: If Bar code length = “1” then Minimum length is entered. If Bar
code length =“2” then Fixed length 1, Fixed length 2, or Fixed length 3 is

entered.

S gt O

Data Collection

$--Interleaved 2 of 5, <00100&000000000 =
. - Decoding, <Mk active >
Check digik, <Mat used=
Bar code length, «<Minimum kengthzs
Minirum length, <6
il i ¥
Change 'POF417' Setting

Mok ackive

@ Active

|Qefaults | | Refresh | | apply |

D

A [T

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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Matrix 2 of 5

Matrix 2 of 5 is a numerical symbology. Note that this is not available when
you use an imager with your 700 Color Computer.

Action

Tap (+) to expand the Matrix 2 of 5 parameter, select the setting to be
changed, then tap an option to change this setting or select an option from

the drop-down list.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.24.1
Options
Decoding 0 Not active (default)
1 Active
Bar code length 0 Any length
1 Minimum length (default)
Minimum length 001-254 Minimum length 1-254 (default is 6)

Note: If Bar code length = “1” then Minimum length is entered.

arqf1as D

Data Collection

&-Matrix 2 of 5, 01006

ecoding, <Mt active =

ar code length, <Minimur lengkh
- Minirmurn length, =6

Eg--TeIepen, =00=

D

=

A [T

] | i

|3

| Defaults | | Refresh |

| &pplhy |

Symbalogies | Symbology Options | BeeperEE

B[
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Telepen

Telepen is an alphanumeric, case-sensitive, full ASCII symbology. Noze
that this is not available when you use an imager with your 700 Color Com-
puter.

Action

Tap (+) to expand the Telepen parameter, select the setting to be changed,
then tap an option to change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.25.1

Options

Decoding 0 Not active (default)
1 Active

Format 0 ASCII (default)
1 Numeric

arc1sr

Data Collection

E?--Matrix 2of 5, <0006

D

zcoding, <Mak ackives
ormat, <ASCII>
#-Code 11, <Dil=

] i [

< [T

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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Code 11

Code 11 is a high density, discrete numeric symbology that is extensively
used in labeling telecommunications components and equipment. Noze
that this is not available when you use an imager with your 700 Color Com-
puter.

Action
Tap (+) to expand the Code 11 parameter, select the setting to be
changed, then tap an option to change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.26.1

Options

Decoding 0 Not active (default)
1 Active

Check digit verification 1 1 digit (defaul)
2 2 digits

Check digit transmit 0 Disable
1 Enable (default)

st 4c1se D

Data Collection

i b Formak, <A5C1=
E-Code 11, <011
Decading, <Mk actives=
- Check digit verification, <1 digit
. Check digit kransmit, <Enables
] i [

D

< [T

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
B[
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QR Code

QR Code (Quick Response Code) is a two-dimensional matrix symbology
containing dark and light square data modules. It has position detection
patterns on three of its four corners and features direct encodation of the
Japanese Kana-Kanji character set. It can encode up to 2509 numeric or
1520 alphanumeric characters and offers three levels of error detection.
Note that this is not available when you use a laser scanner with your 700 Col-
or Computer or if you are using a 730 Computer.

Action

Tap (+) to expand the QR Code parameter, select the setting to be
changed, then tap an option to change this setting or select an option from
the drop-down list.

SNMP OID

1.3.6.1.4.1.1963.15.3.3.1.1.35.1

Options

Decoding 0 Not active

1 Active (default)

& gcae O

Data Collection

& Interlsaved 2 of 5, <001008000000000
=

o Diecading, <ekive s

f-Data Matrix, <13

Eia--l'\'laxicode, <1=

[l i [

D

4[]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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Data Matrix

A two-dimensional matrix symbology, which is made of square modules
arranged within a perimeter finder pattern. The symbology utilizes Error
Checking and Correcting (ECC) algorithm with selectable levels for data
error recovery and Cyclic Redundancy Check algorithm to validate the
data. The character set includes either 128 characters conforming to ISO
646 (ANSI X3.4 - 1986) or 256 extended character set. Maximum capac-
ity of a symbol is 2335 alphanumeric characters, 1556 8-bit byte charac-
ters or 3116 numeric digits. Note that this is not available when you use a
laser scanner with your 700 Color Computer or if you are using a 730 Com-
puter.

Action
Tap (+) to expand the Data Matrix parameter, select the setting to be
changed, then tap an option to change this setting.

SNMP OID

1.3.6.1.4.1.1963.15.3.3.1.1.34.1

Options

Decoding 0 Not active

1 Active (default)

&g O

Data Collection

&R Code, <1>

. ' Decoding, <dctive s

EI aks Makrix, <1

- Decoding, <Active >

&-Maxicade, <1

[l [ T

D

[T

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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MaxiCode

MaxiCode is a fixed-size 2-D matrix symbology which is made up of offset
rows of hexagonal elements arranged around a unique circular finder pat-
tern. ASCII data is encoded in six-bit symbol characters. The symbol con-
tains 33 rows which are alternately 30 and 29 elements wide. There are
five different code sets. A single MaxiCode symbol can encode up to 93
characters of data. Note that this is not available when you use a laser scanner
with your 700 Color Computer or if you are using a 730 Computer.

Action
Tap (+) to expand the MaxiCode parameter, select the setting to be
changed, then tap an option to change this setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.1.1.33.1

Options

Decoding 0 Not active
1 Active (default)

Data Collection

| - Decoding, <dctives
&-Data Matrix, <1=
i zcoding, <fckive s
de, <l=
- Decoding, <Ackive =
] i [

D

<[]

|Qefaults | | Refresh | | apply |

Symbalogies | Symbology Options | BeeperEE
New Tools Accounts J5| E|‘
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Symbology Options

316

12 345

Data
Collection

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > the Data Collection icon to access its control panel

applet.

Use the right and left arrows to scroll to the Symbology Options tab, then
tap this tab to access its parameters. The following are parameters for bar
code symbology options. Note that these are listed in the order of their
appearance within the Symbology Options tab.

Symbology ID

Identifies the bar code symbology in which data is encoded by prepending
a user-specified symbology identifier to the data. You can prepend one of
these types of character strings to identify the symbology:

* User-defined ASCII Character (Option 1):
A user-defined symbology identifier is a single ASCII character. You can
assign a custom identifier character to each bar code symbology. Noze
that this is not available when you use an imager with your 700 Color
Computer.

* AIM ISO/IEC Standard (Option 2 — Required to define symbology IDs):
The AIM Standard has a three-character structure which indicates the
symbology and optional features. See the AIM ISO/IEC Standard for

information.

Action
Select Symbology ID, then select an option to change this parameter set-
ting. Tap (+) to expand the Symbology ID parameter, then select any of

the user ID parameters listed. See the top of the next page for a sample screen
of the Code 39 user ID.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.4.1.22.1

Options
0 Disable (default)

1 User defined (disabled when using an imager)
2 ISO/IEC Standard

£iF|settings & oz 1se (D

Data Collection

y 1D, lez
ode 39 user ID, <*=
ode 128 user ID, <D=
odabar user ID, <D=
ode 93 user ID, <D=
nterleaved 2 of 5 user ID, <I=

Chaﬁge ‘Symbology 10° Setting

[l

<

() Disable
() User defined
() 1S0JIEC Standard
| Defaulks | | Refresh | | Apply |
Symbologies | Symbology Options Beeperlz‘z
E|‘
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SNMP OID:
Options:

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:
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[iTe

Codabar user ID, <D
Code 93 user ID, <D=
5----Interleaved 2 of 5 user ID, <I=
Change 'Code 39 user ID' Setting

N |

]

|Qefaults | | Refresh | | apply |
Symbalogies | Symbology Options BeeperEE
B[

Code 39 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Code 39 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Code 39 user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.3.1

X where x is a single ASCII character. Default is asterisk (*).

Code 128 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Code 128 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Code 128 user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.5.1

X where x is a single ASCII character. Default is asterisk (*).

Codabar User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Codabar bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Codabar user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.2.1
x where x is a single ASCII character. Default is D.
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Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

318

Code 93 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Code 93 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Code 93 user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.4.1

X where x is a single ASCII character. Default is asterisk (*).

Interleaved 2 of 5 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Interleaved 2 of 5 bar code data. Note that this
is not available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Interleaved 2
of 5 user ID parameter, then enter a user ID value to change this parame-
ter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.10.1

X where x is a single ASCII character. Default is I (not lowercase L).

PDF417 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify PDF417 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the PDF417 user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.12.1

X where x is a single ASCII character. Default is an asterisk (*).

MSI User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify MSI bar code data. Noze that this is not avail-
able when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the MSI user ID
parameter, then enter a user ID value to change this parameter setting,.

1.3.6.1.4.1.1963.15.3.3.4.1.11.1
x where x is a single ASCII character. Default is D.
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Plessey User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Plessey bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Action: Tap (+) to expand the Symbology ID parameter, select the Plessey user
ID parameter, then enter a user ID value to change this parameter setting.

SNMP OID: 1.3.6.1.4.1.1963.15.3.3.4.1.13.1
Options: x where x is a single ASCII character. Default is D.

Standard 2 of 5 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Standard 2 of 5 bar code data. Note that this is
not available when you use an imager with your 700 Color Computer.

Action: Tap (+) to expand the Symbology ID parameter, select the Standard 2 of
5 user ID parameter, then enter a user ID value to change this parameter
setting.

SNMP OID: 1.3.6.1.4.1.1963.15.3.3.4.1.23.1
Options: x where x is a single ASCII character. Default is D.

UPCA User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify UPC-A (Universal Product Code) bar code
data. Note that this is not available when you use an imager with your 700
Color Computer.

Action: Tap (+) to expand the Symbology ID parameter, select the UPC A user
ID parameter, then enter a user ID value to change this parameter setting.

SNMP OID: 1.3.6.1.4.1.1963.15.3.3.4.1.6.1
Options: x where x is a single ASCII character. Default is A.

UPCE User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify UPC-E bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Action: Tap (+) to expand the Symbology ID parameter, select the UPC E user
ID parameter, then enter a user ID value to change this parameter setting.

SNMP OID: 1.3.6.1.4.1.1963.15.3.3.4.1.7.1

Options: x where x is a single ASCII character. Default is E.
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320

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

Action:

SNMP OID:
Options:

EAN 8 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify EAN-8 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the EAN 8 user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.8.1
x where x is a single ASCII character. Default is \xFF.

EAN 13 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify EAN-13 (European Article Numbering) bar
code data. Note that this is not available when you use an imager with your
700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the EAN 13 user

ID parameter, then enter a user ID value to change this parameter setting.
1.3.6.1.4.1.1963.15.3.3.4.1.9.1

x where x is a single ASCII character. Default is F.

Matrix 2 of 5 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Matrix 2 of 5 bar code data. Note that this is
not available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Matrix 2 of 5
user ID parameter, then enter a user ID value to change this parameter
setting.

1.3.6.1.4.1.1963.15.3.3.4.1.24.1
x where x is a single ASCII character. Default is D.

Telepen User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Telepen bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Tap (+) to expand the Symbology ID parameter, select the Telepen user
ID parameter, then enter a user ID value to change this parameter setting.

1.3.6.1.4.1.1963.15.3.3.4.1.25.1

X where x is a single ASCII character. Default is an asterisk (*).
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Code 11 User ID

If “1” was selected in the Symbology ID parameter, you can set your own
ASCII character to identify Code 11 bar code data. Note that this is not
available when you use an imager with your 700 Color Computer.

Action: Tap (+) to expand the Symbology ID parameter, select the Code 11 user
ID parameter, then enter a user ID value to change this parameter setting.

SNMP OID: 1.3.6.1.4.1.1963.15.3.3.4.1.16.1

Options: x where x is a single ASCII character. Default is asterisk (*).

700 Series Color Mobile Computer User’s Manual 321



Appendix A — Configurable Settings

Prefix
Prepends a string of up to 20 ASCII characters to all scanned data.

Action
Tap the Prefix parameter, then enter a prefix value to change this parame-
ter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.4.1.29.1

Options
Acceptable values are up to 20 ASCII characters. Embedded null
(«<NUL »>) characters are not allowed. Default is no characters (disabled).

S gtz O

Data Collection

- Symbology 10y <Disabls>
Fix, <=
L SuFfie, £

Change 'Prefix' Settbing

|Qefaults | | Refresh | | apply |
Symbalogies | Symbology Options BeeperEE
New Tools Accounts J5| E|‘
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Suffix
Appends a string of up to 20 ASCII characters to all scanned data.

Action
Tap the Suffix parameter, then enter a suffix value to change this parame-
ter setting,.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.4.1.30.1

Options
Acceptable values are up to 20 ASCII characters. Embedded null
(«<NUL »>) characters are not allowed. Default is no characters (disabled).

gtz O

Data Collection

o Symbology 10y <Disabls>
- Prefix, <=

Change 'suffix' Sektbing

|Qefaults | | Refresh | | apply |
Symbalogies | Symbology Options BeeperEE
New Tools Accounts J5| E|‘
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Beeper/LED

324

12 345

Data
Collection

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > the Data Collection icon to access its control panel

applet.

Use the right and left arrows to scroll to the Beeper/LED tab, then tap this
tab to access its parameters.

Most of these functions are not available when using an imager. The following
table shows which functions are supported either by an imager or by a
laser scanner.

Beeper Function Imager Laser Scanner
Beeper X
Beeper Volume

Beeper Frequency

Good Read Beeps

Good Read Beep Duration

X)) X

The following are parameters for features on the 700 Color Computer.
Note that these are listed in the order of their appearance.
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Beeper

Sets the volume for the good read beep. Note that this is not available when

you use a laser scanner with your 700 Color Computer.

Action

Tap the Beeper parameter, then select an option to change this parameter

setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.1.4.1.6.1

Options
1 Beeper (default)
4 Vibrate (not supported on 730 Computers)

fF | Settings t qc1z20 D & Az 1215 @

Data Collection

----- Eeeper, <Beeper s

Change 'Beeper' Seking —8 hange 'Beeper’ Setting
Eeeper
P |Beeper vl
O vibrate
|Qefaults | | Refresh | | apply | |Qefaults | | Refresh | | apply |

Symbology Options | Beeper/LED | ImagerEE Symbology Options | Beeper/LED | Yirtual 'EE

E|A New Tools Accounts J5| E|‘

700 Color with Imager Screen 730 Screen
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()

Sounds &
Motifications

Beeper Volume

Sets the volume for the good read beep. Note that this is not available when

Action

parameter setting.

you use an imager with your 700 Color Computer.

Tap the Beeper volume parameter, then select an option to change this

SNMP OID
1.3.6.1.4.1.1963.15.3.1.4.1.6.1
Options

0 Low

1 High (default)

2 Medium

3 Off

4 Vibrate

atqc1z04 D

Data Collection

eeper Freguency, <2090
- Gond read beeps, <1
" Good read beep duration, =20

Change 'Beeper volume' Setking

|High vl

Igefaultsl | Refresh | | apply |

Symbology Options | Beeper/LED \n'irtuaI'EE

B[

Disabling the Volume

To disable the beeper, tap Start > Settings > the Personal tab > Sounds &
Notifications > the Volume tab, drag the System volume slider bar to the
left “Silent” position, then tap ok to exit this applet. See Chapter 1,
“Introduction” for more information.
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Beeper Frequency
Sets the frequency for the good read beep. Note that this is not available
when you use an imager with your 700 Color Computer.

Action
Tap the Beeper frequency parameter, then enter a frequency value to
change this parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.1.4.1.7.1

Options
1000—-4095 (default is 2090)

g 1z08 D

Data Collection

- Beeper volums, <High=
per Frequenc

i Gond read beeps,

.. zood read beep duration, <80=

Change 'Beeper frequency’ Setting

[2090 |
Igefaultsl | Refresh | | apply |
Symbology Options | Beeper/LED | Wirtual 'EII

B[
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Good Read Beeps

Sets the number of good read beeps. Note that this is not available when you
use an imager with your 700 Color Computer.

Action

Tap the Good read beeps parameter, then select an option to change this

parameter setting.

SNMP OID

1.3.6.1.4.1.1963.15.3.1.4.1.8.1

Options

0  No beeps

1 One beep (defaulr)
2 Two beeps

at 4c1206 D

Data Collection

-~ Besper valume, =High=
- Besper frequency, <2090
d read beeps, <1
Good read besp duration, <80=

Change 'Good read beeps' Setting
u]
w1
ez

Igefaultsl | Refresh | | apply |

Symbology Options | Beeper/LED \n'irtuaI'EE

B[
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Good Read Beep Duration
Sets the duration of the good read beep. Note that this is not available when
you use an imager with your 700 Color Computer.

Action
Tap the Good read beep duration parameter, then enter a duration value
to change this parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.1.4.1.9.1

Options
0-2550  Beep duration in milliseconds. (default is 80)

g 1z07 D

Data Collection

-~ Besper volume, <High=

- Beeper frequency, <2090
Good read beeps, <1=

B -0 read beep duration, <80:=

hange 'Good read beep duration' Setting —

20 |
Igefaultsl | Refresh | | apply |
Symbology Options | Beeper/LED | Yirtual 'EII

B[
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54
Iy

12 345

Data
Collection

Note: These instructions do 7oz apply to the 730 Computer.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Data Collection to access its control panel applet.

Use the right and left arrows to scroll to the Imager tab, then tap this tab
to access its parameters.

The following are parameters for the imager. Note that these are listed in
the order of their appearance within the Imager tab.

Aimer LED Duration

The Aimer LED Duration controls the time the Aimer LED is turned on
when the scan button is pressed. After this time, images are captured for
decoding. The purpose is to position the Aimer LED on the bar code sym-
bol before attempting to decode the bar code. Note that this is not available
when you use a laser scanner with your 700 Color Computer.

Action

Tap the Aimer LED Duration parameter, then enter a value to change this
setting. Note that values must be in 50 ms increments, such as 500, 650,
or 32500. Values not entered in 50 ms increments are rounded down. For
example, 2489 ms is rounded down to 2450 ms, 149 ms is rounded down
to 100 ms, etc..

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.3.1.1.21.1

Options
0-65500 ms (Default is 0)

& qc1ze D

Data Collection

- Sicky Aimer Duration - msecs, <1000:=
Eia--lrnage Dirmension, <000639000479 =
Lighting Made, <LED Priority:

10 OmniDir Decode Enable, <hat Avalables
[H| ] D
Change 'Aimer LED Durakion - msecs' Sekking —

B |

|Qefaults | | Refresh | | apply |

Beeper/LED | Imager | irtual Wedge | EII
New Tools Accounts J5| E|‘
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Sticky Aimer Duration

The Sticky Aimer Duration controls the time the Aimer LED stays on af-
ter the a bar code read completes or after the trigger button is released.
Note that this is not available when you use a laser scanner with your 700 Col-
or Computer.

Action

Tap the Sticky Aimer Duration parameter, then enter a value to change
this setting. Note that values must be in 50 ms increments, such as 500,
650, or 32500. Values not entered in 50 ms increments are rounded
down. For example, 2489 ms is rounded down to 2450 ms, 149 ms is
rounded down to 100 ms, etc..

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.3.1.1.24.1

Options
0-65535 ms (Default is 1000)

- Lighting Mode, =LED Prioricy >
1D OmniDir Decode Enable, <Mat dvailable=

[H| ] D
Change 'sticky Aimer Duration - msecs' Setting

|1uuu |

|Qefaults | | Refresh | | apply |

Beeper/LED | Imager | irtual Wedge | EII
New Tools Accounts J5| E|‘
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Image Dimension

The image dimensions control the vertical size of the image for decoding.
This can restrict the image to one bar code when otherwise, there might be
more than one bar code in the image to be decoded. Note that this is not
available when you use a laser scanner with your 700 Color Computer.

Action

Tap the Image dimension parameter, select the position to be changed,
then tap an option or enter a value to change this position.

SNMP OID
1.3.6.1.4.1.1963.15.3.3.3.1.1.22.1

Options

Left position 0 Not supported

Right position 0 Not supported

Top position 0-478 Position in pixels (Default is 0)
Bottom position 0-479 Position in pixels (Default is 479)

TEEED

¢ - Bothom position, <479=
[l i [T

|Qefaults | | Refresh | | apply |

Beeper/LED | Imager | irtual Wedge | EII
New Tools Accounts J5| E|‘
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Lighting Mode

The Lighting Mode sets the lighting mode of the imager. When set to
“LED Priority,” the imager depends more on ambient lighting to illumi-
nate the bar code for reading. When set to “Aperture Priority,” the imager
uses its built-in LED to illuminate the bar code for reading. Note that this
is not available when you use a laser scanner with your 700 Color Computer.

Action
Tap the Lighting Mode parameter, then select an option to change this
parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.3.1.1.23.1

Options
0 LED Priority (default)
1 Aperture Priority

| cettings S gt O

Data Collection

5"'."—\imar LED Dwration - msecs, <0=
- Skicky Aimer Duration - msecs, <1000=
Eia--lrnage Dirmension, <000639000479 =
% inhting Made, <LED Priority>
10 OmniDir Decode Enable, <hat Availables
[H| ] D
hange 'Lighting Mode' Setting

() LED Priarity

O Aperture Priority

|Qefaults | | Refresh | | apply |

Beeper/LED | Imager | irtual Wedge | EII
New Tools Accounts J5| E|‘
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1D OmniDir Decode Enable

The 1D OmniDir Decode Enable affects the scanning abilities of the
IT4000 Imager. With 1D omni directional enabled, the imager is able to
decode images and bar code labels regardless of the orientation of the label.
With 1D omni directional disabled, the imager only decodes labels in the
direction of the aimer LED. Note that this is not available when you use a
laser scanner with your 700 Color Computer.

Action
Tap the 1D OmniDir Decode Enable parameter,then select an option to
change this parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.3.3.1.1.25.1

Options
0 Disabled
1 Enabled (default)

S gt O

Data Collection

o Aimet LED Duration - msecs, <0z

- Skicky Aimer Duration - msecs, <1000
Eia--lrnage Dirmension, 0006390004792
Lighting Made, <LED Priority:>

B 10 OrmniDir Decode Enable, <hot é&valables
] i I

|Qefaults | | Refresh | | apply |

Beeper/LED | Imager | irtual Wedge | EII
New Tools Accounts J5| E|‘
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Virtual Wedge

12 345

cuﬁ::;un Use the right and left arrows to scroll to the Virtual Wedge tab, then tap

this tab to access its parameters.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Data Collection to access its control panel applet.

The following are parameters for the virtual wedge scanner. Note that these
are listed in the order of their appearance within the Virtual Wedge tab.

Virtual Wedge

Enables or disables the virtual wedge for the internal scanner. The virtual
wedge retrieves scanned Automatic Data Collection (ADC) data and sends
it to the keypad driver so that the 700 Color Computer can receive and
interpret the data as keypad input.

Because the virtual wedge translates incoming data into keypad input, the
size of the keypad buffer limits the effective length of the label to 128
characters. Longer labels may be truncated. For labels of more than 128

characters, you need to develop an application that bypasses the keypad
buffer.

Action
Tap the Virtual Wedge parameter, then tap an option to change this pa-
rameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.2.1.1.2.1

Options
0 Disable
1 Enable (default)

&gz O

Data Collection

Preamble, <=
E---Postarnble, k=
LG, <>

‘. Code page, <1252

Change 'virtual wedge' Setking
Dizable

@ Enable
|Qefaults | | Refresh | | apply |
Beeper/LED | Imager | virtual Wedge EII
New Tools Accounts J5| E|‘
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Preamble

Sets the preamble that precedes any data you scan with the 700 Color
Computer. Common preambles include a data location number or an op-
erator number.

Action
Tap the Preamble parameter, then enter a preamble value to change this
parameter setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.2.1.1.3.1

Syntax

ADdat a

where data is any acceptable values up to 31 ASCII characters. Embedded
null («<NUL >) characters are not allowed. Below are the non-printing
characters you can use for Virtual Wedge Preambles. Defaulr is blank.

\a Alert (bell)

\b Backspace

\f Form Feed

\n New line/line feed
\r Carriage return

\t Horizontal tab

\v Vertical tab

\xnnnn  znnn is up to four HEX digits. Use leading zeros to fill out to four digits to
ensure proper conversion. For example, to prepend the character M to
scanned data, set the Preamble to either 1) M, or 2) x004D, where 4D is the
HEX equivalent for an uppercase M.

& g0 D

Data Collection

Virtual wedae, <Enablez:=

é---Postarnble, k=
~Grd, ==
“Code page, 12525

hange 'Preamble’ Setting

|Qefaults | | Refresh | | apply |
Beeper/LED | Imager | virtual Wedge EII
New Tools Accounts J5| E|‘
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% Note: When you enter the AD command without data, the preamble is
disabled. If you want to use quotation marks or the following combina-

tions of characters as part of the appended data, separate those characters
from the AD command with quotes. If you do not use quotes as described
here, the 700 Color Computer interprets the characters as another config-
uration command:
AD
AE
AF
KC
BV
EX
DF

Example

To use the two-character string BV as a preamble, scan this command (as a
Code 39 label) or send this command through the network: $+AD" BV”
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Postamble

Sets the postamble that is appended to any data you scan with the 700
Color Computer. Common postambles include cursor controls, such as
tabs or carriage return line feeds.

Action

Tap the Postamble parameter, then enter a postamble value to change this
parameter setting.

SNMP OID
1.3.6.1.4.1.1963.15.3.2.1.1.4.1

Syntax
AEdat a

where data is any acceptable values up to 31 ASCII characters. Embedded
null («<NUL >) characters are not allowed. Below are the non-printing
characters you can use for Virtual Wedge Postambles:

\a
\b
\f
\n
\r
\t
\v

\xnnnn

Alert (bell)

Backspace

Form Feed

New line/line feed
Carriage return
Horizontal tab (default)
Vertical tab

nnnn is up to four HEX digits. Use leading zeros to fill out to four digits to
ensure proper conversion. For example, to prepend the character M to
scanned data, set the Preamble to either 1) M, or 2) x004D, where 4D is the
HEX equivalent for an uppercase M.

St O

Data Collection

G, <>

- Yirtual wedge, =Enabls =
- Preamble, <=

‘. Code page, <1252

Change 'Pastamble’ Setting

C

| Defaults |

| Refresh | | apply |

Beeper/LED | Imager | virtual Wedge EII

Mew Tools Accounts .@. E|‘
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% Note: When you enter the AE command without data, the postamble is
disabled. If you want to use quotation marks or the following combina-

tions of characters as part of the appended data, separate those characters
from the AE command with quotes. If you do not use quotes as described
here, the 700 Color Computer interprets the characters as another config-
uration command.
AD
AE
AF
KC
BV
EX
DF

Example

To use the two-character string BV as a postamble, scan this command (as
a Code 39 label) or send this command through the network: $+AE* BV’
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Grid

Sets the virtual wedge grid, which filters the data coming from this 700
Color Computer. The data server supports data filtering, which allows you
to selectively send scanned data. The virtual wedge grid is similar to the
“format” argument of the C Runtime Library scan function.

Action
Tap the Grid parameter, then enter a grid value to change this parameter
setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.2.1.1.5.1

Syntax
AF<sym D> filter-expression= > editing-expression
where:

o <symID>

The AIM symbology ID (optional).

* filter-expression
Any character string that includes valid filter expression values. Go to

the SDK User’s Manual provided with your Windows CE/PocketPC SDK

for a list of valid filter expression values.

* editing-expression
Any character string that includes valid editing expression values. Go to
the SDK User’s Manual provided with your Windows CE/PocketPC SDK

for a list of valid editing expression values.

St O

Data Collection

o Mirtual wedge, <Enable>
- Preamble, <>
'--Postarnble, k=

id, «>

“Code page, <1252

Change 'arid' Setting

|Qefaults | | Refresh | | apply |
Beeper/LED | Imager | virtual Wedge EII
New Tools Accounts J5| E|‘
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Code Page
Sets the virtual wedge code page. The code page controls the translation
from the character set of the raw collected data to Unicode, which is the

character set expected by Windows CE applications. The default code page
is 1252, which is the Windows Latin 1 (ANSI) character set.

Action
Tap the Code Page parameter, then select an option to change this param-
eter setting.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.2.1.1.6.1

Options
The only acceptable value for the code page parameter is “7252,” which is
the default.

&gtz D

Data Collection

- Yirtual wedge, =Enabls =
- Preamble, <>

Change 'Code page' Setting

[1252 -]
|Qefaults | | Refresh | | apply |
Beeper/LED | Imager | virtual Wedge EII
New Tools Accounts J5| E|‘
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Intermec Settings Control Panel Applet

You may have the Intermec Settings control panel applet. Information
about the settings you can configure with this applet is described in the
Intermec Computer Command Reference Manual. The online manual is
available from the Intermec web site at www.intermec.com.

See “Scanner Control and Data Transfer” in the Intermec Windows CE/
Pocket PC Software Developer’s Kit (SDK) User’s Manual shipped with the

Software Developer’s Kit (SDK) for information about data collection
functions.

E‘ To access the settings from the 700 Color Computer, tap Start > Settings

> the System tab > Intermec Settings to access its control panel applet.
Intermec
Settings
.}:j' Intermec Settings < 45 521 €3
Scanners, Symbologies
202.11 Radio
UDP Plus
700 Settings
Applications

File Edit Yiew Help| [l B[
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SNMP Control Panel Applet

% Note: This applet is not available in units with PSM Build 3.00 or newer.
To determine your PSM build version, tap Start > Programs >
File Explorer > the PSMinfo text file.

C‘ If your unit has PSM Build 3.00 or newer, then you may have the Intermec
Settings control panel applet in place of the SNMP applet. Information
Intermec about the settings you can configure with the Intermec Settings applet is
Settings  Jescribed in the Intermec Computer Command Reference Manual. The
online manual is available from the Intermec web site at
www.intermec.com.

Simple Network Management Protocol (SNMP) parameters include iden-
tification information, security encryption, security community strings,
and traps.

@\ To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > SNMP to access its control panel applet.
SMMP

Tap a tab to access its menus. These tabs represent three groups of settings
or parameters:

* Security (starting on the next page)

* Traps (starting on page 349)

* Identification (starting on page 351)
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8

SHMP

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > SNMP > the Security tab to access its parameters.

The following are parameters that affect encryption and community
strings. Note that these are listed in the order of their appearance within the
Security tab.

Read Only Community
Sets the read-only community string for this 700 Color Computer, which
is required for processing of SNMP get and get next requests.

Action
Tap the Read Only Community parameter, then enter a community
string to change this parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.10.5.1.2.0

Options
The read-only community string can be up to 128 ASCII characters. De-
fault is Public.

Read\Write Community, <privates=
Read Emcryption, OfF=

Wite Encryption, <Off>
Encryplion Key, <>

Change 'Read Only Community’ Setting

|pub|i-: |

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Read/Write Community

Sets the read/write community string, which is required for processing of
SNMP set requests by this 700 Color Computer. An SNMP packet with
this name as the community string will also process SNMP get and next
requests.

Action
Tap the Read/Write Community parameter, then enter a community
string to change this parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.10.5.1.3.0

Options
The read/write community string can be up to 128 ASCII characters. De-
fault is Private.

&g a0 D

Read Only Community, <public=
(o8 = ormmunity, <privates
Read Emcryption, OfF=
Wite Encryption, <Off>
Encryplion Key, <>

hange 'Read)Wwrike Cormmunity' Setking

|private |

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Read Encryption

Sets the packet-level mode of security for SNMP read-only requests. If you
enable read encryption, all received SNMP get and get next packets have
to be encrypted or the packet will not be authorized. If encryption is en-
abled, you can only use software provided by Intermec Technologies.

Note: To enable security encryption, you also need to set the Security En-

cryption Key (page 348).

Action
Tap the Read Encryption parameter, then select an option to change this
parameter setting.

SNMP OID
1.3.6.1.4.1.1963.10.5.1.4.0

Options
1 On SNMP get and get next packets must be encrypted
2 Off SNMP packets do not have to be encrypted (default)

Change 'Read Encrvption’ Setting
on

() Off

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Write Encryption

Sets the packet-level mode of security for SNMP read/write requests. If
you enable write encryption, all SNMP packets that are received with the
read/write community string have to be encrypted or the packet will not
be authorized. You need to use software from Intermec Technologies that
supports encryption.

% Note: To enable security encryption, you also need to set the Security En-
cryption Key (page 348).

Action
Tap the Write Encryption parameter, then select an option to change this
parameter setting.

SNMP OID
1.3.6.1.4.1.1963.10.5.1.5.0

Options
1 On SNMP packets must be encrypted
2 Off SNMP packets do not have to be encrypted (default)

& gcus O

Read Only Community, <public=

- FeadWrite Community, <privates
i Read Emcryptian, <Off=
be Encryption, =OFf>
Encryplion Key, <>

Change "Wwrite Encryption' Setking
on

() Off

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Encryption Key

Identifies the key that this 700 Color Computer uses to encrypt or deci-
pher SNMP packets. Encryption is used only by software provided by In-
termec Technologies. If encryption is enabled, SNMP management plat-
forms will not be able to communicate with the 700 Color Computer.
The encryption key is returned encrypted.

Action
Tap the Encryption Key parameter, then enter a security encryption key
value to change this parameter setting.

Note: You also need to set either Read Encryption (page 346) or Write
Encryption (page 347) or both.

SNMP OID
1.3.6.1.4.1.1963.10.5.1.6.0

Options
The encryption key can be from 4 to 20 ASCII characters. Default is
NULL.

& qcusz O

Read Only Community, <public=
-~ Read/\rite Community, <private=
Read Emcryption, OfF=

Wite Encryption, <Off>

: Encryplion Key, <>

Change 'Encryphion Key' Setting

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Traps

@\ To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > SNMP > the Traps tab to access its parameters.

SNMP . o
The following are authentication and threshold parameters for traps. Noze

that these are listed in the order of their appearance within the Traps tab.

Authentication

Determines whether to send authentication traps. When trap authentica-
tion is enabled, an authentication trap is sent if an SNMP packet is re-
ceived by the master agent with an invalid community string.

Action
Tap the Authentication parameter, then select an option to change this
parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.10.5.2.2.0

Options
1 On (default)
2 Off

& qcusz O

Change 'Authentication' Setting
on

() Off

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Threshold

Determines the maximum number of traps per second that the master
agent generates. If the threshold is reached, the trap will not be sent.

Action
Tap the Threshold parameter, then enter a threshold value to change this
parameter setting.

SNMP 0ID
1.3.6.1.4.1.1963.10.5.2.3.0

Options
Any positive integer value. Default is 10.

& qcusr O

Change 'Threshold' Setting
10 |

|Qefaults | | Refresh | | apply |

Security | Traps | Identification |

B[
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Identification

@\ To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > SNMP > the Identification tab to access its
SNMP parameters.

The following are parameters for contact, location, and name information
for support purposes. Note that these are listed in the order of their appear-
ance within the Identification tab.

Contact

Sets the contact information for the person responsible for this 700 Color
Computer.

Action
Tap the Contact parameter, then enter the name of your contact represen-
tative to change this parameter setting.

SNMP 0ID
1.3.6.1.2.1.1.4.0

Options
The identification contact may be up to 255 ASCII characters. Default is
no characters or blank.

- Mame, =Pocket_PC>
‘o Location, <Add & lacatian F applicable =

hange 'Contact' Setting

|Add an administrator here |

|Qefaults | | Refresh | | apply |
Security | Traps | Identification
B[
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Name
Sets the assigned name for this 700 Color Computer.

Action
Tap the Name parameter, then enter the name of your 700 Color Com-
puter to change this parameter setting.

SNMP OID
1.3.6.1.2.1.1.5.0

Options
The identification name may be up to 255 ASCII characters. Default is no
characters or blank.

ame, <Packet PC
cation, <

Change 'Mame' Setting

[Packet_PC |
|Qefaults | | Refresh | | apply |
Security | Traps | Identification

B[
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Location
Sets the identification location for this 700 Color Computer, such as
“Shipping.”

Action
Tap the Location parameter, then enter the location of where your 700
Color Computer to change this parameter setting.

SNMP 0ID
1.3.6.1.2.1.1.6.0

Options
The identification location may be up to 255 ASCII characters. Default is
no characters or blank.

& g5 D

o Caonkact, =dd an administrator hers=
Marne, =Pocket PO
(| ocation, <Add & loeation iF applicable =

Change 'Location' Setting

|Add a location iF applicable |

|Qefaults | | Refresh | | apply |
Security | Traps | Identification
B[
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Unit Information Control Panel Applet

54
@

Intermec
Settings

o

Unit
Information

Versions

o

Unit
Information

354

Note: This applet is not available in units with PSM Build 3.00 or newer.
To determine your PSM build version, tap Start > Programs >
File Explorer > the PSMinfo text file.

If your unit has PSM Build 3.00 or newer, then you may have the Intermec
Settings control panel applet in place of the Unit Information applet.
Information about the settings you can configure with the Intermec
Settings applet is described in the Intermec Computer Command Reference
Manual. The online manual is available from the Intermec web site at
Wwww.intermec.com.

Unit Information is a read-only control panel applet that provides infor-
mation about your 700 Color Computer, such as software version builds,
available CAB files, and the internal battery status.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Unit Information to access its control panel applet.

Tap a tab to access its menus. These tabs represent three groups of settings
Or parameters:

* Versions (next paragraph)
* Battery Status (starting on page 355)
» CAB Files (starting on page 356)

You can view the latest software build version on your 700 Color
Computer by accessing the Unit Information control panel applet.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Unit Information > the Versions tab to view the latest
software build version. Tap ok to exit this information.

P it 4123 O

. DataCallection Build, <ssaravimg3 123=

| Defaults | | Refresh | | apply | | Defaults | | Refresh | | apply |
Wersions | Battery Status | CaE Files | Wersions | CAE Files | Battery Status |
B[ B[
700 Color Screen 730 Screen
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Battery Status

You can view the battery status for your 700 Color Computer by accessing
the Unit Information control panel applet.

0 To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Unit Information > the Battery Status tab to view the

Unit current status. Tap ok to exit this information.

Information

arc1za O

|Qefaults | | Refresh | | apply |

Wersions | Battery Status | CAE Filesl
B[

700 Series Color Mobile Computer User’s Manual 355



Appendix A — Configurable Settings

CAB Files

356

o

Unit
Information

You can view the latest developer or released version of each CAB file from
Intermec Technologies Corporation that are installed in your 700 Color
Computer via the Unit Information control panel applet. Custom CAB
[files are not displayed in this applet. See the Software Tools User’s Manual for
more information about these files.

To access the information from the 700 Color Computer, tap Start >
Settings > the System tab > Unit Information > the CAB Files tab to view
the current CAB file versions. Tap ok to exit this information.

&g s O

| Defaults | | Refresh | | apply |
Wersions | Battery Status | CiE Files |
B[

When a CAB file is built, a registry entry is created with a build number
for that file. This CAB Files control panel applet looks for a registry key
for each CAB file installed. When the registry entry is found, the CAB file
name and version number information are displayed. If a CAB file has not
been installed, then its information is not displayed.

Below is a list of CAB files from Intermec Technologies that are available
for your 700 Color Computer with their latest developer or released ver-
sion of the software build. Should you need to add any of these to your
700 Color Computer, contact an Intermec representative.

* BtMainStack:
Installation of the Main Bluetooth Stack is handled automatically as part
of the operating system boot-up procedure. See Chapter 4, “Network
Support,” for more information about Bluetooth wireless printing.

* Comm Port Wedge:
The software build for the Comm Port Wedge. Note that the Comm Port
Wedge CAB file is available on the Intermec Developer’s Library CD.

e NPCPTest:
This installs a Norand® Portable Communications Protocol (NPCP)
Printing test application which will print to an Intermec® 4815, 4820,
or 6820 Printer. See Chapter 5, “Printer Support,” for more information.
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* S9C Upgrade:
Installs the files needed to upgrade the S9C scanner firmware. See the
700 Color Management Tools portion of the Intermec Developer’s Library
CD for more information about upgrading the firmware.

e SDK:
Installs the Intermec Software Developer’s Kit (SDK). See the SDK
User’s Manual for more information.

* WinCfg:
Configures the NRINET.INI file, launches the NRINet client, and
loads and unloads the LAN and WLAN device drivers.

* Wireless Printing Sample:
Installs a sample application that developers can use for reference when
they are developing their own Wireless Printing applications. The
source code for this application is included as part of the Wireless Print-
ing SDK on the Intermec Developer’s Library CD. See the SDK User’s
Manual for more information.

¢ ActiveX Control Tools:
This lists some of the CAB files that may be available with which to
install ActiveX Control Tools. See the SDK Online Help for more infor-

mation.

¢ AXCommunication:
Communication controls that transmit or receive messages from in-
put connections.

e AXFileTransfer:
File transfer controls that transmit and receive files using the Trivial

File Transfer Protocol (TFTP).
¢ AXReaderCommand:

Reader command functions that modify and retrieve configuration
information from your 700 Color Computer.

* AXVWedge:
The virtual wedge control that retrieves scanned ADC data and sends
it to the keyboard driver to interpret data as keyboard input.
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Utilities Control Panel Applet

Dock Switch

358

Fig

Utilities

Fig

Utilities

The Utilities control panel applet examines and modifies settings and op-
erational modes of specific hardware and software on the 700 Color Com-
puter, including the dock switch, registry storage, wakeup mask, and ap-
plication launch keys.

To access the settings from the 700 Color Computer, tap Start > Settings
> the System tab > Utilities to access its control panel applet.

Use the left and right arrows to scroll through the tabs along the bottom of
the control panel applet, then tap a tab to access its menus. These tabs rep-
resent the following groups of settings or parameters:

* Dock Switch (next paragraph)
* Registry Save (page 359)

* Wakeup Mask (page 360)

* App Launch (page 361)

From the 700 Color Computer, tap Start > Settings > the System tab >
Utilities > the Dock Switch tab to access the Dock Switch control panel
applet.

Use this applet to control the position of the dock switch. This can be set
either to a COM A (phone jack for a modem) position or to a COM B
(serial) position.

If switched to COM B and suspended, the terminal has the following be-
havior:

e If the 700 Color Computer is on charge, the dock switch remains
switched to COM B.

e If the 700 Color Computer is off charge, the dock switch switches to
COM A and remain in this position until the 700 Color Computer re-
sumes charge.

&gz D

Utilities

Yau can swikch 3 dock betweaen COM A
{a phore jack for a modem) and COMB

Select
@ Swikch o COM & (MODEM)
() Switch to COM B (SERIAL)

Dock, Switch | Registry Save | akeup MaEII
=]

700 Series Color Mobile Computer User’s Manual



Registry Save

Fig
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From the 700 Color Computer, tap Start > Settings > the System tab >
Utilities > the Registry Save tab to access the Registry Save control panel

applet.

For Windows Mobile 2003, the only medium available for saving the reg-

istry is the Flash File System (PSM). Registry data is stored in the

“\Flash_File_Store\Registry” path. Check Enable Registry Storage to en-

able this function.

To ensure that the 700 Color Computer restores the real-time clock after a
cold-boot, check the Enable RT'C Restore option. Note that this does not

apply to the 730 Computer.

& gcz0e O

Utilities

&g O

Utilities

Reqiskry ssttings can be saved betweaen cold
baoats, The rediskry is saved during devics
resets or when applications use the
RegFlushkey function.

Enable Registry Starage

If enabled, the real time clack
can be restored on a cold book

Enable RTC Restare

Reqiskry ssttings can be saved betweaen cold
baoats, The rediskry is saved during devics
resets or when applications use the
RegFlushkey function.

Enable Registry Starage

Dock Switch | Registry Save | akeup MaEII

Dock Switch | Registry Save | akeup MaEII

B[

B[

700 Color Screen
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Wakeup Mask

Fig

Utilities

From the 700 Color Computer, tap Start > Settings > the System tab >
Utilities > the Wakeup Mask tab to access the Wakeup Mask control pan-
el applet.

This applet programs three scanner buttons and the Al and A2 application
keys to be “wakeup” or resume keys. That is, to prompt the 700 Color
Computer to “wake up” or resume activity after going to “sleep” as a result
of being inactive after a length of time. This information will remain be-
tween warm and cold boots.

Check the appropriate box, then tap ok to apply your settings.

& g z06 D

Utilities

Yaou can enable wakeup Fram cartain keys,
Check the keys vou want programmed as
wakeup kevs.,

|:| Middle Scanner Button
|:| Left Scanner Button

Right Scanner Buttan
GOLD + A1 (application 1)
GOLD + A2 (ppplication 2)

Reqistry Save | Wwakeup Mask | App LauncEE

B[

Based on your setting, do the following to “wake up” the 700 Color Com-
puter.

If you select:

Middle Scanner Button

Left Scanner Button

Right Scanner Button
GOLD + Al (Application 1)
GOLD + A2 (Application 2)

Then do this on Then do this on
Numeric Keyboard Alphanumeric Keyboard

Squeeze the button on the Scan Handle ~ Squeeze the button on the Scan Handle

Squeeze the left scanner button Squeeze the left scanner button
Squeeze the right scanner button Squeeze the right scanner button
Press [Gold] © Press [Gold/White] @
Press [Gold] © Press [Gold/White] @29 (Ba2)
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App Launch

W From the 700 Color Computer, tap Start > Settings > the System tab >
Utilities , then scroll to the right to tap the App Launch tab to access the
utilities  Application Launch control panel applet.

This applet programs or maps two scanner buttons and four application
keys to start up to six applications. Note that the left scanner button also acts
as the record button.

For 700 Color Computers with either a laser scanner or an imager,
default mappings are shown in the following illustration.

& g0 O
Utilities
r Butkans Applications —

Set default walues for -
P Defaults

application launch buttons _

akeup Mask | App Launch EII

B[

For 700 Color Computers without either a laser scanner or an imager,

the default maps the Record, Calendar, Contacts, and Tasks applications
the top four and the A3 and A4 buttons are “unassigned” or available for
two more applications.

% Note: Record, Calendar, Contacts, and Tasks are Pocket PC applications.
See Chapter 2, “Windows Mobile 2003,” for more information about these
applications.

* To assign an application to a button, select an application from the ap-
plicable drop-down list box.

* To assign a new application, select the “Add new application” option,
which brings up an Open File dialog and browse SD or CF storage
cards for new applications.

* To disable or unmap a currently mapped application from a correspon-
ding button, select “unassigned” from the applicable drop-down list.

* To restore these buttons to their defaults, tap Defaults in the lower
right corner.
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% Note; You cannot map an application to more than one button. Should
you assign the same application to two buttons, a verification prompt will
appear after the second button to confirm whether you want to remap the
application. If you tap Yes, the applet changes the first button to “unas-
signed” and map the application to the second button.

% Note: All changes are activated immediately upon selection.
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Wireless Network Control Panel Applet

E4

Note: See Chapter 4, “Network Support,” for information about the
802.11b or 802.11b/g radio module.

About the Wireless Network

Terminology

Your wireless adapter (network interface card) connects to wireless net-
works of two types: infrastructure networks and ad-hoc networks.

* Infrastructure networks get you onto your corporate network and the
internet. Your 700 Color Computer establishes a wireless connection to
an access point, which links you to the rest of the network. When you
connect to a network via an access point, you are using the 802.11b or
802.11b/g infrastructure mode.

* Ad-hoc networks are private networks shared between two or more cli-
ents, even with no access point.

Each wireless network is assigned a name (or Service Set Identifier —
SSID) to allow multiple networks to coexist in the same area without in-
fringement.

Intermec Technologies recommends using security measures with wireless
networks to prevent unauthorized access to your network and to ensure
your privacy of transmitted data. The following are required elements for
secure networks:

* Authentication by both the network and the user
* Authentication is cryptographically protected
* Transmitted data

There are many schemes available for implementing these features.

Below are terms you may encounter as you configure your wireless net-
work:

* CKIP (Cisco Key Integrity Protocol)
This is Cisco’s version of the TKIP protocol, compatible with Cisco
Airnet products.

e EAP (Extensible Authentication Protocol)
802.11b or 802.11b/g uses this protocol to perform authentication.
This is not necessarily an authentication mechanism, but is a common
framework for transporting actual authentication protocols. Intermec
Technologies provides a number of EAP protocols for you to choose the
best for your network.
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364

e TKIP (Temporal Key Integrity Protocol)

This protocol is part of the IEEE 802.11i encryption standard for wire-
less LANs., which provides per-packet key mixing, a message integrity
check and a re-keying mechanism, thus overcoming most of the weak
points of WEP. This encryption is more difficult to crack than the stan-
dard WEP. Weak points of WEP include:

* No Installation Vector (IV) reuse protection
* Weak keys

* No protection against message replay

* No detection of message tampering

* No key updates

WEP (Wired Equivalent Privacy) encryption

With preconfigured WEP, both the client 700 Color Computer and
access point are assigned the same key, which can encrypt all data be-
tween the two devices. WEDP keys also authenticate the 700 Color Com-
puter to the access point — unless the 700 Color Computer can prove
it knows the WEP key, it is not allowed onto the network.

WEP keys are only needed if they are expected by your clients. There
are two types available: 64-bit (5-character strings, 12345) (default) and
128-bit (13-character strings, 1234567890123). Enter these as either
ASCII (12345) or Hex (0x3132333435).

WPA (Wi-Fi Protected Access)

This is an enhanced version of WEP that does not rely on a static,
shared key. It encompasses a number of security enhancements over
WEP, including improved data encryption via TKIP and 802.11b or
802.11b/g authentication with EAP.

WiFi Alliance security standard is designed to work with existing
802.11 products and to offer forward compatibility with 802.11i.
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Configuring Your Wireless Network

To start 802.11b or 802.11b/g communications on the 700 Color
Computer, tap Start > Settings > the System tab > Wireless Network to
Wireless access the Profile Wizard for the 802.11b or 802.11b/g radio module.

Metwork

L.@

A profile contains all the information necessary to authenticate you to the
network, such as login name, password or certificate, and protocols by
which you are authenticated.

You can have up to four profiles for different networks. For example, you
may have different login names or passwords on different networks, or you
may use a password on one network, and a certificate on another.

Use the Profiles page to select and configure between the networking envi-
ronments assigned to this 802.11b or 802.11b/g radio.

| Edit Selecked Profile |

I o4 | | Cancel |

I:‘ Erable Microsoft's YWireless Zera Canfig

"Security powered by Odyssey”
=]

¢ Profile:
Tap the drop-down list to choose between four different profiles as-
signed to this unit, then tap Edit Select Profile, make the changes need-
ed for this profile (starting on the next page), then tap OK to return to
the Profiles page.

* Enable Microsoft’s Wireless Zero Config
Check this box to enable Microsoft’s Wireless Zero Config application.
This effectively disables the Intermec software solution for 802.11b or
802.11b/g, including configuration via the CORE application and the
Wireless Network control panel applet.
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Basic
Use the Basic page to set the network type, name, and manage battery
power for this profile. Tap ok or OK to return to the Profiles page.

* Profile Label:
Enter a unique name for your profile.

* Network type:
Tap the drop-down list to select either “Infrastructure” if your network
uses access points to provide connectivity to the corporate network or
internet; or “Ad-Hoc” to set up a private network with one or more par-
ticipants.

* Channel:
If you selected “Ad-Hoc” for the network type, select the channel on
which you are communicating with others in your network. There are
up to 11 channels available.

e SSID (Network Name):
This assumes the profile name wunless another name is entered in this field.
If you want to connect to the next available network or are not familiar
with the network name, enter “ANY” in this field. Consult your LAN
administrator for network names.

* Enable Power Management:
Check this box to conserve battery power (default), or clear this box to
disable this feature.

Profile Wizard o} 4 845 @

| Security ] Advanced ]

Prafils Label:

|PrDFiIe_1 |
Mebwork bype: Channel:
[ad-Hoc M

S2ID (Mebveork Mame):
|INTERMEC |

Enable Power Management

I O | | Cancel |
B[
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Security

The following are available from the 8021x Security drop-down list. Noze
that the last four methods are available if you have purchased the security pack-
age. Contact your Intermec representative for information.

e None (below)
PEAP (page 370)
TLS (page 374)
TTLS (page 377)
LEAP (page 381)

None
Use “None” to disable 802.11b or 802.11b/g Security and enable either
WEP or WPA-PSK encryption.

To Disable 802.1x Security
1 Set 8021x Security as “None.”
2 Set Association to “Open.”

3 Set Encryption to “None.”

48| Profile Wizard o £ 620 @

[Basicl Security .ﬁ\duanced]

8021 Security
|N0ne v|
Association Encryption
|Open v| |Mone v|
I O | | Cancel |

B[
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To Enable WEP Encryption

1
2

Set 8021x Security as “None.”

Set Association to either “Open” if WEP keys are not required; or
“Shared” when WEP keys are required for association.

Set Encryption to “WEP.

encryption.

” See page 364 for information about WEP

If you had set Association to “Shared,” then select a data transmission
key from the Data TX Key drop-down list near the bottom of this
screen, then enter the encryption key for that data transmission in the

appropriate Key # field.

Profile Wizard <} 4 w30 @

[Basicl Security .ﬁ\duanced]

8021 Security
|N0ne v|
Association Encryption
[Shared ~| [wer -
Key 1:| |
Key 2:| |
key 3:| |
Key 4—:| |
Daka TH Key:

I O | | Cancel

B[
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To Enable WPA Encryption Using a Preshared Key
1 Set 8021x Security as “None.”
2 Set Association to “WPA.” See page 364 for information about WPA

encryption.

3 Skip Encryption as it is automatically set to “TKIP.” See page 364 for
more information about TKIP.

4 Enter the temporal key as ASCII (12345) in the Pre-Shared Key field.

417\ Profile Wizard o 4t G4z @

[Basicl Security .ﬁ\duanced]

8021 Security

|N0ne - |
Association Encryption
[urees ~| e -

Pre-Shared Key

I O | | Cancel |
B[
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PEAP (Protected EAP)

This protocol is suitable for performing secure authentication against Win-
dows domains and directory services. It is comparable to EAP-TTLS (see
page 377), both in its method of operation and its security, though not as
flexible. This does not support the range of inside-the-tunnel authentica-
tion methods supported by EAP-TTLS. Microsoft and Cisco both support
this protocol.

Use “PEAP” to configure the use of PEAP as an authentication protocol
and to select “Open,” “WPA,” or “Network EAP” as an association mode.

To Enable PEAP with an Open Association
1 Set 8021x Security as “PEAP.”
2 Set Association to “Open.”

3 Skip Encryption as it is automatically set to “WEP.” See page 364 for
information about WEP encryption.

4 Enter your unique user name and password to use this protocol. Select
Prompt for password to have the user enter this password each time to
access the protocol; or leave Use following password as selected to auto-
matically use the protocol without entering a password.

5 Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

6 Tap Additional Settings to assign an inner PEAP authentication and set
options for server certificate validation and trust. See page 373 for more
information.

8| Profile Wizard o £ 6idE @

[Basicl Security .ﬁ\duanced]

8021 Security

[FEap -]

Association Encryption

[open ~| [wer -
Password

O Prampt For password
@ Use following passweard;

shesbeok s b ke ek

| Get Certficates | [additional Settings |

| O | | Cancel |
B[
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To Enable PEAP with WPA Encryption
1 Set 8021x Security as “PEAP.”

2 Set Association to “WPA.” See page 364 for information about WPA
encryption.

3 Skip Encryption as it is automatically set to “TKIP.” See page 364 for
more information about TKIP.

4 Enter your unique user name and password to use this protocol. Select
Prompt for password to have the user enter this password each time to
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

5 Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

6 Tap Additional Settings to assign an inner PEAP authentication and set
options for server certificate validation and trust. See page 373 for more
information.

Profile Wizard o 4 i @

[Basicl Security .ﬁ\duanced]

8021 Security

[FEap -]

Association Encryption

[urees ~| e -
Password

O Prampt For password
@ Use following passweard;

shesbeok s b ke ek

| Get Certficates | [additional Settings |

| O | | Cancel |
B[
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To Enable PEAP with Network EAP

Set 8021x Security as “PEAP.”

Set Association to “Network EAP.” See page 363 for information about
EAPD.

Set Encryption to either “WEP” or “CKIP.” See page 363 for informa-
tion about CKIP and page 364 for information about WEP encryption.

Enter your unique user name and password to use this protocol. Select
Prompt for password to have the user enter this password each time to
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

Tap Additional Settings to assign an inner PEAP authentication and set
options for server certificate validation and trust. See page 373 for more
information.

Profile Wizard o 4 Bidl @

[Basicl Security .ﬁ\duanced]

8021 Security

[FEap -]

Association Encryption

[HetwarkE&P < | [wEP -
Password

O Prampt For password
@ Use following passweard;

shesbeok s b ke ek

| Get Certficates | [additional Settings |

| O | | Cancel |
B[
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Additional Settings

1 Select an authentication method from the Inner PEAP Authentication
drop-down list.

EAP/MS-CHAP-V2  Authenticates against a Windows Domain Controller and
other non-Windows user databases. This is Microsoft’s
implementation of PEAP.

EAP/Token Card Use with token cards. The password value entered is never
cached. This is Cisco’s implementation of PEAP.

EAP/MD5-Challenge Message Digest 5. A secure hashing authentication algo-
rithm.

2 Check Validate Server Certificate to verify the identity of the authenti-
cation server based on its certificate when using TTLS or PEAP.

3 Enter the Common Names of trusted servers. Note that if these fields are
left blank, the server certificate trust validation is not performed or required.

4 Click ok to return to the Security page.

L8| profile Wizard < £ g0 @

Inner PEAP Aukhertication
[Espims-CHap-v2 -]

Cerkificate Sethings
|:| walidate Server Certificate
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TLS (EAP-TLS)

EAP-TLS is a protocol that is based on the TLS (Transport Layer Security)
protocol widely used to secure web sites. This requires both the user and
authentication server have certificates for mutual authentication. While
cryptically strong, this requires corporations that deploy this to maintain a
certificate infrastructure for all their users.

Use “TLS” to configure the use of EAP-TLS as an authentication protocol,
and select either “Open” or “WPA” as an association mode.

To Enable TLS with an Open Association
1 Set 8021x Security as “TLS.”

2 Set Association to “Open.”

3 Skip Encryption as it is automatically set to “WEP.” See page 364 for
information about WEP encryption.

4 Enter your unique Subject Name and User Name to use this protocol.

5 Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

6 Tap Additional Settings to set options for server certificate validation
and trust. See page 376 for more information.

Profile Wizard

& qcoz0 D

8021 Security

[1s -]
Association Encryption
[open ~| [wer -

| Get Certficates | [additional Settings |

I O | | Cancel

B[
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To Enable TLS with WPA Encryption
1 Set 8021x Security as “TLS.”
2 Set Association to “WPA.” See page 364 for information about WPA

encryption.

3 Skip Encryption as it is automatically set to “TKIP.”See page 364 for
more information about TKIP.

4 Enter your unique Subject Name and User Name as credentials for this

profile.

5 Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

6 Tap Additional Settings to set options for server certificate validation
and trust. See page 376 for more information.

L8| profile Wizard o} £ 933 @

[Basicl Security .ﬁ\duanced]

8021 Security

[1s -]
Association Encryption
[urees ~| e -

| Get Certficates | [additional Settings |

I O | | Cancel |
B[
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Additional Settings
1 Check Validate Server Certificate to verify the identity of the authenti-

cation server based on its certificate when using PEAP or TLS.

2 Enter the Common Names of trusted servers. Note that if these fields are
left blank, the server certificate trust validation is not performed or required.

3 Click ok to return to the Security page.

FF|profile Wizard 4 4£10:04 (D

Cerkificate Settings
[] validate Server Certificate
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TTLS (EAP-Tunneled TLS)
This protocol provides authentication like EAP-TLS (see page 374) but

does not require certificates for every user. Instead, authentication servers
are issued certificates. User authentication is done using a password or oth-
er credentials that are transported in a securely encrypted “tunnel” estab-
lished using server certificates.

EAP-TTLS works by creating a secure, encrypted tunnel through which
you present your credentials to the authentication server. Thus, inside
EAP-TTLS there is another inner authentication protocol that you must
configure via Additional Settings.

Use “T'TLS” to configure the use of EAP-TTLS as an authentication pro-
tocol, and select either “Open” or “WPA” as an association mode.

To Enable TTLS with an Open Association (default configuration)
1 Set 8021x Security as “T'TLS.”
2 Set Association to “Open.”

3 Skip Encryption as it is automatically set to “WEP.” See page 364 for
information about WEP encryption.

4 Enter your unique user name and password to use this protocol. Select
Prompt for password to have the user enter this password each time to
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

5 Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

6 Tap Additional Settings to assign an inner TTLS authentication and an
inner EAP, and set options for server certificate validation and trust. See
page 379 for more information.

43 Profile Wizard <} 4 700 @

[Basicl Security .ﬁ\duanced]

8021 Security

[r1s -]
Association Encryption
[open ~| [wer -

Username:  |ananyraous

Password
O Prampt For password

(®) Use following password;

| Get Certficates | [additional Settings |

| O | | Cancel |
B[
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To Enable TTLS with WPA Encryption

1
2

Set 8021x Security as “I'TLS.”
Set Association to “WPA.” See page 364 for information about WPA

encryption.

Skip Encryption as it is automatically set to “TKIP.” See page 364 for
more information about TKIP.

Enter your unique user name and password to use this protocol. Select
Prompt for password to have the user enter this password each time to
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

Tap Get Certificates to obtain or import server certificates. See page
380 for more information.

Tap Additional Settings to assign an inner TTLS authentication and an
inner EAP, and set options for server certificate validation and trust. See
page 379 for more information.

Profile Wizard < 4 703 @

[Basicl Security .ﬁ\duanced]

8021 Security

[r1s -]

Association Encryption

[urees ~| e -
Password

O Prampt For password
(®) Use following password;

| Get Certficates | [additional Settings |

| O | | Cancel |
B[
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1 Select an authentication protocol from the Inner TTLS Authentication

drop-down list:

PAP

CHAP

MS-CHAP;
MS-CHAP-V2

PAP/Token Card

EAP

Password Authentication Protocol. A simple authentication
protocol that sends security information in the clear.

Challenge Handshake Authentication Protocol. Use of Radius
to authenticate a terminal without sending security data in the
clear. Authenticates against non-Windows user databases. You
cannot use this if authenticating against a Windows NT Domain
or Active Directory.

Authenticates against a Windows Domain Controller and other
non-Windows user databases.

Use with token cards. The password value entered is never

cached.

Extensible Authentication Protocol. See page 363 for informa-
tion about EAP.

2 If you select “EAP” for the inner authentication protocol, then an inner
EAP protocol from the Inner EAP drop-down list.

3 Enter the Common Names of trusted servers. Note that if these fields are
left blank, the server certificate trust validation is not performed or required.

4 Check Validate Server Certificate to verify the identity of the authenti-
cation server based on its certificate when using TTLS, PEAP, and TLS.

5 Enter the Anonymous EAP-TTLS Name as assigned for public usage.
Use of this outer identity protects your login name or identity.

6 Click ok to return to the Security page.

HF | Profile Wizard
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To Get Certificates

Certificates are pieces of cryptographic data that guarantee a public key is
associated with a private key. They contain a public key and the entity
name that owns the key. Each certificate is issued by a certificate authority.

Use this page to import a certificate onto the 700 Color Computer.

Root Certificates

1 Tap the <<< button next to the Import Root Certificate field to select
the root certificate (DER-encoded .CER file) to import.

2 Click Import Root Cert to install the selected certificate.
User Certificate

1 Tap the <<< button next to the Certificate Path field to select the user
certificate (DER-encoded .CER file without the private key) to import.

2 Tap the <<< button next to the Key Path field to select the private key
(.PVK file) which corresponds to the user certificate chosen in step 1.

3 Tap Import User Cert to install the selected certificate.

Web Enrollment
Tap Web Enrollment to obtain a user certificate over the network from an
IAS Server. Tap ok to return to the Security page.

S| Profile Wizard F £ 655 @

Wweh Enrollmsnt
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LEAP (Cisco Lightweight EAP)
LEAP is the Cisco Lightweight version of EAP. See page 363 for informa-
tion about EAP.

Use “LEAP” to configure the use of LEAP as an authentication protocol,
select “Open,” “WPA,” or “Network EAP” as an association mode, or as-
sign Network EAP. Note that this defaults to the Network EAP.

To Enable LEAP with an Open Association
1 Set 8021x Security as “LEAP.”
2 Set Association to “Open.”

3 Skip Encryption as it is automatically set to “WEP.” See page 364 for
information about WEP encryption.

4 Enter your unique User Name to use this protocol.

5 Select Prompt for password to have the user enter this password each
time to access the protocol, or leave Use following password as selected
to automatically use the protocol without entering a password.

FF|rrofile Wizard  &F 4¢ 1103 (D

[Basicl Security .ﬁ\duanced]

8021 Security
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I O | | Cancel |
B[
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To Enable LEAP with WPA Encryption
Set 8021x Security as “LEAD.”

Set Association to “WPA.” See page 364 for information about WPA
encryption.

1
2

Skip Encryption as it is automatically set to “TKIP.” See page 364 for
more information about TKIP.

Enter your unique User Name to use this protocol.

Select Prompt for password to have the user enter this password each
time to access the protocol, or leave Use following password as selected
to automatically use the protocol without entering a password.

Profile Wizard
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[Basicl Security .ﬁ\duanced]

8021 Security
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M |
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To Enable LEAP with Network EAP
1 Set 8021x Security as “LEAP.”

2 Set Association to “Network EAP,” an EAP protocol for the network.
See page 363 for information about EAP.

3 Set Encryption to either “WEP” or “CKIP.” See page 363 for informa-
tion about CKIP and page 364 for information about WEP encryption.

4 Enter your unique User Name to use this protocol.

5 Select Prompt for password to have the user enter this password each
time to access the protocol, or leave Use following password as selected
to automatically use the protocol without entering a password.

| Profile Wizard & A€ 11:10 (D
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Advanced
Use this page to configure additional settings for this profile. Tap ok or
OK to return to the Profiles page.

¢ Detect Rogue APs:
Wireless NICs and APs associate based on the SSID configured for the
NIC. Given an SSID, the BSSID with the strongest signal is often cho-
sen for association. After association, 802.1x authentication may occur
and during authentication credentials to uniquely identify a user —

these are passed between the NIC and the AP.

The base 802.1x technology does not protect the network from “rogue
APs.” These can mimic a legitimate AP to authentication protocols and
user credentials. This provides illegal users ways to mimic legitimate us-
ers and steal network resources and compromise security.

Check this box to detect and report client behavior suspected of being
rogue APs. Once a rouge AP is detected, your 700 Series Computer no
longer associates with that AP until you perform a warm boot.

Clear this box to solve AP connection problems that result when an AP
gets put on the rogue AP list due to inadvertant failed authentications
and 7ot because it is a real rouge.

¢ Enable mixed cell:
Mixed cell is a profile-dependent setting. If enabled, you can connect to
mixed cell without using WEP, then you can query the cell to deter-
mine whether you can use encryption.

* Enable Logging:
Check this box to log what activity incurs for this profile.

-3 profile Wizard o 4: 118 @

seaced

Detect Rogue APs
|:| Enable mixed cel

D Enable Logaging
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Other Configurable Parameters

Audio Volume

Automatic Shutoff

The following parameters can be configured by sending reader commands
through the network or from an application. See “Using Reader Com-
mands” on page 387 for more information.

Changes the volume of all audio signals.

SNMP 0ID
1.3.6.1.4.1.1963.15.3.1.3.0

Options (Syntax Data for Reader Commands)

0 Off

1 Very quiet

2 Quiet

3 Normal (default)
4 Loud

5  Veryloud

Sets the length of time the 700 Color Computer remains on when there is
no activity. When you turn on the 700 Color Computer, it either resumes
exactly where it was when you turned it off or boots and restarts your ap-
plication.

SNMP 0ID
1.3.6.1.4.1.1963.15.11.3.0

Options (Syntax Data for Reader Commands)

1 1 minute
2 2 minutes
3 3 minutes (default)
4 4 minutes
5 5 minutes
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Backlight Timeout

Date/Time

Key Clicks

386

Sets the length of time that the display backlight remains on. If you set a
longer timeout value, you use the battery power at a faster rate.

SNMP 0ID
1.3.6.1.4.1.1963.15.13.1.0

Options (Syntax Data for Reader Commands)
10 10 seconds

30 30 seconds

60 1 minute (default)

120 2 minutes

180 3 minutes

240 4 minutes

300 5 minutes

Sets the current date and time.

SNMP 0ID
Date: 1.3.6.1.4.1.1963.15.501.2.1.0
Time: 1.3.6.1.4.1.1963.15.501.2.2.0

Options (Syntax Data for Reader Commands)
Date Year 0000-9999 (1999)
Month 1-12 (6)
Day 1-31 (1)
Time Hour 0-23 (0)
Minute 0-59 (00)
Second 0-59 (00)

Enables or disables the keypad clicks. The 700 Color Computer emits a
click each time you press a key or decode a row of a two-dimensional
symbology.

SNMP 0ID
1.3.6.1.4.1.1963.15.12.1.0

Options (Syntax Data for Reader Commands)
0 Disable clicks

1 Enable soft key clicks

2 Enable loud key clicks (default)
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Using Reader Commands

After the 700 Color Computer is connected to your network, you can
send the 700 Color Computer a reader command from an application to
perform a task, such as changing the time and date. Some reader com-
mands temporarily override the configuration settings and some change
the configuration settings.

Change Configuration

The Change Configuration command must precede any configuration
command. If you enter a valid string, the 700 Color Computer configura-
tion is modified and the computer emits a high beep. To send the Change
Configuration command through the network, use the $+ [ command]
syntax where command is the two-letter command syntax for the configu-
ration command followed by the value to be set for that command.

You can also make changes to several different commands by using the
$+ [command] . ..[command n] syntax. There are seven configuration
command settings that can be changed in this way. See each command for
information on respective acceptable “data” values.

Command Syntax
Audio Volume BVdata
Automatic Shutoff EZdata
Backlight Timeout DFdata
Key Clicks KCdata
Virtual Wedge Grid AFdata
Virtual Wedge Postamble AEdata
Virtual Wedge Preamble ADdata

% Note: See pages 336 and 338 for more information about the Virtual
Wedge Postamble and Virtual Wedge Preamble commands.

Example 1
To change the Beep Volume to Off, you can send this string to the 700
Color Computer through the network: ~ $+BVO

where:
S+ Indicates Change Configuration.
BV Specifies the Audio Volume parameter.
0 Specifies a value of Off.

Example 2

To change the Beep Volume to Very Quiet and the Virtual Wedge Grid
to 123: $+BV1AF123

where:
S+ Indicates Change Configuration
BV1 Specifies Audio Volume, set to Very Quiet (1)

AF123  Specifies Virtual Wedge Grid, set to a value of 123.
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Set Time and Date

This command sets the date and time on the 700 Color Computer. The
default date and time is June 1, 1999 ar 12:00 AM.

From the network, send the following:
/+ yyyymmddhhmmss
where acceptable values for the date are:

YYyvy 0000-9999 Year

mm 01-12 Month of the year
dd 01-31 Day of the month
hh 00-23 Hour

mm 00-59 Minutes

SS 00-59 Seconds

6 You can also set the time and date by using Configuration Management in

Unit Manager, or by using the Clock control panel applet in the Settings

clock  menu. To access this control panel applet, tap Start > Settings > the
System tab > the Clock icon to access its control panel applet.

& gcesz D

GMT-8 PadificUs =
6:52:08 4M  [a]*
5 /18/2004 -

) Visiting

GMT+1 Paris, Madrid ~

oL Zmmem [
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Configuration Bar Codes

You can change some settings on your 700 Color Computer by scanning

the following Code 39 bar code labels.

* You can use the Data Collection control panel to set the three Virtual

Wedge parameters (starting on page 335).

% Note: When you use a bar code creation utility to make a scannable bar
code label, the utility probably adds opening and closing asterisks automat-
ically. Asterisks are included here for translation purposes.

Audio Volume
% Note: The Audio Volume parameter information is on page 385.

Turn Audio Off

*$+BVO*

Set Audio Volume to very quiet

*$+VBI1*

Set Audio Volume to quiet

*$+BV2*

Set Audio Volume to normal (default)

*$+BV3*

Set Audio Volume to loud

*$+BV4*

Set Audio Volume to very loud

*$+BV5*
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Automatic Shutoff
% Note: The Automatic Shutoff parameter information is on page 385.

Set Automatic Shutoff to 1 minute

*$+EZ1*

Set Automatic Shutoff to 2 minutes

*$+EZ2*

Set Automatic Shutoff to 3 minutes (default)

*$+EZ3*

Set Automatic Shutoff to 4 minutes

*$+EZ4*

Set Automatic Shutoff to 5 minutes

*$+EZ5*

Backlight Timeout
% Note: The Backlight Timeout parameter information is on page 386.

Backlight Timeout 10 seconds

*$+DF10*

Backlight Timeout 30 seconds

*$+DF30*

Backlight Timeout 1 minute (default)

*$+DF60*
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Key Clicks

E4

Backlight Timeout 2 minutes

*$+DF120*

Backlight Timeout 3 minutes

*$+DF180*

Backlight Timeout 4 minutes

*$+DF240*

Backlight Timeout 5 minutes

*$+DF300*

Appendix A — Configurable Settings

Note: The Key Clicks parameter information is on page 386.

Disable key clicks

*$+KC0*

Enable soft key clicks

*$+KC1*

Enable loud key clicks (default)

*$+KC2*
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Virtual Wedge Grid, Preamble, Postamble

392

The following parameters are user-configurable strings. Refer to a full
ASCII chart for more information.

Grid

For Virtual Wedge Grid, the first part of the bar code would be the fol-
lowing, which can include a string of up to 240 characters. Parameter in-
formation starts on page 340.

*$+AF

Preamble

For Virtual Wedge Preamble, the first part of the bar code would be be-
low, followed by a string of up to 31 characters (n0 <NUL>) and an aster-
isk. Default is no characters. Parameter information is on page 336.

*$+AD

Postamble

For Virtual Wedge Postamble, the first part of the bar code would be be-
low, followed by a string of up to 31 characters (n0 <NUL>) and an aster-
isk. Default is no characters. Parameter information is on page 338.

*$+AE
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B Bar Code Symbologies

This appendix contains a brief explanation of some of the bar code
symbologies that the 700 Series Color Mobile Computer decodes and ex-
plains some of the general characteristics and uses of these bar code types.

The 700 Color Computer recognizes eleven of the most widely used bar
code symbologies. With bar code symbologies, like languages, there are
many different types. A bar code symbology provides the required flexibil-
ity for a particular inventory tracking system.

A symbology may be for particular industries, such as food and beverage,
automotive, railroad, or aircraft. Some of these industries have established
their own bar code symbology because other symbologies did not meet
their needs.

Without going into great detail on the bar code structure, note that no two
products use the same bar code. Each product gets a unique bar code.

Industries that use a particular type of bar code symbology have formed
regulating committees or are members of national institutes that issue and
keep track of bar codes. This ensures that each organization that contrib-
utes to a particular industry conforms to its standard. Without some form
of governing body, bar coding would not work.

% Note: “700 Color” pertains to 740, 741, 750, 751, 760, and 761 Com-

puters unless otherwise noted.

700 Series Color Mobile Computer User’s Manual 393



Appendix B

Codabar

Code 11

Code 39

394

— Bar Code Symbologies

Codabar was for retail price-labeling systems. Today it is widely accepted
by libraries, medical industries, and photo finishing services.

Codabar is a discrete, self-checking code with each character represented
by a stand-alone group of four bars and three intervening spaces.

Four different start or stop characters get defined and designated “a”, “b”,
“c”, and “d”. These start and stop characters are constructed using one
wide bar and two wide spaces. A complete Codabar symbol begins with
one of the start or stop characters followed by some number of data char-

acters and ending in one of the start or stop characters.

Any of the start or stop characters may be used on either end of the sym-
bol. It is possible to use the 16 unique start or stop combinations to identi-
fy label type or other information.

Since Codabar is variable-length, discrete, and self-checking, it is a versa-
tile symbology. The width of space between characters is not critical and
may vary significantly within the same symbol. The character set consists
of “0” through “97, “-7, “$”, .7, “/?, “.”, and “+”.

The specific dimensions for bars and spaces in Codabar optimize perfor-
mance of certain early printing and reading equipment. Codabar has 18
different dimensions for bar and space widths. So many different dimen-
sions often result in labels printed out of specification and cause Codabar
printing equipment to be more expensive.

Code 11 satisfies the requirements for a very high density, discrete numer-
ic bar code. The name Code 11 derives from 11 different data characters
that can be represented, in addition to a start or stop character.

The character set includes the 10 digits and the dash symbol. Each charac-
ter is represented by a stand-alone group of three bars and two intervening
spaces. Although Code 11 is discrete, it is not self-checking. A single print-
ing defect can transpose one character into another valid character. One or
two check digits obtain data security.

The specifications for Code 11 suggest that this code should have a narrow
element width of 7.5 mils. This results in an information density of 15
characters per inch.

Code 39 (C39) is the most widely used symbology among the industrial
bar codes. Most major companies, trade associations, and the federal gov-
ernment find this code to fit their needs. The main feature of this symbol-
ogy is the ability to encode messages using the full alphanumeric character
set, seven special characters, and ASCII characters.

Programming for this symbology can be for any length that the application
requires. The application program for the 700 Color Computer handles
symbology at least one character but no more than 32 characters in length.
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When programming the computer for Code 39, it is important to set the
symbology limit as close as possible (minimum and maximum bar code
lengths being scanned). Doing so keeps the computer bar code processing
time to a minimum and conserves battery power.

Bar code readers can respond to Uniform Symbology Specification sym-
bols in non-standard ways for particular applications. These methods are
not for general applications, because of the extra programming required.

Code 39 Full ASCII is one example of non-standard code.
% Note: See page 389 to scan several Code 39 bar code labels available to

change settings on your 700 Color Computer.

Encoded Code 39 (Concatenation)

If the first data character of a symbol is a space, the reader may be pro-
grammed to append the information contained in the remainder of the
symbol to a storage buffer. This operation continues for all successive sym-
bols that contain a leading space, with messages being added to the end of
previously stored ones. When a message is read which does not contain a
leading space, the contents are appended to the buffer, the entire buffer is
transmitted, and the buffer is cleared.

Encoded Code 39 (Full ASCIT)

If the bar code reader is programmed for the task, the entire ASCII charac-
ter set (128 characters) could be coded using two character sequences: a

symbol (“$7,.”,“%”,“/”) followed by a letter of the alphabet.

Code 93

The introduction of Code 93 provided a higher density alphanumeric
symbology designed to supplement Code 39. The set of data characters in
Code 93 is identical with that offered with Code 39. Each character con-

sists of nine modules arranged into three bars and three spaces.

Code 93 uses 48 of the 56 possible combinations. One of these characters,
represented by a square, is reserved for a start or stop character, four are
used for control characters, and the remaining 43 data characters coincide
with the Code 39 character set. An additional single module termination
bar after the stop character concludes the final space.

Code 93 is a variable length, continuous code that is not self-checking. Bar
and spaces widths may be one, two, three, or four modules wide. Its struc-
ture uses edge-to-similar-edge decoding. This makes the bar code immune
to uniform ink spread, which allows liberal bar width tolerances.

Code 93 uses two check characters. Its supporters believes this makes it the
highest density alphanumeric bar code. The dual check digit scheme pro-
vides for high data integrity. All substitution errors in a single character are
detected for any message length.
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Code 128

396

Code 128 (C128) is one of the newest symbologies used by the retail and
manufacturing industries. It responds to the need for a compact alphanu-
meric bar code symbol that could encode complex product identification.

The fundamental requirement called for a symbology capable of being
printed by existing data processing printers (primarily dot-matrix printers)
that produce daily, work-in-progress, job, and product traceability docu-
ments. The ability to print identification messages between 10 and 32
characters long, on existing forms and labels deemed an important require-
ment.

Code 128 uniquely addresses this need as the most compact, complete,
alphanumeric symbology available.

Additionally, the Code 128 design with geometric features, improves scan-
ner read performance, does self-checking, and provides data message man-
agement function codes.

Code 128 encodes the complete set of 128 ASCII characters without ad-
ding extra symbol elements. Code 128 contains a variable-length symbolo-
gy and the ability to link one message to another for composite message
transmission. Code 128, being a double-density field, provides two numer-
ic values in a single character.

Code 128 follows the general bar code format of start zone, data, check
digit, stop code, and quiet zone. An absolute minimum bar or space di-
mension of nine mils (0.010 inch minimum nominal = 0.001 inch toler-
ance) must be maintained.

Characters in Code 128 consist of three bars and three spaces so that the
total character set includes three different start characters and a stop char-
acter.

UCC/EAN-128 Shipping Container Labeling is a versatile tool that can
ease movement of products and information. The Shipping Container La-
beling bar code can take any form and usually has meaning only within the
company or facility where applied.

Because this random data can get mistaken later for an industry standard
code format, the UCC and EAN chose a symbology uniquely identified
from these other bar codes. This standard is for maximum flexibility, to
handle the diversity of distribution in global markets by cost efficiency.

The UCC/EAN-128 Container Labeling specification calls for a FUNC1
to immediately follow the bar code’s start character. FUNCI also follows
any variable-length application field. The specification also calls for the
computer to send “|C1” for the first FUNCI. The specification requires
that the computer send a “<GS>” (hex 1D) for subsequent FUNCI codes
in the bar code.

Because “<GS>” is not compatible with computer emulation data streams,
the Uniform Code Council has been asked to change the specification.
This change is made to send the same three character sequence “|C1” to

identify the embedded FUNCI codes.
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This implementation should provide for clean application coding by iden-
tifying the same sequences for the same scanned codes. If the communica-
tion of Norand bar code types is enabled, the Shipping Container Label
codes precede with a “J”. These strings will appear on the computer dis-
play. The application may have to allow for strings longer than 48 charac-
ters (maximum length indicated in the specification). Actual length vari-
ance depends on the number of variable-length data fields. Allowing for 60
characters should be sufficient. Within the Code 128 specification, the
computer can link bar codes together. If this is to happen, allow for more
characters (computer limit is 100 characters).

The Application Identifier Standard, that is part of the UCC/EAN Ship-
ping Label concept, complements, rather than replaces, other UCC/EAN
standards. Most UCC/EAN standards primarily identify products.

Several industries expressed the need to standardize more than product
identification. The UCC/EAN Code 128 Application Identifier Standard
supplies this tool. The standard adds versatility for inter-enterprise ex-
changes of perishability dating, lot and batch identification, units of use
measure, location codes, and several other information attributes.

For more detailed information on Code 128 UCC/EAN Shipping Label
bar code and Application Identifier Standard, refer to the UCC/EAN-128
Application Identifier Standard specification.

Data Matrix

Data Matrix is a high density 2D matrix code that can store a large
amount of information. It has excellent error correction abilities and is
mostly used for marking and tracking parts.

Data Matrix can store from 1 to about 2000 characters. The symbol is
square and can range from 0.001 inch per side up to 14 inches per side. As
an example of density, 500 numeric-only characters can encode in a 1-inch
square using a 24-pin dot matrix printer.

Data Matrix is used to encode product and serial number information on
electrical rating plates; to mark of surgical instruments in Japan; to identify
lenses, circuit boards, and other items during manufacturing,.

EAN (European Article Numbering)

EAN symbology is similar to UPC symbology, except that it contains 13
characters and uses the first two to identify countries.

The EAN symbology is used in the retail environment throughout most of
Europe. Though similar to UPC symbology, these are not interchangeable.
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12 of 5 (Interleaved)

Matrix 2 of 5

MaxiCode

PDF417

398

I 2 of 5 (Interleaved 2 of 5 Code) is an all-numeric symbology, widely
used for warehouse and heavy industrial applications. Its use has been par-
ticularly prevalent in the automobile industry. The I 2 of 5 symbology can
be placed on smaller labels than what the standard UPC symbology re-
quires.

I 2 of 5 also provides a little more flexibility on the type of material it can
print on. Interleaved 2 of 5 Code has its name because of the way the bar
code is configured.

I 2 of 5 bars and spaces both carry information. The bars represent the
odd number position digits, while spaces represent the even number posi-
tion digits. The two characters are interleaved as one. Messages encoded
with this symbology have to use an even number of characters since two
numeric characters always get interleaved together.

Matrix 2 of 5 is a derivitive of Code 11 and is a linear bar code that is only
read by linear imagers. It is limited to the ten digits and start/stop charac-
ter. Discrete but not self-checking. Matrix 2 of 5 is used with a single
Mmodulo 10 check digit. Compared with Code 11 (using two check dig-
its) and the other industrial symbologies, Matrix 2 of 5 is somewhat more
subject to substitution errors and offers no particular advantage.

MaxiCode is a fixed-size code which holds up to 93 data characters. The
symbol is composed of a central bulls-eye locator and offset rows of hexag-
onal elements; the overall dimensions of the symbol are approximately
1.11 x 1.054 inches. Each element measures 0.035 x 0.041 inches.

Created by United Parcel Service, the MaxiCode symbol was designed for
quick automated scanning of packages on high-speed conveyor lines (spe-
cial cameras can read a MaxiCode on a carton travelling at up to 500 feet
per minute).

The PDF417 symbology is a stacked 2D symbology that allows you to
scan across rows of code. Each row consists of start/stop characters, row
identifiers, and symbol characters, which consist of four bars and four
spaces each and contain the actual data. This symbology uses error correc-
tion symbol characters appended at the end to recover loss of data.

PDF417 can store up to about 1800 printable ASCII characters or 1100
binary characters per symbol. The symbol is rectangular; the shape of the
symbol can be adjusted to some extent by setting the width and allowing
the height to grow with the data. It is also possible to break large amounts
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of data into several PDF417 symbols which are logically linked. There is
no theoretical limit on the amount of data that can store in a group of

PDF417 symbols.
The capacity of PDF417 can be helpful in applications where the data

must travel with the labeled item, where a host database is not always avail-
able for quick look-up. PDF417 is used for hazardous materials labeling;
storing technical specifications, and calibration data on electronic instru-
ments; encoding fingerprints and photographs on the backs of drivers’ li-
censes.

The maximum data density is determined by the smallest elements which
can be reliably printed and scanned. Using the smallest recommended ele-
ment size of 0.0075 inch wide and 0.010 inch high, the maximum data
density in the binary mode is 686 bytes per square inch (106.2 bytes per
square centimeter). In the printable ASCII mode the density is 1144 char-
acters per square inch (177.2 characters per square centimeter).

Micro PDF417 is derived from PDF417. The code has a limited set of
symbol sizes and a fixed level of error correction for each symbol size.
Module dimensions are user-specified so that the symbol may be printed
with a variety of printers. The symbology allows up to 150 bytes, 250 al-
phanumeric characters, or 366 numeric digits to be stored. This is done by
specifying one of three compaction modes: data, text or numeric. Text
Compaction mode permits all printable ASCII characters to be encoded
(values 32 to 126 inclusive) as well as selected control characters. Byte
Compaction mode permits all 256 possible 8-bit byte values to be en-
coded. This includes all ASCII characters value 0 to 127 inclusive and pro-
vides for international character set support

Micro PDF417 is designed for applications where the symbol must be
smaller than PDF417 will allow.

Plessey finds its origin in the pulse width modulated (PWM) code devel-
oped in England. It is widely used for shelf markings in grocery stores.
Pulse width modulated codes represent each bit of information by a bar
and space pair. A zero bit consists of a narrow bar followed by a wide
space, while a one bit consists of a wide bar followed by a narrow space. It
is mainly a numeric symbology (0-9) with six extra characters available for
assigning any symbol or letter desired.

Plessey codes employ a variety of check characters and a polynomial-based
Cyclic Redundancy Check (CRC). For start and stop characters, Plessey
employs a 1101 and previously used a 0101.

This symbology is very limited about what information can be encoded. It
is not considered for new applications.
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MSI Code (Variant of Plessey)

The MSI Plessey bar code is a variant of the Plessey bar code. It is a pulse-
width modulated non-self checking code, and is used primarily in store
shelf labeling. Each character consists of eight elements, four bars and four
spaces. The character set includes the digits 0 through 9. A Modulo 10
checksum is appended to the end of the code. For start and stop checks,
MSI employs a single bit pair of 1 as a start symbol and a single bit pair of
0 as a stop symbol. MSI reverses the 1-2-4-8 BCD pattern for bit pair
weighting to 8-6-2-1.

QR Code (Quick Response Code)

QR Code is a 2D matrix symbology containing dark and light square data
modules. It has position detection patterns on three of its four corners and
features direct encodation of the Japanese Kana-Kanji character set. A 2D
imaging device such as a CCD camera is necessary to scan the symbology.
QR Code is designed with selectable levels of error correction. It supports
industry standard escape sequences to define international code pages and
special encodation schemes. QR Code is used for small item marking ap-
plications using a wide variety of printing and marking technologies. This
document includes descriptions of the character encodation, symbol struc-
ture, reference decode algorithm, and symbol quality measurements for

QR Code.

S 2 of 5 (Standard 2 of 5)

400

The code S 2 of 5 (Standard 2 of 5 Code) is designed primarily for:
* Warehouse inventory handling

* Identification of photo finishing envelopes

e Airline tickets

* Baggage and cargo handling

The code S 2 of 5 is simple and straightforward. All information is con-
tained in the widths of the bars, with the spaces serving only to separate

the individual bars.

Bars can either be wide or narrow, and the wide bars are usually three
times the widths of the narrow bars. Spaces may be any reasonable width
but are typically equal to the narrow bars. Narrow bars are identified as
zero bits and wide bars as one bits.

Remember the code structure by associating the bar positions from left to
right with weighting factors 1, 2, 4, 7, and parity. Exceptions to this rule
are zero, start, and stop. This code is a discrete code, since the white spaces
between the characters are not part of the code. Because the white spaces
carry no information, their dimensions are not critical.

The S 2 of 5 code is self-checking, meaning a scanner passing through a

1€ ¢ - & ng 1 p & &
printing void would detect the proper ratio of wide bars to total bars.
When the scanner spots an error, a non-read will occur.
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Telepen

Appendix B — Bar Code Symbologies

Telepen was devised by George Sims, Managing Director of SB Electronic
Systems Limited, in early 1972, this is the only symbology to directly rep-
resent the full ASCII character set without shift characters. Telepen carries
the double-density numeric-only mode and is very compact. The Telepen
symbol is up to 8 ASCII characters or16 digit per inch, and is easy to
print. It has a fixed 3:1 ratio, with a tolerance at least 0.4x. This symbolo-
gy is extremely secure, with negligible risk of misreading. It is supported
by most leading manufacturers.

UPC (Universal Product Code)

The UPC (Universal Product Code) is the symbology used throughout the
grocery and retail industries. This bar code symbology contains two pieces
of numerical information encoded on the bar code, producer identifica-
tion, and product identification information.

The UPC symbol is 12 characters long. The first character of the UPC
symbol is a number system character, such as “0” for grocery items and “3
for drug- and health-related items.

»

The UPC symbology is for retail environments such as grocery stores, con-
venience stores, and general merchandise stores.

Some retail items are so small that a standard UPC bar code cannot fit on
the packaging. When this occurs there is a permitted shorter version of the
UPC symbology, referred to as UPC-E. UPC-E is six characters long
(eight including number system and check digit), approximately half the
size of a standard UPC bar code.
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Index

The Classes and Functions Index covers classes and functions for the 700 Series
Color Mobile Computer.

The General Index covers all topics. Those in italics are figures, those in bold are
tables.

The Files Index is to assist you in locating descriptions for device drivers, applica-
tions, utilities, batch files, or other files within this publication.
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Classes and Functions

A
add_registry_section, [AddReg]
flags, 224
registry_root_string, 224
value_name, 224
AddReg, [DefaultInstall], 220
[AddReg], add_registry_section
flags, 224
registry_root_string, 224
value_name, 224
AddWep(), 270
ANT_DIVERSITY, GetDiversity(), 263
ANT_PRIMARY, GetDiversity(), 263
ANT_SECONDARY, GetDiversity(), 263
AppName, [CEStrings], 217
Asset management, DeviceURL parameter, 235

Basic connect/disconnect functions, 260
BlockSize, FTP Server, 235
BuildMax, [CEDevice], 218
BuildMin, [CEDevice], 218

C

[CEDevice]
BuildMax, 218
BuildMin, 218
ProcessorType, 218
UnsupportedPlatforms, 218
VersionMax, 218
VersionMin, 218
CESelfRegister, [DefaultInstall], 220
CESetupDLL, [DefaultInstall], 220
CEShortcuts, [DefaultInstall], 220
[CEShortcuts], shortcut_list_section
shortcut_filename, 225
shortcut_type_flag, 225
target_file/path, 225
target_file_path, 225
CESignature
[SourceDiskNames], 220
[Version], 216
[CEStrings]
AppName, 217
InstallDir, 217
ClassID field values
VN_CLASS_ASIC, 244
VN_CLASS_BOOTSTRAP, 244
VN_CLASS_KBD, 244
CloseHandle()
DTR printing, 196, 197
IrDA printing, 190
NPCP printing, 191, 192
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Cold boot, IOCTL_HAL COLDBOOT, 252
ConfigureProfile(), 275
Copyfiles, [Defaultlnstall], 220
[CopyFiles], file_list_section

destination_filename, 223

flags, 223

source_filename, 223
CreateEvent(), 286
CreateFile()

DTR printing, 196, 197

IrDA printing, 190

NPCP printing, 191, 192

D

[Defaultlnstall]

AddReg, 220

CESelfRegister, 220

CESetupDLL, 220

CEShortcuts, 220

Copyfiles, 220
Deprecated functions, 280
DeregisterDevice(), 191

DTR printing, 196
[DestinationDirs], file_list_section, 222
DeviceIOControl(), 258

DTR printing, 196

NPCP printing, 191
DeviceloControl(), NPCP printing, 192, 193
DeviceName, FTP Server, 235
DeviceURL, FTP Server, 235
disk_ordinal, [SourceDiskNames], 220
DIlIRegisterServer, 220
DllUnregisterServer, 220

E

EnableSuppLogging(), 279

EnableWep(), 270

EnableZeroConfig(), 276

EncryptionStatus(), 271

EncryptWepKeyForRegistry(Deprecated), 280

ERROR_INSUFFICIENT_BUFFER
IOCTL_HAL_ITC_READ_PARM, 243
IOCTL_HAL_ITC_WRITE_SYSPARM, 247

ERROR_INVALID_PARAMETER
IOCTL_HAL_ITC_READ_PARM, 243
IOCTL_HAL_ITC_WRITE_SYSPARM, 247

E
File Transfer Protocol. See FTP

file_list_section
[CopyFiles]
destination_filename, 223
flags, 223
source_filename, 223
[DestinationDirs], 222
filename, [SourceDiskFiles], 221
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FTP
client, 237
configurable parameters, 235
BlockSize, 235
DeviceName, 235
DeviceURL, 235
PauseAtStartup, 236
FTPDCMDS subdirectory, 239
RTC 959, 239
server, 237
server requests
CDUP, 237
CWD, 237
DELE, 237
HELP, 237
LIST, 237
MKD, 237
MODE, 237
NLST, 237
NOOP, 237
PASS, 237
PWD, 237
QUIT, 237
RETR, 237
RMD, 237
RNEFR, 237
RNTO, 237
SITE, 238
SITE ATTRIB, 238
SITE BOOT, 238
SITE COPY, 238
SITE EKEY, 239
SITE EVAL, 239
SITE EXIT, 238
SITE GVAL, 239
SITE HELP, 238
SITE KILL, 238
SITE LOG, 238
SITE PLIST, 238
SITE PVAL, 239
SITE RUN, 238
SITE STATUS, 239
SITE TIMEOUT, 239
STOR, 237
SYST, 237
TYPE, 237
USER, 237
XCUP, 237
XCWD, 237
XMKD, 237
XPWD, 237
XRMD, 237
stopping server from application, 240
support, 237

web browsers, 239

G

GetAssociationStatus(), 261
GetAuthenticationMode(), 262
GetBSSID(), 262
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GetCCXStatus(), 269
GetCurrentDriverName(), 279
GetDiversity(), 263
GetLinkSpeed(), 263
GetMac(), 264
GetMedia(Deprecated), 280
GetMedium(Deprecated), 280
GetNetworkMode(), 264
GetNetworkType(), 265
GetNicStats(Deprecated), 280
GetPowerMode(), 266
GetRadiolpAddress(), 269
GetRSSI(), 266
GetRTSThreshold(Deprecated), 280
GetSSID(), 265
GetTXPower(), 267
GetWepStatus(), 268

H

HAL, verion of Pocket PC
IOCTL_HAL GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL GET_OAL_VERINFO, 250
Helper functions, 275

ID field values
IOCTL_HAL ITC _READ PARM
ITC_NVPARM_80211_INSTALLED, 245
ITC_NVPARM_ 80211 _RADIOTYPE, 245
ITC_NVPARM_ANTENNA_DIVERSITY, 244
ITC_NVPARM_BLUETOOTH_INSTALLED,
246
ITC_NVPARM_CONTRAST, 244
ITC_NVPARM_DISPLAY TYPE, 244
ITC_NVPARM_ECN, 244
ITC_NVPARM_EDBG_SUBNET, 244
ITC_NVPARM_EDG_IP, 244
ITC_NVPARM_ETHERNET ID, 243
ITC_NVPARM_INTERMEC_DATACOLLEC-
TION_HW, 245
ITC_NVPARM_INTERMEC_DATACOLLEC-
TION_SW, 245
ITC_NVPARM_INTERMEC_SOFT-
WARE_CONTENT, 244
ITC_NVPARM_LAN9000_INSTALLED, 246
ITC_NVPARM_MANF_DATE, 243
ITC_NVPARM_MCODE, 244
ITC_NVPARM_RTC_RESTORE, 245
ITC_NVPARM_SERIAL NUM, 243
ITC_NVPARM_SERIAL2 _INSTALLED, 246
ITC_NVPARM_SERVICE_DATE, 243
ITC_NVPARM_SIM_PRO-
TECT_HW_INSTALLED, 246
ITC_NVPARM_SIM_PRO-
TECT_SW_INSTALLED, 246
ITC_NVPARM_VERSION_NUMBER, 244
ITC_NVPARM_VIBRATE_INSTALLED, 246
ITC_NVPARM_WAN_FREQUENCY, 245
ITC_NVPARM_WAN_INSTALLED, 245
ITC_NVPARM_WAN_RADIOTYPE, 245
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ITC_NVPARM_WAN_RI, 244
IOCTL_HAL_ITC_WRITE_SYSPARM
ITC_DOCK_SWITCH, 248
ITC_ WAKEUP_MASK, 248
ITC_AMBIENT FRONTLIGHT, 248
ITC_AMBIENT_KEYBOARD, 248
ITC_REGISTRY_SAVE_ENABLE, 248
IDNA
DeviceName, 235
DeviceURL, 235
IDNATarget, FTP Server, 236
InstallDir, [CEStrings], 217
Intermec Device Network Announcement. See IDNA
IOCTL_GET_CPU_ID, 257
IOCTL_HAL_COLDBOOT, 252, 283
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL_GET_BOOTLOADER_VERINFO, 251
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL ITC _READ_PARM, 243
IOCTL_HAL ITC WRITE_SYSPARM, 247
IOCTL_HAL_REBOOQOT, 255, 283
IOCTL_HAL_WARMBOOT, 252, 283
IOCTL_LOAD_NDIS_MINIPORT, 258
IOCTL_PROCESSOR_INFORMATION, 256
IOCTL_UNLOAD_NDIS_MINIPORT, 258
isDHCPEnabled(), 278
isOrinoco(), 276
isSupplicantRunning(), 277
isZeroConfigEnabled(), 276
ITC_DOCK_SWITCH, 248
ITC_ WAKEUP_MASK, 248
ITC_AMBIENT FRONTLIGHT, 248
ITC_AMBIENT_KEYBOARD, 248
ITC_DEVID_80211RADIO_INTEL_2011B, 245
ITC_DEVID_80211RADIO_MAX values
ITC_DEVID_80211RADIO_INTEL_2011B, 245
ITC_DEVID_80211RADIO_NONE, 245
ITC_DEVID_80211RADIO_NONE, 245
ITC_DEVID_INTERMEC_EVIO, 245
ITC_DEVID_INTERMEC2D_IMAGER, 245
ITC_DEVID_OEM2D_IMAGER, 245
ITC_DEVID_SCANHW_MAX values
ITC_DEVID_INTERMEC_EVIO, 245
ITC_DEVID_INTERMEC2D_IMAGER, 245
ITC_DEVID_OEM2D_IMAGER, 245
ITC_DEVID_SCANHW_NONE, 245
ITC_DEVID_SE900_LASER, 245
ITC_DEVID_SE900HS_LASER, 245
ITC_DEVID_SCANHW_NONE, 245
ITC_DEVID_SE900_LASER, 245
ITC_DEVID_SE900HS_LASER, 245
ITC_DEVID_WANRADIO_NONE, 245
ITC_DEVID_WANRADIO_SIEMENS_MC45, 245
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ITC_DEVID_WANRADIO_SIEMENS_MC46, 245
ITC_DEVID_WANRADIO_SIERRA_SB555, 245
ITC_DEVID_WANRADIO_XIRCOM_GEM3503, 245
ITC_IFTP_STOP, 240
ITC_NVPARM_80211_INSTALLED, 245
ITC_NVPARM_80211_RADIOTYPE, 245
ITC_NVPARM_ANTENNA_DIVERSITY, 244
ITC_NVPARM_BLUETOOTH_INSTALLED, 246
ITC_NVPARM_CONTRAST, 244
ITC_NVPARM_DISPLAY_TYPE, 244
ITC_NVPARM_ECN, 244
ITC_NVPARM_EDBG_SUBNET, 244
ITC_NVPARM_EDG_IP, 244
ITC_NVPARM_ETHERNET_ID, 243
ITC_NVPARM_INTERMEC_DATACOLLEC-
TION_HW, 245
ITC_NVPARM_INTERMEC_DATACOLLEC-
TION_SW, 245
ITC_NVPARM_INTERMEC_SOFTWARE_CON-
TENT, 244
ITC_NVPARM_LAN9000_INSTALLED, 246
ITC_NVPARM_MANF_DATE, 243
ITC_NVPARM_MCODE, 244
ITC_NVPARM_RTC_RESTORE, 245
ITC_NVPARM_SERIAL NUM, 243
ITC_NVPARM_SERIAL2 INSTALLED, 246
ITC_NVPARM_SERVICE_DATE, 243
ITC_NVPARM_SIM_PROTECT_HW_INSTALLED,
246
ITC_NVPARM_SIM_PROTECT_SW_INSTALLED,
246
ITC_NVPARM_VERSION_NUMBER, 244
ITC_NVPARM_VIBRATE_INSTALLED, 246
ITC_NVPARM_WAN_FREQUENCY, 245
ITC_NVPARM_WAN_INSTALLED, 245
ITC_NVPARM_WAN_RADIOTYPE, 245
ITC_NVPARM_WAN_RI, 244
ITC_REGISTRY_SAVE_ENABLE, 248

K

KernelloControl
IOCTL_GET_CPU_ID, 257
IOCTL_HAL COLDBOOT, 252, 283
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL GET_OAL_VERINFO, 250
IOCTL_HAL GET_RESET_INFO, 253
IOCTL_HAL ITC _READ_PARM, 243
IOCTL_HAL ITC WRITE_SYSPARM, 247
IOCTL_HAL_REBOOT, 255, 283
IOCTL_HAL WARMBOOT, 252, 283
IOCTL_PROCESSOR_INFORMATION, 256
KernelloControl(), 242
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L

IpBytesReturned
IOCTL_GET_CPU_ID, 257
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL_GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL ITC _READ_PARM, 243
IOCTL_HAL ITC WRITE_SYSPARM, 247
IOCTL_PROCESSOR_INFORMATION, 256
IpInBuf
IOCTL_GET_CPU_ID, 257
IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL_GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL ITC READ_PARM, 243
IOCTL_HAL ITC WRITE_SYSPARM, 247
IOCTL_HAL_REBOOT, 255
IOCTL_HAL_WARMBOOT, 252
IOCTL_PROCESSOR_INFORMATION, 256
lpInBufSize
IOCTL_GET_CPU_ID, 257
IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL_REBOOT, 255
IOCTL_HAL_WARMBOOT, 252
IpOutBuf
IOCTL_GET_CPU_ID, 257
IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL GET_BOOT_DEVICE, 254
IOCTL_HAL_GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL GET_DEVICE_INFO, 242
IOCTL_HAL GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL ITC READ_PARM, 243
IOCTL_HAL ITC WRITE_SYSPARM, 247
IOCTL_HAL_REBOOQOT, 255
IOCTL_HAL_WARMBOOT, 252
IOCTL_PROCESSOR_INFORMATION, 256

M
ManifestName, FTP Server, 236

N
nDeviceld, NLEDGetDevicelnfo, 282
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NDIS_ENCRYPTION_1_ENABLED

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_1_KEY_ABSENT

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_2_ENABLED

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_2_KEY_ABSENT

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_3_ENABLED

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_3_KEY_ABSENT

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_DISABLED

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_ENCRYPTION_NOT_SUPPORTED

EncryptionStatus(), 271

GetWepStatus(), 268
NDIS_MIXED_CELL_OFF, SetMixedCellMode(), 274
NDIS_MIXED_CELL_ON, SetMixedCellMode(), 274
NDIS_NET_AUTO_UNKNOWN

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_MODE_ESS

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_MODE_IBSS

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_MODE_UNKNOWN

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_TYPE_DS, GetNetworkType(), 265
NDIS_NET_TYPE_FH, GetNetworkType(), 265
NDIS_NET_TYPE _OFDM_2_ 4G

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_TYPE_OFDM_5G

GetNetworkMode(), 264

SetNetworkMode(), 273
NDIS_NET_TYPE_UNDEFINED, GetNetworkType(),

265

NDIS_NETWORK_EAP_MODE_OFF

GetCCXStatus(), 269

SetCCXStatus(), 274
NDIS_NETWORK_EAP_MODE_ON

GetCCXStatus(), 269

SetCCXStatus(), 274
NDIS_POWER_LEVEL_1, GetTXPower(), 267
NDIS_POWER_LEVEL_15, GetTXPower(), 267
NDIS_POWER_LEVEL_30, GetTXPower(), 267
NDIS_POWER_LEVEL_5, GetTXPower(), 267
NDIS_POWER_LEVEL_63, GetTXPower(), 267
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NDIS_POWER_LEVEL_UNKNOWN, GetTXPower(),
267
NDIS_RADIO_ASSOCIATED, GetAssocationStatus(),
261
NDIS_RADIO_AUTH_MODE_AUTO
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_ERROR
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_OPEN
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_SHARED
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_WPA
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_WPA_NONE
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_AUTH_MODE_WPA_PSK
GetAuthenticationMode(), 262
SetAuthenticationMode(), 272
NDIS_RADIO_POWER_AUTO
GetPowerMode(), 266
SetPowerMode(), 273
NDIS_RADIO_POWER_MODE_CAM
GetPowerMode(), 266
SetPowerMode(), 273
NDIS_RADIO_POWER_MODE_FAST_PSP
GetPowerMode(), 266
SetPowerMode(), 273
NDIS_RADIO_POWER_MODE_PSP
GetPowerMode(), 266
SetPowerMode(), 273
NDIS_RADIO_POWER_UNKNOWN
GetPowerMode(), 266
SetPowerMode(), 273
NDIS_RADIO_SCANNING, GetAssociationStatus(), 261
nInBufSize
IOCTL_HAL_GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL_ITC_READ_PARM, 243
IOCTL_HAL_ITC_WRITE_SYSPARM, 247
IOCTL_PROCESSOR_INFORMATION, 256
nInfold, NLEDGetDevicelnfo, 282
NLED_COUNT_INFO, NLEDGetDevicelnfo, 282
NLED_SETTINGS_INFO_ID, NLEDGetDevicelnfo,
282
NLED_SUPPORTS_INFO_ID, NLEDGetDevicelnfo,
282
NLEDGetDevicelnfo, 282
NLEDSetDevice, 282
nOutBufSize
IOCTL_GET_CPU_ID, 257
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IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL_GET_BOOT_DEVICE, 254
IOCTL_HAL _GET_BOOTLOADER_VERINFO,
251
IOCTL_HAL_GET_DEVICE_INFO, 242
IOCTL_HAL_GET_DEVICEID, 249
IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL_ITC_READ_PARM, 243
IOCTL_HAL_ITC_WRITE_SYSPARM, 247
IOCTL_HAL_REBOOT, 255
IOCTL_HAL_WARMBOOT, 252
IOCTL_PROCESSOR_INFORMATION, 256

o

Object store
IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL_REBOOQOT, 255
IOCTL_HAL_WARMBOOT, 252
Oldstyle device ID, 249
OSVERSIONINFO.dwBuildNumber, 218
OSVERSIONINFO.dwVersionMajor, 218
OSVERSIONINFO.dwVersionMinor, 218

P

PauseAtStartup, FTP Server, 236

plnput, NLEDSetDevice, 282

Pocket PC
IOCTL_HAL_GET_BOOTLOADER_VERINFO,

251

IOCTL_HAL GET_OAL_VERINFO, 250

pOutput, NLEDGetDevicelnfo, 282

Processor information, IOCTL_PROCESSOR_IN-

FORMATION, 256
ProcessorType, [CEDevice], 218
Provider, [Version], 216

Q

Query Information functions, 261

RadioConnect(), 260
RadioDisassociate(), 261
RadioDisconnect(), 260
ReadFile(), NPCP printing, 191
Reboot methods
IOCTL_HAL_COLDBOOT, 283
IOCTL_HAL_REBOOT, 283
IOCTL_HAL_WARMBOOT, 283
RegFlushKey(), 123, 233
RegisterDevice(), 191
DTR printing, 196
Registry
FTP Server parameters, 235
save location, IOCTL_HAL_ITC_WRITE_SYSPARM,
247
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RegOpenKeyEx(), 285
RegQueryValueEx(), 285
RegSetValueEx(), 285
RemoveWep(), 275
RenewDHCP(), 278
ResetRadioToSystemSave(), 279
RFC 959, 239

Root, FTP Server, 236

S

Set information functions, 270
SetAuthenticationMode(), 272
SetCCXStatus(), 274
SetChannel(), 272
SetDiversity(Deprecated), 280
SetMixedCellMode(), 274
SetNetworkMode(), 273
SetPowerMode(), 273

SetRTSThreshold(Deprecated), 280

SetSSID(), 274
SetTXRate(Deprecated), 280
SHFullScreen(), 233

shortcut_list_section, [CEShortcuts]

shortcut_filename, 225
shortcut_type_flag, 225
target_file/path, 225
target_file_path, 225
Signature, [Version], 216
SIM cards
protection hardware, 246
protection software, 246
software installed, 246
[SourceDiskFiles], filename, 221
[SourceDiskNames]
CESignature, 220
disk_ordinal, 220
SourceDisksNames.MIPS, 221
SourceDisksNames.SH3, 221
StartScanList(), 277
StartSupplicant(), 277
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StopSupplicant(), 278

string_key, [Strings], 217

[Strings], string_key, 217
SwitchPacketDriver(), 280
SYSTEMINFO.dwProcessorType, 218

U

UDP, FTPDCE, 237

UDP broadcasts, IDNATarget parameter, 236
UnsupportedPlatforms, [CEDevice], 218
UUID, 249

\')

[Version]

CESignature, 216

Provider, 216

Signature, 216
VersionMax, [CEDevice], 218
VersionMin, [CEDevice], 218
VN_CLASS_ASIC, 244
VN_CLASS_BOOTSTRAP, 244
VN_CLASS_KBD, 244

w

WAN radio IDs
ITC_DEVID_WANRADIO_NONE, 245
ITC_DEVID_WANRADIO_SIEMENS_MC45, 245
ITC_DEVID_WANRADIO_SIEMENS_MC46, 245
ITC_DEVID_WANRADIO_SIERRA_SB555, 245
Warm boot
IOCTL_HAL_REBOOT, 255
IOCTL_HAL_WARMBOOT, 252
Wireless TCP/IP installations, BlockSize parameter, 235
WriteFile()
DTR printing, 196, 197
IrDA printing, 190
NPCP printing, 191, 192

X
Xscale processor ID, IOCTL_GET_CPU_ID, 257
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General Index

Numbers

1470 Imager. See Imager
1551/1553 Tethered Scanner
See also Tethered scanner
configuring, 209
reset to factory defaults, 212
troubleshooting, 212
1D laser scanner, about, 199
1D OmniDir Decode Enable, configuration parameter,
334
2D Imager, about, 199
4820 printer, NPCP driver, 191
6804DM printer
DTR driver, 196
IrDA driver, 190
6804T printer
DTR driver, 196
IrDA driver, 190
6805A printer
DTR driver, 196
IrDA driver, 190
6806 printer
DTR driver, 196
IrDA driver, 190
6808 printer
DTR driver, 196
IrDA driver, 190
printer support, 189
681T printer, DTR driver, 196
6820 printer
IrDA driver, 190
NPCP driver, 191
printer support, 189
6920 Communications Server, ManifestName parameter,
236
740 Color Computer, 284
781 printers, DTR driver, 196
782T printer, printer support, 189
802.11
antenna color code, 127
API, 259
channel, 366
communications setup, 129, 365
configuration profiles, 259
CORE module, 133
LEAP
network EAP, 383
WPA encryption, 382
network type, 366
PEAP
network EAP, 372
WPA encryption, 371
profile label, 366
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profile security information, WEP encryption, 368
profiles, 365
advanced settings, 384
basic information, 366
security information, 367
SSID (network name), 366
TTLS, WPA encryption, 378
WPA authentication, Zero Configuration, 109
WPA authentication with pre-shared key, Zero Config-
uration, 109
WPA encryption, 369
zero configuration, WEP encryption, 108
802.11 CF radio CORE module, 133
installing available modules, 132
loading a module, 133

A

Abstract Syntax Notation.1. See ASN.1
Accessory list, 22
Accounts, via Inbox, 75
Activation wizard
Phone application, CDMA radios, 145
phone application, CDMA radios, 140
ActiveSync
ActiveSync Help, 45
adding programs, 42
adding programs to Start menu, 43
Folder behavior connected to e-mail server, 74
installing applications, 119
Microsoft Reader, 90
Pocket Internet Explorer
favorite links, 94
mobile favorites, 95
Mobile Favorites folder, 94
Start menu icon, 27
URL, 44
Windows Mobile, 44
ActiveX control tools, unit information control panel, CAB
files, 357
AD command, with/without data, 337
Adding bookmarks, Microsoft Reader, 93
Adding drawings to text, Microsoft Reader, 93
Adding programs
ActiveSync, 42
Pocket Internet Explorer, 42
to the Start menu, 43
via ActiveSync, 43
via File Explorer, 43
Windows Mobile, 41
Adjusting settings, Windows Mobile, 41
Adobe Acrobat Reader, URL, 177
AE command, with/without data, 339
Aimer LED Duration, configuration parameter, 330
All-Day events, Calendar, 48
creating, 52
Alpha plane on keypad, 285
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Alphanumeric keypad
alpha (blue) key sequences, 15
[gold/white] key sequences, 13
registry settings
alpha plane, 285
gold plane, 285
unshifted plane, 285
scan codes, 288
Ambient lighting, 2
Annotations index, Microsoft Reader, 93
Antenna, radio type, 127
APIs
802.11, 259
AT command interface, 177
IrSock, 190
App launch, control panel applet, 361
Application keys
app launch control panel applet, 361
wakeup mask control panel applet, 360
Appointments
Calendar
adding a note, 54
assigning to a category, 56
changing, 51
creating, 51
deleting, 58
finding, 58
making recurring, 55
setting a reminder, 53
viewing, 49
via Calendar, 46
APS linear imager, about, 199
ASCII
printing, 190
printing to a port, port print method, 190
raw text to printer, 190
ASN.1, 187
AT command interface, 177
testing, 178
Attaching notes to text, Microsoft Reader, 93
Audio, phone application, 155
Audio control panel applet, input mixing, 8
Audio files, Windows Media Player, 89
Audio system
external headset jack, 4
microphone, 4
speaker, 3
AutoCab, command line syntax, 124
AutoFTP, 240
AutolP, 186
Automatic Private IP. See AutolP
Automatic shutoff
bar code configuration, 385, 390
configuration parameter, 385
Autostart FTP, 240
AvantGo channels, Pocket Internet Explorer, 96
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AXCommunication, 357
AXFileTransfer, 357
AXReaderCommand, 357
AXVWedge, 357

Backlight control panel applet
ambient light sensor, 2
keypad, 11

Backlight timeout
bar code configuration, 386, 390
configuration parameter, 386

Bar code configuration
audio volume, 385
automatic shutoff, 385
backlight timeout, 386
key clicks, 386

Bar codes
configuration

audio volume, 389
automatic shutoff, 390
backlight timeout, 390
Code 39, 389
key clicks, 391
internal scanner supported symbologies, 203
scanning labels, 389
supported symbologies, 295
symbologies
Codabar, 394
Code 11, 394
Code 128, 396
Code 39, 394
Code 39 concatenation, 395
Code 39 full ASCII, 395
Code 93, 395
Data Matrix, 397
EAN, 397
I12of5, 398
Matrix 2 of 5, 398
MaxiCode, 398
Micro PDF417, 399
MSI code, 400
PDF417, 398
Plessey, 399
QR code, 400
S 2 of 5, 400
Telepen, 401
UPC, 401
tethered scanner supported symbologies, 213

Battery
ambient lighting, 2
low battery conditions, 6
RAM maintenance, 6
status, 5

Index

Battery status, unit information control panel applet, 355
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Beeper
configuration parameter
frequency, 327
volume, 325, 326
disabling the volume, 326
selecting a volume, 9
silencing the volume, 10
supported functions, 324
volume, turning it on, 7
when not available
beeper frequency, 327
good read beep duration, 329
good read beeps, 328
Bell Mobility activation process, 176
Block recognizer, Windows Mobile input panel, 32
Bluealps CORE module
installing available modules, 132
loading a module, 133
Bluetooth
accessing, 182
activating, 182
unit information control panel, main stack CAB file,
356
WPport, 183
Bluetooth compatibility, network support, 182
Books, Microsoft Reader
adding bookmarks, 93
adding drawings, 93
annotations index, 93
attaching notes, 93
copying, 93
downloading, 90
highlighting, 93
reading, 92
removing, 93
searching, 93
Browsing the Internet, Pocket Internet Explorer, 97
Build information, software, 18

C

CAB files
after the extraction, 228
creating, 216
INF files, 216
with CAB Wizard, 231
installation functions, SETUP.DLL, 228
placing files onto storage card, 122
unit information control panel applet, 356
Cabinet Wizard
creating CAB files, 231
troubleshooting, 232
using the application, 216
Cabling, scanner, 207
Calendar
all day events, 48
creating, 52
appointments
adding a note, 54
assigning to a category, 56
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changing, 51
creating, 51
deleting, 58
finding, 58
making recurring, 55
setting a reminder, 53
viewing, 49
categories, 47
meetings, sending a request, 57
options, changing, 59
Pocket Outlook, 46
recurrence pattern, 49
Start menu icon, 27
synchronizing, 47
Call Guard alert, enable while roaming, Phone application,
CDMA radios, 147
Call history, Phone application
CDMA radios, 144
GSM radios, 150
Capacitor, internal super, 6
Capturing thoughts and ideas, via Notes, 71
Card support
CompactFlash cards, 19
MultiMediaCards, 19
radios, 21
Secure Digital cards, 19
Carrier, location of ESN, 160
Categories
calendar, 47
contacts, assigning to, 65
CDMA/1xRTT, 135
activation with SB555 Watcher, 160
Bell Mobility, 176
Sprint, 167
Telus, 176
Verizon, 163
antenna color code, 127
AT command set, 177
copying files from web site, 157
via Microsoft ActiveSync, 158
via storage cards, 158
CORE module, 136
location of ESC, 160
phone activation, 140
phone application, 140
setting up, 157
terminology, 157
CElmager
location of the executable file, 122
migrating AUTORUN.DAT files, 122
Channel, 802.11 radio module, 366
Clock
restore real-time after cold-boot, 359
setting date and time, 388
Windows Mobile settings, 41
Closing drivers, NPCP, 192
Codabar, 394
configuration parameter, 298
user 1D, 317

700 Series Color Mobile Computer User’s Manual



Code 11, 394
configuration parameter, 312
user ID, 321
Code 128, 396
configuration parameter, 301
ENCI1 character, 303
user ID, 317
Code 39, 394
configuration parameter, 296
user ID, 317
Code 93, 395
configuration parameter, 300
length, 300
user ID, 318
Code Division Multiple Access. See CDMA/1xRTT
Codes
11, 394
128, 396
39, 394
39 concatenation, 395
39 full ASCII, 395
93, 395
Cold boot, performing, 17
COM A, modem position, 358
COM B, serial position, 358
COM port
configuration, 205
wedge settings, 205
COM1, NPCP parameter, 191
COM1 port, 190
Comm port wedge
disabling, 205
enabling, 204
error messages, 205
limitations, 207
settings, 205
unit information control panel, 356
Command line syntax, AutoCab, 124
Common Object Resource Environment. See CORE
Communications
DTR, 197
NPCP, 194
CompactFlash cards
card support, 19
installing applications, 120
migrating applications, 122
packaging an application, 118
Computer shutdown, 6
Concatenation, 395
Configuration parameters
1D OmniDir decode enable, 334
aimer LED duration, 330
automatic shutoff, 385
backlight timeout, 386
beeper, 325
frequency, 327
volume, 326
codabar, 298
user ID, 317
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code 11, 312
user 1D, 321
code 128, 301
FNCI1 character, 303
user 1D, 317
code 39, 296
user 1D, 317
code 93, 300
length, 300
user 1D, 318
datamatrix, 314
date/time, 386
EAN
13 user ID, 320
8 user ID, 320
good read
beep duration, 329
beeps, 328
identification
contact, 351
location, 353
name, 352
image dimension, 332
interleaved 2 of 5, 309
user 1D, 318
key clicks, 386
lighting mode, 333
macro PDF, 306
matrix 2 of 5, 310
user 1D, 320
maxicode, 315
micro PDF417, 308
MSI, 305
user 1D, 318
PDF417, 306
user 1D, 318
plessey, 304
user 1D, 319
prefix, 322
QR code, 313
security
encryption key, 348
read encryption, 346
read-only community string, 344
read/write community string, 345
write encryption, 347
SNMP, security subnet mask, 316
standard 2 of 5, 297
user 1D, 319
sticky aimer duration, 331
suffix, 323
telepen, 311
user 1D, 320
trap
authentication, 349
threshold, 350
UPC
A user ID, 319
E user ID, 319
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UPC/EAN, 299
virtual wedge, 335
code page, 341
grid, 340
postamble, 338
preamble, 336
volume, 385
Configuring service settings, Phone application, GSM ra-
dios, 152
Connecting to
an ISP, 98
e-mail server, 114
work, 102
Connecting to a mail server, via Inbox, 75
Connections
See also Getting connected
directly to e-mail server, 114
ending, 113
setting up an e-mail account, 114
to an ISP, 98
via modem, 98
to work, 102
via modem, 103
via VPN server, 111

via modem
to an ISP, 98
to work, 103

via VPN server, to work, 111
via wireless network, 106
Conserving battery power, 2
Contacts
adding a note, 64
adding a telephone number
CDMA radios, 144
GSM radios, 150
adding to speed dial, 68
assigning to a category, 65
changing, 63
changing options, 68
copying, 65
creating, 61, 63
deleting, 67
finding, 67
MSN Messenger
managing, 87
sending messages, 88
working with, 86
Pocket Outlook, 60
sending a message, 66
Start menu icon, 27
synchronizing, 61
viewing, 62
Control panel applets
Audio, 8
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backlight, 2, 11
clock, 388
data collection, 294
beeper volume, 9
beeper/LED, 324
imager, 330
symbologies, 295
symbology options, 316
vibrator, 20
virtual wedge, 335
intemec settings
beeper volume, 10
vibrator, 21
intermec settings, 294, 342
phone settings
CDMA radios, 146
GSM radios, 151
power
battery status, 5
RAM maintenance, 6
SNMP, 343
identification, 351
security, 344
traps, 349
system, wireless network, 129, 365
unit information, 354
battery status, 5, 355
CARB files, 356
versions, 18, 354
utilities, 358
app launch, 361
dock switch, 358
registry save, 123, 359
wakeup mask, 360
wireless network, 363
Converting writing to text, 35
Copying, contacts, 65
Copying text, Microsoft Reader, 93
CORE, 132
802.11 CF module, 133
802.11 radio module
details, 135
general, 134
accessing from
Programs panel, 132
Today screen, 133
activating, 132
installing available modules, 132
loading a module, 133
module for 8§02.11 NIC, 259
WAN monitor, GSM/GPRS, 138
WAN radio module
CDMA/1xRTT, 136
general, 138
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Creating

a modem connection

to an ISP, 98

to work, 103
a VPN server connection, to work, 111
a wireless network connection, 106
CAB files, 216

with CAB Wizard, 231
contacts via Contacts, 61
document via Pocket Word, 78
drawing via Notes, 37
INF files, 216
note via Notes, 71
task via Tasks, 70
workbook via Pocket Excel, 82

standard 2 of 5 user ID, 319
sticky aimer duration, 331
suffix, 323
telepen, 311
telepen user ID, 320
UPC-E user ID, 319
UPC-A user ID, 319
UPC/EAN, 299
virtual wedge, 335
virtual wedge code page, 341
virtual wedge grid, 340
virtual wedge postamble, 338
virtual wedge preamble, 336

vibrator, 20

Data Matrix, 397
configuration parameter, 314

Index

D Date, setting, 388

Data, Phone application, CDMA radios, 147 Date/Time, configuration parameter, 386
; DHCP, 186
Data collection

configuration parameters
1D OmniDir decode enable, 334
aimer LED duration, 330
beeper, 325
beeper frequency, 327
beeper volume, 326
codabar, 298
codabar user ID, 317

Display full screen, 233
Dock switch, control panel applet, 358
Docks, modem support, 16
DRAM
low battery shutdown, 6
maintenance, 6
Drawing mode, Pocket Word, 81
Drawing on the screen

code 11, 312 Ié;ee ikOVNVOtZS o
code 11 user ID, 321 Driv(;; et Word,
code 128, 301 e

code 128 FNCI1 character, 303
code 128 user ID, 317

communications, 197

installing, 196

code 39, 296 ing, 1
code 39 user ID, 317 opening,
code 93, 300 removing, 196

code 93 length, 300

code 93 user ID, 318
datamatrix, 314

EAN-13 user ID, 320
EAN-8 user ID, 320

good read beep duration, 329
good read beeps, 328
image dimension, 332
interleaved 2 of 5, 309
interleaved 2 of 5 user ID, 318
lighting mode, 333

macro PDF, 306

matrix 2 of 5, 310

matrix 2 of 5 user ID, 320
maxicode, 315

micro PDF417, 308

MSI, 305

MSTI user ID, 318
PDF417, 306

PDF417 user ID, 318
plessey, 304

plessey user ID, 319
prefix, 322

QR code, 313

standard 2 of 5, 297
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writing to, 197
NPCP

closing, 192

communications, 194

I/O controls, 193

installing, 191

opening, 192

reading from, 192

removing, 191

writing to, 192
O’Neil. See DTR printing

DTR printing, 196

closing driver, 197
communications, 197
opening driver, 197
removing driver, 196
writing to driver, 197

E

E-mail account, setting up an account, 114
E-mail server, getting connected, 114
EAN, configuration parameter, 299

13 user ID, 320

8 user ID, 320
Editing a profile, 365
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Edition information, 24 creating a VPN server connection, 111
Emails, SMS messages via Phone application creating a wireless network connection, 106
CDMA radios, 145 Windows Mobile, 98
GSM radios, 151 Gold plane on keypad, 284
Encoded Code 39 Good read, configuration parameter
concatenation, 395 beep duration, 329
full ASCII, 395 beeps, 328
Ending a connection, 113 Grid data, configuration parameter, 340
Epson Escape Sequences, 190 GSM/GPRS, 138
Error messages antenna color code, 127
comm port wedge, 205 AT command set
tethered scanner, 205 MC45, 177
ESN, location on computer, 160 MC46, 177
Ethernet, communications setup, 128 CORE module, 138
ETSI GSM 07.05 interface specifications, 177 phone application, 149, 154

ETSI GSM 07.07 interface specifications, 177

European Article Numbering. See EAN H
European Article Numbering code. See EAN Handset o
phone application, 154
F volume, 156
Favorite links, Pocket Internet Explorer, 94 Headset jack, external, 4
File Explorer Hiding your location from everyone except 911, CDMA
adding programs to Start menu, 43 radios, 146
removing programs, 43 Highlighting text, Microsoft Reader, 93
Windows Mobile, 40 I
Find feature, Windows Mobile, 40
Flash File Store I2 of 5. See Interleaved 2 of 5
migrating applications, 122 I/O controls, NPCP driver, 193
packaging an application, 118 Identification, configuration parameter
Flash file system, control panel applet, 359 contact, 351
Folder behavior connected to e-mail server location, 353
ActiveSync, 74 name, 352
IMAP4, 74 IDNA
POP3, 74 IDNATarget, 236
SMS, 74 ManifestName, 236
FRAME_NOT_ACKED, 193 Image dimension, configuration parameter, 332
FTP Imager
configurable parameters beeper functions not available
IDNATarget, 236 beeper frequency, 327
ManifestName, 236 good read beep duration, 329
Root, 236 good read beeps, 328
heartbeat, 237 beeper/LED parameters, beeper, 325
server, installing applications, 120 control pan.el appet, data collection, 330
FTPDCMDS subdirectory, FTP support, 239 data collection parameters
Full screen display, 233 1D OmniDir decode enable, 334
aimer LED duration, 330
G datamatrix, 314
GDI approach, 190 image dimension, 332
General Packet Radio Service. See GSM/GPRS lighting mode, 333
Getting connected maxicode, 315
directly to an e-mail server, 114 QR code, 313
ISP, 98 sticky aimer duration, 331
setting up an e-mail account, 114 settings, 206
to an ISP, 98 supported
creating a modem connection, 98 beeper functions, 324
to work, 102 functions, 330
creating a modem connection, 103 symbologies, 295
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symbologies not available
CIP 128 French Pharmaceutical, 302
Code 11, 312
Code 128 FNCI1 character, 303
EAN 128 ]C1, 302
Macro PDF, 306
Matrix 2 of 5, 310
micro PDF417, 308
Telepen, 311
symbology user IDs not available
Codabar, 317
Code 11, 321
Code 128, 317
Code 39, 317
Code 93, 318
EAN 13, 320
EAN 8, 320
Interleaved 2 of 5, 318
Matrix 2 of 5, 320
MSI, 318
PDF417, 318
Plessey, 319
Standard 2 of 5, 319
Telepen, 320
UPC A, 319
UPCE, 319
vibrator, enabling, 20
IMAP4, Folder behavior connected to e-mail server, 74
Inbox
accounts, 75
composing/sending messages, 77
connecting to a mail server, 75
downloading messages from server, 76
getting connected, 98
managing e-mail messages and folders, 74
Pocket Outlook, 73
Start menu icon, 27
synchronizing e-mail messages, 73
using My Text, 39
INF files, creating, 216
Input Mixing, Audio control panel applet, 8
Input panel
block recognizer, 32
keyboard, 31
letter recognizer, 33
Pocket Word, 79
selecting typed text, 33
transcriber, 33
Windows Mobile, 28
word suggestions, 31
Installation functions, SETUP.DLL, 228
Installing applications
using a storage card, 120
using CompactFlash cards, 120
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using Secure Digital cards, 121

with ActiveSync, 119

with FTP Server, 120
Installing drivers

DTR, 196

NPCP, 191
Instant messaging, 84
Integrated scanners. See Internal scanners
Interface specifications, ETSI GSM 07.0x, 177
Interleaved 2 of 5, 398

configuration parameter, 309

user 1D, 318

Intermec part numbers, 22
Intermec settings, 294, 342

beeper volume, 10

vibrator, 21
INTERMEC_PACKET_DRIVER, SwitchPacketDriver(),

280

Internal scanners

configuring, 202

supported symbologies, 203
Internet explorer

software build version, 18

Windows Mobile 2003 edition, 24
Internet Service Provider. See ISP
IOCTL_NPCP_BIND, 193
IOCTL_NPCP_CANCEL, 193
IOCTL_NPCP_CLOSE, 193
IOCTL_NPCP_ERROR, 193
IOCTL_NPCP_FLUSH, 193
IrDA printing, 190
ISP

connecting to via Windows Mobile, 98

creating, a modem connection, 98

Pocket Internet Explorer, 94

Windows Mobile, 98
ITC_KEYBOARD_CHANGE, CreateEvent(), 286
ITU-T interface specifications, 177

K
Keeping a to-do list, via Tasks, 69
Key clicks
bar code configuration, 386, 391
configuration parameter, 386
Key sequences
alpha (blue) keys
alphanumeric, 15
numeric, 14
[gold] keys, numeric, 12
[gold/white] keys, alphanumeric, 13
Keyboard
See also Keypad
Windows Mobile input panel, 31
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Keypad
advanced remapping, 286
alphanumeric
alpha (blue) key sequences, 15
[gold/white] key sequences, 13
scan codes, 288
backlight control panel applet, 11
change notification, 286
driver registry settings, 286
numeric
alpha (blue) key sequences, 14
[gold] key sequences, 12
scan codes, 287
planes, 284
remapping, 284
sample registry keys, 290

L

Laser scanner

configuration parameters, 292

data collection parameters
beeper frequency, 327
beeper volume, 326
codabar, 298
codabar user ID, 317
code 11, 312
code 11 user ID, 321
code 128, 301
code 128 FNCI1 character, 303
code 128 user ID, 317
code 39, 296
code 39 user ID, 317
code 93, 300
code 93 length, 300
code 93 user ID, 318
EAN-13 user ID, 320
EAN-8 user ID, 320
good read beep duration, 329
good read beeps, 328
interleaved 2 of 5, 309
interleaved 2 of 5 user ID, 318
macro PDF, 306
matrix 2 of 5, 310
matrix 2 of 5 user ID, 320
micro PDF417, 308
MSI, 305
MSI user 1D, 318
PDF417, 306
PDF417 user ID, 318
plessey, 304
plessey user ID, 319
prefix, 322
standard 2 of 5, 297
standard 2 of 5 user ID, 319
suffix, 323
telepen, 311
telepen user ID, 320
UPC-E user ID, 319
UPC-A user ID, 319
UPC/EAN, 299

418

virtual wedge, 335
virtual wedge code page, 341
virtual wedge grid, 340
virtual wedge postamble, 338
virtual wedge preamble, 336
SNMP configuration parameters
identification contact, 351
identification location, 353
identification name, 352
security encryption key, 348
security read encryption, 346

security read-only community string, 344
security read/write community string, 345

security subnet mask, 316
security write encryption, 347
trap authentication, 349
trap threshold, 350
supported
beeper functions, 324
symbologies, 295
symbologies not available
Datamatrix, 313
datamatrix, 314
maxicode, 315
LEAP
802.11 radio module
network EAP, 383
WPA encryption, 382
profile security information, 381
WEP encryption, 381

Letter recognizer, Windows Mobile input panel, 33
Letting your location be visible, CDMA radios, 146

Library, Microsoft Reader, 91

Lighting Mode, configuration parameter, 333

Line printing, 190

Location, Phone application, CDMA radios, 146

LPT9 printer device, 191

M

Macro PDF, configuration parameter, 306

Managing e-mail messages and folders, via Inbox, 74

Matrix 2 of 5, 398
configuration parameter, 310
user 1D, 320
MaxiCode, 398
configuration parameter, 315
Meetings
Calendar, sending a request, 57
via Calendar, 46
Menus, Windows Mobile settings, 41
Messages
sending to, contacts, 66
via Inbox
composing/sending, 77
downloading from server, 76
MIBs
ASN.1, 187
files, 187
object identifier, 188
OIDs, 188
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Micro PDF417, 399
configuration parameter, 308
Microphone, 4
phone application, 154

Microsoft Developer Network Library. See MSDN library

Microsoft Exchange e-mail account, 84
Microsoft Passport account, 84
Microsoft Reader
books
downloading, 90
reading, 92
removing, 93
features, 93
adding bookmarks, 93
adding drawings, 93
annotations index, 93
attaching notes, 93
copying text, 93
highlighting text, 93
searching for text, 93
using the library, 91
Windows Mobile, 90
Microsoft’s Wireless Zero Config, 365
Migrating applications
Flash File Store, 122
CompactFlash storage cards, 122
Secure Digital storage cards, 122
Migrating to a 700 Color Computer, 124
Mobile Favorites, Pocket Internet Explorer, 95
Mobile Favorites folder, Pocket Internet Explorer, 94
Modem position, COM A, 358
Modems, creating a connection
to an ISP, 98
to work, 103
MP3 files, Windows Media Player, 89
MSDN library, 240
MSDN Windows CE documentation, 186
MSI, 400
configuration parameter, 305
user 1D, 318
MSN Messenger
about, 84
accounts
Microsoft Exchange e-mail, 84
Microsoft Passport, 84
contacts
managing, 87
sending messages, 88
working with, 86
setting up an account, 85
using My Text, 39
MultiMediaCards, card support, 19

N

NDIS_SUPP_LOGGING_OFF, EnableSuppLogging(),
279

NDIS_SUPP_LOGGING_ON, EnableSuppLogging(),
279

NDISUIO_PACKET_DRIVER, SwitchPacketDriver(),
280
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Network adapters
antenna color code, 127
Ethernet communications, 128
no networking, 130
wireless 802.11, 129
wireless printing, 182
Network EAP
LEAP security method, 383
PEAP security method, 372
Network settings, Phone application, GSM radios, 153
Network type, 802.11 radio module, 366
NLED driver, vibrator, 281
NLED_SETTINGS_INFO_ID, NLEDSetDevice, 282
Notes
adding to
appointments, 54
contacts, 64
creating a note, 71
drawing on the screen, 37
creating a drawing, 37
selecting a drawing, 37
Pocket Outlook, 71
recording a message, 38
Start menu icon, 27
synchronizing notes, 72
writing on the screen, 34
alternate writing, 35
converting writing to text, 35
selecting the writing, 34
tips for good recognition, 36
NPCP printing, 191
about, 191
closing driver, 192
COM1 parameters, 191
communications, 194
driver I/O controls, 193
installation, 191
LPT9, 191
opening driver, 192
reading from driver, 192
removal, 191
sample code, 194
unit information control panel, NPCPTEST CAB file,
356
writing to driver, 192
Numeric keypad
alpha (blue) key sequences, 14
[gold] key sequences, 12
registry settings
alpha plane, 285
gold plane, 285
unshifted plane, 285
scan codes, 287

(o)
O’Neil printing
See also DTR printer
installing driver, 196
Object Store, packaging an application, 118
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Opening drivers network settings, GSM radios, 153
DTR, 197 view current settings via Phone application, CDMA
NPCP, 192 radios, 148

Owner information, Windows Mobile settings, 41 PhoneUltility, 154

ring, 155

P vibrate, 155

Packaging an application Planes, keypad, 284
CompactFlash storage cards, 118 Plessey, 399
Flash File Store, 118 configuration parameter, 304
Object Store, 118 user ID, 319
Persistent Storage Manager, 118 Pocket Excel
Secure Digital storage cards, 118 about, 82

Page format printing, 190 creating a workbook, 82

Password Pocket Internet Explorer
Pocket Excel, 82 about, 94
Windows Mobile settings, 41 adding programs, 42

PB20 printers, printer support, 189 AvantGo channels, 96

PDF417, 398 browsing the Internet, 97
about the laser scanner, 199 favorite links, 94
configuration parameter, 306 getting connected, 98

user ID, 318 mobile favorites, 95

PEAP Mobile Favorites folder, 94

802.11 radio module software build, 18

network EAP, 372 Start menu icon, 27

WPA encryption, 371 viewing mobile favorites and channels, 97
profile security information, 370 Pocket Outlook, 46

WEP encryption, 370 Calendar, 46

Performing a cold boot, 17 Pocket Word

Persistent Storage Manager. See PSM about, 78

Phone application creating a document, 78
CDMA radios, 140 drawing mode, 81

activation wizard, 140, 145 recording mode, 80
adding contact to speed dial, 68, 144 synchronizing, 81
call history, 144 tips, 83
customizing phone settings, 146 typing mode, 79
enable Call Guard alert while roaming, 147 writing mode, 80
hiding your location except from 911, 146 POP3, Folder behavior connected to e-mail server, 74
letting your location be visible for everyone, 146 Postamble
reset connection settings for PCS Vision, 147 configuration parameter, 338
sending SMS messages, 145 with/without data, 339
toggle between automatic or Sprint roaming, 147 Power
update your PCS Vision profile, 147 control panel
view current phone settings, 148 battery status, 5
voice mail, 145 RAM maintenance, 6
GSM radios, 149 Windows Mobile settings, 41
adding contact to speed dial, 150 Preamble
call history, 150 configuration parameter, 336
customizing phone settings, 151 with/without data, 337
finding, setting, selecting networks, 153 Prefix, configuration parameter, user ID, 322
sending SMS messages, 151 Printer support, 190
service settings, 152 IrDA printer driver, 190
Phone Info, Phone application, CDMA radios, 148 NPCP printer driver, 191
Phone jack position, control panel applet, 358 O’Neil printer driver, 196
Phone settings Profile label, 802.11 radio module, 366
control panel applet Profiles
CDMA radios, 146 802.11 radio module, 365
GSM radios, 151 advanced settings, 384

customizing via Phone application basic information, 366
CDMA radios, 146 security information, 367
GSM radios, 151 editing, 365
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Programs, adding or removing, Windows Mobile, 41
PSM

determining build version, 16

packaging an application, 118
PSM build, 294

Q
QR code, 400

configuration parameter, 313

Quick Response Code. See QR Code

R

Radios
See also Network adapters
card support, 21
Reader commands, 387
configuration change, 387
date and time settings, 388
Reading from drivers, NPCP, 192
Real-Time Clock, restore after cold-boot, 359
Record button, recording a message, 38
Recording, via Notes, 38
Recording a message, Pocket Word, 80
Recording mode, Pocket Word, 80
Recovery CD
AutoCab method, 124
AUTOUSER.DAT file, 123
RegFlushKey() API, 233
S9C upgrade, 357
updating the system software, 121
Recurrence pattern, Calendar, 49
RegFlush utility, 123
Registry
keypad remapping, 286
sample view of key mapping, 290
writing to a storage card, 123
Registry Save, control panel applet, 359
Registry settings
AutoCfg, 186
AutoFTD, 241
Autolnterval, 186
AutoIP/DHCP, 186
DhcpMaxRetry, 186
DhcpRetryDialogue, 186
EnableDHCP, 186
keypad driver, 286
keypad planes
alpha, 285
gold, 285
unshifted, 285
Removing drivers
DTR, 196
NPCP, 191
Removing programs, Windows Mobile, 41, 43
Reset button, 17
Reset connection settings for PCS Vision, Phone applica-
tion, CDMA radios, 147
Roaming, toggle between automatic or Sprint, Phone ap-
plication, CDMA radios, 147
RTC. See Real-Time Clock
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S
S 2 of 5. See Standard 2 of 5

S9C, unit information control panel, upgrade files, 357
Sabre 1551E or 1553
See also Tethered scanner
cabling, 207
settings, 206
Sample code, NPCP printing, 194
SB555 Watcher
activation, 160
Bell Mobility, 176
Sprint, 167
Telus, 176
Verizon, 163
copying files to computer, 157
via Microsoft ActiveSync, 158
via storage cards, 158
location of ESN, 160
Scan codes
alphanumeric keypad, 288
numeric keypad, 287
SCAN Mute, Audio control panel applet, 8
Scanner
beeper volume
selecting, 9
turning it off, 10
turning it on, 7
mute feature, turning it off, 8
unit configuration parameters
automatic shutoff, 385
backlight timeout, 386
date/time, 386
key clicks, 386
volume, 385
utilities configuration, button wakeup mask, 360
Scanner cabling, 207
Scheduling appointments and meetings, via Calendar, 46
SDK, unit information control panel, 357
SDMMC Disk, 122
Searching for text, Microsoft Reader, 93
Secure Digital cards
card support, 19
installing applications, 120, 121
migrating applications, 122
packaging an application, 118
Security, configuration parameter
encryption key, 348
read encryption, 346
read-only community string, 344
read/write community string, 345
subnet mask, 316
write encryption, 347
Selecting, drawing via Notes, 37
Sending and receiving messages, via Inbox, 73
Serial port, modem support, 16
Serial position, COM B, 358
Services, Phone application, GSM radios, 152
Setting date and time, 388
Setting up an e-mail account, 114
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SETUP.DLL, installation functions, 228
SIM cards
IMSI assigned
CDMA/1xRTT, 137
GSM/GPRS, 139
installation status, GSM/GPRS, 139
phone number assigned, GSM/GPRS, 138

Simple Network Management Protocol. See SNMP
SMS, Folder behavior connected to e-mail server, 74

SMS messages, Phone application
CDMA radios, 145
GSM radios, 151
Snap-on modems, 16
SNMP, 187
configuration parameters
identification contact, 351
identification location, 353
identification name, 352
security encryption key, 348
security read encryption, 346
security read-only community string, 344

security read/write community string, 345

security subnet mask, 316
security write encryption, 347
trap authentication, 349
trap threshold, 350
SNMP OIDs
1D OmniDir decode enable, 334
aimer LED duration, 330
automatic shutoff, 385
backlight timeout, 386
beeper, 325
frequency, 327
volume, 326
codabar, 298
user 1D, 317
code 11, 312
user 1D, 321
code 128, 301
FNCI1 character, 303
user 1D, 317
code 39, 296
user 1D, 317
code 93, 300
length, 300
user 1D, 318
datamatrix, 314
date/time, 386
EAN
13 user ID, 320
8 user ID, 320
good read
beep duration, 329
beeps, 328
identification
contact, 351
location, 353
name, 352
image dimension, 332
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interleaved 2 of 5, 309
user 1D, 318
key clicks, 386
lighting mode, 333
macro PDF, 306
matrix 2 of 5, 310
user 1D, 320
maxicode, 315
micro PDF417, 308
MSI, 305
user 1D, 318
PDF417, 306
user 1D, 318
plessey, 304
user 1D, 319
prefix, 322
QR code, 313
security
encryption key, 348
read encryption, 346
read-only community string, 344
read/write community string, 345
write encryption, 347
security subnet mask, 316
standard 2 of 5, 297
user 1D, 319
sticky aimer duration, 331
suffix, 323
telepen, 311
user 1D, 320
trap
authentication, 349
threshold, 350
UPC
A user ID, 319
E user ID, 319
UPC/EAN, 299
virtual wedge, 335
code page, 341
grid, 340
postamble, 338
preamble, 336
volume, 385
Software Developer’s Kit. See SDK
Software versions, 18, 354
700 Series Computer, 18
unit information control panel applet, 356
Speaker, 3
Speakerphone
phone application, 154
volume, 156
Speed dial, Phone application
CDMA radios, 144
GSM radios, 150

Sprint activation process, 167

SSID (network name), 802.11 radio module, 366

Standard 2 of 5, 400
configuration parameter, 297
user 1D, 319
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Start Menu, adding programs, 43
via ActiveSync, 43
via File Explorer, 43
Status icons, Windows Mobile, 26
Sticky Aimer Duration, configuration parameter, 331
Storage media, 19
Stream device driver
NPCPPORT.DLL, 191
ONEIL.DLL, 196
Suffix, configuration parameter, 323
Symbologies
internal scanner supported symbologies, 203
scanning labels, 389
tethered scanner supported symbologies, 213
user IDs
Codabar, 317
Code 11, 321
Code 128, 317
Code 39, 317
Code 93, 318
EAN 13, 320
EAN 8, 320
Interleaved 2 of 5, 318
Matrix 2 of 5, 320
MSI, 318
PDF417, 318
Plessey, 319
Standard 2 of 5, 319
Telepen, 320
UPC A, 319
UPCE, 319
when not available
imager, 304, 305, 306, 308, 310, 311, 312
laser scanner, 313, 314, 315
Synchronizing
AvantGo channels, 96
Calendar, 47
contacts, 61
e-mail messages, 73
favorite links, 94
mobile favorites, 95
notes, 72
Pocket Word, 81
Tasks, 70
System, Phone application, CDMA radios, 147

T

Tasks
creating a task, 70
Pocket Outlook, 69
Start menu icon, 27
synchronizing, 70
TCP/IP client, DHCP server, 186
Telepen, 401
configuration parameter, 311
user 1D, 320
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Telus activation process, 176
Testing AT commands, 178
Tethered scanner
capabilities, 207
disabling, 205
enabling, 205
error messages, 205
limitations, 207
settings, 205
supported symbologies, 213
Text messages, Windows Mobile, 39
Time, setting, 388
Tips for working, Pocket Excel, 83
TLS
802.11 profile
certificates, 380
WPA encryption, 375
profile security information
WEP encryption, 374
WPA encryption, 375
Today, Windows Mobile settings, 41
Today screen, Windows Mobile, 26
Tools CD
Bluetooth documentation, 182
CARB files, 120, 356
CE Imager, 122
Comm Port Wedge CAB file, 356
management tools installed on desktop, 119
MIB files, 187
sample NPCP code, 194
Wireless Printing Development Guide, 182
wireless printing sample, 357
wireless printing SDK, 182
Tracking people, via Contacts, 60
Transcriber, Windows Mobile input panel, 33
Trap configuration parameters
authentication, 349
threshold, 350
Traps, control panel appet, SNMP, 349
Troubleshooting
1551/1553 Tethered Scanners, 212
CAB Wizard, 232
TTLS
802.11 radio module, WPA encryption, 378
profile security information, WEP encryption, 377
Typing mode, Pocket Word, 79
Typing on the screen, Pocket Word, 79

U

Unit, configuration parameters
automatic shutoff, 385
backlight timeout, 386
date/time, 386
key clicks, 386
volume, 385
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Unit information
battery status, 355
CAB files, 356
ActiveX control tools, 357
Bluetooth stack, 356
Comm Port Wedge, 356
NPCP printer, 356
S9C Upgrade, 357
SDK, 357
Windows configuration, 357
wireless printing sample, 357
versions, 18, 354
Unit Manager, date/time, 386
Universal Product Code. See UPC
Unshifted plane on keypad, regular keypad, 284
UPC, 401
configuration parameter, 299
A user ID, 319
E user ID, 319
Update your PCS Vision profile, Phone application,
CDMA radios, 147
Updating, bootloader, 119
URLs
ActiveSync, 44
Adobe Acrobat Reader, 177
AT command interface
CDMA/1xRTT SB555, 177
GPRS/GSM MC45, 177
GPRS/GSM MC46, 177
full screen display, 233
MIBs, 187
Microsoft Exchange e-mail account, 84
Microsoft Passport account, 84
Microsoft support, 25
MSDN library, 240
MSDN Windows CE documentation, 186
Windows Mobile, 25
Windows Mobile support, 25
Utilities control panel applet
app launch, 361
dock switch, 358
registry save, 359
wakeup mask, 360

\'
Verizon activation process, 163
Vibrator
enabling, 20
phone application, 155
programming, 281
Video files, Windows Media Player, 89

Viewing mobile favorites and channels, Pocket Internet

Explorer, 97
Virtual wedge
bar code configuration

grid, 392

424

postamble, 392
preamble, 392
configuration parameter, 335
code page, 341
grid, 340
postamble, 338
preamble, 336
Voice mail, Phone application, CDMA radios, 145
Volume
bar code configuration, 385, 389
configuration parameter, 385
phone application, 154, 156

VPN server, creating a connection, to work, 111

w

Wakeup mask, control panel applet, 360
WAN monitor CORE module
CDMA/1xRTT, 135
GSM/GPRS, 138
installing available modules, 132
loading a module, 133
WAN rado CORE module
installing available modules, 132
loading a module, 133
WAP pages, 94
connecting to an ISP, 98
Watcher applications
activating, Sprint, 167
downloading, Sprint, 167
using
Sprint, 170
Verizon, 163
Web browsers, FTP support, 239
Web pages, 94
connecting to an ISP, 98
Welch Allyn 1470 Imager
cabling, 207
settings, 206
WEP encryption
LEAP security method, 381
PEAP security method, 370
profile security information, 367, 368
TLS security method, 374
TTLS security method, 377
zero configuration, 108
Windows CE documentation (MSDN), 186

Windows configuration, unit information control panel,

WinCfg CAB file, 357
Windows Media files, Windows Media Player, 89
Windows Media Player
Start menu icon, 27

Windows Mobile, 89
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Windows Mobile
ActiveSync, 44
basic skills, 26
Calendar, 46
command bar, 28
Contacts, 60
edition information, 24
getting connected, 98
Inbox, 73
MSN Messenger, 84
navigation bar, 28
Notes, 71
notifications, 29
Pocket Excel, 82
Pocket Word, 78
pop-up menus, 29
programs, 27
status icons, 26
support URLs, 25
Tasks, 69
Today screen, 26
where to find information, 25
Windows Media Player, 89
writing on the screen, 34
Wireless Network, creating a connection, 106
Wireless network, 129, 365
Wireless printing
Bluetooth compatible module, 182
unit information control panel, WP_SAMPLE.CAB file,
357
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Wireless WAN
AT command interface
CDMA/1xRTT SB555, 177
GPRS/GSM MC45, 177
GPRS/GSM MC46, 177
CDMA/1xRTT, 135
GSM/GPRS, 138
testing AT commands, 178
Work
creating
a modem connection, 103
a VPN server connection, 111
getting connected, 102
WPA authentication
802.11 radio module, Zero Configuration, 109
with pre-shared key, Zero Configuration, 109
WPA encryption
802.11 radio module, 369
LEAP security method, 382
PEAP security method, 371
TLS security method, 375
TTLS security method, 378
WPport, 183
Writing mode, Pocket Word, 80
Writing on the screen
See also Notes
Pocket Word, 80
Writing to drivers
DTR, 197
NPCP, 192
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Files Index

Numbers

80211APIL.DLL, 259
80211CONF.EXE, 259
80211SCAN.EXE, 259
802PM.DLL, 259

A
AUTOUSER.DAT, 120, 121

C

CABWIZ.DDF, 231
CABWIZ.EXE, 216, 231
CEIMAGER.EXE, 122
COREDLL.DLL, 281
CPL802.CPL, 259

D
DEVICEID.H, 249

E
EXITME.BIN, 239

F

FTPDCE.EXE, 237, 239
AutoFTP, 241
FTP Server, 234
FTPDCE.TXT, 239

INTERMEC.MIB, 187
ITCADC.MIB, 187
ITCSNMP.MIB, 187
ITCTERMINAL.MIB, 187

M

MAKECAB.EXE, 231
MOD80211.DLL, 259
N

NETWLAN.DLL, 259
NLED.H, 282
NLEDGetDevicelnfo, 282
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NLEDSetDevice, 282
NPCPPORT.DLL, 191
NRINET.INI, 357

o

OEMIOCTL.H
IOCTL_GET_CPU_ID, 257
IOCTL_HAL_COLDBOOT, 252
IOCTL_HAL_GET_BOOT_DEVICE, 254
IOCTL_HAL_GET_BOOTLOADER_VERINFO,

251

IOCTL_HAL_GET_OAL_VERINFO, 250
IOCTL_HAL_GET_RESET_INFO, 253
IOCTL_HAL_ITC_READ_PARM, 243
IOCTL_HAL_ITC_WRITE_SYSPARM, 247
IOCTL_HAL_REBOOT, 255
IOCTL_HAL_WARMBOOT, 252

ONEIL.DLL, 196

P

PKFUNCS.H
IOCTL_HAL_GET_DEVICEID, 249
IOCTL_PROCESSOR_INFORMATION, 256
PRISMNDS.DLL, 259

R

REBOOTME.BIN, 239

_ RESETMEPLEASE . TXT, 228
RPM.EXE, 221

RPMCE212.INI, 221

S

SETUP.DLL, 220, 228
DIlIMain, 228
Sprint_Watcher_PPC_2002-03xxx.CAB, 168

T
TAHOMA.TTEF, 221

U
URODDSVC.EXE, 259

w
WCESTART.INI, 221
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