
Wingbits GEOSigner Manual 

Welcome to the Wingbits GEOSigner. This guide will walk you through the steps to set up 
and interact with your GEOSigner using a serial monitor. 

1. Insert USB into PC 

• Insert the Wingbits GEOSigner into an available USB port on your computer. 

2. Open Your Favorite Serial Monitor 

• Open a serial monitor of your choice. For this manual, we will use the Arduino IDE 
as an example. 

3. Select the COM Port of the GEOSigner 

• In the Arduino IDE, go to Tools > Port, and select the COM port associated with the 
GEOSigner. 

4. Select Baud Rate 115200 

• Set the baud rate to 115200. This is the communication speed the GEOSigner operates 
at. 

5. Start the Serial Monitor 

• Open the serial monitor in the Arduino IDE by navigating to Tools > Serial Monitor, 
or by pressing Ctrl+Shift+M. 

6. Test the Device 

• Type a random command (for example, AT+SYSSTATUS) to check if the device is 
responding. 

 

Commands Overview 

The GEOSigner responds to various commands, all of which are prefixed with AT+. 
Commands are categorized into three main sections: system-related, security-related, and 
data-related. 

Command Format: 

• Prefix: AT+ (This indicates attention). 
• Category: SYS, SEC, DATA. 
• Verb-Action Style: This indicates the task to be completed (e.g., RESET, STATUS). 

 



System-Related Commands (AT+SYS) 

These commands are for managing the system's status and functions. 

• Restart the device: 
Type AT+SYSRESET 
This command will restart the GEOSigner. 

• Check device status: 
Type AT+SYSSTATUS 
This will show the current status of the GEOSigner. 

• View device ID: 
Type AT+SYSID 
This command will display the unique device ID. 

• Start OTA functionality: 
Type AT+SYSOTA 
This initiates an over-the-air (OTA) update process. 

 

Security-Related Commands (AT+SEC) 

These commands focus on encryption and authentication tasks. 

• Sign a piece of data: 
Type AT+SECSIGN 
Use this command to sign a specified piece of data for authentication purposes. 

 

Data Commands (AT+DATA) 

These commands handle data collection and management. 

• Scan for surrounding Bluetooth devices: 
Type AT+DATABLE 
This command will list the surrounding Bluetooth devices. 

• Get GPS coordinates: 
Type AT+DATAGPS 
This command will retrieve the current GPS coordinates from the GEOSigner. 

• Scan for surrounding Wi-Fi devices: 
Type AT+DATAWIFI 
This command will list all surrounding Wi-Fi networks. 

• Retrieve all data at once: 
Type AT+DATAALL 
This command will display all the available data, including Bluetooth devices, GPS 
coordinates, and Wi-Fi networks. 



Setting Up the Arduino IDE to Flash the GEOSigner (ESP32-C3) with New 
firmware 

This chapter will guide you through the process of setting up the Arduino IDE to flash new 
firmware onto the Wingbits GEOSigner, which is based on the ESP32-C3 chip. Follow the 
steps carefully to ensure the flashing process is smooth. 

 

1. Install Arduino IDE (if not already installed) 

If you do not have the Arduino IDE installed on your computer, follow these steps: 

1.1. Download Arduino IDE 
Go to the official Arduino website: 
https://www.arduino.cc/en/software  

1.2. Install the Arduino IDE 
Download and install the appropriate version for your operating system (Windows, macOS, 
Linux). Follow the installation prompts. 

 

2. Install ESP32 Add-On 

To flash software onto the GEOSigner, you need to add support for ESP32-C3 in Arduino 
IDE. 

2.1. Open the Arduino IDE 
After installation, open the Arduino IDE. 

2.2. Open Preferences 
Go to File > Preferences in the menu bar. 

2.3. Add ESP32 URL 
In the “Additional Boards Manager URLs” field, paste the following URL: 

https://espressif.github.io/arduino-esp32/package_esp32_index.json 

Click OK to save your preferences. 

2.4. Install ESP32 Add-On 
Go to Tools > Board > Boards Manager. 
In the search bar, type “ESP32” and install the package labeled esp32 by Espressif Systems. 

 
  

https://www.arduino.cc/en/software


3. Insert GEOSigner into PC 

Insert the Wingbits GEOSigner into an available USB port on your computer. Ensure the 
device is properly connected. 

 

4. Select the ESP32-C3 Board in Arduino IDE 

4.1. Select the ESP32-C3 Board 
Go to Tools > Board and select ESP32C3 Dev Module from the list. 

4.2. Select the Correct Port 
Go to Tools > Port and select the COM port that corresponds to the GEOSigner. 

 

5. Check If Settings Are Correct 

Before flashing the new software, ensure the following settings are correctly configured in 
the Tools menu: 

• Board: "ESP32C3 Dev Module" 
• Port: Ensure the correct port is selected (e.g., /dev/cu.usbmodem14201 on macOS) 
• USB CDC On Boot: "Enabled" 
• CPU Frequency: "160MHz (WiFi)" 
• Core Debug Level: "None" 
• Erase All Flash Before Sketch Upload: "Disabled" 
• Flash Frequency: "80MHz" 
• Flash Mode: "QIO" 
• Flash Size: "4MB (32Mb)" 
• JTAG Adapter: "Disabled" 
• Partition Scheme: "No FS 4MB (2MB APP x2)" 
• Upload Speed: "921600" 
• Zigbee Mode: "Disabled" 

Note: 
It is extremely important that USB CDC On Boot: "Enabled" is selected. If this setting is 
not enabled, the built-in USB port will stop functioning, preventing further communication 
with the device. 

The "No FS 4MB (2MB APP x2)" partition scheme allows for a larger sketch size by 
dedicating 2MB of space for the application code and supporting dual boot for safer OTA 
updates, without reserving memory for a file system. This is only necessary if your sketch 
is large and requires additional memory. 

Ensure these settings are correct before proceeding with the upload of the new firmware. 

 



6. Flash New Software to GEOSigner 

6.1. Open Your Sketch 
Write or open the new sketch you want to upload to the GEOSigner. 

6.2. Upload the Sketch 
Click the Upload button (the right arrow icon) or go to Sketch > Upload to flash the new 
software to the GEOSigner. 

6.3. Monitor the Upload Process 
Once you click upload, the Arduino IDE will compile the code and begin uploading it to the 
GEOSigner. You can monitor the process in the console window at the bottom of the IDE. If 
successful, you will see a message indicating that the upload is complete. 

 
 
 
 
 
  



Most Common Faults and How to Resolve Them 

Here are some of the most common issues you may encounter while working with the 
Wingbits GEOSigner, along with tips on how to resolve them. 

 

1. No Serial Communication 

Issue: 
The serial monitor does not display any output, and there is no communication between the 
GEOSigner and the PC. 

Possible Cause: 

• You may have programmed the device with USB CDC On Boot: "Disabled". 

Solution: 

• Check the setting: Verify that you selected USB CDC On Boot: "Enabled" in the 
Arduino IDE settings and flash again. 

• Unplug and Reconnect: Unplug the GEOSigner, reconnect it to your PC, and restart 
the serial monitor. 

 

2. Sketch Too Big 

Issue: 
The sketch size exceeds the available memory on the device, leading to a compilation error. 

Error Message Example: 

Sketch uses 1820790 bytes (138%) of program storage space. Maximum is 
1310720 bytes. 
Global variables use 65884 bytes (20%) of dynamic memory, leaving 261796 
bytes for local variables. Maximum is 327680 bytes. 
text section exceeds available space in board. 
Compilation error: text section exceeds available space in board. 

Solution: 

• Optimize the Sketch: Visit this guide for tips on reducing the size of your sketch. 
• Check Partition Scheme: Ensure you are using the "No FS 4MB (2MB APP x2)" 

partition scheme to allocate more space for your sketch. 

 

 

 

https://support.arduino.cc/hc/en-us/articles/360013825179


3. Missing Partition File 

Issue: 
You may encounter an error where the necessary partition file cannot be found during 
compilation. 

Error Message Example: 

/Users/woutercoppen/Library/Arduino15/packages/esp32/hardware/esp32/3.1.0-
RC1/tools/partitions/{build.partitions}.csv: No such file or directory 
exit status 1 
Compilation error: exit status 1 

Solution: 

• Verify the Board settings: Ensure the correct board (ESP32C3 Dev Module) is 
selected, and if needed ensure that the correct partition scheme is selected.  

 



FCC Statement 

1. This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: 

(1) This device may not cause harmful interference. 

(2) This device must accept any interference received, including interference that may cause undesired operation. 

2. Changes or modifications not expressly approved by the party responsible for compliance could void the user's authority to operate 

the equipment. 

NOTE:  

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. 

These limits are designed to provide reasonable protection against harmful interference in a residential installation. 

This equipment generates uses and can radiate radio frequency energy and, if not installed and used in accordance with the 

instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur 

in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can be determined 

by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of the following measures: 

Reorient or relocate the receiving antenna. 

Increase the separation between the equipment and receiver. 

Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.  

Consult the dealer or an experienced radio/TV technician for help. 

SAR Information Statement 

Your device is a radio transmitter and receiver. It is designed and manufactured not to exceed the emission limits for exposure to 

radiofrequency (RF) energy set by the Federal Communications Commission of the U.S. Government. These limits are part of 

comprehensive guidelines and establish permitted levels of RF energy for the general population. The guidelines are based on 

standards that were developed by independent scientific organizations through periodic and thorough evaluation of scientific studies. 

The standards include a substantial safety margin designed to assure the safety of all persons, regardless of age and health. The 

exposure standard for device employs a unit of measurement known as the Specific Absorption Rate, or SAR. The SAR limit set by the 

FCC is 1.6 W/kg. * Tests for SAR are conducted with the device transmitting at its highest certified power level in all tested frequency 

bands. Although the SAR is determined at the highest certified power level, the actual SAR level of the device while operating can be 

well below the maximum value. This is because the device is designed to operate at multiple power levels so as to use only the power 

required to reach the network. In general, the closer you are to a wireless base station antenna, the lower the power output. Before a 

device model is available for sale to the public, it must be tested and certified to the FCC that it does not exceed the limit established by 

the government adopted requirement for safe exposure. The tests are performed in positions and locations (e.g., at the ear and worn 

on the body) as required by the FCC for each model. The highest SAR value for this model device when worn on the body, as 

described in this user guide, is 1.101W/Kg(Body-worn measurements differ among device models, depending upon available 

accessories and FCC requirements). While there may be differences between the SAR levels of various device and at various positions, 

they all meet the government requirement for safe exposure. The FCC has granted an Equipment Authorization for this model device 

with all reported SAR levels evaluated as in compliance with the FCC RFexposure guidelines. SAR information on this model device is 

on file with the FCC and can be found under the Display Grant section of http://www.fcc.gov/ oet/fccid after searching on  

FCC ID: 2BKJ9-GEOSIGNER Additional information on Specific Absorption Rates (SAR) can be found on the Cellular 

Telecommunications Industry Asso-ciation (CTIA) web-site at http://www.wow-com.com. * In the United States and Canada, the SAR 

limit for device used by the public is 1.6 watts/kg (W/kg) averaged over one gram of tissue. The standard incorporates a sub-stantial 

margin of safety to give additional protection for the public and to account for any variations in measurements. 

 

Body-worn Operation 

This device was tested for typical body-worn operations. To comply with RF exposure requirements, a minimum separation distance 

  of 5mm must be maintained between the user’s body and the device, including the antenna. Third-party belt-clips, holsters,   

and similar accessories used by this device should not contain any metallic components. Body-worn accessories that do not meet 

these requirements may not comply with RF exposure requirements and should be avoided. Use only the supplied or an approved 

antenna.  

 

 



IC STATEMENT 

This device complies with Industry Canada licence-exempt RSS standard(s) 

Operation is subject to the following two conditions: 

(1) This device may not cause interference, and 

(2) This device must accept any interference, including interference that may cause undesired 

operation of the device. 

This equipment complies with IC radiation exposure limits set forth for an uncontrolled 

environment. End user must follow the specific operating instructions for satisfying RF 

exposure compliance. This transmitter must not be co-located or operating in conjunction with 

any other antenna or transmitter. 

These requirements set a SAR limit of 1.6 W/kg averaged over one gram of tissue. 

The highest SAR value for this model phone when tested for worn on the body is 1.101 W/Kg. This device was tested for typical 

body-worn operations. To comply with RF exposurerequirements, a minimum separation distance of 5mm must be maintained between 

the 

user’s body and the device, including the antenna. Third-party belt-clips, holsters, and similar 

accessories used by this device should not contain any metallic components. Body-worn 

accessories that do not meet these requirements may not comply with RF exposure 

requirements and should be avoided. Use only the supplied or an approved antenna. 

Le présent appareil est conforme aux CNR d'Industrie Canada applicables aux appareils radio 

exempts de licence. 

 

Ce dispositif est conforme aux normes autoriser-exemptes du Canada RSS d'industrie 

L'exploitation est autorisée aux deux conditions suivantes : 

(1) l'appareil ne doit pas produire de brouillage, et 

(2) l'utilisateur de l'appareil doit accepter tout brouillage radioélectrique subi, même si le 

brouillage est susceptible d'en compromettre le fonctionnement.Cet équipement  

est conforme avec l'exposition aux radiations IC définies pour un environnement  

non contrôlé. L'utilisateur final doit respecter les instructions de fonctionnement spécifiques pour satisfaire la conformité aux 

expositions RF. Cet émetteur ne doit pas être co-localisées  

ou opérant en conjonction avec une autre antenne ou transmetteur.Ces exigences définissent 

la valeur SAR limite à 1.6 W / kg en moyenne par gramme de tissu.La valeur SAR la plus 

 élevée pour ce modèle de téléphone testé lorsque porté sur le corps est 1.101 W/Kg.  

Cet appareil a été testé pour des opérations portés sur le corps typiques. Pour se conformer 

aux exigences d'exposition aux radiofréquences, une distance minimale de 5 mm doit être 

maintenue entre le corps de l'utilisateur et le combiné, y compris l'antenne. Les pinces de 

ceinture, les étuis et autres accessoires similaires utilisés par cet appareil ne doivent pas 

contenir de composants métalliques. Les accessoires portatifs qui ne répondent pas à ces 

exigences peuvent ne pas se conformer aux exigences d'exposition RF et doit être évitée. 

Utilisez uniquement l'antenne fournie ou une antenne approuvée 
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