Product Description

The NRFLR12XX is a low-power, remote transceiver module that uses the Nordic nRF52840 MCU
and Semtech's latest SX1262/LLCC68 LoRa transceiver. The module conforms to Class A, B and C
specifications of LoRaWAN 1.0.3, supports LoRa peer-to-peer (P2P) communication mode, and
can quickly realize custom LoRa network.

With LPWAN communication capabilities, the module is ideal for a variety of iot applications,
including home automation, sensor networking, building automation, and various iot networking
scenarios.

Due to the built-in nRF52840 MCU in the module, sensors and other external peripheral
interfaces can be directly driven without the need for additional MCUS. In addition, NRFLR12XX
can communicate with the external host MCU via USB, UART using the AT command.

Product Features

* LoRaWAN 1.0.3 specification compliant

* Supported bands: EU868,US915

* LoRaWAN Activation by OTAA/ABP

* LoRa Point-to-Point (P2P) communication

* Easy-to-use AT Command set via UART interface

* TCXO crystal for LoRa chip

* 10 ports: UART, I12C, GPIO, USB

* Temperature range: -400] to +85[]

* Supply voltage: 2.0~ 3.6 V

* Low-Power Wireless Systems

* Ultra-Low Power Consumption 6 UA in sleep mode

* LoRa PA Boost mode with 25.449 dBm output power

* Serial Wire Debug (SWD) interface

* Module size: 20 mm x 20 mm x 3.6mm

Quick use

* Software installation-Install the Arduino IDE

To the Arduino's official website to download the Arduino IDE and install, website:
https://www.arduino.cc/en/software

Once the Arduino IDE has been installed successfully, you can now configure the IDE to add the
NRF52840 to its board selection by following these steps.

1.0pen Arduino IDE and go to File > Preferences.
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4 Restart the Arduino IDE.
5.0pen the Boards Manager from Tools Menu.
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6.Write NRF52 in the search bar as shown. This will display the available NRF52 series boards that
you can add to the list of Arduino boards. Select and install the latest version of the nRF series

board.
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7.0nce the BSP is installed, select Tools > Boards Manager > Adafruit nRF52 Boards >Nordic
nRF52840 Boards.
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* Compile an Example with Arduino IDE

1.After setting up the circuit for testing NRFLR12XX Module according to "Module minimum
system application schematic diagram",Connect NRFLR12XX via USB and view the COM port of
NRFLR12XX in Windows Device Manager. If the module is not detected, double-click the reset
button.
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2.Select an nRFLR12XX board. Choose Tools > Boards Manager > Adafruit
nRF52 Boards > Nordic nRF52840 Boards.
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3.0pen the Tools Menu and select a COM port. COM314 is currently used.
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4.Click Setch to open the Manage Libraries
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5.Install the library by typing RadiolLib in the search bar and clicking Instsl|

@ Library Manager X
Type All w | Topic |All w
Mo;e info i o - 2

RadioLib

by Jan Gromes

Universal wireless communication library User-friendly library for sub-GHz radic modules (SX1278, RF69, CC1101, SX1268,
LR1110 and many others), as well as ham radio digital modes (RTTY, SSTV, AX.25 etc.] and other protocols (Pagers,
LoRaWAN].

[T PR

Version 7.1.2

SlimLoRa

by clavisound

SlimLoRa Library LoRaWAN library with OTAA join, ADR support and most important MAC commands for EUS68 suitable for
AVR's with 32Kbytes. It uses 14kBytes of program flash instead of S2kBytes of Radiolib or 22kBytes of LMIC. Tested awr32u4 /
ATmega22u4 and HopeRF 95w (SX1276) on Adafruit Feather. ABP untested. Session is stored to EEPROM. Testers wanted and
PR's for other regions. It supports downlinks.

Mare info

W
Close
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7.In the program interface that opens, modify the configuration information, as shown below,

and then click Burn program..

& sx126x_Transmit_Interrupt | Arduino 1.8.19 - O ht
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S3126x_Transmit_Interrupt §

// include the library
#include <RadioLib.h>

ff 5X1262 has the following connections:
f/ W55 pin: 10
ff DIOLl pim: 2
Jf WRST pin: 3
ini=atd F-i o

S¥1262 radio = new M:Jdu]_em‘i'l, 38, 42, 43):

ff or detect the pinout automatically using RadioBoards
J/ https://github.com/radiclib-org/RadiocBoards

Nardic nRF! 40 8.1.1, Level O (Relea rial on COM3NS

8.After the program is burned, the NRFLR12XX module will run!



FCC WARNING

FCC Caution: Any changes or modifications not expressly

approved by the party responsible for compliance could void the user's
authority to operate this equipment.

This device complies with Part 15 of the FCC Rules.

Operation is subject to the following two conditions: (1) This device may not
cause harmful interference, and (2) this device must accept any interference
received, including interference that may cause undesired operation.

This device and its antenna(s) must not be co-located or operating in conjunction
with any other antenna or transmitter.

15.105 Information to the user.

(b) For a Class B digital device or peripheral, the instructions furnished the
user shall include the following or similar statement, placed in a prominent
location in the text of the manual:

Note: This equipment has been tested and found to comply

with the limits for a Class B digital device, pursuant to part 15 of the FCC Rules.
These limits are designed to provide reasonable protection against harmful
interference in a residential installation. This equipment generates, uses and
can radiate radio frequency energy and, if not installed and usedin
accordance with the instructions, may cause harmful interference to radio
communications. However, there is no guarantee that interference will not
occur in a particular installation. If this equipment does cause harmful
interference to radio or television reception, which can be determined by
turning the equipment off and on, the user is encouraged to try to correct the
interference by one or more of the following measures:

—Reorient or relocate the receiving antenna.

—Increase the separation between the equipment and receiver.

—Connect the equipment into an outlet on a circuit different from that to which
the receiver is connected.

—Consult the dealer or an experienced radio/TV technician for help.

This equipment complies with FCC radiation exposure limits set forth for an

uncontrolled environment. This equipment should be installed and operated with
minimum distance 20cm between the radiator and your body. Radiation Exposure
Statement:

This equipment complies with FCC radiation exposure limits set forth for an
uncontrolled environment.

This transmitter must not be co-located or operating in conjunction with any other



antenna or transmitter.

The availability of some specific channels and/or operational frequency bands
are country dependent and are firmware programmed at the factory to match
the intended destination.

The firmware setting is not accessible by the end user.

The final end product must be labelled in a visible area with the following:
“Contains Transmitter Module “FCC ID: 2BDNA-NRFLR1262-ELE”



Requirement per KDB996369 D03

2.2 List of applicable FCC rules

List the FCC rules that are applicable to the modular transmitter. These are
the rules that specifically establish the bands of operation, the power, spurious
emissions, and operating fundamental frequencies. DO NOT list compliance
to unintentional-radiator rules (Part 15 Subpart B) since that is not a condition
of a module grant that is extended to a host manufacturer. See also Section
2.10 below concerning the need to notify host manufacturers that further
testing is required.3

Explanation: This module meets the requirements of FCC part 15C (15.247).it Specifically
identified AC Power Line Conducted Emission, Radiated Spurious emissions, Band edge

and RF Conducted Spurious Emissions, Conducted Peak Output Power, Bandwidth, Power
Spectral Density, Antenna Requirement.

2.3 Summarize the specific operational use conditions

Describe use conditions that are applicable to the modular transmitter,
including for example any limits on antennas, etc. For example, if point-to-
point antennas are used that require reduction in power or compensation for
cable loss, then this information must be in the instructions. If the use
condition limitations extend to professional users, then instructions must state
that this information also extends to the host manufacturer’s instruction
manual. In addition, certain information may also be needed, such as peak
gain per frequency band and minimum gain, specifically for master devices in

5 GHz DFS bands.
Explanation: The product antenna uses an irreplaceable antenna with a gain of 3.35dBi

2.4 Single Modular

If a modular transmitter is approved as a “Single Modular,” then the module
manufacturer is responsible for approving the host environment that the
Single Modular is used with. The manufacturer of a Single Modular must
describe, both in the filing and in the installation instructions, the alternative
means that the Single Modular manufacturer uses to verify that the host
meets the necessary requirements to satisfy the module limiting conditions.
A Single Modular manufacturer has the flexibility to define its alternative
method to address the conditions that limit the initial approval, such as:
shielding, minimum signaling amplitude, buffered modulation/data inputs, or
power supply regulation. The alternative method could include that the limited



module manufacturer reviews detailed test data or host designs prior to giving
the host manufacturer approval.

This Single Modular procedure is also applicable for RF exposure evaluation
when it is necessary to demonstrate compliance in a specific host. The module
manufacturer must state how control of the product into which the modular
transmitter will be installed will be maintained such that full compliance of the
product is always ensured. For additional hosts other than the specific host
originally granted with a limited

module, a Class Il permissive change is required on the module grant to
register the additional host as a specific host also approved with the module.
Explanation: The module is a single module.

2.5 Trace antenna designs

For a modular transmitter with trace antenna designs, see the guidance in
Question 11 of KDB Publication 996369 D02 FAQ — Modules for Micro-Strip
Antennas and traces. The integration information shall include for the TCB
review the integration instructions for the following aspects: layout of trace
design, parts list (BOM), antenna, connectors, and isolation requirements.

a) Information that includes permitted variances (e.g., trace boundary limits,
thickness, length, width, shape(s), dielectric constant, and impedance as
applicable for each type of antenna); b) Each design shall be considered a
different type (e.g., antenna length in multiple(s) of frequency, the
wavelength, and antenna shape (traces in phase) can affect antenna gain
and must be considered); c) The parameters shall be provided in a manner
permitting host manufacturers to design the printed circuit (PC) board
layout; d) Appropriate parts by manufacturer and specifications; e) Test
procedures for design verification; and f) Production test procedures for
ensuring compliance

The module grantee shall provide a notice that any deviation(s) from the
defined parameters of the antenna trace, as described by the instructions,
require that the host product manufacturer must notify the module grantee
that they wish to change the antenna trace design. In this case, a Class I
permissive change application is required to be filed by the grantee, or the
host manufacturer can take responsibility through the change in FCC ID

(new application) procedure followed by a Class Il permissive change
application

2.6 RF exposure considerations

It is essential for module grantees to clearly and explicitly state the RF
exposure conditions that permit a host product manufacturer to use the
module. Two types of instructions are required for RF exposure information: (1)
to the host product manufacturer, to define the application conditions

(mobile, portable — xx cm from a person’s body); and (2) additional text needed



for the host product manufacturer to provide to end users in their end-product
manuals. If RF exposure statements and use conditions are not provided, then
the host product manufacturer is required to take responsibility of the module
through a change in FCC ID (new application).

Explanation: The module complies with FCC radiofrequency radiation exposure limits for
uncontrolled environments. The device is installed and operated with a distance of more
than 20 cm between the radiator and your body." This module follows FCC statement

design, FCC ID : 2BDNA-NRFLR1262-ELE
2.7 Antennas

A list of antennas included in the application for certification must be provided
in the instructions. For modular transmitters approved as limited modules, all
applicable professional installer instructions must be included as part of the
information to the host product manufacturer. The antenna list shall also
identify the antenna types (monopole, PIFA, dipole, etc. (note that for example
an “omni-directional antenna” is not considered to be a specific “antenna
type”).

For situations where the host product manufacturer is responsible for an
external connector, for example with an RF pin and antenna trace design, the
integration instructions shall inform the installer that unique antenna connector
must be used on the Part 15 authorized transmitters used in the host product.



The module manufacturers shall provide a list of acceptable unique
connectors.

Explanation: The product antenna uses an irreplaceable antenna with a gain of
3.35dBi

2.8 Label and compliance information

Grantees are responsible for the continued compliance of their modules to the
FCC rules. This

includes advising host product manufacturers that they need to provide a
physical or e-label stating “Contains FCC ID” with their finished product. See
Guidelines for Labeling and User Information for RF Devices — KDB
Publication 784748.

Explanation: The host system using this module, should have label in a visible
area indicated the following texts: "Contains

FCC ID: 2BDNA-NRFLR1262-ELE

2.9 Information on test modes and additional testing requirements5

Additional guidance for testing host products is given in KDB Publication
996369 D04 Module Integration Guide. Test modes should take into
consideration different operational conditions for a stand-alone modular
transmitter in a host, as well as for multiple simultaneously transmitting
modules or other transmitters in a host product.

The grantee should provide information on how to configure test modes for
host product evaluation for different operational conditions for a stand-alone
modular transmitter in a host, versus with multiple, simultaneously transmitting
modules or other transmitters in a host.

Grantees can increase the utility of their modular transmitters by providing
special means, modes, or instructions that simulates or characterizes a
connection by enabling a transmitter. This can greatly simplify a host
manufacturer's determination that a module as installed in a host complies
with FCC requirements.

Explanation: Shenzhen Elecrow Limited can increase the utility of our modular
transmitters by providing instructions that simulates or characterizes a
connection by enabling a transmitter.

2.10 Additional testing, Part 15 Subpart B disclaimer

The grantee should include a statement that the modular transmitter is only
FCC authorized for the specific rule parts (i.e., FCC transmitter rules) listed on
the grant, and that the host product manufacturer is responsible for
compliance to any other FCC rules that apply to the host not covered by the
modular transmitter grant of certification. If the grantee markets their product



as being Part 15

Subpart B compliant (when it also contains unintentional-radiator digital
circuity), then the grantee shall provide a notice stating that the final host
product still requires Part 15 Subpart B compliance testing with the modular
transmitter installed.

Explanation: The module without unintentional-radiator digital circuity, so the
module does not require an evaluation by FCC Part 15 Subpart B. The host
should be evaluated by the FCC Subpart B.
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