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1. INTRODUCTION

eLR100-AD-SU is a Developer's Kit designed for developers to develop loT-related devices using LoRa communication.
The Kit contain eLR100-AD-SU LoRa module from the eWBM.

The eLR100-AD-SU can be controlled by AT-Command via the UART interface and also has connectors for use by
connecting to the Arduino board and Shield Type.

1.1. FEATURES

<> eLR100-UL-00 Module include
B eWBM ultra low power advanced security MCU MS500

- Cortex MO

- Hardware Security system.

B Semtech SX1276 radio transceiver supporting LoRar

- High sensitivity down to -135.5 dBm

902.3MHz to 914.9 MHz (125 kHz)

903.0MHz to 914.2 MHz (500 kHz)

Max 14 dBM Output Power

LoRa Alliance Certified

B UART Communication Interface

- AT-Command set support for LoRaWAN
<> SMA connector
<> Compatible with 3.3V/5V I/O Arduino Type Host Board
m 5VI/0
B Arduino Connectors

B Grove Connectors
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1.2. BLOCK DIAGRAM

Confidential

Figure 1. Hardware Block Diagram

Arduino : eLR100-UL-00

Connector Module

| IOREF(5V)

:

Grove

Connector

Figure 2. Power Supply
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2. FUNCTIONAL DESCRIPTION

2.1. PART DESCRIPTION

Grove Connector
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Figure 3. eLR100-AD-SU Parts
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Figure 4. eLR100-AD-SU Arduino & Grove Header
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Figure 5. Input Power, Power LED

2.2.1. Input Power

Inputs from the power source enter power through Pin 5 and 6 in the Arduino Headpin Interface (JA1). Pin 2(IREF)
requires the Level Shift (U3) to be supplied as a pin for V5 power.

2.2.2. Power LED (LED1)

LED1 illuminates when an external power supply of 5V is applied and 3.3V is output normally via a circuit on the
board.
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2.3. RESET
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Figure 6. Reset Header, Switch
2.3.1. LoRa Module (eLR100-UL-00) Reset (SW1)

There are 3 ways to reset the LoRa module (eLR100-UL-00). Rress SW1, applying a reset signal (Low Active)
through the Socket Header (D7), or Sending software Reset via AT-Command via UART.

Hardware Reset

LoRa Module (eLR100-UL-00) Reset I/0 is available for both 3.3V/5V.

Software Reset

UART enables reset by entering AT+Command 'AT+RESET".

For more information, please refer to the separate ATCOMMAND_Manual technical details.
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2.4. ARDUINO TYPE HEADER GROVE CONNECTOR

T

NOILM3LLY
53

=z
=
°
"nf?
o=
pl
]

o

Figure 7. Arduino Type Header Description

2.4.1. D2,D3:UART (out/in)

B Header communicating with Arduino (UNO ).
B AT-COMMAND, Debug, Firmware Update are all possble.
H 5VI/O.

2.4.2. D4 : State (Out)

B Header pin to check the status of LoRa Module (eLR100-UL-00).
- Normal Mode : HIGH

-  Sleep Mode : LOW

eLR100-UL-00 Manual for Consumer Products, Rev. 0.2, 02/2020
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- 5vi/o.

B Connect with LED2 to check signal status.
- Normal Mode : ON

- Sleep Mode : OFF

2.4.3. D7 :LoRa Reset (IN)

B Connected to the Reset of the LoRa Module (eLR100-UL-00).
B The PNP TR is connected inside the eLR100-AD-SU, which allows control of all 3.3V/5V.

2.4.4. Grove Connector

B The A0, A1 D8, D9 SCL, and SDA signal lines are not connected to the LoRa Module (eLR100-UL-00)

but directly to the Grove Connector in the Arduino Header.
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3. APPLICATION

3.1.FIRMWARE UPLOAD

3.1.1. Board Setting
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Figure 8. Boot Mode

1. Jumperin Boot Mode Header (J1) to set the Firmware Upload Mode.

Table1 Jumper Setting

Mode Jumper Setting Description

Default Mode I I I

(ROM BOOT) I Ji

Normal Operation Mode

Firmware Upload Mode
(UART to Flash Boot)

W

Firmware Update Mode

2. Connect a 5V power supply to the Arduino Header. Connect a 5V power supply to the IOFF as well.
3. Connect the Uart cable to DO,D1 of the Arduino Header.
4. Press LoRa Reset Switch (SW1) to reset.
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5. Perform Firmware Upload.

3.1.2. Firmware Updater Setting & Upload

24 o

< ter | |

@sm COMPol BaudRate [230400 +] [scan]  connect |

C smml & QsPl I“'

- Application

FW Image: | Upload | | ~ o

Figure 9. Firmware Setting 1

With the eLR100-AD-SU connected to your PC, click Scan.

Set COM Port to the port to which the eLR100-AD-SU is connected.
Select QSPI..

Click ... to select the .img file to upload.

el

| L 9

| @BM COMPort [COMS | BaudRate 230400 | Scs ” Disconnect I._o

" SRAM & QSPI
Application
FW Image : |C:\Users\jn!ee\l)uwnluads\AT_SIave_KRﬁZU_DLS?ﬁD‘Ii pload e 'o
| -

Figure 10. Firmware Setting 2

5. Click Connect.
6. Click Upload.
7. Check the Upload status through the green bar.

< 500 Firmware L ;
Info x
R O | [Fesil]
o Firmware upload success ! " SRAM & QSPI
| Application = - — S
FWimage: |CA\Users _I Ipload
| | § [ = ] ._-..._.._.__.-._-.__.--.o

Figure 11. Firmware Setting 3

8. “Firmware Upload Success !” Confirm the message and click it.

B After upload, return the Board settings to their default values.

eLR100-UL-00 Manual for Consumer Products, Rev. 0.2, 02/2020
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3.2. ARDUINO EXAMPLE

B Arduino Library works only on Arduino UNOs.

To install the eWBM LoRa Library, download the files that are being distributed.

Please refer to our homepage for the file. (http://www.e-wbm.com/)

3.2.1. Installing the Arduino Library (Importing)
B Run Arduino IDE

- From the menu, access and select Sketch - Include Library - Add. ZIP Library.
- Select a deployed .ZIP file..

<> For more information, see Link below.
https://www.arduino.cc/en/Guide/Libraries#toc4

3.2.2. Running the Arduino Example

B After running the Arduino IDE, access and select Tools -ard Board -> Arduino UNO order from the menu.

B Select File -> Extensions -> eWBM LoRa -> LoRa -> LoRaCommunication from the menu after running the
Arduino IDE.

eLR100-UL-00 Manual for Consumer Products, Rev. 0.2, 02/2020 12|24
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3.2.3. Upload the Program

B Connect the USB cable.

USB Port

o axwmm ARDUINO

-
O mnman

Figure 12. Arduino Port

B From the Arduino IDE menu, access and select Tools -> Board -> Arduino UNO order.
B From the Arduino IDE menu, select Tools -> Port to select the port you connected to.

B Upload.
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3.3. LORA BEHAVIOR EXAMPLE (LORACOMMUNICATION.INO)
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i S e

Figure 13. UART Pad Description

B LoRa Module Communication : Arduino Software UART Port (D2,D3)
= Baud rate: 38400
= Data bit: 8bit
= Stop bit: 1bit
= Parity bit: None

B LoRaCommunication.ino example If you appear in the Console as shown below during the initial run, it

is normal.

LoRa Network Start
LoRa Module Version : 1.1.15-e07713e-Darthvader
LoRa Device EUI : 02:02:02:02:02:02:02:02
Select Lora Mode : OTAA (1) or ABP (2) ?
Figure 14. LoRa Command

B LoRa motion mode must be selected and operated in either OTAA or ABP mode..
= Choose according to the purpose and join
= LoRaWAN. For more information on LoRa, please refer to the LoRaWAN Specification document.

3.3.1. LoRa Preferences

Refer to the AT-COMMAND command manual for detailed settings.

B [f the module does not succeed with Join, check the communication with the Gateway and check the
Network Server.

B The initial Class setting for the module is set to Class A.
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4. HOST DEVICE APPLICATION

4.1.CIRCUIT

B VCC 3.3V, VDD_RFS Voltage Range : 3.0V to 3.6V

Confidential

Figure 14. Application Circuit
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4.2.MODULE MECHANICAL DIMENSION
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Figure 15. Module Mechanical Dimension
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4.3.ANTENNA

Please perform the antenna design that followed the specifications of the antenna

About the signal line between an antenna and a module

It is a 50-ohm line design. (SMA Reverse)

Fine tuning of return loss etc. can be performed using a matching network.

However, it is required to check "Class1 change" and "Class2 change"

which the authorities define then.

The concrete contents of a check are the following three points.

1) It is the same type as the antenna type of antenna specifications.

2) An antenna gain is lower than a gain given in antenna specifications.

3) The emission level is not getting worse.

4.3.1. Antenna gain

ELECTRICAL DATA SPECIFICATIONS
FREQUENCY RANGE 902 ~ 923.1 MHz
IMPEDANCE 50 & NOMINAL
V.S.W.R LESS THAN 1:2.0
GAIN(PEAK) 1.85 dBi
RADIATION PATTERN OMNI - DIRECTIONAL
POLARIZATION VERTICAL

Figure 16. Antenna Specification

eLR100-UL-00 Manual for Consumer Products, Rev. 0.2, 02/2020 1724
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4.3.2. Antenna Reference Trace Design

RF traces from eLR100-UL-00 module pads pin 47 and J2 pin 1 to the antenna must be made using micro-strip traces.
This micro-strip trace must respect the design of the Gerber file associated with the following figures in order to
obtain a uniform transmission line with a characteristic impedance of 50 ohms.

The reference trace design is shown as the green trace along with the side copper filled with vias on the left side.

of Figure where components C6, C7 are not installed; they were options on the reference board for future uses;
these uses are not FCC authorized yet.

As preliminary information the traces width of all sections are all 0.5mm and the length of eLR100-UL-00 pad to J2
connector are 6.2mm; However, refer to associated Gerber files for more details on dimensions and refer to
EWBM Inc for more details on the Gerber files. Table 1 shows the parts used in the reference trace design.
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Figure 17. Antenna Reference Trace Design
Part Number Reference Description Manufacture
LQPO3TN10NHO02D R10 10nH, 3% Murata
SMA, Subminiature Coaxial ..
SMA-4R-PCB(1.8T) J2 Connector 50 ohm Sungjin
N/A ce, C7 Not Installed N/A

Table 1. Antenna Micro-strip Trace Parts
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4.3.3 PCB Stack-Up and Trace

PCB Stack up for the reference board:

SOLDER LEVEL  ( SEE NOTE 2A )
P — g COPPER PLATE 7\ 5 o
FIAYER 1 S~ COPPER FOL

~—Prepregs 105 ym +/-18(er — 3.57) ( SEE NOTE 1A )
LAYER 2 - COPPER FOL 35 ym

1.6 mm +/-0.16 =—CORE 1190 um(er - 4.40)

LAYER 3 I -— COPPER FOIL 35 um
=—Prepregs 105 um +/-18(er — 3.57)

LAYER 4 | <~ COPPER FOL__ "
o R COPPER PLATE _/ 35.um
SOLDER LEVEL  ( SEE NOTE 2A )

NOTE 1A: DELECTRIC FR4
2A: SURFACE PROTECTION: Chemical Gold

THE BOARD MUST BE RoHS COMPLIANT

Figure 18. PCB Stack-Up

Below figure 18 shows the Top layer routing of the complete reference board.
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Inner 2 O(:l

PCB Material: FR-4, 1.6T, 4-Layer

Routing

Inner 3 @(.)

. s . .

.
Inner 2 IR R
L] L L I

. .
. #%s"e%e%e"s

Inner 3

Bottom

Figure 19. PCB Trace

4.3.4 Test Procedure for ensuring compliance
The below test is to be performed both at design verification stage and in production for ensuring compliance.

1. Initiate Continuous Transmission in the appropriate modulation mode from the device i.e.,902.3MHz, 908.7MHz,
914.9MHz; FHSS mode and 903MHz, 907.8MHz, 914.2MHz; DTS mode

2. Verify RF power through conducted measurement at junction J2

3. The measured Tx power should be within the datasheet specification for Transmit output power.
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COPYRIGHT NOTICE

Copyright © 2019 eWBM Co., Ltd. All rights reserved.

This document is the copyrighted work of eWBM Co., Ltd. and is owned by eWBM Co., Ltd. It is provided as a
reference for the sole purpose of MS500 microcontroller based system design.

No part of the software and documentation may be reproduced, transmitted, or translated, in any form or by
any means, electronic, mechanical, manual, optical, or otherwise, without prior written permission of e WBM

Co., Ltd.

NO WARRANTY NOTICE

eWBM Co., Ltd. makes no warranty of any kind in regard to this material which is delivered to you as is,
including, but not limited to, the implied warranties.as to its accuracy or fitness for a specific purpose. Any use of
this technical documentation or the information contained therein is at the risk of the user. eWBM Co., Ltd. shall
not be liable for errors contained therein or for.incidental consequential damages in connection with the

furnishing, performance or use of the material.
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FCC Statement

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two
conditions: (1) This device may not cause harmful interference, and (2) this device must accept
any interference received, including interference that may cause undesired operation.

This equipment has been tested and found to comply with the limits for a Class B digital device,
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable
protection against harmful interference in a residential installation. This equipment generates,
uses and can radiate radio frequency energy and, if not installed and used in accordance with
the instructions, may cause harmful interference to radio communications. However, there is
no guarantee that interference will not occur in a particular installation. If this equipment does
cause harmful interference to radio or television reception, which can be determined by turning
the equipment off and on, the user is encouraged to try to correct the interference by one of the
following measures:

-Reorient or relocate the receiving antenna.

-Increase the separation between the equipment and receiver.

-Connect the equipment into an outlet on a circuit different from that to which the

receiver is connected.

Any changes or modifications not expressly approved by the party responsible for compliance could void
the user's authority to operate this equipment.

The antenna(s) must be installed such that a minimum separation distance of at least
20 cm is maintained between the radiator (antenna) and all persons at all times.

IC Statement

This device complies with Industry Canada license-exempt RSS standard(s). Operation is
subject to the following two conditions : (1) This device may not cause interference; and (2)
This device must accept any interference, including interference that may cause undesired
operation of the device. Le présent appareil est conforme aux CNR d’Industrie Canada
applicables aux appareils radio exempts de licence. L’exploitation est autorisé aux deux
conditions suivantes : (1) I'appareil ne doit pas produire de brouillage, et (2) I'utilisateur de
I'appareil doit accepter tout brouillage radioélectrique subi, méme si le brouillage est
susceptible d’en compromettre le fonctionnement.

The antenna (or antennas) must be installed so as to maintain at all times a distance
minimum of at least 20 cm between the radiation source (antenna) and any individual. This
device may not be installed or used in conjunction with any other antenna or transmitter.
I’exposition aux RF

L’antenne (ou les antennes) doit tre install e de fa on maintenir tout instant une distance
minimum de au moins 20 cm entre la source de radiation (I'antenne) et toute personne
physique.
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NTEGRATION INSTRUCTIONS

The module complies with Part15.247/RSS-247.

The modular transmitter is only FCC authorized for the specific rule part(i.e, FCC transmitter rules) listed on
the grant. The host product manufacturer is responsible for compliance to any other FCC rules that apply
to the host not covered by the modular transmitter grant of certification.

The final host / module combination may also need to be evaluated against the FCC Part 15B criteria for
unintentional radiators in order to be properly authorized for operation as a Part 15 digital device.

The module is authorized with trace antenna design type.

And the module is designed to operate with a dipole antenna.

(Connector: SMA reverse / peak gain: 1.85dBi)

The trace antenna design must be performed as specified in the manual. The use of any other antenna or
any changes to the reference trace design are subject to additional testing and authorization through a
Class Il permissive change.

The module is a limited single-modular transmitter that complies with the § 15.212(a) modular

rules which requires the host operating condition as ; The host product should supply the

regulated power of 3.3V DC to module. The power design should be performed as specified in the manual.
The module is limited to installation in mobile or fixed applications. At least 20 cm of separation distance
between the transmitting antenna device and the user's body must be maintained at all times.

The transmitter module must not be co-located or operating in conjunction with any other

antenna or transmitter except in accordance with FCC multi-transmitter product procedures.

The OEM integrator will be responsible to satisfy SAR/ RF Exposure requirements, when the

module integrated into the host device.

The module is labeled with its own FCC ID and IC certification. If the FCCID and IC

Certification Number are not visible when the module is installed inside another device,

then the outside of the device into which the module is installed must also display a label

referring to the enclosed module. In that case, the final end product must be labeled in a

visible area with the following:

"Contains FCC ID: 2ARG9-ELR100", "Contains IC : 25891-ELR100"

Host User Manual

The host manual shall include the following regulatory statement; Part 15.19: This device
complies with Part 15 of the FCC Rules. Operation is subject to the following two
conditions: (1) This device may not cause harmful interference, and (2) this device must
accept any interference received, including interference that may cause undesired
operation. Part 15.21: Any changes or modifications not expressly approved by the party
responsible for compliance could void the user's authority to operate this equipment. The
antenna(s) must be installed such that a minimum separation distance of at least 20 cm is
maintained between the radiator (antenna) and all persons at all times.

Host Product labeling

The module is labeled with its own FCC ID and IC certification. If the FCC ID and IC
Certification Number are not visible when the module is installed inside another device,
then the outside of the device into which the module is installed must also display a label
referring to the enclosed module. In that case, the final end product must be labeled in a
visible area with the following:

"Contains FCC ID: 2ARG9-ELR100", "Contains IC : 25891-ELR100"
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